Android 12 Pixel expereience for A71 (All models) (FOD Working)

Search This thread


New member
Apr 21, 2022
Hey, so I held off from installing the newest update on the 18th, could I still install this without any issues? If it fails would it brick my phone or could I fix it? I have a bad track record where every time I do something with tech everything goes wrong and it breaks.
Tengo un problema no me deja instalar la rom, flashea perfectamente bien pero cuando arranco me manda a recovery una y otra vez?!
Le he dado un borrado luego borro la caché, los datos y la memoria interna pero sigo con el mismo problema

Mod translation via GT:
I have a problem it won't let me install the rom, it flashes perfectly fine but when I boot it sends me to recovery over and over again?!
I have given it a wipe then I clear the cache, data and internal memory but I still have the same problem
Last edited by a moderator:

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    What is this?
    Pixel Experience is an AOSP based ROM, with Google apps included and all Pixel goodies (launcher, wallpapers, icons, fonts, bootanimation)

    Our mission is to offer the maximum possible stability and security, along with essential and useful features for the proper functioning of the device

    Based on Android 12.0 (11 is available but 12 has no difference in terms of issues and is faster an the better ui and everything else of course)
    Disclaimer:- This will void warranty.

    You will need to unlock bootloader.
    *All your data will be lost*

    Read all the steps correctly
    BUGS:- bluetooth ear/headphones do not work workaround- ( go into phh treble settings misc features and enable force-disable a2dp offload (thanks to @Lil_Boudy for figuring it out!)
    If bluetooth crashes your system disable media recommendations under Sound & Vibration > Media > Show media recommendations
    mtp not working (mtp does work in twrp and in some custom kernels the one linked here does not fix mtp as it is not changing too many things compared to other custom kernels which brick some phones)
    sim 1 incoming and outgoing does not work (you can revieve calls and call but you wonth hear anything nor will your mic go trying to fix) (workaround is to put your sim into slot 2) (i have heard that other people dont have this issue so i guess try your luck)

    DO NOT let the phone die of battery you will not be able to boot and it will be hard to get back into the system (workaround- in magisk install acca and install this apk after installing then set profile to default (this will shut down the phone at 5% hence removing the risk of your phone not booting after hitting 0%
    You tell me
    Kernel A71 Download
    Source (Kernel Source)
    download (magisk)
    Rom download.

    1.Need TWRP 3.4.0 or higher!
    2. Unpack the "xz" archive and put the .img file onto the sd card or internal (if you dont have a sd card do step 3 then transfer the img file to your phone)
    3. In TWRP head to factory reset format type yes and hit enter
    4. Flash the img file (as system obviously)
    5 flash faizauthar12's kernel (this makes android feel smoother and makes the wake and sleep time instant!)
    5.45 install magisk (the one linked above only) (optional but you should as a lot of modules are listed here are very important (ie the acc module and the fast charging module)
    5.5.Reboot and enjoy!

    Zainullah Boot fix (if you cant boot)

    install oneui boot into oneui change date to 3 months from now
    check for updates
    boot into download mode
    flash twrp 3.6.0 and vbmeta
    boot into twrp
    do format data
    flash multidisabler
    flash rom
    flash kernel as boot
    do factory reset
    if it boots you into fastboot shutdown flash twrp only and try another factory reset and reboot (In twrp)

    apply this config
    and this LIB
    also enable extra cameras in phh treble settings - samsung settings for ultrawide

    Get fast charging
    by default a71 on pe charges really slow this enables fast charging for the a71 on pixel experience
    to install download from
    Now install the module it will ask you to use volume keys follow the insturctions and choose 4500mah 27w once installed reboot! now enjoy faster charging (note: this will not affect battery/ will barely affect battery )

    Increase performance without any battery impact or (by feravolt and gloeysik)
    Step 1
    - Uninstall ANY OTHER KERNEL MANAGER app including smartpack/Ktweaks to avoid conflict, since this app uses AI and machine learning to dynamically boost performance when needed

    - Install FDE AI Magisk Module to make it a system app, thus it will work better and removes all kernel locks from OEMs (I'm looking at you, Samsung)

    - Update FDE AI to the latest version by downloading the latest APK here, since the fde ai magisk module will only install fde ai 12.4.1, not the latest version:

    - Move to the bottom of the screen and select AI Chat, then type /advancedai (no space, no uppercase letters). This will going to make the AI more effective, without you having to do anything.

    - Go to the settings tab and use the AUTO settings for FDE AI.
    install gms doze magisk module
    install cloudflaredns4magisk
    install adaway (optional if you want ads or not) , allow superuser for it download this in adaway click he button in the middle click add click file and add the file then go back to the main menu and click the reload button now

    also enable extra cameras in phh treble settings - samsung settings for ultrawide

    install universal safteynet fix zygsik to get safteynet working
    ALL credit goes to phusson , ponces and rest of the devs

    thats literally the one i linked

    The link to the kernel DL was broken, which is why I fixed it. (y) ;)

    Cheers: Badger50
    Then, you may really need to find a firehose file then, good luck 🤞
    How did you manage to get it working?
    I followed these steps but It still doesn't work.
    1. Turned on zygisk
    2. Configured denylist (added play services and google play too)
    3. Enabled denylist
    4. Cleared cache and data of everything on the denylist
    5. Installed USNF Zygisk and rebooted
    At this point I get a response validation error from SafetyNet 'attest', and my banking app says I failed safetynet.
    6. I installed Magisk hide props config and tried the A51 fingerprint, but got a CTS mismatch error, but I pass basic integrity.
    What did I miss?
    You should have your safety net passed if you install USNF.

    Screenshot_20220129-084954_SafetyNet Test.png
    @Williamtung that AODEnabler you sent didnt work for me. I flash it in Magisk and it says installed but doesn't show up in the modules list and doesn't work.
    Ah,yes. Have you heard of
    It installs the magisk modules and I need to use this to install the zip. Then you should see the module appears properly and having AOD with fingerprint works