[Android 13][ LineageOS 20] [MIDO]-Vanilla By Zeelog [Stable ,No Bugs, Smooth]

Search This thread


Senior Member
rom is nice but hotspot and wifi doesnt work when i enable it, it always errors
Same here on latest build.

I'm coming from MIUI 11 android 7, unlocked the bootloader, flashed the latest zeelog TWRP, clean wipe, terminal'd mkdir, put files on device, flashed ROM and NikGApps Basic, boot, no wifi.
tried again with last firmware for mido before ROM and GApps, no wifi.

Cache partition was left as ext4 and Data was formatted to F2FS.

Anyone else having issues wifi not working?
Last edited:


Senior Member
After installing NikGapps do the wipe/factory reset from TWRP. This fixed a non-functioning Play Store that couldn't connect to the network.

I think you misunderstand me, I would love to get to the point of having an issue with Play Store but from first boot after a clean flash, WiFi does not work but worked on Pixel Experience, Stock/Xiaomi EU MIUI etc without issue
Aug 3, 2011
Installed this on my Redmi Note 4 from Android 9 after upgrading the TWRP (weirdly the old TWRP recovery would not detect my internal storage at all..hence ADB sideloaded that) and then installed the ROM and NikGApps basic right from Internal Storage. The installer said it was a dirty flash and I was worried it may not work...Formatted data and wiped Cache after that and it works like it should, Wifi, FM radio, LTE Data all ok.

Thank you to the Dev..Great job team!


Feb 6, 2021
Hello. I'm having the same problem with you.

Follow these simple steps to create a modified zip file:
- unzip everything from the original zip
- before editing the update-script, disable word wrapping in your text editor just to be sure that you delete the whole line beginning with getprop("ro.product.device")...
- just in case if you use Windows with an ancient text editor, check that you save the file with Unix/Linux line feeds
- zip everything
- open the new zip file and make sure that it has the same directory structure as the original one

Don't forget to disable signature verification in TWRP before flashing the new zip.

Is your IMEI lost or not? Note that I updated my original post #50 because of the wrong block size. It should be 1536k. You should overwrite the partitions with zeros only as a last resort if everything else failed.


Senior Member
Sorry, I have just noticed that I mixed up the dd options above. When you use dd, you must specify the block size not in sectors, but in bytes. So if you use bs=3072 count=1, you delete only the first 3072 bytes of the partition. To delete the whole partition, you need to specify its size which is 1572864 bytes. You can use bs=1572864 or bs=1536k instead.

dd if=/dev/zero of=/dev/block/bootdevice/by-name/modemst1 bs=1536k count=1
dd if=/dev/zero of=/dev/block/bootdevice/by-name/modemst2 bs=1536k count=1

I hope that after rebooting, both partitions will be recreated and you can use the original firmware update zip without the need to modify the updater-script. I don't know if your IMEI will be restored. It's never a good idea to play with modemst1, modemst2, persist and some other partitions which are specific to your phone if you haven't made a backup. However, there are several guides on the Internet, describing how people succeeded in restoring their IMEI using the tool QPST.
before playing with those partitions be sure to backup at very least:
modemst1, modemst2, fsg, fsc partitions and if possible backup your original QCN with QPST first
I lost IMEI as well, but I was able to generate a couple of new ones and flash them with QPST and restore them to a functional state.
Now I have some backups in case someone needs them.

A couple of things I would like to report about this rom:
1) without typing manually "mkdir -p /data/media/0/" after flashing the rom, it goes into some kind of bootloop, so why not adding the command to the zip script directly?
2) WiFi doesn't work at all for me, I tried several versions of the rom but it just doesn't work. Any hint?


Works awesome.
This should be the best ROM for Note 4X.
I think I found a very minor bug which is you can't search in settings. [screenshot included]
Thanks a lot , Zeelog.


  • Screenshot_20230203-232957_Settings.png
    126.1 KB · Views: 66


Jun 23, 2022
A month later I'm realy satisfied but from time to time the screen stays black and I have no display anymore. The only solution consists in rebooting.

Anyone having the same issue ?
Yep. Happens when I pause Youtube in Brave browser for a while. When I wake the phone up again, the screen stays black and I have to reboot.


Apr 20, 2019
can suggest some alternative to Phone by Google its lagging and playstore wont update it (says app isn't compatible) ?


Senior Member
Apr 8, 2012
Does anyone know where the "sweep back gesture" is in the settings? Or is it missing from the ROM?


Senior Member
Jun 2, 2015
LG V30
Xiaomi Mi 10T / 10T Pro
The mido is no longer my daily driver so i never put any SIM on it until recently. Tried two SIMs, both can receive messages but neither can make/receive phone calls nor activate mobile data. Already tried turning airplane on / off to no avail. The country is Indonesia. If anyone ever experienced this and managed to solve this, kindly point me in the right direction.

Edit : Switch the SIM as SIM2 triggered mobile data but call function somehow still won't work.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    [SOLVED] Radios - WiFi, BlueTooth & GSM - not working when upgrading from stock ROM

    Hi guys, I just spent three days trying to make radios work on this otherwise awesome ROM.
    1. I upgraded the firmware on my mido to V11.0.2.0.NCFMIXM (using MiFlash, guide here - if you get an error about a log file not found, just create an empty "log" folder and an empty .txt file with the given name in it).
    2. After flashing Zeelog's TWRP, doing factory reset and wiping partitions (system, vendor, data, internal storage), you need to install the latest LOS 17.1 with kernel 3.18.
    3. Then restart to recovery, wipe partitions and install LOS 20 and Gapps. Or any other ROM, this issue plagued PixelExperience as well.
    I had LOS 15.1 since it came out in 2018 and I stopped using my mido in 2020, that's why I didn't have the baseband from V11.0.2.0.NCFMIXM (which came out in 2019). Now I wanted to resurrect the phone to have it as a backup in case I loose or break my main driver OnePlus 8T. Apart from this radios hitch, LOS 20 works like a charm on this great old piece of HW, including banking apps. Job well done everyone involved!

    @anandsvm You can link this post in the installation guide for anyone who might encounter the same issue.
  • 22


    LineageOS is a free, community built, aftermarket firmware distribution of Android , which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed.

    What's working

    All Features are working and tested from last 3 months.

    Known issues:
    -None -

    SELinux Status Enforcing.
    CTS Passes without Root.
    Encrypted By Default.
    OTA works.

    Note : All development of these amazing ROMs is done by Zeelog. The OP anandsvm is tester ,provide assistance and collect and submit bug reports.


    Telegram Channel

    How to Install(Follow All Instruction)
    (Dont Report Bugs if you dont follow below Instructions)

    Android 13 Release Notes/Installation Guide

    1. Clean Flash
    • Clean flash is mandatory: you are required to backup all of your existing data to your computer or your preferred cloud service and avoid using nandroid backup.

    2.Flash TWRP
    • Flash the new TWRP Recovery made by Zeelog : ( Mandatory)due to various changes in fstab file and encryption implementation, you are required to flash the new TWRP of which the link is undermentioned

    3. Wipe and format Device ( Both are different)
    • After you flash and boot into the new TWRP recovery, format data and reboot to the recovery again.
    Now, wipe all the partitions (i.e. system, vendor, data, internal storage). Wiping Internal might throw an error because of missing /data/media/ which is okay, reboot to recovery again.
    This format data and wiping of other partitions is required only once every clean flash.
    NB : encryption is now enabled by default and that is why a clean flash would cost you a data format.

    4.Flash ROM and Gapps
    *To use internal storage for transferring files from PC

    From TWRP > tap Advanced > Terminal > run command: mkdir -p /data/media/0/

    • Copy the latest releases LineageOS 20.0 Android 13 rom and latest NikGapps (optional) (basic edition is preferred) to your internal storage/otg media/sd card etc.
    Flash the rom + gapps (if you need) using the usual method.

    Nik Gapps Download : Link
    Nik Gapps Addon : Link


    GitHub/OTA Release : Link

    Dev Profile : Link

    Support my efforts: Donate to Zeelog


    ROM OS Version: Android 13
    ROM Kernel: Linux 4.9
    ROM Firmware Required: Latest Firmware V11.0.2.0.NCFMIXM

    Version Information
    Stable Release Date: 2022-10-06
    Januay Secuity Patch Update is here
    Lineage-20-Android 13- 20230114-UNOFFICIAL mido- Vanilla by Zeelog

    Release 6 Changelog->
    -January security patch
    -Synced latest LineageOS sources as of 14th January 2023
    -Synced Kernel with latest Google android-4.9 [4.9.337]
    -Add full support for F2FS
    -Launcher: Add option to enable/disable search bar in app drawer
    -Dirac: Update lottie and dirac tile
    -FM: Switched to Revamped FM radio (credit: iusmac)
    -Fix notification light text
    -Translation updates

    ROM Download: GitHub

    MD5: 2a27ec0c84694b7e23d20b44a2b86184

    Support my efforts: Donate to Zeelog
    Changelog for Android 13:

    Release 1 : Oct 6

    - Initial Build - Android 13
    - October security patch
    - Synced latest LineageOS sources as of 06 October 2022
    - Synced kernel with latest Google's android-4.9 as of 06 October 2022
    - Merged latest CLO tags as of 06 October 2022
    - FBE (File based encryption) enabled by default *

    Release 2 : Oct 7
    *Fixed sdcard detection

    Release 3 : Oct 21

    Synced latest LineageOS sources as of 21 October 2022
    - Android 13 release 11
    - Synced kernel with latest Google's android-4.9 as of 21 October 2022
    - Merged latest CLO tags as of 21 October 2022
    - Revamped default launcher - added more features
    - Update Dialer, Messaging & Contacts apps
    - Added smart charging feature
    - Added more custom button actions
    - Add more fonts
    - Memory & cache optimizations
    - Updated Aperture camera app
    - Add flashlight blink notification feature

    Release 4: Nov 10
    - November security patch
    - Synced latest LineageOS sources as of 09 November 2022
    - Synced kernel with latest Google's android-4.9 as of 09 November 2022
    - WiFi: Add WPA3 security support
    - Hotspot: Add WPA3 security support
    - Hotspot: Add hidden SSID feature
    - Wifi/BT: Add WiFi/BT timeout options
    - Launcher updates
    - Add more private DNS providers

    Release 5: Dec 24
    - December SP
    - Synced latest LineageOS sources as of 24 Dec 2022
    - Synced Kernel with latest Google android-4.9.336
    - Fixed reboot issues related to Wi-Fi SSID length
    - Fixed reboot issues related to charging
    - Add lockscreen weather
    - Add weather tile
    - Integrated hotspot in Internet tile
    - Add more screen recorder options
    - Add firewall status bar icon
    - Add notification sound panel in volume panel (when unlinked)
    - Add compass tile
    - Launcher: Add memory info bar
    - Add support for Micro-G
    - Add screenshot tile
    - Add GameSpace feature
    - Fixed L2TP/PSK VPN
    - Fixed jelly browser download dialogue
    - Fixed crash with Clock analogue widget

    Release 6 Jan 14 2023

    -January security patch
    -Synced latest LineageOS sources as of 14th January 2023
    -Synced Kernel with latest Google android-4.9 [4.9.337]
    -Add full support for F2FS
    -Launcher: Add option to enable/disable search bar in app drawer
    -Dirac: Update lottie and dirac tile
    -FM: Switched to Revamped FM radio (credit: iusmac)
    -Fix notification light text
    -Translation updates
    The rom has received an update, it was posted on the telegram channel yesterday.

    - April security patch
    - Synced latest LineageOS sources as of 12 April 2023
    - includes March security update
    - Android 13 QPR2
    - Kernel: Reclaimed 90Mb RAM
    - Kernel updates
    - Add volume tile
    - Revamped wallpaper & styles (fonts/shapes moved to this section)
    - Add Icon styles
    - Back to LineageOS Network traffic impl*
    (now supports various status bar locations)
    - Add lock screen weather icon color support
    - Launcher updates: add shake to clear

    Until now I'm still using the version from february. Can somebody confirm that under "security lockscreen" there is no option to use fingerprint for unlocking?