[Android 4.1+]Proxy/GateWay for Android Auto

Search This thread

ZP2XdaDev

New member
Jul 19, 2019
4
0
Sorry that was a broken APK, removed it now, re-download the app please (version 2.2) that will be an APK and you can install it using adb or copy it over to the slave device.
Ok, Emil,
I copied 2.2.zip file from desktop PC to smartphone SD Card via USB cable, but I can not open it on smartphone.
On desktop pc I can not see any *.apk file inside 2.2.zip file
Where is AAGateWay.apk file? A previous downloaded 2.3.zip look similar to 2.2.zip file. I can not find apk file.
:)
Emil,
Seems everything is all right now . . . After installing archive extractor application on smartphone, AAGateWay.apk was successfully installed on smartphone.
Now, I must get in my Suzuki.
Happy new year !!!
 
Last edited:

Emil Borconi

Recognized Developer
Feb 18, 2008
3,207
2,906
Tg. Secuiesc / Kezdivasarhely
Ok, Emil,
I copied 2.2.zip file from desktop PC to smartphone SD Card via USB cable, but I can not open it on smartphone.
On desktop pc I can not see any *.apk file inside 2.2.zip file
Where is AAGateWay.apk file? A previous downloaded 2.3.zip look similar to 2.2.zip file. I can not find apk file.
Don't know how you got a zip, that should be the apk, rename the zip to apk
 

ZP2XdaDev

New member
Jul 19, 2019
4
0
Don't know how you got a zip, that should be the apk, rename the zip to apk
Emil,
Well, that was because my linux machine saved file without extension.
Seems everything is all right now . . . After installing archive extractor application on smartphone, AAGateWay.apk was successfully installed on smartphone.
Now, I must get in my Suzuki.
Happy new year !!!
 

baaca

New member
Oct 24, 2020
1
0
Master is running android 10 (BV6300Pro not-root), slave - MK809V android 5.1.1, car - Toyota ProAce Verso
  1. Running in root mode: (Yes)
  2. If running in non-root mode, is the splashscreen visible on the car: (N/A)
  3. If running in non-root mode, did you set the masters BT inside AAGW app?: (Yes)
  4. Did the slave actually turned on the hotspot on the slave: (Yes)
  5. On the master did you select the slaves BT in the Wifi Launcher app?: (Yes)
  6. When the master connected to the car's BT did the Wifi launcher app started up?: (Yes)
  7. Did the master connected to the slaves hotspot?: (Yes)
  8. Did the AA icon appeared on the master at all (in the notification bar)?: (Yes)
In car display is connection icon allowed and after first press on it I can see in mobile some "Android Auto would like" setting. I am not able to finished this settings, Next button is not working and app gets stuck. In car display is showen only error. Next press on icon does not toggel up this dialog on mobile and only showen same error in car. AAGateway in version 2.2 downloaded few days before dev lab went down. Any idea how to solve it? thx
 

Attachments

  • Screenshot_20210112-234807.jpg
    Screenshot_20210112-234807.jpg
    29.7 KB · Views: 172

khanh3t

New member
Jan 31, 2012
1
0
Thank you Emil,
I had test with banana pi m2 zero with ver 1.0 alpha and 2.2
Both of version google assistant is lag and can't recognize correct. With 2.2 very lag
 

peeeter

New member
Sep 18, 2007
1
0
Paypal payments are not working on the site for me. I tried paying with a credit card link and the paypal link. In both cases, the "Processing, Please Wait" screen, and it stalls there. I don't see account activity in PayPal or on my Credit Card, and putting my email address into the downloads page finds no purchases with that email.

I tried in Chrome and Safari on Mac.

I tried 30 minutes later with a different credit card and it went through, so I'm not sure if it's an issue with the site getting back errors from PayPal, or if it's all on PayPal's side.

I'm happy to recreate it if it will help you troubleshoot.

Thank you,

Peter
 
Last edited:

we87

Senior Member
Oct 15, 2008
52
11
Master is running Pie or above and slave is tethering:
  1. Running in root mode: (No)
  2. If running in non-root mode, is the splashscreen visible on the car: (Yes)
  3. If running in non-root mode, did you set the masters BT inside AAGW app?: (Yes)
  4. Did the slave actually turned on the hotspot on the slave: (Yes)
  5. On the master did you select the slaves BT in the Wifi Launcher app?: (Yes)
  6. When the master connected to the car's BT did the Wifi launcher app started up?: (Yes)
  7. Did the master connected to the slaves hotspot?: (No)
  8. Did the AA icon appeared on the master at all (in the notification bar)?: (Yes)
Master: Samsung Galaxy S20 FE running Android 10
Slave: OnePlus 3T running Android 8
Car: Volkswagen Jetta

I get the splash screen on the dash, the master brings up android auto and then immediately crashes and re-opens. I have not gotten this to work yet. I am not 100% sure what else to try.
 

arl16

Senior Member
Jun 6, 2008
273
102
Eldersburg, MD
Hi Emil - Thanks for your work on this.

I purchased and downloaded 2.2 on my (slave) Unrooted Samsung S8 running Android PIe. When I try to install, I'm getting the error, "There was a problem parsing the package". Any tips on getting this running would be appreciated.

PS I have an old, rooted S5 lying around I could use if you think that would work better. Thanks!
 

alanzhurq

New member
Feb 3, 2021
2
0
Hi Emil - Thanks for working on Wireless AA.

I just purchased and downloaded 2.2p on my slave rooted Samsung S6. and able to pair BT with my master Samsung S20+, also my master phone has connected with HUR wifi name after I plug in my slave phone with my car. But my S20+ just keeps refreshing and my car doesn't show anything about AA. Could you help me where I made mistake? I have recorded a long video but I can't upload it here since it is too big.
you can see my master phone(record phone) keep refreshing while connecting with the slave phone. And just let you can see I have connected everything, not sure where I missed it.

Much apprecaited!
Alan
 

mason10198

New member
Feb 3, 2021
1
0
Hi everyone,
I have this nearly working...
  • SLAVE: Samsung Galaxy S4 Active / AT&T / ROOTED / Android 5.0.1
  • MASTER: Samsung Galaxy S9+ / AT&T / Stock / Android 10
  • Case 1
Everything seems to be working up until the point that the two devices should be connecting to each other via WiFi. The slave is not creating a hotspot. I cannot manually turn on the hotspot either, since the phone has no SIM or plan (toast message like - "Insert SIM to use this..."). I was under the impression that AAGateway would (on a rooted device) force the hotspot to enable regardless of activation status, but it does not seem to work in my case.

Does anyone have more insight into this?
 

alanzhurq

New member
Feb 3, 2021
2
0
Hi Emil - Thanks for working on Wireless AA.

I just purchased and downloaded 2.2p on my slave rooted Samsung S6. and able to pair BT with my master Samsung S20+, also my master phone has connected with HUR wifi name after I plug in my slave phone with my car. But my S20+ just keeps refreshing and my car doesn't show anything about AA. Could you help me where I made mistake? I have recorded a long video but I can't upload it here since it is too big.
you can see my master phone(record phone) keep refreshing while connecting with the slave phone. And just let you can see I have connected everything, not sure where I missed it.

Much appreciated!
Alan

Update:

I reinstall a new ROM for my slave phone, and it isn't working still. My car can detect the slave now, however, it will disconnect immediately and ask me to plug it again. I tried so many times, it only shows AAwireless waiting for Master one or two times, but it only stays for 2 sec and gone....


    1. Running in root mode: (No) Before Slave was rooted, but after I reinstall ROM it isn't
    2. If running in non-root mode, is the splashscreen visible on the car: (No) Car keeps showing AA disconnected, unplug and replug in your phone. But there two times it shows AAGateway waits for Master, but it only kept for 1 sec and disconnect again.
    3. If running in non-root mode, did you set the masters BT inside AAGW app?: (Yes)
    4. Did the slave actually turned on the hotspot on the slave: (Yes)
    5. On the master did you select the slaves BT in the Wifi Launcher app?: (Yes)
    6. When the master connected to the car's BT did the Wifi launcher app started up?: (Yes)
    7. Did the master connected to the slaves hotspot?: (Yes)
    8. Did the AA icon appeared on the master at all (in the notification bar)?: (Yes) Not sure actually. There are so many things that pop up on Master phone when I plug a slave phone with the car.
 
Last edited:

zell180

Member
Apr 13, 2011
22
5
Hi Android Auto should be installed both on Slave and Master or only Master?

I'm trying with Samsung S8 (Android 9 root) as Slave and Samsung S10 Lite (Android 11 no-root)
Car is Mercedes GLA H247 with MBUX
When i connect slave i see that he do what i expect, AndroidAuto open on Master but soon close

Master is running Pie or above and slave is tethering:
Running in root mode: Yes
Did the slave actually turned on the hotspot on the slave: Yes
On the master did you select the slaves BT in the Wifi Launcher app?: Yes
When the master connected to the car's BT did the Wifi launcher app started up?: Yes and soon close
Did the master connected to the slaves hotspot?: Yes
Did the AA icon appeared on the master at all (in the notification bar)?: Yes but disappear soon
 
Last edited:

akhilareekal

New member
May 3, 2014
1
0
Purchased the app few days back and its Awsome! (y)(y)

Master Device - LG G8x - Stock Rom Android 10
Slave Device - Redmi 4 - Rom Lineage 14.1 with ROOT (Android Version 7.1) - Somehow Couldnt get it worked with the slave device running Oreo+ ROMs

The only issue i face is every first time the slave device is connected to HU after a reboot the prompt "if you want to use AAGW as the default app for this action" pops up. If i select always it never shows up for suceeding connections until the phone reboots again.

With the custom rom i get around 5-6 days of standby time in the slave device but whenver i keep the car unused for more than a week and then i have to switch on the slave device and have to wait for the pop up and press always to get it working again. I was planning to hide the slave device under the glovebox and hide all the wiring for a neat setup. But this one simple issue is holding me back from it :cautious::cautious: .

Is there any workaround??:unsure::unsure:
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    when will this be available for purchase on the google play store? i refuse to support paypal and their business practices in any manner. thanks.
  • 111
    Background
    - Couple of years ago Google have launched Android Auto, but up till recently the only way to connect your device to the car/head unit was to plug in a USB cable. As of 2018 this starts to change, BUT it looks like you will need to get new hardware for this and older cars/head units won't be upgraded to support this, neither phones with older OS.

    Concept
    - Since many of us will like to have this wire free but not ready / willing or have the possibility to upgrade the units/cars/phones I have thought of a way to achieve this, by using a small auxiliary device, like for example a very cheap and basic Android TV stick, which can be plugged in/mounted in the car and which can fulfil the roll of a Wifi antenna for your car.

    This app should allow you to transform any android powered device into a Wifi receiver for your Android Auto compatible Car/Headunit. Please do not confuse Android Auto, with Android powered headunit (usually Chinese, like MTCB, MTCD, Joying, etc).

    AAGateWay Documentation.

    Beta released (04.01.2020)

    What is it?

    AAGateWay is a an app which should allow you to use an auxiliary (slave) device to connect your existing Android Auto compatible car to your phone (master) using a hotspot created on your phone.

    How to use it?

    SLAVE SETUP


    1) Install the app using XDA Labs (Only on SLAVE) : https://www.b3itlabs.com/prod.php?id=3
    2) Configure

    • FOR BOTH ROOTED AND NOT-ROOTED SLAVES
      • CASE 1: Master is running Pie or higher
        1. Pair Master and Slave over BT (do this from the normal BT settings)
        2. Open app
        3. If slave is ROOTED and ONLY if you are using a TV STICK convert the app to system app. (if app not visible after conversion, reboot device)
        4. Enable the start tethering option (If asked make sure you manually configure the hotspot, to have the name HUR and the password AndroidAutoConnect)
        5. Select the masters phone BT MAC
        6. Exit
      • CASE 2: Master is running Android 8 or lower
        1. Create a Wifi hotspot from the master
        2. Connect slave to it
        3. Reopen AAGateWay and select the masters hotspot from the "Phone Wifi SSID" list
    • Slave is ROOTED - This will give a much bigger compatibility with cars, it should work with any car/unit (but depends a lot on the slave used, read below)
    • Slave is NOT ROOTED - This mode won't work on all cars and it has caveats.


    MASTER SETUP


    • CASE 1: Master is running Pie or higher
      1. Install WiFi Launcher for HUR (https://play.google.com/store/apps/details?id=com.borconi.emil.wifilauncherforhur)
      2. Make sure WiFi Launcher is version 2.1 or higher!!!
      3. Open WiFi Launcher
      4. FOR Android 10, set permission location to ALWAYS!!!!!!
      5. Select slaves BT from the BT list and exit
      6. DO NOT ENABLE ANY OF THE OTHER OPTIONS!!!!
    • If you do not want to use WiFi Launcher you can use the following Tasker task to launch AA on any condition you want: https://drive.google.com/file/d/1UO-Z5P0oQpHEdrQjYqvSM48L1TI-K5g8/view?usp=sharing
    • CASE 2: Master is running Android 8 or lower
      1. Open Android Auto, go to Settings, scroll down tap the version 10 times, then from the 3 dotted top right corner select start headunti server.
      2. Exit Android Auto
      3. Leave the Headunit Server running
      4. When you get into the car turn on the hotspot on the master (or use Tasker, automate or anything else do that for you)



    CONNECTING
    • Go to the car, plug in the slave to the car's USB and start the car
    • Slave is ROOTED
      • Nothing should happen, car should NOT detect the phone (SLAVE) at this stage. If the car does detect the slave being connected, it means your slave doesn't allow a proper USB toggle, in which case you should try enabling non-root mode.
      • Master is Pie and above
        1. If you selected to tether from the slave, at this point you should see the slave turning on the hotspot, otherwise you might see the slave trying to connect to a Wifi network.
        2. Slave will notify master
        3. Master will automatically start WiFi Launcher
        4. Master will connect to slaves hotspot
        5. Master will start AA on the phone and notifies slave
      • Slave will enable USB
      • If you are using a phone as slave you will get a prompt if you want to use AAGW as the default app for this action, make sure you select ALWAYS ans yes. (TV stick should work automatically)
      • Projection should start
    • Slave is NOT-ROOTED (or running in non-root mode)
      • You will get a prompt to use AAGateWay for this action, make sure you select always.
      • Car should display a splah-screen saying waiting for master. (on some car's screen you might see a scrambled image)
      • After splash-screen is displayed, the slave will start tethering, or will try to connect to the masters hotspot depending on the setting.
      • Once a network connection is established between the 2 devices, you will see the AA icon turning on on the master and Android Auto should be displayed on the car's screen. It is possible that the screen will stay /turn black, if that happens, you can try to press the home button on the infotainment system, then re-open Android Auto on it.

    Troubleshoot and getting help

    As the thread has so much information it will be really nice if we can try to stick to one format of troubleshooting, by using one of this 2 templates:

    • Master is running Pie or above and slave is tethering:
      1. Running in root mode: (Yes/No)
      2. If running in non-root mode, is the splashscreen visible on the car: (Yes/No)
      3. If running in non-root mode, did you set the masters BT inside AAGW app?: (Yes/No)
      4. Did the slave actually turned on the hotspot on the slave: (Yes/No)
      5. On the master did you select the slaves BT in the Wifi Launcher app?: (Yes/No)
      6. When the master connected to the car's BT did the Wifi launcher app started up?: (Yes/No)
      7. Did the master connected to the slaves hotspot?: (Yes/No)
      8. Did the AA icon appeared on the master at all (in the notification bar)?: (Yes/No)
    • Master is running Oreo or below and master is tethering:
      1. Running in root mode: (Yes/No)
      2. If running in non-root mode, is the splashscreen visible on the car: (Yes/No)
      3. If running in non-root mode, did you set the masters BT inside AAGW app?: (Yes/No)
      4. Did you select the masters hotspot name in AAGW?: (Yes/No)
      5. Have you started the Headunit server on the master?: (Yes/No)
      6. On the master did you select the cars BT in the Wifi Launcher app?: (Yes/No)
      7. When the master connected to the car's BT did the Wifi launcher app started up (notification bar)?: (Yes/No)
      8. Did the master turned on the hotspot?: (Yes/No)
      9. Did the slave connected to the masters hotspot?: (Yes/No)

    • Getting rid of all automation and manually starting it all (regardless of Android version on master and slave):
      1. Uninstall AAGW on the master
      2. Start the headunit server from within Android Auto on the master
      3. Create a hotspot on the master
      4. Open AAGW on the slave and make sure it's not set to tether
      5. in AAGW make sure you select the masters hotspot
      6. If AAGW is set to non-root mode make sure you select the masters BT (just press the button AAGW will do a BT scan of nearby devices and you can pick it from the list)
      7. Go to the car and plug the slave in
      8. Start the car
        • If slave is running in ROOT mode, slave will first try to connect to the masters Wifi and you will see a notification on the master that AA is running, only then the car should recognise a plugged in device.
        • If the slave is running in non-root mode, first you will see a splash screen on the car, then you will see slave connects to masters Wifi (if not already connected), then you will see AA starting on the master.
    • How do I collect a bug report / logcat
      1. Open Settings > About phone.
      2. Scroll down to the Build number.
      3. Tap the Build number 7 times in quick succession until "You're now a developer" appears.
      4. Return to the Settings menu and select Developer options.
      5. At the top of the screen, make sure 'Developer options' is set to On (green).
      6. Scroll down to Debugging and enable both USB debugging and Bug Report Shortcut on (green).
      7. Tab on Logger buffer sizes: Default setting is 256K. Select 16M to help capture more information for debugging. Of note, it can affect the apps performance especially with lower spec phone, so change it back after you have finished submitting bug reports.
      8. On slave make sure you enable debugging inside AAGW, on master open Android Auto go to developer settings and make sure force logging is enabled.
      9. Reproduce the problem
      10. Hold the Power button down until the menu appears.
      11. Select Take bug report. and wait for the device to capture the bug report.
      12. Tap the 'Bug report captured' notification when it appears.
      13. Send the bug report by email to [email protected]



    Know problems, workaround:
    • - Latency & lag. This will be really down to the devices you are using. I have tested it with a MK808B Plus, it work’s ok most of the time but occasionally you will get the odd lag. I’ve also tested it with a Nexus 7 tablet, and there was no lag at all, so device does matter, as well as probably ROM.
    • - I get random disconnection. There can be 2 causes for this, one the USB connection fails between the car and the auxiliary device, or the Wifi fails between the phone and the auxiliary device. In my tests I saw a few Wifi disconnections without any reason on the MK808, but non on the Nexus. Changing the tethering option from WPA2 to Open did help with this.
    • - App is closed without error or reason. The app runs in a background process, with a minimal interaction with the foreground, some devices/OS will kill background apps. I saw this happening on Nokia and I saw this happening on OnePlus as well. Try disabling battery optimisation for AAGateWay, that might help.
    • - I just cannot get it to work… Try using a phone, that will at least give you some visual guidance. Make sure that your device connects to the phone Wifi hotspot, make sure that AA Headunit server is running on the phone (try to force stop Goolge Play Services, stop and restart the headunit server)… All fails contact me
    • - Nothing happens on the master, using Wifi Launcher for HUR app. In this case, try to manually start the headunit server on the master, and manually turn on a hotspot, then reconfigure you're slave to connect to the masters hotspot (even if the master is running Pie or higher).


    Device compatibility:
    Master:

    Any phone which normally works with Android Auto

    Slave with ROOT:
    • - Tested and know to work: - MK809V, Nexus 7 (depending on rom), Sony X Compact (depending on rom)
    • -Tested and not working as expected: Pixel 2, MK808B
    • - While root is necessary, not all phones can toggle USB port on and off by software. And there can be other problems, for example on some devices when you turn off the USB the phone loses the ability to detect the power connection as well, which is use as trigger to start the whole process. It is almost impossible to predict if a phone will be a good slave candidate or not.

    Other things
    - Xiaomi phones (MIUI makes a mess), try not to use it for Slave
    - Generally older phones (pre oreo) are more likely to work fine as a slave device.

    Any suggested slave?
    - Yes, use an MK809V TV stick, as the experience with it, is pretty slick and it should work out of the box. If you get a MK809IV try to get the one with Android 5.1.1 as the one with Android 7.1 has problems with the tethering.

    FAQ.
    Q: Can I use this with any car and phone combination?
    A: Assuming your car is already Android Auto compatible, then YES.


    Q: Can I also automate the start of the Headunit server?
    A: Only with a rooted phone, using the following shell command: am startservice -W com.google.android.projection.gearhead/com.google.android.projection.gearhead.companion.DeveloperHeadUnitNetworkService

    Q: Can I use Wifi-Direct to connect instead of WIfi?
    A: No.

    Q: Does the traffic come out from my monthly data allowance?
    A: NO, traffic between auxiliary device and phone hotspot does NOT count as internet traffic, HOWEVER if you do have other apps on the auxiliary device which download updates, etc in the background that WILL be counted as internet traffic. So I suggest double check the apps on the aux device and disable all those which aren’t needed.


    Q: Will the car/head unit provide enough power?
    A: It should provide at least 500mA that’s the standard USB current, while I cannot guarantee that will be enough in all cases, it should do, assuming you do turn off all unneeded services on the TV stick.

    Q. What about start up time?
    A. It will depend a lot on the device you are using. A low-entry TV stick boot time is about 1 minute, which can be a bit too much for an initial car setup. As mentioned earlier, these devices usually have 2 USB ports, you can for example connect the power USB port to a continues power supply in the car, in which case the boot time will be non-existent since the device is always running. If you are using a phone, the phone battery will probably hold the charge just fine for a couple of days, if you disable all apps on it and you set up a profile to go into aeroplane mode when it’s not charging. Tasker or Automate are your friends for that. If you cannot connect the TV stick to a continues power source, you might consider using a small portable power pack which powers the tv stick (should hold power for a few days) and the power pack can be charged while the car is running.

    Q. Can I decrease boot time for TV Sticks/Phones by removing all unrelated software.
    A. Yes, actually quite a lot. Once you have your configuration ready and everything is working as expected, you can uninstall/disable all packages beside this ones:
    • package:android
    • package:com.android.apkinstaller
    • package:com.android.providers.settings
    • package:com.android.packageinstaller
    • package:com.notriddle.null_launcer (or any other launcher, but NULL launcher has no memory consumption, no app drawer no nothing, perfect for headless - see: https://github.com/notriddle/null-launcher )
    • package:com.android.inputmethod.latin
    • package:com.android.settings
    • package:uk.co.borconi.emil.aagateway
    • package:com.android.shell
    • package:com.android.systemui
    Easy way to list / disable all apps will be using a computer and following commands
    Code:
     adb shell pm list packages
    This will list all installed packages
    Code:
     adb shell pm disable xxxx
    where you replace xxxx with the package name (Ex: com.android.shell )


    Q. Will using Wifi 5Ghz give me better performance?
    A. Well if both of your devices support it, SURE!

    Q. Is the source code available?
    A. Sort-of, please see: https://github.com/borconi/AAGateWay this is only for the sketch, however new version does contain code which lift restrictions on 3rd party apps in Android Auto. To prevent the abuse of this by some, further code won't be updated to GitHub, however if you want to build your own version, please do contact me for details.


    Guarantee or Warranty
    - Due to the fact that there are so many possibilities and combinations of cars, head units, slave and master devices, there is no way for me to test all of them, however if you did purchase the software and you are not able to get it to work for any reason, please email me on [email protected] and I'm more then happy to refund the purchase.


    Teaser:
    24
    Good news, I've made the breakthrough I needed on the slave side, waiting for more confirmations but looks very promising.
    If all goes well I should be able to update the app on the next week or so, possibly to RC or stable state.
    22
    Updates from the Netherlands, CP & EB IT is officially opened :) next week I will start the work on the promo video then Kickstarter campaign is on....
    21
    Just got off the phone with the guys who are going to shoot the promo video, we should have that by no later then 23rd of August done, so I really hope that by that day the kick-starter will be live.
    21
    Hi guys.

    Sorry to be radio silent, indeed I was relatively busy with HUR and OBD2AA as well as other non Android Auto related work. Today I have finally managed to push out a stable release for HUR, and obd2aa is also doing pretty well, so in the next period I will continue to develop the AAGateWay, that being said my schedule looks like this:

    - This weekend, working all weekend, preparing photos from 5 different events across the UK so that will tied me up till Tuesday
    - Wednesday morning hitting the road (travelling to Romania - 3 days road trip)
    - I'm not sure how much I will be in Romania
    - October 20 I'm flying to the States for 2 weeks.

    So as you can see I will be quite a lot on the road, but I will take my Sony headunit and some dev tools with me to Romania and will carry on working, my target is to have a stable version of this app before I fly to the states.

    I will try to put together a list of most common problems I saw here and wishes tomorrow so you can all see and know what's happening as well as input new ideas if you have any.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone