• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Android 5.1.1 (B830) problem with eclipse/android studio/adb app installation

Search This thread

makalele2

Senior Member
Oct 17, 2011
89
11
I've found very annoying problem and I need your help

When I'm trying to install app via eclipse, android studio or console I'm very often getting an exception from adb:

iMac-Piotr:build piotr$ adb install /Users/piotr/git/alphabet/Alphabet.apk
8724 KB/s (38782865 bytes in 4.341s)
java.lang.UnsatisfiedLinkError: No implementation found for java.lang.String android.os.SystemProperties.native_get(java.lang.String, java.lang.String) (tried Java_android_os_SystemProperties_native_1get and Java_android_os_SystemProperties_native_1get__Ljava_lang_String_2Ljava_lang_String_2)
at android.os.SystemProperties.native_get(Native Method)
at android.os.SystemProperties.get(SystemProperties.java:64)
at android.os.Environment$UserEnvironment.<init>(Environment.java:144)
at android.os.Environment.initForCurrentUser(Environment.java:82)
at android.os.Environment.<clinit>(Environment.java:76)
at android.os.Environment.getLegacyExternalStorageDirectory(Environment.java:421)
at android.os.Debug.<clinit>(Debug.java:96)
at android.ddm.DdmHandleHello.handleHELO(DdmHandleHello.java:164)
at android.ddm.DdmHandleHello.handleChunk(DdmHandleHello.java:91)
at org.apache.harmony.dalvik.ddmc.DdmServer.dispatch(DdmServer.java:171)
java.lang.UnsatisfiedLinkError: android.os.Debug
at android.ddm.DdmHandleHello.handleFEAT(DdmHandleHello.java:176)
at android.ddm.DdmHandleHello.handleChunk(DdmHandleHello.java:93)
at org.apache.harmony.dalvik.ddmc.DdmServer.dispatch(DdmServer.java:171)
java.lang.UnsatisfiedLinkError: android.os.Debug
at android.ddm.DdmHandleProfiling.handleMPRQ(DdmHandleProfiling.java:187)
at android.ddm.DdmHandleProfiling.handleChunk(DdmHandleProfiling.java:88)
at org.apache.harmony.dalvik.ddmc.DdmServer.dispatch(DdmServer.java:171)
Aborted

I can't find any solid solution only workaround: restart eclipse/android studio, kill-start adb server, reconnect device. If it'll manage to work it only works for a short period of time.
Problem persists on 2 different machines with different usb cables. It's definitely some bug in lollipop (everything worked on kitkat), because as you can read on stackoverflow it happens on htc and asus devices too.
There are answers that manufacturers fixed them, but what can I do about Huawei?
I use Mac OS X so solutions for windows won't work for me.

I ofc have programmer mode on, usb debugging on, disabled confirmation on installation from adb. But the option "verify apps via usb" it grayed out and some people said that disabling it can make it working. Adb 1.0.32.