Android Auto NOT compatible with Huawei phones

Search This thread

WDawn

Senior Member
May 5, 2006
537
51
44
Zwevegem
Just a heads up for people that are looking out how to solve the issues with Huawei/honor phones with Android auto: Allthough this issue has been reported as early as 2016, this is still not solved. The newest models of both Honor and Huawei with Android Oreo still suffer from the same issue.

Phones reported NOT compatible with Android Auto:

Huawei P8
Huawei P8 Lite
Huawei P9
Huawei P9 Lite
Huawei P9 Plus
Huawei P10
Huawei P10 Lite
Huawei P10 Plus
Huawei Mate 8
Huawei Mate 9
Huawei Mate 9 Pro
Huawei Mate 10
Huawei Mate 10 Lite
Huawei Mate 10 Pro
Honor 6
Honor 6X
Honor 7X
Honor 8
Honor 9

Problems reported are
- black screen when connecting
- No in call screen
- Waze not working
- Media not playing correctly

I've made a facebook page to adress this issue and to gather the people confronted with this issue : https://www.facebook.com/Huawei-NOT-compatible-with-Android-Auto-187291041864969/
If you are faced with this issue, like and follow this page in order to put some pressure on Huawei/Google to solve this issue. I'll post every update/possible fix on this page. Let's hope there will be a fix asap.
@moderator of this forum: I don't want to spam this forum, just want to help out people that have this issue. Thanks for understanding.
 
Last edited:
  • Like
Reactions: midterm_2003

ahhl

Senior Member
Jul 23, 2007
1,073
114
i am on mate7. it works perfectly

Sent from my HUAWEI MT7-TL10 using Tapatalk
 

digeetal

Member
Oct 28, 2012
6
0
Is this xda page owned by the same person who created @huaweinotcompatiblewithandroidauto facebook profile?

Please add Honor 8, 9 and P9 Lite to the list.
 

weasley

Senior Member
Dec 23, 2004
269
11
My Mate 10 Pro BLA-L29 work perfectly with Android Auto on my Sony XAV-100 I don't understanding why people keep saying it not working
 

WDawn

Senior Member
May 5, 2006
537
51
44
Zwevegem
My Mate 10 Pro BLA-L29 work perfectly with Android Auto on my Sony XAV-100 I don't understanding why people keep saying it not working
I 'm on BLA-L29 too, and it's not working. Works perfectly with a Note so it's defenately the phone that messes up.

I have no in call screen on my head unit and with every reboot I have to wipe all data of AA to make it kinda work.

Using stock cable btw.
 

weasley

Senior Member
Dec 23, 2004
269
11
I 'm on BLA-L29 too, and it's not working. Works perfectly with a Note so it's defenately the phone that messes up.

I have no in call screen on my head unit and with every reboot I have to wipe all data of AA to make it kinda work.

Using stock cable btw.

I am using the stock cable as well . And no issue at all so it definitely not the phone .

It work every time I plugged in the Mate 10 Pro to my Sony XAV100
 

WDawn

Senior Member
May 5, 2006
537
51
44
Zwevegem
I am using the stock cable as well . And no issue at all so it definitely not the phone .

It work every time I plugged in the Mate 10 Pro to my Sony XAV100
You're lucky :D

Just trying to narrow this issue down

What's your build? Here I have 8.0.0.29 (C432) in Belgium.

Very weird that some units have it, others don't.
 
Last edited by a moderator:

weasley

Senior Member
Dec 23, 2004
269
11
you're lucky :d

just trying to narrow this issue down

what's your build? Here i have 8.0.0.29 (c432) in belgium.

Very weird that some units have it, others don't.


8.0.0.128 c636
 

Attachments

  • IMG_20180205_193354.jpg
    IMG_20180205_193354.jpg
    136.4 KB · Views: 5,007
Last edited by a moderator:

Infinity03

Member
Nov 14, 2010
31
4
Call screen not working on Honor 7x, reverts to using the built in dialer .

Edit: Waze doesn't work either.
 
Last edited:
  • Like
Reactions: WDawn

nickfrost

Member
Mar 31, 2011
9
3
Huawei Mate 10 Pro here (BLA-L229 8.0.0.128(C636)), not working with AA as well. Sometimes I am able to see the time and temperature in the top right corner. Otherwise everything is black. After disconnecting the phone, the screen stays blank until I turn off the car.
The same in-dashboard screen works perfectly with a Samsung Galaxy S7 and an iPhone 6s (CarPlay). Tried different cables (original too) and tried reinstalling AA, but no luck.
Car is a North American Chevrolet Cruze 2016.
 
  • Like
Reactions: WDawn

Nikorasu

Senior Member
Jan 2, 2010
327
103
Mate 9 (Nougat and Oreo) AA working fine MINUS CALL SCREEEN, with Pioneer Z5050BT, although Waze was wonky from the start (Nov-Dec '17). With AA 3.0, everything seems quite stable on Mate9.

P10+ Nougat freezes often despite having the same setup. Funny cause they are using similar hardware.
 
Last edited:

Dadatt

Member
Mar 17, 2012
28
8
Honor View 10 does not work with 2017 Seat Leon with Full Link
Only black screen. I can hear Spotify and G assistant - any chance that Huawei/Honor will fix that?
 
  • Like
Reactions: midterm_2003

Shriioz

New member
Feb 27, 2018
1
0
Android auto aka AA, works with Huawei p10, 02/27-2018

Greatings from Denmark!!

Just installed AA on my p10 today, so it works now. I installed it from apkmirror the newest version.

If AA is not avaliable in your country, then use a vpn(set to Germany) . That's what I did since AA is not avaliable in Denmark. After setup and testing AA Uninstall vpn and you are all golden!!!!!

I got this working on a seat Ibiza 2016 1,0 tsi orginal multimedia radio.
 

manstrategist

New member
Mar 5, 2018
1
0
My Honor 6x keeps giving me the message "to use android auto please park your car and check your android phone" Nothing works and I keep getting the standard USB port message asking me to hwether I want to use just for charging or MTP . But my choice always defaults to charging and AA does not work. AA loads on the phone but nothing on my Pioneer 5090BT HU. I am on EMUI 5.0. BLN-L22C65B340. Please help.
 

Radish95

Member
Jul 15, 2016
20
2
P9 Lite here and all seems to work well. never had a problem with my new car (AA 3.0)

Edit: all work on stock apps. If i try to install something like waze or others it freeze for 2/3 sec then it give me black screen and i have to disconnect the phone.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Just a heads up for people that are looking out how to solve the issues with Huawei/honor phones with Android auto: Allthough this issue has been reported as early as 2016, this is still not solved. The newest models of both Honor and Huawei with Android Oreo still suffer from the same issue.

    Phones reported NOT compatible with Android Auto:

    Huawei P8
    Huawei P8 Lite
    Huawei P9
    Huawei P9 Lite
    Huawei P9 Plus
    Huawei P10
    Huawei P10 Lite
    Huawei P10 Plus
    Huawei Mate 8
    Huawei Mate 9
    Huawei Mate 9 Pro
    Huawei Mate 10
    Huawei Mate 10 Lite
    Huawei Mate 10 Pro
    Honor 6
    Honor 6X
    Honor 7X
    Honor 8
    Honor 9

    Problems reported are
    - black screen when connecting
    - No in call screen
    - Waze not working
    - Media not playing correctly

    I've made a facebook page to adress this issue and to gather the people confronted with this issue : https://www.facebook.com/Huawei-NOT-compatible-with-Android-Auto-187291041864969/
    If you are faced with this issue, like and follow this page in order to put some pressure on Huawei/Google to solve this issue. I'll post every update/possible fix on this page. Let's hope there will be a fix asap.
    @moderator of this forum: I don't want to spam this forum, just want to help out people that have this issue. Thanks for understanding.
    1
    Huawei P10 with Oreo Beta from Spain.

    Incoming call and media not working.
    1
    Call screen not working on Honor 7x, reverts to using the built in dialer .

    Edit: Waze doesn't work either.
    1
    Huawei Mate 10 Pro here (BLA-L229 8.0.0.128(C636)), not working with AA as well. Sometimes I am able to see the time and temperature in the top right corner. Otherwise everything is black. After disconnecting the phone, the screen stays blank until I turn off the car.
    The same in-dashboard screen works perfectly with a Samsung Galaxy S7 and an iPhone 6s (CarPlay). Tried different cables (original too) and tried reinstalling AA, but no luck.
    Car is a North American Chevrolet Cruze 2016.
    1
    Honor View 10 does not work with 2017 Seat Leon with Full Link
    Only black screen. I can hear Spotify and G assistant - any chance that Huawei/Honor will fix that?