Android: Chrome latest update - Recent searches building up under search bar. How to remove?

Search This thread

Hand76

Senior Member
Jul 1, 2010
929
168
Long Island N.Y.
I find this so annoying. And it just started about a week ago on all my Android devices after updating Chrome.

I want to stop Recent Searches (those little magnifying glasses) from appearing under the search bar in Chrome. Or turn off search history altogether. Turning off web activity doesn't work with Chrome. I can't find anything to stop this.

Thanks in advance
 
Last edited:
Dec 3, 2022
14
8
To stop Recent Searches from appearing under the search bar in Google Chrome, you can follow these steps:

  1. Open Google Chrome and click on the three dots in the top-right corner of the browser window to open the menu.
  2. In the menu, click on "Settings" to open the Settings page.
  3. In the Settings page, click on the "Search engine" section on the left side of the page.
  4. In the "Search engine" section, you will see an option called "Manage search engines." Click on this option to open a list of all the search engines that you have added to Chrome.
  5. In the list of search engines, find the one that you use as your default search engine, and click on the three dots next to it to open the context menu.
  6. In the context menu, click on "Edit" to open the edit window for that search engine.
  7. In the edit window, you will see a checkbox next to the option called "Show search suggestions as you type." Uncheck this box to disable the Recent Searches feature.
  8. Click on "Save" to save your changes and close the edit window.
After following these steps, Recent Searches should no longer appear under the search bar in Google Chrome. If you want to enable the feature again in the future, you can follow the same steps and check the "Show search suggestions as you type" box again.
 
  • Like
Reactions: Hand76

Hand76

Senior Member
Jul 1, 2010
929
168
Long Island N.Y.
To stop Recent Searches from appearing under the search bar in Google Chrome, you can follow these steps:

  1. Open Google Chrome and click on the three dots in the top-right corner of the browser window to open the menu.
  2. In the menu, click on "Settings" to open the Settings page.
  3. In the Settings page, click on the "Search engine" section on the left side of the page.
  4. In the "Search engine" section, you will see an option called "Manage search engines." Click on this option to open a list of all the search engines that you have added to Chrome.
  5. In the list of search engines, find the one that you use as your default search engine, and click on the three dots next to it to open the context menu.
  6. In the context menu, click on "Edit" to open the edit window for that search engine.
  7. In the edit window, you will see a checkbox next to the option called "Show search suggestions as you type." Uncheck this box to disable the Recent Searches feature.
  8. Click on "Save" to save your changes and close the edit window.
After following these steps, Recent Searches should no longer appear under the search bar in Google Chrome. If you want to enable the feature again in the future, you can follow the same steps and check the "Show search suggestions as you type" box again.

Just realized I didn't specify Android. Going to edit my post but thank you. Unfortunately this doesn't work in Chrome for Android. No option to manage search engines
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    That's the flag you need to disable guys
    #organic-repeatable-queries
    1
    That's the flag you need to disable guys
    #organic-repeatable-queries
    Seems to work fine! I really appreciate the info. Can't thank you enough.
  • 1
    To stop Recent Searches from appearing under the search bar in Google Chrome, you can follow these steps:

    1. Open Google Chrome and click on the three dots in the top-right corner of the browser window to open the menu.
    2. In the menu, click on "Settings" to open the Settings page.
    3. In the Settings page, click on the "Search engine" section on the left side of the page.
    4. In the "Search engine" section, you will see an option called "Manage search engines." Click on this option to open a list of all the search engines that you have added to Chrome.
    5. In the list of search engines, find the one that you use as your default search engine, and click on the three dots next to it to open the context menu.
    6. In the context menu, click on "Edit" to open the edit window for that search engine.
    7. In the edit window, you will see a checkbox next to the option called "Show search suggestions as you type." Uncheck this box to disable the Recent Searches feature.
    8. Click on "Save" to save your changes and close the edit window.
    After following these steps, Recent Searches should no longer appear under the search bar in Google Chrome. If you want to enable the feature again in the future, you can follow the same steps and check the "Show search suggestions as you type" box again.
    1
    I just uninstalled latest update and this problem solved.
    1
    That's the flag you need to disable guys
    #organic-repeatable-queries
    1
    That's the flag you need to disable guys
    #organic-repeatable-queries
    Seems to work fine! I really appreciate the info. Can't thank you enough.