Android Oreo immersive mode problems

Search This thread

0hfrankieboy

Member
Oct 10, 2016
33
16
Does anyone experience extreme lag when using immersive mode on Oreo? I find that my phone lags when trying to turn the screen back on. It is especially evident when the screen has been off for more than 10 minutes. It is so bad that I cannot answer phone calls if the screen has been off for a few minutes as I hear the ringtone but the screen stays black. Does anyone know of a solution ? Immersive mode is a must have for me and I will have to revert to nougat for the time being if no solution is available.
 

0hfrankieboy

Member
Oct 10, 2016
33
16
I had the same problem and battery drain. Try using the following command to enter immersive mode. It fixed the lag and battery drain for me.

adb shell settings put global policy_control immersive.navigation=apps,-com.google.android.googlequicksearchbox


This did the trick! I just changed .navigation to .full so I could get the status bar to hide too.
Thank you
 

coolhandz

Senior Member
Apr 1, 2011
357
98
Denver
I had the same problem and battery drain. Try using the following command to enter immersive mode. It fixed the lag and battery drain for me.

adb shell settings put global policy_control immersive.navigation=apps,-com.google.android.googlequicksearchbox

Do you enter this command into terminal emulator? Just the same way you wrote starting with "adb shell."
 

Ezrem

Senior Member
Jun 30, 2008
60
11
I had the same problem and battery drain. Try using the following command to enter immersive mode. It fixed the lag and battery drain for me.

adb shell settings put global policy_control immersive.navigation=apps,-com.google.android.googlequicksearchbox

What kind of battery drain? I had lag on Oreo before I went back to Nougat, and also weird battery issues like apps reporting hours of use when they were only on screen for minutes.

If nav bar hiding was the cause of both issues I might try Oreo again.
 

bokononfoma

Member
Nov 25, 2013
10
18
What kind of battery drain? I had lag on Oreo before I went back to Nougat, and also weird battery issues like apps reporting hours of use when they were only on screen for minutes.

If nav bar hiding was the cause of both issues I might try Oreo again.

Yes. I had similar experience. I did a factory reset but still had the problem. Hiding the nav bar was the cause, and using this command fixed the problem.
 
  • Like
Reactions: housepabldroid

JimSmith94

Senior Member
Jul 21, 2007
2,743
522
Midlothian, TX

boojay

Senior Member
Oct 15, 2010
633
164
Is there a way to couple this command with Tasker so we can pick and choose which apps are immersive? That's how I've been doing it with Custom Navigation Bar, i.e. creating immersive profiles and enabling/disabling them for specific apps. Now thanks to this thread, I'm finding out it's probably what's causing my wake problems.
 

bush911

Senior Member
Oct 12, 2012
557
91
重庆
Thank you sir, this has been bothering me so long since Oreo update.
I have done factory reset, done clean update, cleaned the internal storage etc...
your comments really works for me.
I had the same problem and battery drain. Try using the following command to enter immersive mode. It fixed the lag and battery drain for me.

adb shell settings put global policy_control immersive.navigation=apps,-com.google.android.googlequicksearchbox
 

housepabldroid

Senior Member
Apr 8, 2012
83
11
Genoa
Guys i use "tiles" and among the various options there is the tile for "immersive mode".
Works with all apps.

Just Whatsapp has some problem: if you enter emoji, the insertion bar disappears and you have to click the "back" button to see everything.
 
Last edited:

Atomregen

Senior Member
Dec 9, 2010
385
163
Is there a way to couple this command with Tasker so we can pick and choose which apps are immersive? That's how I've been doing it with Custom Navigation Bar, i.e. creating immersive profiles and enabling/disabling them for specific apps. Now thanks to this thread, I'm finding out it's probably what's causing my wake problems.

You can run the command as a shell, you also have to check use root.

Sent from my Pixel XL using XDA Labs
 

boojay

Senior Member
Oct 15, 2010
633
164
So I've been testing another workaround for the past 24 hours and it seems to be working. It's actually a really simple solution that makes use of my first post about using Tasker to enable/disable immersive profiles for specific apps. All I did was add a task that disabled immersive mode whenever I turn off my screen, and voila, no more delays when waking the phone.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 16
    I had the same problem and battery drain. Try using the following command to enter immersive mode. It fixed the lag and battery drain for me.

    adb shell settings put global policy_control immersive.navigation=apps,-com.google.android.googlequicksearchbox
    5
    How did you make a taker profile by chance? I got a bunch but can't seem to get this right with tiles installed. I'm not rooted as well but the delay is really bugging me.
    Sorry for the slow response. This is the current setup I have and it works perfectly. If you're using Custom Navigation Bar (CNB) to activate immersive mode, I did it as follows:

    1) Create two profiles in CNB, one called Immersive and one called Navigation (or whatever you'd like to call them). Those naming schemes should be pretty self-explanatory as to what each profile is meant to do and you should set them up accordingly within that app. In case it's not clear though, set up Immersive to hide the status bar and/or Nav bar. Conversely, set Navigation to do the opposite.

    2) Next, within Tasker, you'll create two tasks, also called Immersive and Navigation (or again, whatever you'd like to call them). For the Immersive task, select +, Plugin, CNB, Action > Enable Profile, Select Profile > Immersive. Within the same Immersive task, add a second line by again selecting +, Plugin, CNB, Action > Disable Profile, Select Profile > Navigation. For the Navigation task, follow the exact same steps, but choose the appropriate (opposite) CNB profiles instead.

    3) For app-specific immersion, in Tasker profile, select +, Application, choose all apps you'd like to be Immersive, then pick Immersive as the task and add Navigation as the exit task.

    4) Finally, create another Profile by selecting +, State, Display, Display State, Off, and pick the Navigation task.

    You can fiddle around with that and probably just skip step 3) to create a Profile activating the Immersive task whenever you turn the screen on and conversely, the Navigation task when you turn the screen off, but this is how I like mine to work, with per app-specific immersive mode.
    2
    Does anyone experience extreme lag when using immersive mode on Oreo? I find that my phone lags when trying to turn the screen back on. It is especially evident when the screen has been off for more than 10 minutes. It is so bad that I cannot answer phone calls if the screen has been off for a few minutes as I hear the ringtone but the screen stays black. Does anyone know of a solution ? Immersive mode is a must have for me and I will have to revert to nougat for the time being if no solution is available.
    2
    I had the same problem and battery drain. Try using the following command to enter immersive mode. It fixed the lag and battery drain for me.

    adb shell settings put global policy_control immersive.navigation=apps,-com.google.android.googlequicksearchbox


    This did the trick! I just changed .navigation to .full so I could get the status bar to hide too.
    Thank you
    2
    Nevermind, found the command.
    settings put global policy_control immersive.navigation=
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone