Android Q: Viper4android compatible?

Search This thread

Knxed_

Senior Member
Oct 14, 2015
83
17
N/A
I've been trying to get viper4android working on Android q for quite some time but the module and the app itself does not want work at all. Plus when viper asks you to install the driver from the app it will end up in a bootloop. Has anybody found a temp workround for it?

Device: Pixel 2 XL Android version: Q Beta 3
 

1959best

Member
May 1, 2018
12
3
Samsung Galaxy S21
Always used the magisk repo version before- I tried this many times on Q, with and without AML, but always got the dreaded install driver dialogue. Also tried SE Linux permissive, but no luck. I've never used the apk before, but am sat here now listening to music quite happily. It's survived a couple of reboots (just checking).
 

Knxed_

Senior Member
Oct 14, 2015
83
17
N/A
Ok, got it working on beta 3, using the apk 2.7.1.0 from XDA. It appears to install as a magisk module, along with AML. It didn't work on my first try, then all was good. I need to run it in compatibility mode from the menu. https://labs.xda-developers.com/store/app/com.pittvandewitt.viperfx

Hm, I just tried that. I downloaded the one off XDA LABS and checked compatibility mode on the app. Still showing up as driver not installed. Viper4Android is literally the key element for my phones such a good module.
 

ifellouttabed

Member
Dec 27, 2012
23
18
Hm, I just tried that. I downloaded the one off XDA LABS and checked compatibility mode on the app. Still showing up as driver not installed. Viper4Android is literally the key element for my phones such a good module.

I just upgraded to Android 10 on my Pixel 2XL and have Viper running now. Download stable 2.7.1.0 from XDA Labs, grant root with Magisk. Check compatibility mode THEN install the driver. Restart, make changes, and then be sure to check "Attach audio effects" in settings once you make your changes.
 
I just upgraded to Android 10 on my Pixel 2XL and have Viper running now. Download stable 2.7.1.0 from XDA Labs, grant root with Magisk. Check compatibility mode THEN install the driver. Restart, make changes, and then be sure to check "Attach audio effects" in settings once you make your changes.
Mhh doesn't work for me this way.still asking for driver after reboot lol
 

Lbknight24

New member
Sep 4, 2019
1
0
Thanks. Worked for me on second try. Followed the instructions rebooted didn't work, installed drivers again rebooted and then it worked.
 

1dopewrx05

Senior Member

Ok, here's what you gotta do to get it to work, this is the ONLY method I've had consistently work for me from beta 3-public release(did it an hour ago and worked perfectly)

First, uninstall any viper you have also make sure you completely uninstall audio modification library if you have it installed, not disable, uninstall it and reboot after uninstalling what I've listed.

After you're all booted back up, install viper from labs (link in this thread)(Also, forget about compatibility mode, don't use it) now open viper but do NOT install the driver yet, just open the application then go to magisk and install audio modification library but dont let magisk reboot the phone after it installs. Once installation completed, go back to viper and install the driver and let it reboot. Once booted, go straight to magisk and DISABLE audio modification library (uncheck the box next to it if you dont get what I mean) don't uninstall it. After disabling AML head back to viper and install the driver again. Now once rebooted is the moment of truth, if you open viper and its installed you're obviously done but if it's not installed you have to take this next step: don't install the driver just yet, go to magisk and re-enable AML then back to viper and install the driver. I don't see why this would not work for you guys, I know this isn't the easiest tutorial to follow but make sure you follow it to a T, if you mess any step up you need to start from scratch and uninstall both AML and viper and start again.

Good luck guys and may the audiophile Gods be on your side through this process!:D
 

sidhaarthm

Senior Member
Mar 1, 2009
435
130
London, U.K.
Ok, here's what you gotta do to get it to work, this is the ONLY method I've had consistently work for me from beta 3-public release(did it an hour ago and worked perfectly)

First, uninstall any viper you have also make sure you completely uninstall audio modification library if you have it installed, not disable, uninstall it and reboot after uninstalling what I've listed.

After you're all booted back up, install viper from labs (link in this thread)(Also, forget about compatibility mode, don't use it) now open viper but do NOT install the driver yet, just open the application then go to magisk and install audio modification library but dont let magisk reboot the phone after it installs. Once installation completed, go back to viper and install the driver and let it reboot. Once booted, go straight to magisk and DISABLE audio modification library (uncheck the box next to it if you dont get what I mean) don't uninstall it. After disabling AML head back to viper and install the driver again. Now once rebooted is the moment of truth, if you open viper and its installed you're obviously done but if it's not installed you have to take this next step: don't install the driver just yet, go to magisk and re-enable AML then back to viper and install the driver. I don't see why this would not work for you guys, I know this isn't the easiest tutorial to follow but make sure you follow it to a T, if you mess any step up you need to start from scratch and uninstall both AML and viper and start again.

Good luck guys and may the audiophile Gods be on your side through this process!:D

Take a bow good sir, it worked! Had to follow the steps to the end as first time around it didn't work. Now seems to be alright (see attached) :D

For anyone else wondering, I upgraded from Aug 9.0 build to Q (020) last night by flashing the factory ROM without wipe. Rooted, ads disabled and now ViperFX working. Life is goooood :angel:
 

Attachments

  • Screenshot_20190905-111125.png
    Screenshot_20190905-111125.png
    141.8 KB · Views: 5,564
Take a bow good sir, it worked! Had to follow the steps to the end as first time around it didn't work. Now seems to be alright (see attached) :D

For anyone else wondering, I upgraded from Aug 9.0 build to Q (020) last night by flashing the factory ROM without wipe. Rooted, ads disabled and now ViperFX working. Life is goooood :angel:
I think it also worked for me now but in your screeny it says not enabled.same with me.
But i have all the options for speaker headphones usb etc.think it worked
 

sidhaarthm

Senior Member
Mar 1, 2009
435
130
London, U.K.
what do you mean with didnt enable it?
i did all the steps, i can adjust all settings but if i play something in g music it still says not enabled....what did i miss?

By enabling, I meant turning on the master limiter and other settings. I adjusted mine with a nice YouTube track playing in the background and it all worked a treat. Yet to do my Bluetooth earphones though :)
 

carelockh

Senior Member
Jan 19, 2012
140
47
35
Winston-Salem, NC
@1dopewrx05 I followed your mini tutorial to a T and it worked perfectly. Thank you for taking the time to do this, I really appreciate it. Just updated my old faithful to 10 earlier and gonna mess around with some of the neat features. I can't live without Viper, it's essential to me. :)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 108

    Ok, here's what you gotta do to get it to work, this is the ONLY method I've had consistently work for me from beta 3-public release(did it an hour ago and worked perfectly)

    First, uninstall any viper you have also make sure you completely uninstall audio modification library if you have it installed, not disable, uninstall it and reboot after uninstalling what I've listed.

    After you're all booted back up, install viper from labs (link in this thread)(Also, forget about compatibility mode, don't use it) now open viper but do NOT install the driver yet, just open the application then go to magisk and install audio modification library but dont let magisk reboot the phone after it installs. Once installation completed, go back to viper and install the driver and let it reboot. Once booted, go straight to magisk and DISABLE audio modification library (uncheck the box next to it if you dont get what I mean) don't uninstall it. After disabling AML head back to viper and install the driver again. Now once rebooted is the moment of truth, if you open viper and its installed you're obviously done but if it's not installed you have to take this next step: don't install the driver just yet, go to magisk and re-enable AML then back to viper and install the driver. I don't see why this would not work for you guys, I know this isn't the easiest tutorial to follow but make sure you follow it to a T, if you mess any step up you need to start from scratch and uninstall both AML and viper and start again.

    Good luck guys and may the audiophile Gods be on your side through this process!:D
    11
    After a few failed attempts with other methods, I tried the one posted by @1dopewrx05 here: https://forum.xda-developers.com/showpost.php?p=80185220&postcount=13, and it worked perfect on my OP7T Pro McLaren 5G (T-Mobile, Android 10, March security patch).

    To summarize:

    1. Install V4A stable from Labs
    2. Open V4A - do not install the driver
    3. Install Audio Modification Library (AML) Magisk Module - do not reboot after
    4. Open V4A - install the driver (auto reboot)
    5. Open Magisk - disable (uncheck) AML, do not reboot after
    6. Open V4A
      • if you are prompted to install the driver, allow it to install and reboot after
      • if you are not prompted to install the driver, reboot manually, then open V4A again, you will be prompted

    After the last install and reboot, V4A is working for me without needing to enable AML, or any compatibility settings in settings.
    7
    Maybe anybody will work with my method.
    Android 10 xiaomi.eu mi max 3.

    Install from magisk v4a reboot(don't install drivers)
    Install selinux permission and set on permissive reboot
    Install from magisk aml and reboot
    Go to app v4a install drivers and reboot
    When rebooting phone go to fastboot you must reboot it with recovery go to data/adb/modules/v4a
    Change name post-fs-data.sh to post-fs-data.bak and reboot to system.

    Go to app and Enjoy v4a ?
    4
    Glad that I could help guys:good: V4A has always been a must have for me so I definitely understood the urgency of you guys that couldn't get it going.
    3
    Ok, here's what you gotta do to get it to work, this is the ONLY method I've had consistently work for me from beta 3-public release(did it an hour ago and worked perfectly)

    First, uninstall any viper you have also make sure you completely uninstall audio modification library if you have it installed, not disable, uninstall it and reboot after uninstalling what I've listed.

    After you're all booted back up, install viper from labs (link in this thread)(Also, forget about compatibility mode, don't use it) now open viper but do NOT install the driver yet, just open the application then go to magisk and install audio modification library but dont let magisk reboot the phone after it installs. Once installation completed, go back to viper and install the driver and let it reboot. Once booted, go straight to magisk and DISABLE audio modification library (uncheck the box next to it if you dont get what I mean) don't uninstall it. After disabling AML head back to viper and install the driver again. Now once rebooted is the moment of truth, if you open viper and its installed you're obviously done but if it's not installed you have to take this next step: don't install the driver just yet, go to magisk and re-enable AML then back to viper and install the driver. I don't see why this would not work for you guys, I know this isn't the easiest tutorial to follow but make sure you follow it to a T, if you mess any step up you need to start from scratch and uninstall both AML and viper and start again.

    Good luck guys and may the audiophile Gods be on your side through this process!:D

    Take a bow good sir, it worked! Had to follow the steps to the end as first time around it didn't work. Now seems to be alright (see attached) :D

    For anyone else wondering, I upgraded from Aug 9.0 build to Q (020) last night by flashing the factory ROM without wipe. Rooted, ads disabled and now ViperFX working. Life is goooood :angel: