[Android R][OFFICIAL] Evolution X for Mi 9 Lite [pyxis]

Search This thread

Echo2124

Senior Member
  • Jan 29, 2017
    100
    31
    Melbourne
    Xiaomi Mi CC9 / Mi 9 Lite
    Hi!! I'm new and this is my first post at this forum :)

    I found a solution for a Bootloop when this rom is instaled first time. It's easy:

    - Install like instructions says, and when Evolution X install finish, before restart, go to Wipe menu at TWRP and format data again (delete word 'yes' and type again). Then reboot to system
    - When you stay at bootloop step, enter to TWRP
    - Then instal file att. below for "Disable Force Encryption (DFE)"
    - Reboot system and profit :)

    Sources Helped me:

    https://forum.xda-developers.com/t/...ained-and-with-benefits.3915179/post-81380769

    Doing that will break the lockscreen of your phone. As it Android 10 and above you can't use a PIN if you disable dm-verirty.
     

    Echo2124

    Senior Member
  • Jan 29, 2017
    100
    31
    Melbourne
    Xiaomi Mi CC9 / Mi 9 Lite
    Has anyone got this rom to work without flashing disable force-encryption/dm-verity beforehand. I want to use the latest version of this rom but if I don't flash DFE I just get bootloops. I would be great if the dev were to come out with a new version that rectifies this issue, as its clear that I am not the only one having issues with the latest version of the rom. Even when following the exact instructions line to line, I still get the same issue. I am on the latest EEA firmware and I did a clean flash, yet I get bootloops.
     

    pourmadeesse

    Senior Member
    Apr 6, 2011
    67
    9
    Has anyone got this rom to work without flashing disable force-encryption/dm-verity beforehand. I want to use the latest version of this rom but if I don't flash DFE I just get bootloops. I would be great if the dev were to come out with a new version that rectifies this issue, as its clear that I am not the only one having issues with the latest version of the rom. Even when following the exact instructions line to line, I still get the same issue. I am on the latest EEA firmware and I did a clean flash, yet I get bootloops.
    I use latest version without bootloop and no flashing to disable force-encryption.
    Maybe you should try to install April 6th version and when it's ok, you make clean install of latest version (April 11th)
     

    Accuface93

    Member
    Jan 17, 2018
    22
    1
    I use latest version without bootloop and no flashing to disable force-encryption.
    Maybe you should try to install April 6th version and when it's ok, you make clean install of latest version (April 11th)
    I checked it and it doesn't work. I have bootloop all the time. I really don't know how the last update works for you ...
     
    • Like
    Reactions: majster95

    DarkAngelGR

    Recognized Developer
    New Update is available!

    Download here
    Changelog here

    NOTE:
    1) CLEAN FLASH IS REQUIRED FOR THIS UPDATE (due to vendor update, else you get bootloop, hate me all you want xP).
    2) Some devices had bootloop issue on last update, this build worked fine for the tester so it should work for you as well.

    If you want to support me feel free to tip at Paypal which will help me pay the server costs.


    Don't forget to join my groups (https://t.me/dagrpyxis / https://t.me/EvolutionXPyxis) and my channel to be up-to-date (https://t.me/memegang_pyxis)

    Hope you enjoy this update
     

    KIngOrNot

    Senior Member
    Jun 25, 2013
    107
    29
    Bcn
    Battery consumption seems to be okay, NFC is also functional in the latest version. The only issue I've faced so far is that the buffer fix hasn't been applied which makes the camera pretty much not usable unless you install the bufferfix.
    Well, I just tried to install bufferfix and I couldn't do it. Don't know why. That wasn't a problem before.
     

    fumareddu

    Member
    Jul 14, 2017
    33
    6
    Well, I just tried to install bufferfix and I couldn't do it. Don't know why. That wasn't a problem before.
    It was the same for me in the previous build. For some reason i just couldn't install the buffer fix so i didn't do it.

    I guess i will be waiting a bit, at least until someone find the right buffer fix to flash and the procedure to do it. i use the camera everyday and i really can't work without it.
     

    KIngOrNot

    Senior Member
    Jun 25, 2013
    107
    29
    Bcn
    It was the same for me in the previous build. For some reason i just couldn't install the buffer fix so i didn't do it.

    I guess i will be waiting a bit, at least until someone find the right buffer fix to flash and the procedure to do it. i use the camera everyday and i really can't work without it.

    It was the same for me in the previous build. For some reason i just couldn't install the buffer fix so i didn't do it.

    I guess i will be waiting a bit, at least until someone find the right buffer fix to flash and the procedure to do it. i use the camera everyday and i really can't work without it.
    I found what I did wrong. In twrp when you mount vendor you have to mount system too. BUT you have to check that system is not mounted only read. Means, uncheck that option down on the screen.
    Edit- no, doesn't work
     

    fumareddu

    Member
    Jul 14, 2017
    33
    6
    I found what I did wrong. In twrp when you mount vendor you have to mount system too. BUT you have to check that system is not mounted only read. Means, uncheck that option down on the screen.
    Edit- no, doesn't work
    it ain't that, or at least it wasn't for me.

    I don't know if you made your test correctly though as since a few monts, TWRP has an option that basically unmount system everytime you flash a zip file so you gotta turn that off or it doesn't matter how many times you manually mount system it will always be unmounted as soon as you hit flash.

    When i did this however, i only managed to break my camera completely (with buffer fix flashed from magisk it simply acted as if the buffer fix wasn't there and freezed so i tried flashing manually) and it kept crashing everyime it launched and i had to dirty flash to fix it.
     

    KIngOrNot

    Senior Member
    Jun 25, 2013
    107
    29
    Bcn
    it ain't that, or at least it wasn't for me.

    I don't know if you made your test correctly though as since a few monts, TWRP has an option that basically unmount system everytime you flash a zip file so you gotta turn that off or it doesn't matter how many times you manually mount system it will always be unmounted as soon as you hit flash.

    When i did this however, i only managed to break my camera completely (with buffer fix flashed from magisk it simply acted as if the buffer fix wasn't there and freezed so i tried flashing manually) and it kept crashing everyime it launched and i had to dirty flash to fix it.
    I tried to go back to 5.2 but I got bootloop. Probably I should first to flash stock rom.
    Edit: Iwent back to stable miui 12. Before bufer was working perfect on stock. Not anymore. I'm just don't getting what is wrong. Twrp,Magisk...
    Went back to 5.2. I crashed camera too. Stock camera disapered
    And gcam wouldnt open. Then in moment of desparesion I installed open cam just to try to have any working cam. Than I tryed again buffer and gcam... And it's Working. I dont move from 5.2 till android 12...
     
    Last edited:

    DarkAngelGR

    Recognized Developer
    Hello everyone,

    There is an issue with idle drain being too high (not on drugs) and in order to fix this you need to flash Chinese Beta A11 Firmware, this doesn't require any wipe, just flash the firmware and reboot. Please note, that Widevine will be L3 so no HD content on Netflix and etc.

    Regarding issue with going back to previous versions, that won't be possible due to old versions (the ones before 5.5) didn't ship dtbo image and thus will lead to fastboot if you flash them.

    Hope you enjoy Evolution X and have a nice week
     

    fumareddu

    Member
    Jul 14, 2017
    33
    6
    Try installing from Magisk, it worked for me
    Can you or the OP specify which buffer fix did you use so i can try and update to latest version as well?

    also @DarkAngelGR I currently seems to have no problems with the A10 stable firmware i had to flash to be able to use the version of april 6 of this rom(that one that caused bootloop for some), the phone has a confortable 2 days uptime of normal use. does it mean that i can use the version of 17 as well with no issue or the battery drain occurs with that version of the rom and it's a "mandatory" update?

    Thank you
     

    pourmadeesse

    Senior Member
    Apr 6, 2011
    67
    9
    Can you or the OP specify which buffer fix did you use so i can try and update to latest version as well?

    also @DarkAngelGR I currently seems to have no problems with the A10 stable firmware i had to flash to be able to use the version of april 6 of this rom(that one that caused bootloop for some), the phone has a confortable 2 days uptime of normal use. does it mean that i can use the version of 17 as well with no issue or the battery drain occurs with that version of the rom and it's a "mandatory" update?

    Thank you
    I used file pyxis-buffer-q.zip attached
     

    Attachments

    • pyxis-buffer-q.zip
      498.1 KB · Views: 9
    • Like
    Reactions: fumareddu

    Synt4x3rror

    Member
    Oct 15, 2014
    10
    2
    Did a clean flash of the April 17th build, and everything seems to be working ok.

    Today I flashed the A11 firmware, as suggested by the OP. Currently using the 21.4.14 firmware.

    Again, so far so good, if I see anything break will post here.
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 2
      Hello everyone,

      There is an issue with idle drain being too high (not on drugs) and in order to fix this you need to flash Chinese Beta A11 Firmware, this doesn't require any wipe, just flash the firmware and reboot. Please note, that Widevine will be L3 so no HD content on Netflix and etc.

      Regarding issue with going back to previous versions, that won't be possible due to old versions (the ones before 5.5) didn't ship dtbo image and thus will lead to fastboot if you flash them.

      Hope you enjoy Evolution X and have a nice week
      1
      Can you or the OP specify which buffer fix did you use so i can try and update to latest version as well?

      also @DarkAngelGR I currently seems to have no problems with the A10 stable firmware i had to flash to be able to use the version of april 6 of this rom(that one that caused bootloop for some), the phone has a confortable 2 days uptime of normal use. does it mean that i can use the version of 17 as well with no issue or the battery drain occurs with that version of the rom and it's a "mandatory" update?

      Thank you
      I used file pyxis-buffer-q.zip attached
    • 8



      EvoBanner.png


      Evolution X 5.6 for the Xiaomi Mi 9 Lite [pyxis]

      Code:
      /*
      
      * Your warranty is void. Or vaild, probably?
      
      *
      
      * I am not responsible for bricked devices, dead SD cards, Ebolation X,
      
      * thermonuclear war, or the current economic crisis caused by you following
      
      * these directions. YOU are choosing to make these modificiations, and if
      
      * you point your finger at me for messing up your device, I will LMAO at you.
      
      */



      qE4kqsj.png


      Living, Breaking, Keep Evolving.

      Pixel UI, customization and more, we are Evolution X!



      - Team Evolution X -

      @joeyhuab

      @peaktogoo (Now RealAkito)



      Reach us on Twitter! @EvolutionXROM





      RgqrlpK.png




      What are our features?

      - Just flash and check "The Evolver"




      n6b8AXD.png

      You tell me

      DO NOT FLASH GAPPS, ALREADY INCLUDED

      u5tIlfT.png


      DO NOT FLASH GAPPS, ALREADY INCLUDED

      gMGb8ee.png


      First Time Install / Clean Flash
      1. Download the proper flashable ZIP for your device
      2. Reboot to Recovery
      3. Wipe Data/Cache/System
      4. Format Data (Optional)
      5. Flash the ROM
      6. Reboot to System
      7. Reboot to Recovery (Optional)
      8. Flash Magisk (Optional)
      9. Reboot to System and #KeepEvolving

      Update / Dirty Flash
      1. Download the proper flashable ZIP for your device
      2. Reboot to Recovery (Optional)
      3. Flash Magisk (Optional)
      4. Flash the ROM
      5. Reboot to System and #KeepEvolving









      Light Screenshots / Dark Screenshots / Download

      Donate to me! / Official Chat / Device Support








      LU9gsrQ.png



      4
      New Update is available!

      Download here
      Changelog here

      NOTE: CLEAN FLASH IS REQUIRED FOR THIS UPDATE

      If you want to support me feel free to tip at Paypal


      ** Hotfix **
      I was informed that SD cards weren't detected due to a kernel issue. To fix this issue install the file below, don't use this on any other ROM as it will cause issues
      3
      New update is now available!!

      Download here
      Changelog here

      If you want to support me by buying me a Monster or help me pay the server bills, here is my PayPal.

      Don't forget to join my Telegram group and channel.

      Thanks for using Evolution X
      2
      I found it on Settings > System > System Update, but I'd guess you've already tried that?

      Maybe wait till OP posts again?
      Yeah, i think i manually updated to version of april 7 when i download and dirty flashed to get rid of the defective buffer fix. That didn't fix my camera though so i have no idea why your's is working. Anyway i guess it's wait until next version as there are a few things broken.

      @Echo2124:
      There is a big disclaimer in the first page saying that things might be broken. This is a new release as it's android 11. The previous version of this rom based on android 10 was close to perfect and by far the most stable i tried on this phone. Give it a little time or simply don't jump to new versions asap and check the topic if everything it's working. This is a free service and one of the few dudes still writing stuff for this device (afaik other than this and miui there are no other Android 11 rom out).
      2
      New Update is available!

      Download here
      Changelog here

      NOTE:
      1) CLEAN FLASH IS REQUIRED FOR THIS UPDATE (due to vendor update, else you get bootloop, hate me all you want xP).
      2) Some devices had bootloop issue on last update, this build worked fine for the tester so it should work for you as well.

      If you want to support me feel free to tip at Paypal which will help me pay the server costs.


      Don't forget to join my groups (https://t.me/dagrpyxis / https://t.me/EvolutionXPyxis) and my channel to be up-to-date (https://t.me/memegang_pyxis)

      Hope you enjoy this update
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone