Android SD cards and the ext4 filesystem

rodhh

New member
Nov 6, 2014
1
0
21
Hello. What filesystem do you format your SD cards in for using with Android? I suspect most keep the factory format - exFAT or FAT32, which is a garbage filesystem, but can be read by Windows without extra trouble.

When I was preparing a new card to put in a new phone the other day, I faced that choice, and being a Linux user, decided on ext4, which has journaling, is tried and tested, and a default for most Linux systems. I also threw in a couple of extra partitions, one of them with FAT32, just in case some app had trouble saving to ext4.

Everything seamed to work well, no complains from Android. One app could not save to the ext4 partition, but that was expected, it had no trouble saving to the FAT32 one. However I later noticed problems with the card. It took me a bit to map out the problematic behavior, but here it is:

- Can read/write files in all dirs on the FAT32 partition
- Can read/write files in the root dir of the ext4 partition
- Can't write files on any sub-directory of the ext4 partition, regardless if the dir was created in the computer or by the phone's file explorer.
- Reading from sub-dir seams weird. Video files written when the SD was on the computer don't open, but I was able to read a file created by TWRP.
- TWRP can read and write to it's default directories inside the ext4 partition (which are sub-directories).

Just in case, I tried multiple file explorer apps. This kinda suggest some user read/write permission issues, however I can't find anyone reporting anything similar anywhere on the web.

Any ideas?
Anyone using ext4?
Could the multi-partitioning of the SD card be an issue somehow?

Thanks