Another ColorOS Camera Port [Last Update : Version K1&K2] [18/07/15]

Search This thread

ilea94

Senior Member
Sep 3, 2010
160
17
Thank you for the response.

Tried your new zip and still not working.

Here is a new logcat.

Rom : CM 12.1 by jgcaap
Latest apk from BootMGR works except Beautify preview .
 

Attachments

  • 2015-06-30-10-36-46.txt
    229.1 KB · Views: 24

infinityplus

Senior Member
Feb 3, 2015
249
1,068
Bangalore
Ok so just tested this app a bit.

First off, nice work :D Really nice app, good feeling and it seems more reactive.

I have some questions though. First off, is it normal if there are some missing plugins, such as 50 MP, Picture plus? Still on the plugins, they seem to bug when trying to add them (sometimes they dissapear, mostly when activating the slow lens).

What is the gallery hack?

Picture plus, panaroma, ubifocus, etc aren't included because they don't work.. There should be a total of 11 plugins showing inside plugin manager.. If a few of them are missing u can manually install them either by extracting the flashable zip and installing the apks OR download and install them from my drive folder
Thank you for the response.

Tried your new zip and still not working.

Here is a new logcat.

Rom : CM 12.1 by jgcaap
Latest apk from BootMGR works except Beautify preview .
Kinda busy now.. So will check it out in a few hours... Thanks for the info!
 

matssa

Senior Member
Jan 8, 2015
1,817
1,898
Picture plus, panaroma, ubifocus, etc aren't included because they don't work.. There should be a total of 11 plugins showing inside plugin manager.. If a few of them are missing u can manually install them either by extracting the flashable zip and installing the apks OR download and install them from my drive folder

Ok thanks, didn't know that Picture Plus was KIA as well ^^ Do you know why it is broken? Panorama was broken ages ago, but not Picture Plus :/

I hope you will be able to get all this back on track! :) And good luck with your work ;)
 

davebugyi

Senior Member
Mar 16, 2010
3,729
946
Bratislava
www.myspace.com
@infinityplus
Everything works fine, except when switching to front facing camera, I get an FC. - To use camera again, have to wipe data, or else upon starting there will be only black screen. - uninstalled version I, removed data, installed ver J.

Logcat:
http://pastebin.com/Uzj7Hh0L

More info: FC occurs only when in PHOTO mode, front camera works while switching to it in VIDEO.
My basic logcat reading skills say something about something wrong with picture size obtaining
 
Last edited:

AcmE85

Senior Member
Jan 19, 2012
2,930
3,691
J works fine so far. Thanks!
It sometimes force closes when opening it after camera next.
Is it possible to implement a 4:3 viewfinder?
 

matssa

Senior Member
Jan 8, 2015
1,817
1,898
I'm also facing issues with the HDR plugin. With HDR, we should have a photo where everything is focused the same way (not a one-spot focus). With the new version, it does the same thing as a normal photo, still have a one-spot focus. Anyone has the same thing?

---------- Post added at 09:49 AM ---------- Previous post was at 09:47 AM ----------

@infinityplus
Everything works fine, except when switching to front facing camera, I get an FC. - To use camera again, have to wipe data, or else upon starting there will be only black screen. - uninstalled version I, removed data, installed ver J.

Logcat:
http://pastebin.com/Uzj7Hh0L

More info: FC occurs only when in PHOTO mode, front camera works while switching to it in VIDEO.
My basic logcat reading skills say something about something wrong with picture size obtaining

Strange, I don't have this issue when being in normal photo mode and changing to front face camera. Switched back and no FC. Do you use the find7 camera HAL?

Tested in both modes, and tested taking photos.
 

AcmE85

Senior Member
Jan 19, 2012
2,930
3,691
HDR does not change the way it focuses.
What it does is combine multiple pictures to compensate for too high or low exposure in Auto-Mode.

It always worked the way you described it if you focus on something particular.
 
  • Like
Reactions: dslsd

davebugyi

Senior Member
Mar 16, 2010
3,729
946
Bratislava
www.myspace.com
I'm also facing issues with the HDR plugin. With HDR, we should have a photo where everything is focused the same way (not a one-spot focus). With the new version, it does the same thing as a normal photo, still have a one-spot focus. Anyone has the same thing?

---------- Post added at 09:49 AM ---------- Previous post was at 09:47 AM ----------



Strange, I don't have this issue when being in normal photo mode and changing to front face camera. Switched back and no FC. Do you use the find7 camera HAL?

Tested in both modes, and tested taking photos.

No, using CM HAL MOD.
 

matssa

Senior Member
Jan 8, 2015
1,817
1,898
No, using CM HAL MOD.

Try using Find7 mod, it works nicely ;) unless you use CameraNext, which isn't really necessary anymore...

---------- Post added at 09:58 AM ---------- Previous post was at 09:58 AM ----------

HDR does not change the way it focuses.
What it does is combine multiple pictures to compensate for too high or low exposure in Auto-Mode.

It always worked the way you described it if you focus on something particular.

Kk i'll test this out and put a screen ;)
 
  • Like
Reactions: davebugyi

matssa

Senior Member
Jan 8, 2015
1,817
1,898
Flashed the find 7 HAL from bootmgr's thread. Same FC :/
Strange... What ROM are you using? Did you wipe camera data after flashing find7 camera HAL?

Can anybody please mirror the flashable zip with the plug-ins? Currently I have no pc, and on my phone mediafire doesn't download properly.

Thanks in advance :)
Uggg sorry, can't right now, my PC at work can't download from Mediafire and I can't download from my phone either (don't have enough cell range...).

I'll post this ASAP.

---------- Post added at 11:17 AM ---------- Previous post was at 11:12 AM ----------

Can anybody please mirror the flashable zip with the plug-ins? Currently I have no pc, and on my phone mediafire doesn't download properly.

Thanks in advance :)

https://drive.google.com/file/d/0B6J41qgBEupcLW9ZZThWc0E0UzQ/view?usp=sharing
 
  • Like
Reactions: orangerot.

davebugyi

Senior Member
Mar 16, 2010
3,729
946
Bratislava
www.myspace.com
Mmm... Really strange... May need to try it out on the next nightly perhaps...

More tests on the front cam, BOOTMGR's latest version works, CameraNext works Camera FV-5 too, and Cameranext and also Camera FV-5 front cam works even when this port is crashed. So it is not the HAL crashing, but the app.

FINALLY got it working.

Crash stopped after the following plugins were removed: GIFCamera, DoubleExposure. If I had these plugins installed the front camera crashed, without them it works perfectly. Strange thing that they are working fine with the back camera.

However when closing the camera (wiping from recents) while in front facing mode, upon next start it still won't start - same FC with getpicturesize () nullpoint exception.
 
Last edited:
  • Like
Reactions: matssa

infinityplus

Senior Member
Feb 3, 2015
249
1,068
Bangalore
@infinityplus
Everything works fine, except when switching to front facing camera, I get an FC. - To use camera again, have to wipe data, or else upon starting there will be only black screen. - uninstalled version I, removed data, installed ver J.

Logcat:
http://pastebin.com/Uzj7Hh0L

More info: FC occurs only when in PHOTO mode, front camera works while switching to it in VIDEO.
My basic logcat reading skills say something about something wrong with picture size obtaining

Strange.. I haven't checked the logcat yet since I am at work.. But I am guessing the FC is being caused by a FaceBeautify plugin because everytime you switch to front cam this plugin gets loaded automatically.. Check if you have this installed and also make sure its the latest version


Edit: Just did a test by uninstalling FaceBeauty plugin and I can reproduce the error you are getting.. There seems to be a bug in the new camera app which requires the facebeauty plugin to be installed for the front camera to work.. Already figured out what's causing this and will fix this in the next update
 
Last edited:

puma9S

Member
Nov 20, 2011
49
11
I get a force close every time I try to start the app, with the latest version :/
I've tried Version H, just to see if something is wrong with my phone, but this version works just fine.
I'm using Euphoria OS with Android 5.1, and I already tried to uninstall all plugins.
It's very strange, though the Camera from BOOTMGR works for me..
 

infinityplus

Senior Member
Feb 3, 2015
249
1,068
Bangalore
I get a force close every time I try to start the app, with the latest version :/
I've tried Version H, just to see if something is wrong with my phone, but this version works just fine.
I'm using Euphoria OS with Android 5.1, and I already tried to uninstall all plugins.
It's very strange, though the Camera from BOOTMGR works for me..

Check if u have the lastest FaceBeauty installed.. If u do and it still FCs then try fetching a logcat for me so I can figure out whats causing the issue
 
  • Like
Reactions: Zootopia and puma9S

Top Liked Posts