• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Another ColorOS Camera Port [Last Update : Version K1&K2] [18/07/15]

Search This thread

Riichard63

Senior Member
Jan 23, 2013
1,043
524
Hey can you try to work on some out of service plugins, such as Picture Plus? :D Ca serait pas mal que ça marche, ça évite d'avoir des photos trop lourdes, ou pas assez précises ^^

Oh un français :)
For picture plus it's a bit different as algorithm is in HAL. Plugin just alows to call this HAL function and it's not same kind of edition sadly =/
 
  • Like
Reactions: matssa

matssa

Senior Member
Jan 8, 2015
1,817
1,898
Oh un français :)
For picture plus it's a bit different as algorithm is in HAL. Plugin just alows to call this HAL function and it's not same kind of edition sadly =/

Ah God damn it... Oh well, maybe @BOOTMGR is already working on this for his own port... ;)

Et oui, un autre français ;) j'ai vu ça avec ta signature de Tapatalk ;) Tu dois bien maîtriser l'info pour pouvoir modifier les codes etc ^^ je sais pas compiler une apply pour Android, surtout que j'ai pas le PC pour non plus ^^
 

Aki07

Senior Member
Nov 12, 2012
140
28
Christchurch
OnePlus 7T
@infinityplus, you're welcome =)

And try this one for slow shutter, I removed the info text that is place at the same place than progress bar : https://drive.google.com/file/d/0BxTNUQcAK2cPZVRnRUxrb09mbkk/view?usp=sharing

Latest Test version does seem to work ! Thank you.

Still noticed few bugs :


1. Beautify Plugin preview not working
2.Colorful Filter (or so :D ) doesn´t seem to work at all. Just got a black screen for a few seconds,

ROM : CM 5.1 with CM stock HAL

Its working fine for me. May be OS bug. try clearing ur data and see if its working. Install latest plugin too.
 

paulissimo

Member
Sep 17, 2014
28
26
Aveiro
Forced close when reopening the camera

@infinityplus Just installed version J and the new plugins (all working), but i got FCs a few times (tested with different plugins), when, after closing the camera (with home or back button) and reopening it again. Also reported by some members on oneplus forum

Loved the Slow Lens video plugins with slow motion 4x and noticed that it records normal sound, see video below (2 seconds of recording time)
But I'll just disable sound with that plugin on and it's fine with me.

Love your work and Portuguese members on Oneplus forum too :cool:
 
  • Like
Reactions: Zootopia

infinityplus

Senior Member
Feb 3, 2015
249
1,068
Bangalore
@infinityplus Just installed version J and the new plugins (all working), but i got FCs a few times (tested with different plugins), when, after closing the camera (with home or back button) and reopening it again. Also reported by some members on oneplus forum

Loved the Slow Lens video plugins with slow motion 4x and noticed that it records normal sound, see video below (2 seconds of recording time)
But I'll just disable sound with that plugin on and it's fine with me.

Love your work and Portuguese members on Oneplus forum too :cool:
Lol I wasn't aware there were more users of my app outside this forum.. The bug u are talking about has been rectified in the latest test release.. It was a problem with slow video mode causing issues when resuming camera

Edit: also slow video mode always used to record sound like that even in the older versions.. The only way of syncing it is to manually sync the video and audio with any video editor software
 
Last edited:

phoenixita

Senior Member
Apr 7, 2011
2,425
2,278
27
Civitavecchia
Lol I wasn't aware there were more users of my app outside this forum.. The bug u are talking about has been rectified in the latest test release.. It was a problem with slow video mode causing issues when resuming camera

Edit: also slow video mode always used to record sound like that even in the older versions.. The only way of syncing it is to manually sync the video and audio with any video editor software

Do you know a good one that can be used on the phone?
 

hums87

Senior Member
Mar 22, 2011
56
5
Mhh i have an FC when i try to open the APP, have deinstalled all other Version and Plugins..

Why the New Version is so small?? Around 4mbs

My last installed Version H has more than 8mb??


Last Version H is working, but J i have an fc

Edit: I have test it with the flashable zip, same result fc at starting the app [emoji19]
 
Last edited:

infinityplus

Senior Member
Feb 3, 2015
249
1,068
Bangalore
Honestly I am a little confused now.. Some people are having FCs and some are not.. I have tested my Test2 apk release with 4 roms as of now (resurrection remix, euphoria, cm latest 12.1 nightly and slimsaber) and I can't reproduce any of the issues.. Maybe there is something going wrong with your ROM setup or maybe an xposed module?

I'll be releasing two variations of Version K tomorrow (K1 and K2).. One is of same version from J and the other is a slightly older version (Test2).. I have included a bugfixes with both of them.. So everyone can try and see which one is stable for them.. Also will be only providing flashable camera zip from hereon with plugins included to avoid confusion with people using the wrong plugins (Only till bootmgr updates his app too)

Also people who are still facing FCs with Test2.apk please provide a log
 
Last edited:

Riichard63

Senior Member
Jan 23, 2013
1,043
524
Try one of my test files and see which one works for you

That's weird as on Mi3/4 we have fc when we quit the camera and open it again. Opening another time after fc and it just open well.

Some unexplainable issues. Some got crashes and it's stable for some other.

It may be a different device latest version is acting weird. But better picture quality than previous one imo.

Envoyé de mon MI 4 en utilisant Tapatalk
 
  • Like
Reactions: dslsd

mangzone

Member
Feb 27, 2015
47
3
bug report (version J)
it crashes frequently when I switch white balance mode or switch to front camera or change some other settings.

btw thanks for your great work
 

imcrazyz

Senior Member
Jan 29, 2015
71
6
@infinityplus, first off thanks you for your great work, it's working fine on my Oppo Find 7a. Btw there're codes on the slow shutter bar. I noticed you have uploaded a test.apk. I will wait for the stable version release. :)
Another issue is when I switched to video mode, there're two or three flickering white lines, I would relate this to "old movie shooting" whereby there's graphic issue I suppose.
https://www.youtube.com/watch?v=C_pQnsRNrjk The flickering white lines in this video.
 

sneakerspark

Senior Member
Jan 5, 2013
504
227
Islamabad
OnePlus 7T
@infinityplus, first off thanks you for your great work, it's working fine on my Oppo Find 7a. Btw there're codes on the slow shutter bar. I noticed you have uploaded a test.apk. I will wait for the stable version release. :)
Another issue is when I switched to video mode, there're two or three flickering white lines, I would relate this to "old movie shooting" whereby there's graphic issue I suppose.
https://www.youtube.com/watch?v=C_pQnsRNrjk The flickering white lines in this video.

The issue lies with the color os and Cm libs. Im using oxygen Os libs and there are no video artifacts. Plus camera performance improved significantly. ( i mean it) just a few draw backs that slow shutter, clear image is not available.

Sent from my A0001 using XDA Free mobile app
 

Top Liked Posts