• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

another XDA SIMLOCK trick

Search This thread
R

Rick

Guest
This message contains all postings in this thread
dated before January 19th 2003





Subject: another XDA SIMLOCK trick
From: Rick
Date: 10 Jan, 2003 10:14:25

Hello people,
I found a variation of the SIMLOCK bypass trick for XDA
mentioned in another thread on this forum.
There is no need to call a un-answering number and wait.
I think it still works only for 3.02 (ENG/GER/whatever).

HOWTO:

1) find a non-existent number you can call. any number that
returns you "the number you dialed is incorrect". For Italy, a
good one is a 4 digit number beginning with 9.
2) have the phone screen active and the non existent number
ready.
3) turn GSM on. When the X disappears, wait 1-2 seconds and then
call the non-existen number.
4) after a while, you will see provider registration, and then a
message saying the number can't be dialed.
5) tap OK, you're hooked to your network!

With this trick, you will neither see the "enter unlock code" or
"application error" message. It works all the time!

BTW, I got my official unlock code from O2... but it does not
work, it just says "invalid password"!!! I am waiting for them
to fix it, in the meantime, I can use my phone...

Let's share the good tricks!!! :)

Ciao,
Rick
Italy




Subject: Rubbish
From: MADmanFREE
Date: 14 Jan, 2003 18:26:22

This did not work for me at all..

The closest I got was something about changing the number in
Ireland, from the operator... I'm using 3.01 in the uk

If you can clarify that this trick does indeed work in the UK I
would be greatfull...




Subject: Faaantastic
From: Peter
Date: 14 Jan, 2003 23:45:49

30 seconds..........UNLOCKED...........why has it taken me 8
months to do this????

Excelent!!! Thanks for the info.

Pete.
:) :) :) :)




Subject: Worked at last
From: MADmanFREE
Date: 15 Jan, 2003 19:42:28

http://b
oard.dserver.org/e/eitcenter/00000868.html


I found another article describing exactly the same thing.

It worked for me by Just ringing the houseand allowing it to go
on for a few moments. The Sim code request never appeared. And
now I've been using the Vodafone chip in my o2 XDA for 24hrs.

Good luck everybody




Subject: how about for SPV?
From: xDAguy
Date: 16 Jan, 2003 03:45:45

Crazy to buy an SPV phone, but since I live in Asia -would the
trick do the same for the SPV?

/Harry :wink:




Subject: addendum
From: Rick
Date: 17 Jan, 2003 09:51:28

I must add that, when using this trick, you can lose your
provider's signal, go back under coverage, and the phone
recovers just fine, without asking for code :)

But... who needs this trick, now that the XDA dev team created
the manipulator? :)

Ciao
Rick
 
G

Guest

Guest
u can also ring somone , and when they answer hang up, but the phone has to atleast ring 4 times. this way also, u dont get that crash msg, which makes the phone more stable.
 
F

Fud

Guest
???

This doesn't work for me. You dont get a chance to dial the number - the enter pin dialog shows up and disconnects GSM before it gets a chance to dial.
 
F

Fud

Guest
Soldering Job!

Hmmm connected up as per "wiring diagram" and Manipulator did squat. ActiveSync tried to establish a connection but failed.

I tested pin9 on the XDA and it appears to be a ground! Are you sure that wiring diagram is right or if all XDA's are the same - coz I double checked my end and it's definately a ground???
 

Peter Poelman

Retired Administrator
Jan 19, 2003
1,129
58
Amsterdam
Re: Soldering Job!

Fud said:
I tested pin9 on the XDA and it appears to be a ground! Are you sure that wiring diagram is right or if all XDA's are the same - coz I double checked my end and it's definately a ground???

It could well be at ground level, but it's definitely not a ground. It's RTS. You will probably only need to connect RX, TX and GND if all you want to do is unlock it.

You did tell ActiveSync not to touch the serial port while you were running the Manipulator, right ?
 
F

Fud

Guest
Humble Pie is actually quite nice with cream.

Yeah your right - the 9 pin is not ground and I'm clearly not on ground lvl!
Dunno how but i checked and double checked and my meter was tellin me it was ground. Sorry - I am a worm!!

Anywho, I have turned off ActiveSync - I was just trying to test the connection. I have resoldered the thing and made sure its right but I still cant get it to work. Radio version is 4.06 and bootloader 5.15.
 
F

Fud

Guest
Still no joy

OK I've been on this too long now. I have wired up TX RX and GND as you suggested but still nothing. How long does it take to connect? It just sits on scanning ports.

Somebody on another forum aso had probs with bootloader 5.15? Are there known problems? How do I use a terminal prog to access it? Ive tried Win Hyperterminal to connect but I cant type the commands in (suggesting its not actually connected)

All I need is to unlock to use my Vodafone sim, I might as well go get a O2 sim rather than mess around with the serial cable.