ANXCamera - CLOSED ON XDA ONLY [16th FEB 2020]

Status
Not open for further replies.
Search This thread

Akashdip

Senior Member
Feb 27, 2018
340
92
I tired this one same problem :(
Seems like something is missing from your device. But what might it be? I have not installed any type of firmware since buying this device. So my firmware is the stock firmware that ships with the device.im using arter kernel but it also worked on illusion v4.2 pi exp+.
I have not flashed any vendor or stuff as it comes default with the pi exp+ ROM. I just flashed this through magisk manager.
 

lawong

Senior Member
Sep 23, 2010
734
98
Huawei P40 Pro
what is the difference for k20 pro between ANXRaphaelCustLibsPie_150.InfiniteCostlyRedhead.zip and ANXCustLibsPie_150.InfiniteCostlyRedhead.zip , the only one with front camera can pop up work for me is ANXRaphaelCustLibsPie_150.InfiniteCostlyRedhead.zip but it doesnt fix 48mp cam , all others fix 48mp camera but without pop up camera
 

kaem84

Senior Member
Feb 16, 2014
93
20
V165 is the first version where anxcamera will start ginkgo, few features are broken on q coz you don't have official q vendor

I can confirm - from version 165, anxcamera starts working on ginkgo. Unfortunately on android 10 macro and wide lens do not work :(
Does this mean that until there is no official Android 10, the developers of anxcamera are not able to make fully functional camera with all lenses on ginkgo/redmi note8?
 

AEonAX

Senior Member
Dec 10, 2012
173
460
Pune
I can confirm - from version 165, anxcamera starts working on ginkgo. Unfortunately on android 10 macro and wide lens do not work :(
Does this mean that until there is no official Android 10, the developers of anxcamera are not able to make fully functional camera with all lenses on ginkgo/redmi note8?
It's not me, it's you.:laugh:

Current issues need to be handled by kernel or vendor devs. Anxcamera is getting wrong camera IDs, can't be fixed from my side as I don't know where it gets that from
 

Micha_Btz

Senior Member
Hey,
I tried to build it from source with the original grus q kamera but I have no luck.
~/handy/ANXCamera [grus-q L|✚ 9 …1] $ ./recompile.sh
I: Using Apktool 2.4.0-dirty
I: Checking whether sources has changed...
I: Checking whether sources has changed...
I: Checking whether sources has changed...
I: Checking whether sources has changed...
I: Checking whether resources has changed...
I: Building resources...
W: aapt: brut.common.BrutException: brut.common.BrutException: Could not extract resource: /prebuilt/linux/aapt_64 (defaulting to $PATH binary)
W: First type is not attr!
W: A/ (46837): First type is not attr!
brut.androlib.AndrolibException: brut.common.BrutException: could not exec (exit code = 134): [aapt, p, --version-code, 3, --version-name, 3.0, --no-version-vectors, -F, /tmp/APKTOOL9201931831697409911.tmp, -0, arsc, -0, ogg, -0, mp3, -0, zip, -0, png, -0, assets/model/actionmodel/tt_action_detection_v4.0.model, -0, assets/model/ar_scan/tt_arscan_raw_v2.0.dat, -0, assets/model/audiorecognize/kws_v2.0.model, -0, assets/model/facefitting/tt_facefitting_v2.1.model, -0, webp, -0, res/drawable-nodpi-v4/list_divider.9.png, -0, res/drawable-nodpi-v4/on_screen_hint_frame.9.png, -0, res/drawable-nodpi-v4/seekbar_progress_primary.9.png, -0, res/drawable-nxhdpi-v4/camera_preview.9.png, -0, res/drawable-nxhdpi-v4/camera_preview_notch_nvirtualkey.9.png, -0, res/drawable-nxhdpi-v4/camera_preview_nvirtualkey.9.png, -0, res/drawable-nxhdpi-v4/camera_preview_virtualkey.9.png, -0, res/drawable-nxhdpi-v4/female_age_info_pop.9.png, -0, res/drawable-nxhdpi-v4/ic_ai_hint_bg.9.png, -0, res/drawable-nxhdpi-v4/ic_ai_hint_bg2.9.png, -0, res/drawable-nxhdpi-v4/ic_camera_mode_exit_button.9.png, -0, res/drawable-nxhdpi-v4/ic_camera_mode_exit_button_full.9.png, -0, res/drawable-nxhdpi-v4/ic_camera_mode_exit_button_full_pressed.9.png, -0, res/drawable-nxhdpi-v4/ic_camera_mode_exit_button_pressed.9.png, -0, res/drawable-nxhdpi-v4/ic_live_music_text_bg.9.png, -0, res/drawable-nxhdpi-v4/ic_object_tracking.9.png, -0, res/drawable-nxhdpi-v4/ic_object_tracking_succeed.9.png, -0, res/drawable-nxhdpi-v4/magic_mirror_info_pop.9.png, -0, res/drawable-nxhdpi-v4/male_age_info_pop.9.png, -0, res/drawable-nxhdpi-v4/portrait_hint_text_background.9.png, -0, res/drawable-nxhdpi-v4/screen_on_proximity_sensor_hint.9.png, -0, res/drawable-nxhdpi-v4/screen_on_proximity_sensor_hint_fg.9.png, -0, res/drawable-nxhdpi-v4/v6_ic_toast_frame.9.png, -0, res/drawable-xhdpi-v4/actionbar_translucent.9.png, -0, res/drawable-xhdpi-v4/ic_ai_hint_recommend_bg.9.png, -0, res/drawable-xhdpi-v4/notification_bg_low_normal.9.png, -0, res/drawable-xhdpi-v4/notification_bg_low_pressed.9.png, -0, res/drawable-xhdpi-v4/notification_bg_normal.9.png, -0, res/drawable-xhdpi-v4/notification_bg_normal_pressed.9.png, -0, res/drawable-xxhdpi-v4/camera_preview.9.png, -0, res/drawable-xxhdpi-v4/camera_preview_notch_nvirtualkey.9.png, -0, res/drawable-xxhdpi-v4/camera_preview_nvirtualkey.9.png, -0, res/drawable-xxhdpi-v4/female_age_info_pop.9.png, -0, res/drawable-xxhdpi-v4/ic_ai_backlight_pop_selected.9.png, -0, res/drawable-xxhdpi-v4/ic_ai_backlight_pop_unselected.9.png, -0, res/drawable-xxhdpi-v4/ic_ai_hint_bg.9.png, -0, res/drawable-xxhdpi-v4/ic_ai_hint_bg2.9.png, -0, res/drawable-xxhdpi-v4/ic_camera_mode_exit_button.9.png, -0, res/drawable-xxhdpi-v4/ic_camera_mode_exit_button_full.9.png, -0, res/drawable-xxhdpi-v4/ic_camera_mode_exit_button_full_pressed.9.png, -0, res/drawable-xxhdpi-v4/ic_camera_mode_exit_button_pressed.9.png, -0, res/drawable-xxhdpi-v4/ic_live_music_text_bg.9.png, -0, res/drawable-xxhdpi-v4/ic_object_tracking.9.png, -0, res/drawable-xxhdpi-v4/ic_object_tracking_succeed.9.png, -0, res/drawable-xxhdpi-v4/magic_mirror_info_pop.9.png, -0, res/drawable-xxhdpi-v4/male_age_info_pop.9.png, -0, res/drawable-xxhdpi-v4/portrait_hint_text_background.9.png, -0, res/drawable-xxhdpi-v4/screen_on_proximity_sensor_hint.9.png, -0, res/drawable-xxhdpi-v4/screen_on_proximity_sensor_hint_fg.9.png, -0, res/drawable-xxhdpi-v4/v6_ic_toast_frame.9.png, -0, res/drawable/actionbar_translucent.9.png, -0, jpg, -0, arsc, -I, ../ANXMiuiPortTools/MiuiFrameworks/1.apk, -I, ../ANXMiuiPortTools/MiuiFrameworks/16.apk, -S, /home/mdomann/handy/ANXCamera/./src/ANXCamera/res, -M, /home/mdomann/handy/ANXCamera/./src/ANXCamera/AndroidManifest.xml]

I use debian sid with apktool Apktool 2.4.0-dirty, someone an idea to fix this?
Thanks
Micha
 
D

Deleted member 8320586

Guest
Does some know if there's a version working for custom roms on GRUS? Latest doesn't work, 139 doesn't work
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 187
    ANXCamera - Miui Camera Port
    Port for AOSP-Based Pie ROMs on Xiaomi's Devices

    Instructions for Use:
    1. Download the Zip from MOD EDIT: dl link removed
    2. Supported Devices
      • oosberyllium is Poco F1 with OOS
      • singularity is all below devices, One for all, Plus Ultra, AOSP+MIUI
      • beryllium is poco
      • dipper is mi8
      • polaris is mix2s
      • perseus is mix3
      • cepheus is mi9
      • lavender is rn7
      • violet is rn7p
      • whyred is rn5/p
      • equuleus is mi8p
      • raphael is k20p
      • platina is mi8l
      • tulip is rn6p
      • gemini is mi5
      • grus is mi9se
      • sirius is mi8se
      • davinci is mi9t/k20
      • pyxis is cc9
      • laurus is cc9e
      • cactus cereus laurel_sprout lotus nitrogen onc riva rosy tiare ursa chiron jason mido sagit sakura vince wayne <-- Needs devs and testers
    3. Install the Zip via Magisk if you have it, Install via TWRP only if you don't have Magisk
    4. Install the Appropriate Addon (Required for most phones)
    5. Keep a note of the release you will be using, for issue discussion etc.
    6. Start Using
    7. Uninstall via Magisk, or flash same again in TWRP to uninstall

    IMPORTANT NOTE
    There are currently two DEVs making build me and Luffitys.
    • AEonAX - Owns a POCO, Makes builds with Lots of features and Bugs
    • Luffitys - Owns a MI8, Makes Debloated Version, with Lots of features removed and Less bugs due to feature removal. He is not on XDA

    Choose a version as per your liking, try both.


    ChangeLogs
    v160: AOSP
    Highly Experimental Version, Has Bugs, Re-Ported from Tucana, Added VLOG, SuperEIS, SuperNight, GoogleLens + More
    If you can't tolerate or don't know the bypass, Use V158

    v158: AOSP
    Add Andromeda, Enable Focus Peaking for Violet, ANXBattle-ized

    v156: AOSP
    Updated Device Features XML
    INTL Watermarks for Davinci and Raphael thanks to @nckmml
    Fix Violet Thanks to @Dyneteve
    Added Ginkgo, Begonia, Begoniain
    Added Daisy_Sprout and Jasmine_Sprout

    v152 :AOSP
    Fixed Manifest for Q, Added Back Bootlooping Permissions

    v151: AOSP
    Add Q Support (Use DocumentMode)
    Revert V29Utils,
    Add support for YSL,
    Kill ParallelProcess Support
    No PocoLibs By Default

    v148: AOSP
    Remove Studio Lighting for Lavender
    Add 240fps to Violet, Lavender and Whyred

    v146: AOSP
    Removed TikTok infection from ShortVideo, Fix WideSelfie.
    DIsabled ParallelProcessing, Fixed Watermark Implementation

    v145: AOSP
    Add tissot, fix panorama crash

    v141: AOSP
    Rebase on MiuiCamera from MIUI Q on Raphael 9.9.3
    Raw Support
    Mimoji now separate Addon @FIX_mimoji
    Portrait Fixed for Cepheus, Raphael, DaVinci, Violet and Maybe Lavender. use #fix_custlibs

    Featureset for Beryllium:
    • 960fps Works
    • 240fps Works, use Gphotos
    • Photo Works
    • Square Works
    • Panorama Works
    • Manual Mode Works
    • Portrait Mode
    • 4k30 eis
    • Dynamic Shots
    • Studio Lighting
    • Mimoji


    AntiFeatureset:
    • Portrait Mode (works for some)
    • 120fps
    • Night Mode (works for some)
    • AI Mode (works for me)
    • 960FPS doesn't record in left Landscape, try right landscape
    • POCO Q, Wait for Official Miui Q, Or use PA Q, ANX works on it.

    Donate @ https://www.paypal.me/XEonAX
    Special Thanks to @CodeElixir for his work with lib modding and fixes shutter button bug
    LogCat are required to help, Solutions will also be very much appreciated.


    All those who followed/starred/forked https://github.com/XEonAX/ANXMiuiCamera10 or https://github.com/XEonAX/ANXCamera10 make sure to change to https://github.com/XEonAX/ANXCamera
    This is a leaner repository

    MOD EDIT: Telegram link removed, please read the STICKY!

    People asking about EIS:
    It is only available at 30fps, please don't ask about 1k60fps or 4k60fps, currently it won't be possible.

    People asking about the Bug Fixes:
    If you have the fix please tell me, as I don't ;)
    Currently known issues and their workarounds, if any are available here
    https://github.com/XEonAX/ANXCamera10/issues
    Please do check there before reporting anything.


    There is an abandoned alpha release for Oreo at https://github.com/XEonAX/ANXMiuiCamera9/tree/master/out
    If anyone interested to bring it to working condition please contact me.

    To Learn How to Port MiuiCamera join this MOD EDIT: LINK REMOVED
    and watch this porting videos recorded livestream at https://mega.nz/#F!sGx0US5B!hXy30KunCOjmVmZ7kUMW3g
    or https://www.youtube.com/playlist?list=PLKwynvsh3Ed3zMZHwJCiaP8n-gHzhXUCA

    XDA:DevDB Information
    ANXCamera, Device Specific App for the Xiaomi Poco F1

    Contributors
    AEonAX, CodeElixir, amog787, abhishek987, mustang_ssc, psygarden
    Source Code: https://github.com/XEonAX/ANXCamera


    Version Information
    Status: Stable
    Beta Release Date: 2018-12-23

    Created 2018-12-15
    Last Updated 2020-02-16
    18
    New Build Out

    Install below via Magisk if you have it, Install via TWRP only if you don't have Magisk

    AOSP+MIUI (One For All, Plus Ultra)
    https://github.com/XEonAX/ANXCamera...raUnity_94.ComfortableMulticoloredNoctule.zip

    OOS Poco
    https://github.com/XEonAX/ANXCamera...93.DamagedPowderblueIvorybilledwoodpecker.zip

    ChangeLog:
    Updated to 9 4 26, Dynamic Shot, PortraitMode without Beautify, Better Quality, Faster performance, OTA Update Bootloop Fixed, It works on my machine™.

    Supports
    beryllium
    dipper
    lavender
    perseus
    polaris
    violet

    All bugs Fixed depending on your Luck

    Portrait mode for OOS is experimental.
    Consider yourself lucky if it works for you, other wise consider yourself unlucky
    960fps on PE CAF Broken, Contact ROM Dev

    Fight:MOD EDIT: Telegram link removed, please read the STICKY!


    I will update XDA, and site later
    14
    Thread closed at op's request.

    I recommend to read the FORUM RULES especially those:


    13. Advertising and Income Generation
    Commercial advertising, advertising referral links, pay-per-click links, all forms of crypto-mining and other income generating methods are forbidden. Do not use XDA-Developers as a means to make money.



    It's not allowed to post with the intention to sell something or generate income.

    strongst
    Forum Moderator
    10
    Any chance of removing the Settings > Device watermark from being checked by default? Does anyone really want this?

    Only cringy guys who want to boast that they got a Poco

    Friend of mine bought a stock Mi 9 and took many photos on her trip to New Zealand. Not really tech savvy, and it wasn't until half way through her trip, and sharing on social media, did someone let her know to disable the setting.

    I set up my wife's phone. Not really tech savvy, using a custom rom and this modded version, and same preset. It's a horrible idea by Xiaomi to have watermarks on by default. Since this is a custom version, I would think most users could benefit from having it be unchecked by default. I happy to be part of the antiwatermark group!

    Hopefully the dev agrees.

    You can add me to that list.

    The only thing that watermark is useful for is reviews when camera's from different devices are compared.

    I'm on a Poco Facebook group with guys who definitely know how to disable the feature, but most if not all photo posts there have it for some reason lmao. Some people really just wanna brag, and it's pure cringe.

    Only Chinese phone companies do this afaik.


    BN117 Disables Watermark by default
    8
    The ported camera is from MIUI 8.12.27 not? How could be different for you? I am using the MIUI replace for original and everything perfect. Used port on PE also was perfect.

    Ports for Poco in newer builds are based on 9.1.24 and no longer on 8.12.27
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone