ANY apk or file that can bind folders?

Search This thread

xdaprogramm

Member
Mar 20, 2019
32
1
As ive written in my past posts, using exagear (windows emulator based on wine), before I try to give that one su and read external sd and make final attempts to read more than 1 folder... im trying to bind folders. from terminal on phone. I did it with ADB and usb connected to PC with bindfs, I make a bind between Download\ and folder on external SD card, it is read by Exagear as it sees the External folder instead of the actual Download folder. But the moment I disconnect from PC or disable ADB debugging, the bind is lost, Download folder even disappears, have to reboot to restore folder.

Im using Magisk to give any such app su. So I give SU to terminal emulator apk and when I perform the same bindfs command it binds the 2 folders but only in the terminal. If I browse the folders with file explorer I won't see the External SD folder when going to Download'\ and neither will the exagear (unlike when done from ADB). So I need to bind them when away from PC, so I can 'see'the external sd

Tried FolderMount apk, few others, commands, which one works to properly bind as can be seen in all apps or particular? My final stop will be to try reverse engineer and see if su will allow exagear to see more than 1 folder (it only sees Download folder)
 
Last edited:
FBind Magisk module: (read last pages)
https://forum.xda-developers.com/apps/magisk/module-magic-folder-binder-t3621814

Rclone Mount Magisk module (on repository). Check the use of rclone with local storage.

Also the apps Apps2sd (by Vicky Bonick, see thread on XDA), Folder Mount, Luc* Pat* (ignore the piracy side of it, it has some nice other features) and maybe others can bind folders (may not work fine on some Android versions).
 

xdaprogramm

Member
Mar 20, 2019
32
1
Ok I try fbind module, how do I use it? i installed the module in Magisk 20.4 and now i need the correct syntax. I tried
PHP:
fbind <external sd path> storage/emulated/0/download>
andit throws me into the menu

1) non_media_to_external 5) documentation
2) media_to_external 6) all_commands
3) obb_to_external 7) exit_wizard
4) troubleshooting 8) boot_log

--> OPTION <enter>:

Which one to do what I want /mnt/media_rw/MD6H-KDY5/My\ Folder /mnt/runtime/write/emulated/0/download

where the first folder is a folder on external sd that has to be mounted as download folder

ALSO I cant remove something, I created mnt/runtime/read/emulated/0/mnt/media_rw/MD6H-KDY5/My Folder and mnt/runtime/read/emulated/0/mnt/runtime/write/emulated/0/download
(oops partially solved this as explained here by enabling core only module in Magisk manager, reboot phone then they can be deleted). But then they are back if i allow fbind modules.. Final solution was to put (overwrite) some empty config.txt in data/adb/fbind and then I can delete the folders, it seems to read it from there. So no need to switch to Core only in magisk or uninstall the fbind.



It is why I need to do this correctly to not make a mess

OK did it with bindfs as I explain in other thread and important to do is in Magisk Settings in Mount Namespace Mode set it to Global, then use ScanMediaPlz apk or without it, reboot phone and retry again command in Terminal and see if external SD content will be on the Download folder
 
Last edited: