• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Any wireless connection disables mobile data - TMobIile

Search This thread

comhack

Senior Member
Mar 8, 2010
442
44
Pale Blue Dot
www.comhack.com
I have a very odd issue, if I connect to wifi, I can search the internet just fine but I cannot make phone calls or get text messages. Sometimes the texts will go through and other times it gives an error. I went through all of the network settings but cannot find the culprit, does any one know what I am missing???

Thanks
 

Swizzle82

Account currently disabled
Dec 20, 2013
1,719
647
Texas
I have a very odd issue, if I connect to wifi, I can search the internet just fine but I cannot make phone calls or get text messages. Sometimes the texts will go through and other times it gives an error. I went through all of the network settings but cannot find the culprit, does any one know what I am missing???

Thanks
I'm having issues with calls being dropped and messages not being sent when on Wi-Fi. Changing wifi calling preference does nothing. Turning wifi calling off does nothing. I turn wifi off and calls and messages are fine. Doesn't happen all of the time though. So not sure what's going on.
 

utnick

Senior Member
Nov 8, 2009
337
157
Texas
I have a very odd issue, if I connect to wifi, I can search the internet just fine but I cannot make phone calls or get text messages. Sometimes the texts will go through and other times it gives an error. I went through all of the network settings but cannot find the culprit, does any one know what I am missing???

Thanks
Did you disable Mobile Data Always Active under Developer Options?

Though I'm not sure that would be the culprit as I have it disabled, but don't suffer the problems you're experiencing. So I guess this wasn't really helpful. I apologize.

Or maybe you should? And perhaps that will fix it? If it doesn't then I apologize again.
 
  • Like
Reactions: comhack

comhack

Senior Member
Mar 8, 2010
442
44
Pale Blue Dot
www.comhack.com
Did you disable Mobile Data Always Active under Developer Options?

Though I'm not sure that would be the culprit as I have it disabled, but don't suffer the problems you're experiencing. So I guess this wasn't really helpful. I apologize.

Or maybe you should? And perhaps that will fix it? If it doesn't then I apologize again.

It is enabled but I will disable it and see if that helps any.
 

comhack

Senior Member
Mar 8, 2010
442
44
Pale Blue Dot
www.comhack.com
Did you disable Mobile Data Always Active under Developer Options?

Though I'm not sure that would be the culprit as I have it disabled, but don't suffer the problems you're experiencing. So I guess this wasn't really helpful. I apologize.

Or maybe you should? And perhaps that will fix it? If it doesn't then I apologize again.

I disabled it and it seemed to work. I will let you know if it keeps working. Thanks a lot chief.
 

JonnyTrulove

Senior Member
Aug 23, 2017
179
146
Philly
freebitco.in
LG V30
Google Pixel 2
Been having connection issues since day 1. Changing different settings has worked for periods of time but nothing seems permanent. I have to cycle airplane mode to fix it every time to fix.

Was reading up on other sites and this is wide spread enough to find posts about it all over. Haven't seen anything to pinpoint why it happens or who is effected. Best I've found is that it may have something to do with when the phone switches to 5gUC and then off. But mine switches on and off of that relatively often and it doesn't do it every time. Though it does seem to do it if I'm on Wi-Fi and it's flipping to a good 5G signal to a not good one. So maybe it's when both radios are active.

Oh and I'm on TMobile, Swapped from Sprint sim.

Oh one more theory... I keep seeing messages from Sprint / T-Mobile about switching to the T-Mobile network. But I am currently using a T-Mobile SIN. These aren't generic messages. Messages they're geared directly to specific lines on my account, including . Now I don't know if somehow I could be on a T-Mobile SIM and still on the Sprint network, because that goes against a lot of stuff. Stuff I know regarding how the networks are being operated but I am a little out of the loop so I guess it could just be roaming back and forth or something And they had set something up at the tower so that you don't even see it do such. But anyway, if this weird theory were true, maybe that's the only people that it's affecting.
 

comhack

Senior Member
Mar 8, 2010
442
44
Pale Blue Dot
www.comhack.com
I'm sure that you set the default APN to Tmobile, right? My coworker was using a sprint sim and after getting another sim from Tmobile, her phone works fine. Of course, she doesn't have a pixel 6 so it could be something with the device. I love my P6 but there are some quirks. About to try this ArmorSuit skin screen protector later today as the hard ones do not register fingerprints.
 
  • Like
Reactions: JonnyTrulove

deyunta1991

Member
Apr 23, 2011
16
3
30
Atlanta
OnePlus 8T
T-Mobile 5Guc Is actually crazy fast I get really good download speeds and actually mine upload too it's way different from 4G to me just look at my results 👀💯
Screenshot_20211203-105600 (1).png
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I have a very odd issue, if I connect to wifi, I can search the internet just fine but I cannot make phone calls or get text messages. Sometimes the texts will go through and other times it gives an error. I went through all of the network settings but cannot find the culprit, does any one know what I am missing???

    Thanks
    Did you disable Mobile Data Always Active under Developer Options?

    Though I'm not sure that would be the culprit as I have it disabled, but don't suffer the problems you're experiencing. So I guess this wasn't really helpful. I apologize.

    Or maybe you should? And perhaps that will fix it? If it doesn't then I apologize again.
    1
    I'm sure that you set the default APN to Tmobile, right? My coworker was using a sprint sim and after getting another sim from Tmobile, her phone works fine. Of course, she doesn't have a pixel 6 so it could be something with the device. I love my P6 but there are some quirks. About to try this ArmorSuit skin screen protector later today as the hard ones do not register fingerprints.
    1
    Very nice speeds