Question Anyone get viper4android worked on A13 (Pixel 6 series)?

Search This thread

kunwar89

Member
Aug 8, 2020
9
1
Google Pixel 6a
What's the .bin file you method?
You only need to flash the .zip (V4A_Magisk_Module_0.4.0.zip for v0.4.0) file in the magisk app and install the .apk (V4A_App_0.4.0.apk).
very strange that when i download the file on my phone it gets downloaded as .bin file instead of .zip. so i downloaded it first on my pc and now its working. Thank u for such quick updates !
 

21071992

Senior Member
Feb 26, 2012
211
29
They are still in development, you may refer to the change logs on GitHub.
Can V4A work with Usb audio player pro? I enable Hires audio driver and Usc dac in UAPP setting, when playing music with UAPP, V4A isn't processing, playing music in other apps like youtube, apple music V4A is processing
 

llsl

Member
Dec 17, 2017
17
17
Can V4A work with Usb audio player pro? I enable Hires audio driver and Usc dac in UAPP setting, when playing music with UAPP, V4A isn't processing, playing music in other apps like youtube, apple music V4A is processing
I'm not sure if the v4a_re works with uapp, but I remember v4a 2.7 works with uapp on my old Pixel 2 (if I remember correctly).
 

21071992

Senior Member
Feb 26, 2012
211
29
I'm not sure if the v4a_re works with uapp, but I remember v4a 2.7 works with uapp on my old Pixel 2 (if I remember correctly).
I'm using v4a_re 0.5.0 and when playing music with uapp (hires driver), v4a doesn't work, playing music with poweramp (hires output setting), v4a also doesn't work, maybe these apps use there own drivers and v4a can't process
 

llsl

Member
Dec 17, 2017
17
17
I'm using v4a_re 0.5.0 and when playing music with uapp (hires driver), v4a doesn't work, playing music with poweramp (hires output setting), v4a also doesn't work, maybe these apps use there own drivers and v4a can't process
Maybe you are right, I haven't used a wired headphone with dac adapter cable for a long time.
 

pentium0

Senior Member
Feb 13, 2012
119
58
Oakland
Viper4Android RE 0.5 seems like a huge update, since there is DCC now.

Has anyone got 0.5 App and Module to work on Pixel 6 pro?

I tried, without uninstalling Wavelet, and without AudioModification magisk module, and get the no processing message as attached.

Screenshot_20230607-175402.png

I'm on magisk 26.1
 
  • Like
Reactions: Jaysmith696

Lughnasadh

Senior Member
Mar 23, 2015
5,496
6,559
Google Nexus 5
Huawei Nexus 6P
Viper4Android RE 0.5 seems like a huge update, since there is DCC now.

Has anyone got 0.5 App and Module to work on Pixel 6 pro?

I tried, without uninstalling Wavelet, and without AudioModification magisk module, and get the no processing message as attached.

I'm on magisk 26.1
Working for me on A14B3 with Canary Magisk 26102. Did you enable Legacy Mode? Might want to try it without Wavelet as well.
 
  • Like
Reactions: bibos85

fil3s

Senior Member
Aug 30, 2014
1,705
507
44
bendigo
mobiledevices11.blogspot.com
Thank you... I'll try without Wavelet installed and with canary magisk.

I used rootless jamesdsp on my Samsung a34 before I rooted it.

It's actually got really good reverb.

 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    I've been some weeks debugging this issue for A13, might be close to solve it. I need someone with the following requirements:

    - Pixel 6 or Pixel 6 Pro
    - Android 12. Preferably stock, if not in stock mention your custom ROM.
    - Stock kernel
    - Viper installed from the latest Magisk module: https://github.com/programminghoch10/ViPER4AndroidRepackaged/releases/tag/v24

    What I need after all requirements met is to send me the following files from your system:
    /system/etc/audio_effects.conf
    /vendor/etc/audio_effects.xml

    Update:
    I also need you to let me know if the driver installation is already done after installing the module and restarting (no driver pop-up message in app) or after pressing driver installation in the app.
    I've been messing with this for a while. I figured out why it won't work, but I don't have a solution yet... maybe someone on this thread can help.

    Every version of Android thus far has loaded audio effects from /vendor/lib/soundfx. Android 13, however, apparently loads the audio effects libs from /vendor/lib64/soundfx. While audio_effects.xml may look identical, the default path is lib64 instead of lib.
    V4A only provides /vendor/lib/soundfx/libv4a_fx.so, so when EffectsFactoryConfigLoader starts parsing audio_effects.xml, it can't find libv4a_fx.so because it's looking for it in /vendor/lib64/soundfx (logcat gives...)
    (
    09-24 01:32:51.487 2648 2648 E EffectsFactoryConfigLoader: Could not find library in effect directories: libv4a_fx.so
    )

    You can *find* libv4a_fx.so by changing the patch in the module's install.sh to
    sed -i "/<libraries>/ a\ <library name=\"v4a_fx\" path=\"..\/..\/lib\/soundfx\/libv4a_fx.so\"\/>" $AUDIO_EFFECTS_FILE
    but this only works to find it, not open it (logcat gives....)
    (
    09-25 02:53:20.184 841 875 E EffectsFactoryConfigLoader: Could not dlopen library /vendor/lib64/soundfx/../../lib/soundfx/libv4a_fx.so: dlopen failed: "/vendor/lib/soundfx/libv4a_fx.so" is 32-bit instead of 64-bit
    )

    The change to looking for audio effects libs in /vendor/lib64/soundfx matters because lib64 is full of 64-bit *.so files, whereas lib is full of 32-bit, and apparently the audio effects are being run as 64-bit binaries now.

    So where I've gotten is how to find and try to open libv4a_fx.so. Where I'm stuck is how to actually open it.... I feel like there has to be a way to run just that one audio effect as 32-bit, but I have no idea how to do it yet
    8
    I've been some weeks debugging this issue for A13, might be close to solve it. I need someone with the following requirements:

    - Pixel 6 or Pixel 6 Pro
    - Android 12. Preferably stock, if not in stock mention your custom ROM.
    - Stock kernel
    - Viper installed from the latest Magisk module: https://github.com/programminghoch10/ViPER4AndroidRepackaged/releases/tag/v24

    What I need after all requirements met is to send me the following files from your system:
    /system/etc/audio_effects.conf
    /vendor/etc/audio_effects.xml

    Update:
    I also need you to let me know if the driver installation is already done after installing the module and restarting (no driver pop-up message in app) or after pressing driver installation in the app.
    7
    I followed these steps (https://forum.xda-developers.com/t/...how-to-root-magisk-only.4382059/post-86183993) and it works on A12, but after the same steps on A13, the V4A cannot install the driver and didn't work. Does anyone successfully install the V4A? Thanks in advance!

    Update:
    Can anyone help @mustang_ssc with the required files (https://forum.xda-developers.com/t/anyone-get-viper4android-worked-on-a13.4480467/post-87518703)

    Just to be clear, I know V4A works on many phones on the A13, but we're actually talking about the Pixel 6 (or 7) series, and no matter what magisk mods we've tried, it keeps asking for driver install.

    Happy new year with the V4A reborn!


    I have got it worked on my 6 pro (Dec update). Here is what I did:

    • Download the magisk .zip and .apk file from the link above
    • Install .zip via magisk manager
    • Install .apk file
    • Reboot
    • Enable Master limiter and Legacy mode in V4A
    • Open a music app and enjoy it!
    Screenshot_20230102-151908.png
    5
    Got it from an A12 custom ROM but I would like to get it from the stock ROM for a cleaner revision.
    Sent. A12 developer build.
    5
    I have a Pixel 6 Pro running A13 and Magisk 25.1. I installed V4A using the magisk module ViPER4Android_FX-v2_7_2_1-2721.zip and like everyone else I get the driver loop. I added the following lines to the post-fs-data.sh file:

    magiskpolicy --live 'allow audioserver audioserver_tmpfs file { read write execute }'
    magiskpolicy --live 'allow audioserver system_file file { execmod }'
    magiskpolicy --live 'allow mediaserver mediaserver_tmpfs file { read write execute }'
    magiskpolicy --live 'allow mediaserver system_file file { execmod }'
    magiskpolicy --live 'allow audioserver unlabeled file { read write execute open getattr }'
    magiskpolicy --live 'allow hal_audio_default hal_audio_default process { execmem }'
    magiskpolicy --live 'allow hal_audio_default hal_audio_default_tmpfs file { execute }'
    magiskpolicy --live 'allow hal_audio_default audio_data_file dir { search }'
    magiskpolicy --live 'allow app app_data_file file { execute_no_trans }'
    magiskpolicy --live 'allow mtk_hal_audio mtk_hal_audio_tmpfs file { execute }'


    The the location of the post-fs-data.sh file is /data/adb/modules/ViPER4AndroidFX

    When I got in my car and Android Auto started playing music I instantly noticed a difference. V4A was indeed processing the audio, however, I couldn't open the app to make any changes to any of the settings because as soon as I open the v4a app I get the message "Driver not installed blah, blah". As far as I can tell there is no way to clear the message off the screen to be able to make any settings changes in the app. I wanted to listen to music in my car so I uninstalled V4A right then and rebooted. When my phone connected to AA and started playing music the sound was back to "normal".