• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Question Anyone having issues with VoWiFi NA version?

Search This thread
I just got the NA version of the ROG Phone 5 and sadly I cannot get VoWiFi working on TMobile. Sadly I'm in an area where I don't get the best signal and it's extremely important for this feature to work. Especially considering I spent 1k+ for this phone... Any help/guidance would be appreciated.
 
Have you enabled it in settings and then tried a reboot?

I've also noticed that it may not work until the SIM is installed BEFORE initial setup (or before a factory reset)
Yeah I tried that but didnt work so i manually enabled it using the phone dialer and after i toggle it on or off it will turn on but it turns off after reboot so need to root it so i can make the settings stick.
 
Thank you. I was debating between ROG or xperia 1iii. but if this works. Ill get ROG.
If you dont mind, can you please post the dialer code
Sure here you go *#*#3642623344#*#*
You should be able to copy and paste if that doesn't work try pasting but delete the last * and add it manually. If that still doesn't work just manually type it in. But I tested it out a few times nd it works even turned on airplane mode and it works. Wi-fi calling was a deciding factor for me lol was about to return it until I found out I could get it to work properly.
 

Trickster29

Member
Apr 10, 2014
29
11
ASUS ROG Phone 5
Thank you. I was debating between ROG or xperia 1iii. but if this works. Ill get ROG.
If you dont mind, can you please post the dialer code

Sure here you go *#*#3642623344#*#*
You should be able to copy and paste if that doesn't work try pasting but delete the last * and add it manually. If that still doesn't work just manually type it in. But I tested it out a few times nd it works even turned on airplane mode and it works. Wi-fi calling was a deciding factor for me lol was about to return it until I found out I could get it to work properly.
I'd like to add that after running the dialing code you have to enable wifi calling in the settings app.

Aswell as that, at least for me, I need to disable and re-enable it within settings after re-running the dial after reboot, for it to actually reconnect


Just to avoid any confusion.

This does work tho! Kva is right!
 
Last edited:
  • Like
Reactions: daviddem

daviddem

Senior Member
Mar 5, 2012
304
57
I'd like to add that after running the dialing code you have to enable wifi calling in the settings app.

Aswell as that, at least for me, I need to disable and re-enable it within settings after re-running the dial after reboot, for it to actually reconnect


Just to avoid any confusion.

This does work tho! Kva is right!
Thank you both. Ill order the phone and try it.
 
  • Like
Reactions: Trickster29
I'd like to add that after running the dialing code you have to enable wifi calling in the settings app.

Aswell as that, at least for me, I need to disable and re-enable it within settings after re-running the dial after reboot, for it to actually reconnect


Just to avoid any confusion.

This does work tho! Kva is right!
It's so stupid wish they enabled it by default would make all our lives easier
 
  • Like
Reactions: Trickster29
I agree, but idk if they need some authorization from T-Mobile to enable it by default and we're just the end user working around that.

Otherwise, I'm not really sure at all why the functionality is developed but not enabled by default.
Yeah it's stupid I ended up talking to advanced tech support and the guy has never heard of ROG phone 5 and said I should return it cuz it seems like it's a hardware issue.... I'm like dude it's your system not giving me proper access's and authorizing my phone... He's like I guess you know more about phones than I do... The idiot even made me reset my phone to try and fix it even though I told him several times that has nothing to do with it.... I swear I have no idea how some of these morons get jobs as IT... At least have basic IT understanding....
 
They're not in IT. They're customer service reps. They read from a script.

Check out the movie The Internship. It's just like that.
Well, when I'm talking to the advanced Technical team I am not talking to customer service reps... I talked to a customer service rep and they forwarded me to the IT team. Considering they are called advanced technical teams I would assume they are in IT. whereas the initial person I talked to was and clearly stated she was a customer service rep.
 

twistedumbrella

Recognized Developer
Sep 3, 2007
9,346
9,568
abandonedcart.gitlab.io
ASUS ROG Phone 5
The only difference between the two people you spoke with is that one had access and authorization to suggest more "advanced" solutions. I'm not saying they shouldn't have better training, but legitimate IT professionals rarely work the call center as more than a summer job.

Anyway, the point was that they're a waste of time unless the issue is the SIM card or your plan. It's unfortunate.

Dial codes typically trigger an intent. If you can track down the intent, you can have it launch automatically on boot. Once that's taken care of, it shouldn't be too hard to automatically enable the setting. That is assuming you called because setting the prop didn't work.

Another alternative if you do have a property and can't write to system is setting it with a magisk module, since the system is read only on a firmware level.
 
Last edited:
The only difference between the two people you spoke with is that one had access and authorization to suggest more "advanced" solutions. I'm not saying they shouldn't have better training, but legitimate IT professionals rarely work the call center as more than a summer job.

Anyway, the point was that they're a waste of time unless the issue is the SIM card or your plan. It's unfortunate.

Dial codes typically trigger an intent. If you can track down the intent, you can have it launch automatically on boot. Once that's taken care of, it shouldn't be too hard to automatically enable the setting. That is assuming you called because setting the prop didn't work.

Another alternative if you do have a property and can't write to system is setting it with a magisk module, since the system is read only on a firmware level.
How would I set that up using magisk module? One Issue I have noticed is the wifi calling turns itself off after a while. sometimes it works for several hours other times maybe a day but then turns off and I have to restart the phone and run the command again.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Thank you. I was debating between ROG or xperia 1iii. but if this works. Ill get ROG.
    If you dont mind, can you please post the dialer code
    Sure here you go *#*#3642623344#*#*
    You should be able to copy and paste if that doesn't work try pasting but delete the last * and add it manually. If that still doesn't work just manually type it in. But I tested it out a few times nd it works even turned on airplane mode and it works. Wi-fi calling was a deciding factor for me lol was about to return it until I found out I could get it to work properly.
    1
    So do you get wifi calling with US ROG phone on Tmobile?
    Yup just have to manually enable it Everytime it boots up but if you root it you can set the props and it will be permanent. In the process of doing that atm.
    1
    Thank you. I was debating between ROG or xperia 1iii. but if this works. Ill get ROG.
    If you dont mind, can you please post the dialer code

    Sure here you go *#*#3642623344#*#*
    You should be able to copy and paste if that doesn't work try pasting but delete the last * and add it manually. If that still doesn't work just manually type it in. But I tested it out a few times nd it works even turned on airplane mode and it works. Wi-fi calling was a deciding factor for me lol was about to return it until I found out I could get it to work properly.
    I'd like to add that after running the dialing code you have to enable wifi calling in the settings app.

    Aswell as that, at least for me, I need to disable and re-enable it within settings after re-running the dial after reboot, for it to actually reconnect


    Just to avoid any confusion.

    This does work tho! Kva is right!
    1
    I'd like to add that after running the dialing code you have to enable wifi calling in the settings app.

    Aswell as that, at least for me, I need to disable and re-enable it within settings after re-running the dial after reboot, for it to actually reconnect


    Just to avoid any confusion.

    This does work tho! Kva is right!
    Thank you both. Ill order the phone and try it.
    1
    I'd like to add that after running the dialing code you have to enable wifi calling in the settings app.

    Aswell as that, at least for me, I need to disable and re-enable it within settings after re-running the dial after reboot, for it to actually reconnect


    Just to avoid any confusion.

    This does work tho! Kva is right!
    It's so stupid wish they enabled it by default would make all our lives easier