• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Anyway to recover from this?

Search This thread

NickG1801

Member
May 24, 2010
24
2
T-Mobile Variant OP7P, was on Latest Pixel Experience+, Sim Unlocked, Unlocked Bootloader - Went to transition the phone back to T-Mobile stock OOS, not sure what happened. But since, The Sim card is recognized, but carrier and phone # are not, resulting in no service, also cannot modify APN settings.

Have tried to MSM back to all different firmware, remains the same, SIM Active, but not usable for mobile data or anything else
 

blackhawk

Senior Member
Jun 23, 2020
6,449
2,116
Try clearing the sim toolkit data, clear system cache and network reset.
Replace sim card. They are suspectable to ESD; always handle them like a stick of ram. While they are dirt cheap, a failure can prove costly in other ways.

A factory reset to purge it if less drastic measures don't work.
Not sure, never had to play with that.
 

hammered58

Senior Member
Nov 4, 2017
323
79
Wisconsin
T-Mobile Variant OP7P, was on Latest Pixel Experience+, Sim Unlocked, Unlocked Bootloader - Went to transition the phone back to T-Mobile stock OOS, not sure what happened. But since, The Sim card is recognized, but carrier and phone # are not, resulting in no service, also cannot modify APN settings.

Have tried to MSM back to all different firmware, remains the same, SIM Active, but not usable for mobile data or anything else
Hello, I was previously on a htc u11 and had something similar as in no data connection and no wifi, Mac address issue,,the thing that fixed my problem was an "erase persist" command in bootloader, not saying this will help your problem , just throwing it out there.
 

NickG1801

Member
May 24, 2010
24
2
Try clearing the sim toolkit data, clear system cache and network reset.
Replace sim card. They are suspectable to ESD; always handle them like a stick of ram. While they are dirt cheap, a failure can prove costly in other ways.

A factory reset to purge it if less drastic measures don't work.
Not sure, never had to play with that.
I MSM'd to stock firmware versions around 10 times, nothing different. Should've mentioned that the SIM works fine on my other phone, thing is totally clueless on how to read my SIM card it seems, registers as having one inserted and all, just doesn't do anything

Cannot even access APN settings when updated to the latest TMO Android 11, started from first Android 9 distro and continued updating on both paths, TMO and International versions of OOS, even tried flashing back to Pixel Experience- the ROM that was being used right before this took place.
 

NickG1801

Member
May 24, 2010
24
2
Hello, I was previously on a htc u11 and had something similar as in no data connection and no wifi, Mac address issue,,the thing that fixed my problem was an "erase persist" command in bootloader, not saying this will help your problem , just throwing it out there.
Weird thing is Wifi works, think I may have messed up EFS but not sure, IMEI is still valid and Wifi works, seems like only 2.4Ghz though with the speed of it
 
  • Like
Reactions: hammered58

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello, I was previously on a htc u11 and had something similar as in no data connection and no wifi, Mac address issue,,the thing that fixed my problem was an "erase persist" command in bootloader, not saying this will help your problem , just throwing it out there.
    Weird thing is Wifi works, think I may have messed up EFS but not sure, IMEI is still valid and Wifi works, seems like only 2.4Ghz though with the speed of it
    1
    Hard reboot stimulates pulling the battery. Not normally found in recovery. Done by holding down a button(s) depending on the phone or physically disconnecting the battery.
    Still no luck 👎, thanks again for the suggestion though