AOSP browser without root (yes you read that right) 4.3

blackhand1001

Senior Member
Sep 3, 2011
1,302
685
0
Same problem on my Moto G, Someone have an solution ?
In that case uninstall to provider, reboot, and then attempt to install the browser without the provider. The moto g likely does not have the provider installed by default so it doesn't need to be shorted out to get the aosp browser to install.

Sent from my Galaxy Nexus using XDA Premium 4 mobile app
 
  • Like
Reactions: maty3ux

maty3ux

Member
Nov 30, 2013
9
4
23
I had try this way, but i can't uninstall the provider because it's an system apps, i can désactived update, but that don't change anything.
Thanks for your help ;)
 
Last edited:

VyNkx

New member
Jan 1, 2014
1
0
0
BrowserProviderProxy.apk not found in /System/Apps

hi, I have everything which are needed to install AOSP browser, Except Two files named BrowserProviderProxy.apk and BrowserProviderProxy.odex, even though I tried the Whole procces without these two of them, but nothing worked. (I have 7" Android tab Running 4.0.4 ICS)
 

Abhijeet30

New member
Jan 1, 2014
3
0
0
hey! I want this for my Samsung Galaxy Star Pro which runs on JB 4.1.2 This phone also lacks the stock browser.. :( So Plz Help!
 
Last edited:

L.F.B.

Senior Member
Feb 29, 2012
824
357
93
Im on 4.4.2 in my nexus 7.

Installed the first file from zip, bit the browser.apk wont install. Say: not installed.
Whats the problem?
Please help.
 

Xuxe85

New member
May 25, 2014
1
0
0
Hey,
I'm on a sgs5 with android 4.4.2.
I can't seem to get the installation running. When I install browserproxy.app it says installation complete (instead of failed as mentioned in the description) and when I try to install signed browser.app it says installation failed. Please help, I really need that browser, chrome is driving me nuts!
 

tolinho

Member
Jan 25, 2008
18
1
0
Hey,
I'm on a sgs5 with android 4.4.2.
I can't seem to get the installation running. When I install browserproxy.app it says installation complete (instead of failed as mentioned in the description) and when I try to install signed browser.app it says installation failed. Please help, I really need that browser, chrome is driving me nuts!
I'm having the exact same issue.
Also running KitKat 4.4.2 unRooted

Is there a fix for this?
Thanks
 

Rohit02

Senior Member
Sep 17, 2012
4,090
3,798
0
Pune
I cant find browserproviderproxy in the zip file.. I just got the bookmarksync and the aosp apk from the OP download link.

I am missing something? Did any one tried it on 4.4.4?
 

zer0day

Senior Member
Oct 29, 2007
234
14
0
It's crashing on my replacement Xperia Z3 Compact. Oddly enough, it worked on the one I sent back because it was defective. I'm seeing this crash:

10-21 21:42:57.565: E/AndroidRuntime(5672): Process: com.android.browser, PID: 5672
10-21 21:42:57.565: E/AndroidRuntime(5672): java.lang.NoClassDefFoundError: com.android.browser.BrowserWebView
10-21 21:42:57.565: E/AndroidRuntime(5672): at com.android.browser.TitleBar.setFixedTitleBar(TitleBar.java:125)
10-21 21:42:57.565: E/AndroidRuntime(5672): at com.android.browser.TitleBar.<init>(TitleBar.java:73)
10-21 21:42:57.565: E/AndroidRuntime(5672): at com.android.browser.BaseUi.<init>(BaseUi.java:142)
10-21 21:42:57.565: E/AndroidRuntime(5672): at com.android.browser.PhoneUi.<init>(PhoneUi.java:64)
10-21 21:42:57.565: E/AndroidRuntime(5672): at com.android.browser.BrowserActivity.createController(BrowserActivity.java:90)
10-21 21:42:57.565: E/AndroidRuntime(5672): at com.android.browser.BrowserActivity.onCreate(BrowserActivity.java:73)
10-21 21:42:57.565: E/AndroidRuntime(5672): at android.app.Activity.performCreate(Activity.java:5231)
10-21 21:42:57.565: E/AndroidRuntime(5672): at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1087)
10-21 21:42:57.565: E/AndroidRuntime(5672): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2201)
10-21 21:42:57.565: E/AndroidRuntime(5672): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2286)
10-21 21:42:57.565: E/AndroidRuntime(5672): at android.app.ActivityThread.access$800(ActivityThread.java:144)
10-21 21:42:57.565: E/AndroidRuntime(5672): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1246)
10-21 21:42:57.565: E/AndroidRuntime(5672): at android.os.Handler.dispatchMessage(Handler.java:102)
10-21 21:42:57.565: E/AndroidRuntime(5672): at android.os.Looper.loop(Looper.java:212)
10-21 21:42:57.565: E/AndroidRuntime(5672): at android.app.ActivityThread.main(ActivityThread.java:5137)
10-21 21:42:57.565: E/AndroidRuntime(5672): at java.lang.reflect.Method.invokeNative(Native Method)
10-21 21:42:57.565: E/AndroidRuntime(5672): at java.lang.reflect.Method.invoke(Method.java:515)
10-21 21:42:57.565: E/AndroidRuntime(5672): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:902)
10-21 21:42:57.565: E/AndroidRuntime(5672): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:718)
10-21 21:42:57.565: E/AndroidRuntime(5672): at dalvik.system.NativeStart.main(Native Method)
 

javi.man

New member
Oct 18, 2016
1
0
0
hi @digital.cookies ! Could you update your android browser app with new features? like "save pages for offline reading" "receive notifications from websites" and "draw pattern to unlock", etc. The app is working ok, the only bug is when you set your booksmarks and most visited pages as homepage, shows "err_connection_failed" and then a blank page. Many thanks!!
 
Last edited: