• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

AOSP Kitkat 4.4.4 for MicroMaX Canvas 2+ A110Q (MTK6589) [SUPERFAST] [SUPERBATTERYBAC

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    SYSTEM PARTITION NEEDED
    Features of Android 4.4.4 KitKat on MicroMaX Canvas 2+ A110Q (MTK6589) [SUPERFAST] [SUPERBATTERYBACKUP]

    -Latest Android 4.4.4
    -Latest Android 4.4.4 Stock Camera with Gallery
    -Good Battery Backup
    -Playing Games Smoothly
    -Buttery Smooth
    -Settings themed
    -New Status Bar
    -3G SIM Switch
    -Sim Toolkit
    -New Bootlogo
    -Init.d Scripts
    -Latest Playstore
    -New LockScreen
    -New Dialer
    -New Contacts
    -New Messages
    And Many More.........

    Bugs :
    for phone memory mount use MTP
    Tell if you see any more....


    Installation :
    How To Flash :

    use KK support CWM Recovery AND system partition needed.

    ( You Can Take CMW Backup for Revert back to your old system )
    1) Download ROM zip File below link
    2) Put into External/Internal SD Card
    3) Go To CMW Recovery
    4) Wipe Data/Factory Reset
    5) Wipe Cache
    6) From Advance Menu Do Delvik Cache Clear
    7) Go in Mount And Storage select FORMAT SYSTEM
    8) Select Install From SD and Select file And Click YES
    9) Select ROM zip And Select YES
    10) Reboot
    11) Congrats You have Rom now....Report if you find bugs

    (It will take around 5 Min. for first boot)

    MORE Screen Shots

    If flashing CUSTOM BASED ROM destruction in whatsoever in your world, neither me, nor any of my dev brothers and not even WEB OR FORUM SITE is responsible for that.
    You are the one who has choosen to modify your phone and so all risk and durability is your only, no one

    Original ROM Developer :- http://forum.turkdevs.com

    (credit : smiletolif to, NeedRom, xda developers, 4pda.net . If I forgot a any developer name please suggest me I will add defiantly & Swapnil Bunjkar )

    All things happen because of all above users, developers and forums, so give Thanks and Credit them,
    I am not developer I am just Porter.

    DOWNLOADS
    customroms.theSwapnil.cOM
    Mirror1
    Mirror2 [Thanks to mohitk144]
    for root problem flash this
    For MemFixorSwap [Thanks to asainiboy]

    XDA:DevDB Information
    AOSP Kitkat 4.4.4 for MicroMaX Canvas 2+ A110Q (MTK6589) [SUPERFAST] [SUPERBATTERYBAC, ROM for the Micromax Canvas 2 Plus A110Q

    Contributors
    theswapnil
    Source Code: forum.turkdevs.com

    ROM OS Version: 4.4.x KitKat
    ROM Kernel: Linux 3.4.x
    ROM Firmware Required: 4.4.4
    Based On: AOSP

    Version Information
    Status: Stable

    Created 2015-03-12
    Last Updated 2015-03-18
    2
    Great rom..!!!

    Used this rom for last 1 hr n its simply awesome...
    No proximity sensor issue..
    No video drivers problem...
    Youtube video plays flawlessly...
    No glitches...:D
    The only reason i uninstalled it was because it is not root.(superuser is installed bt no root permission)...
    Eagerly waiting for someone to provide solution to that...
    I found some bugs bt i think they can be solved easily...

    Bugs which i found:
    Mic not working in google search..(works in call and voice recording)
    Inbuilt camera do not give full 8 mp resolution(google camera works fine)
    When connected to pc only sd card is connected and internal is not(not a big deal)..

    Great work dev...
    For me its one of the best kitkat rom...:)
    Just provide solution to for root
    2
    Mega.co.nz does not seem to work for me. Will it be possible to provide alternate link to download the ROM.

    I'm unable to download the ROM since the link given is not working :(

    u_knw_who, Can u please give link on google drive for the ROM? I am unable to download from mega.co.nz links as that seems blocked. Help please!

    alternate link for rom is here... AOSP Kitkat 4.4.4 for MicroMaX Canvas 2+ A110Q (MTK6589)
    1
    Simlink Error

    Many ROMs have this error and none of the ROM porters have solution for this. :crying:

    Not sure, but is it something to do with different versions of Micromax Canvas 2+? Manish's one ROM had similar error which he had solved in his next update.
    1
    how to move apps to SD card..?? any solution.
    and how to revert back original system partition?

    Dear bro search "a110q system partition" on google.