Question AOSP rom backup restores but won't start?

Search This thread

Aserar

Senior Member
Oct 10, 2014
150
24
So I made a backup through OrangeFox of my A13 AOSP rom (checked every option). Now I tried to restore the backup and the restore goes normally but when I reboot to system it shows Poco logo for couple seconds then reboots to recovery and internal memory is messed up. I formatted data and tried installing the rom then restoring data alone, then data and super system, Ans the result was the same which is the rom animation starts and "starting Android" loading screen appears but never goes away. Any idea on how to get it working?
Thanks in advance
 
  • Like
Reactions: cyanGalaxy
Are you trying to restore the Backup after you formated data/reflashed ROM ?

I trusted TWRP backups twice, and both times it failed.

I think to backup /data, you also have to backup /metadata, because /metadata stores the encryption-key for /data.

I also recommend the app "Swift Backup" from Play Store, it's the best app for backing up apps + appdata, messages, and call history. Requires Root to backup app-data of course.
 
  • Like
Reactions: Aserar

lapirado

Senior Member
Aug 25, 2015
250
84
38
OnePlus 3
Xiaomi Poco F3
So I made a backup through OrangeFox of my A13 AOSP rom (checked every option). Now I tried to restore the backup and the restore goes normally but when I reboot to system it shows Poco logo for couple seconds then reboots to recovery and internal memory is messed up. I formatted data and tried installing the rom then restoring data alone, then data and super system, Ans the result was the same which is the rom animation starts and "starting Android" loading screen appears but never goes away. Any idea on how to get it working?
Thanks in advance
Yeah seems like is a tough (or impossible) mission to recover a backup in alioth.
I've done twice too, and both didn't booted too.
And this in twrp skkk, so I guess it's the same thing in all recoveries.
 
  • Like
Reactions: Aserar

Aserar

Senior Member
Oct 10, 2014
150
24
Yeah seems like is a tough (or impossible) mission to recover a backup in alioth.
I've done twice too, and both didn't booted too.
And this in twrp skkk, so I guess it's the same thing in all recoveries.


Are you trying to restore the Backup after you formated data/reflashed ROM ?

I trusted TWRP backups twice, and both times it failed.

I think to backup /data, you also have to backup /metadata, because /metadata stores the encryption-key for /data.

I also recommend the app "Swift Backup" from Play Store, it's the best app for backing up apps + appdata, messages, and call history. Requires Root to backup app-data of course.

Okay so I figured it out. You basically need to flash the same backed-up rom first and fully boot it to system. This will take care of encryption, then reboot to recovery, then restore your backup (boot/data/super). At this point reboot won't work yet. You need to go back to recovery and reflash the rom again then boot into system. For me it booted once but the status bar was missing. I did a restart and voila! It worked.
 
Last edited:
Okay so I figured it out. You basically need to flash the same backed-up rom first and fully boot it to system. This will take care of encryption, then reboot to recovery, then restore your backup (boot/data/super). At this point reboot won't work yet. You need to go back to recovery and reflash the rom again then boot into system. For me it booted once but the status bar was missing. I did a restart and voila! It worked.
Thanks for sharing your solution!

Sounds a bit quirky but I'm glad someone got TWRP Backup Restores working!

Man the bloody forced encryption.. i hate it. 😅
 
  • Like
Reactions: lapirado

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Yeah seems like is a tough (or impossible) mission to recover a backup in alioth.
    I've done twice too, and both didn't booted too.
    And this in twrp skkk, so I guess it's the same thing in all recoveries.


    Are you trying to restore the Backup after you formated data/reflashed ROM ?

    I trusted TWRP backups twice, and both times it failed.

    I think to backup /data, you also have to backup /metadata, because /metadata stores the encryption-key for /data.

    I also recommend the app "Swift Backup" from Play Store, it's the best app for backing up apps + appdata, messages, and call history. Requires Root to backup app-data of course.

    Okay so I figured it out. You basically need to flash the same backed-up rom first and fully boot it to system. This will take care of encryption, then reboot to recovery, then restore your backup (boot/data/super). At this point reboot won't work yet. You need to go back to recovery and reflash the rom again then boot into system. For me it booted once but the status bar was missing. I did a restart and voila! It worked.
    1
    So I made a backup through OrangeFox of my A13 AOSP rom (checked every option). Now I tried to restore the backup and the restore goes normally but when I reboot to system it shows Poco logo for couple seconds then reboots to recovery and internal memory is messed up. I formatted data and tried installing the rom then restoring data alone, then data and super system, Ans the result was the same which is the rom animation starts and "starting Android" loading screen appears but never goes away. Any idea on how to get it working?
    Thanks in advance
    1
    Are you trying to restore the Backup after you formated data/reflashed ROM ?

    I trusted TWRP backups twice, and both times it failed.

    I think to backup /data, you also have to backup /metadata, because /metadata stores the encryption-key for /data.

    I also recommend the app "Swift Backup" from Play Store, it's the best app for backing up apps + appdata, messages, and call history. Requires Root to backup app-data of course.
    1
    So I made a backup through OrangeFox of my A13 AOSP rom (checked every option). Now I tried to restore the backup and the restore goes normally but when I reboot to system it shows Poco logo for couple seconds then reboots to recovery and internal memory is messed up. I formatted data and tried installing the rom then restoring data alone, then data and super system, Ans the result was the same which is the rom animation starts and "starting Android" loading screen appears but never goes away. Any idea on how to get it working?
    Thanks in advance
    Yeah seems like is a tough (or impossible) mission to recover a backup in alioth.
    I've done twice too, and both didn't booted too.
    And this in twrp skkk, so I guess it's the same thing in all recoveries.
    1
    Okay so I figured it out. You basically need to flash the same backed-up rom first and fully boot it to system. This will take care of encryption, then reboot to recovery, then restore your backup (boot/data/super). At this point reboot won't work yet. You need to go back to recovery and reflash the rom again then boot into system. For me it booted once but the status bar was missing. I did a restart and voila! It worked.
    Thanks for sharing your solution!

    Sounds a bit quirky but I'm glad someone got TWRP Backup Restores working!

    Man the bloody forced encryption.. i hate it. 😅