[APK][W/ or W/O ROOT] Full ADOBE FLASH 10.1 working on HTC SENSE UI Eclair 2.1 Rom~!

Does this Flash 10.1 work for your HTC Desire?


  • Total voters
    175
Search This thread

jsoneng

Senior Member
Sep 12, 2008
247
1
Buangkok Green
WARNING: THIS WILL ONLY WORK WITH HTC SENSE UI ECLAIR 2.1~!!! NOT ON STOCK ECLAIR 2.1...

Hi all,

I take no credit on this .apk files that I came across while searching for flash player for our HTC Desire..

I tried installing it in and miraculously it works on our Stock Browser.. If the first time you install the .apk file and it cannot load flash player.. Do reboot your phone and try again..

Source: http://forum.xda-developers.com/show...9&postcount=16



How it work on our 2.1 roms:

Android 2.2 has a new feature called com.google.android.feature.GOOGLE_PLUGIN. And Flash uses it to embed itself inside browser. So browser in 2.1 does not see plugin.
BUT!There’s another thing inside – a permission called android.webkit.permission.PLUGIN. It is already used by Flash Lite on HTC devices. So my APK will work and replace Flash Lite. But I did not test, because I do own… Acer Liquid!
So! HTC users! Try this one! And if it will work instead of your flash lite – report. Your help will be used to port full-blown Flash to other 2.0 and 2.1 devices (yeah! 2.0 is also supported!).


Screenshots:
image_thumb88.png
image_thumb89.png
 
Last edited:

epitomic

New member
Mar 20, 2010
4
0
Hey the attachment works fine, but the link to the source thread is broken. Can fix it? Thanks?
 

aibo

Senior Member
Sep 15, 2007
341
41
Hello all. This apk brings nothing, it just act like flash lite. Websites that don't work with flashlite still don't work with this
 

yukkio

Senior Member
May 19, 2009
1,377
109
Flash lite still works instead of full flash... If we could disable flash lite for non rooted users.
 

jsoneng

Senior Member
Sep 12, 2008
247
1
Buangkok Green
source link edited.. weird.. i tried on mine.. full flash is working for me... adobe website also state i had succesfully installed flash 10.1 .... hmx..
 

FloHimself

Senior Member
May 27, 2010
558
218
Ok, now i've installed:

* HTC Flash Lite Plugin
* HTC Flash Player Version 7
* Adobe Flash Player 10.1

How do I know which one is used by the Webbrowser?
Are they all needed for full flash support?
 

EddyOS

Senior Member
Jan 2, 2010
15,281
4,030
London
iPlayer needed me to upgrade to 10.3 BETA (which I did) and it works but it's VERY choppy (using MCR FroYo)
 

scopes64

Senior Member
Feb 25, 2006
89
36
Can anyone confirm this as working? I am not convinced it replaces Flash lite

Testing.

Before start adobe flash version 10.1.123.391, Vanilla HTC desire so this is flash lite

Install APK and reboot, Version 10.1.123.391

I have installed / removed and tested in all combinations and not joy. So for me no matter what combo I try it does not replace the Flash lite version pre installed.

Phone: HTC Desire, T-Mobile UK, software 1.15.110.1