[APP][2.2+][2013-03-15] Linaro builds of Firefox/Fennec for Android ARMv6

xmixahlx

Senior Member
Oct 31, 2011
111
121
0
NOTE: If you are looking for Linaro builds of Firefox/Fennec for Android ARMv7, those are over here.

UPDATE: Producing Beta, Aurora and Nightly builds again.

UPDATE: Mozilla has updated the build system to start creating ARMv6 builds of Beta, Aurora, and Nightly. Due to this (great!) news, I've stopped producing Debug, Default and Optimize builds of Firefox/Fennec and will only continue with Linaro builds for now.

Notes:
* These builds are ARMv6 ONLY!
* Supports Flash. v11/v10.3 recommended
* Fennec may currently only work for Android 2.2+ devices per Mozilla's Dev Team, but YMMV.
* Tested without issue on Republic Wireless LG Optimus S (LG LS670, AOSP 2.3.5, CM7).
* If you have issues with Sync, remove Nightly/Beta/Aurora installations from your PC and use Release to initiate pairing of your ARMv6 device

Troubleshooting:
* If you receive the error "Secure Connection Failed" with error code "sec_error_no_memory", you must disable TLS support:
1. browse to about:config
2. search for "tls"
3. toggle "security.enable_tls" to false
(Screenshot attached: 2012.06.15-10.24.25.jpeg)

ADBlock Plus:
* Development builds of AB+ work. (Tested with b3478). They can be found here.

-Michael


CURRENT DOWNLOADS (Mediafire)

~2013-03-15
814a3c08e5b394dd5aed5d3cb33db648 Beta 20.0 2013-03-15
557018e64da8325e88ea0fd8bfba5929 Aurora 21.0a2 2013-03-15
ffe80fd36443d9cb1d31a74d33030d7a Nightly 22.0a1 2013-03-15

OLDER DOWNLOADS

LINARO ONLY BUILDS (Mediafire)
~2012-10-31
cf3967e4d3333b032d9c056c0a3cf815 Release 16.0.2 2012-10-31 Linaro Optimize
fe97389213953d74ac8130bb8765d447 Beta 17.0 2012-10-31 Linaro Optimize
eb723bd3728ca2b53b80d83698fcf351 Aurora 18.0a2 2012-10-31 Linaro Optimize
65bcff80fa5f1278866c56de8dbfd03a Nightly 19.0a1 2012-10-31 Linaro Optimize

Build Notes to aid in testing:
* "Linaro" builds use Ray Donnelly's patched Linaro Android Toolchain version 4.6.3-2011.12
 

Attachments

Last edited:

Mike B.

Recognized Contributor
Nov 17, 2011
3,140
3,173
263
/
Working very nicely (except for sync), including Flash, on a rooted LG P506 (LG Thrive) running GB 2.37 with CM7-7.2 and a 2.6.35 kernel.

Let's hope sync comes to the ARM6 eventually...
 

xmixahlx

Senior Member
Oct 31, 2011
111
121
0
Working very nicely (except for sync), including Flash, on a rooted LG P506 (LG Thrive) running GB 2.37 with CM7-7.2 and a 2.6.35 kernel.

Let's hope sync comes to the ARM6 eventually...
Sync is working on my ARMv6 device (Republic Wireless AOSP/CM7 LG Optimus S). I have access to another ARMv6 device to verify shortly.
 
Last edited:

Mike B.

Recognized Contributor
Nov 17, 2011
3,140
3,173
263
/
That's good news since our phones are very similar, but still no luck here.

The MacBook is sending the data to the sync server, the phone is paired and connected, the sync account is active, everything looks good except that Fennec doesn't seem to know anything about the sync'd data (bookmarks, passwords, history).
 
Last edited:

xmixahlx

Senior Member
Oct 31, 2011
111
121
0
Just verified on another Republic Wireless LG Optimus S that Firefox Sync is working as expected (Well... at least for that device...).
 

Mike B.

Recognized Contributor
Nov 17, 2011
3,140
3,173
263
/
Working! After several tries, I finally managed to import/sync my data from desktop to phone.

Unfortunately, I changed too many things to be sure of what the actual problem was, but I'll attempt to narrow it down as soon as time permits.

Two things I know I changed were: install in internal memory instead of SD card, and login to the server (with security key) first instead of going directly to the pairing.Other factors, such as addons, Wifi vs. 3G, etc. are probably irrelevant.

Fennec is now back on the SD card and I'll check on whether it keeps on syncing properly.

No other issues to report (yet). Thanks for giving us this version. Firefox in sync with the MacBook will be a pleasure to use.

Update: after 12 hours, sync still behaving as it should.
 
Last edited:

Mike B.

Recognized Contributor
Nov 17, 2011
3,140
3,173
263
/
Minor glitch: sync doesn't seem to survive a reboot.

I first noticed after my weekly CWM recovery backup, but it happens even with a plain reboot. The sync account vanished and Fennec gave me a new set of pairing codes. It was a simple matter of re-pairing from the MacBook, but in an ideal world, that account should remain just like the Google accounts.

I run Fennec on the SD card (moved with Titatnium Backup) but no data2SD. Anybody else have that problem?
 

thebenefactor

Senior Member
Apr 25, 2011
204
86
0
It is not crashing and also connecting normally but main issue with me is that its only showing white pages after loading successfully as i can see new icons in title bar. Any idea why so? :( my phone is samsung galaxy3
 

xmixahlx

Senior Member
Oct 31, 2011
111
121
0
It is not crashing and also connecting normally but main issue with me is that its only showing white pages after loading successfully as i can see new icons in title bar. Any idea why so? :( my phone is samsung galaxy3
Can you give me more information about your phone? What is your Android OS? Chipset? Is this the right information here?:
http://www.gsmarena.com/samsung_i5800_galaxy_3-3395.php

Sorry, not familiar with your device.
 

Mike B.

Recognized Contributor
Nov 17, 2011
3,140
3,173
263
/
Somehow it seems that sync is starting too early in the boot process. I'm still trying to figure out where the Fennec sync account is stored and therefore when it becomes available. I wonder if the official ARMv7 builds behave differently or if those sync issues are more generic. Either way it's not a show stopper.
 

xmixahlx

Senior Member
Oct 31, 2011
111
121
0
Somehow it seems that sync is starting too early in the boot process. I'm still trying to figure out where the Fennec sync account is stored and therefore when it becomes available. I wonder if the official ARMv7 builds behave differently or if those sync issues are more generic. Either way it's not a show stopper.
It is under Settings > Accounts & Settings with your Gmail accounts, IIRC.
 

Mike B.

Recognized Contributor
Nov 17, 2011
3,140
3,173
263
/
Yes, that's where it appears, but after a reboot it's gone and I haven't figured out yet where it might live in Titanium backups so that I could restore it.
 

xmixahlx

Senior Member
Oct 31, 2011
111
121
0
Yes, that's where it appears, but after a reboot it's gone and I haven't figured out yet where it might live in Titanium backups so that I could restore it.
Ah! Yeah... that would explain why it isn't working after a reboot, but I don't know why it would be missing (???).

I've updated the Nightly and changed some build settings (removing the updater, for example, since it won't work). Here it is.
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone