[APP][25MAR10]Gen.Y DualBOOT v1.0.6.0[W|Q|VGA][CAB|EXT]

Search This thread


New member
Nov 13, 2010
Do the Android files need to be in the root of the SD card, or can they be put in a folder? Is there a registry change I can make to point to a folder instead of the root? Thanks.


New member
Jan 8, 2012
hey.. wazzup.. this app is crazy man.. i just want to know if this works with htc p3400.. it runs windows mobile 6.

and where do i get the android files for my device? i just found out it's also called htc GENE..

thanks for the help.
Last edited:


Sep 2, 2009
hi there,

I may not understant corectly, this app it supposed to give you the option when you power on the device to choose the operating system correct?
Because i install it on my blackstone and is booting normal to windows mobile and then i enter to my applications to find the dual boot app, if is like this what i need it for, is the same as i go and select haret.exe.


Nov 16, 2011
Возможно ли сделать так, что бы программа перед запуском haret.exe запускала clrcad.exe?

Is it possible to do so, that would be before you start the program then launched haret.exe clrcad.exe?


Jan 13, 2012
Hey Guys,

I've got the HTC touch Pro 2 but cannot find out which screen res to use - I installed VGA internal storage, but the screen was all over the place and the warning came up for no android found... I'm going to reg edit to the location of the android but which is the correct version of Gen.Y Dual Boot?


New member
Jan 15, 2012
Dear sir
thanx for dual boot application.
i have htc iolite and i am trying but when run haret one pop-up window appear
"termination haret due to unhandled exception (pc=10c6fb4)
and i not use this application so please guide me how can i do.
waiting for your kind reply.


New member
Jan 20, 2012
i install it on main memory but when run it don't find android says android is missing.. i'm with FroyoB BSY V2 (Raph100).. What to do?


New member
Jan 23, 2012
Hi, I have even a small doubt regarding Android on Xperia, Xperia x1 if WM 6.5 also starts taking the Android one x2 could do? should not? I could solve this question?

PS: Sorry for the bad English, my language is Spanish.


New member
May 2, 2011

I installed Froyo 2.2 with success. I have a few questions.. maybe more than a few :p

1. Everytime I restart my phone with WM and then go launch the Haret.exe I get the pink screen and then it loads to Android (very quick after the first time). Is this correct?

2. I installed the dual boot. When I select Android, i still get the pink screen.. I like pink but I don't want the pink screen.. What should I do?

3. In Android I get "SD card damaged. you may have to reformat it". When I enter the SD card via WM it's empty.. Wasn't it suppose to have the Android partions on it? Can I format it via WM? Will I lose my Android?

4. Quick ways to export contact list from WM and import it to Android? I tried "that" Omnia programme but it doesn't work. Hence I don't even remember its name LOL

Thankk youuuu
Last edited:


New member
Feb 10, 2012
It doesn't work on my Blackstone

I have tried GenY's DualBoot from storage card and from mobile's folders. It doesn't work. It just shows the interface and then the 'progress' bar progresses 'backwards' and then it gets stuck. Clicking on Android icon, Reboot radio button or Fast Reboot radio button everything triggers an error pop up window saying error in 'sub_main_so and so' continue? yes/no. If you say yes, it simply quits the app and goes into windows :(

Somebody please help me.


Sep 18, 2011
2.3.1 and 6.5 on HTC HD2 dual boot

I'm running the dual boot with the Android 2.3.1 and WM 6.5...I been looking on the how to update the 2.3.1 to 2.3.5. or 2.3.7....does anyone have the ideas? or the how to?....it's a little complicated just to get these two to work, but they do. auto boot or you select. your choice.
I found the how to on these 2 else where if i may post the link, i will...ill wait to hear replies from the Mods here or Some upper Authority.
I'm a noobie.
Thank You


New member
Feb 26, 2012
Hi, I can ask a version for Samsung Omnia 2 WVGA Android Internal Stogare Boot'a file "Haret"?
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Just to clear up the most asked question in this thread, this app will NOT work with the HTC HD2, because there is no android distro available yet for that platform (SnapDragon)

    Gen.Y DualBOOT: Dual boot solution for Windows Mobile devices with XDANDROID

    Before I start, I wanted to give my props to all android developers that made android possible on our devices: please support these guys: XDANDROID team (Diamond/Raphael/Blackstone..), Topaz Android Team & others that I might have missed

    *Just to clear things up, this is only a bootlauncher app, u still need to install android for yourself on your device

    Android on WM devices is getting more and more popular, especially with the latest developments, and it's almost ready for daily use. I wanted to have an app so we could easily boot into both WM & Android, and Gen.Y DualBOOT was the solution. This release is made for VGA devices, and supports booting Android both from Internal Storage (moviNAND, e.g. Touch Diamond) & Storage Card (SDMemory, e.g. Touch Pro). WVGA version and QVGA version is also ready. This app has been tested on WM6.1, but will work perfectly on WM6.5.x as well.
    Keep in mind that your android setup must be installed already at the root of your storage card in order for this app to work correctly (e.g. \Internal Storage\haret.exe or \Storage Card\haret.exe respectively)

    User Guide
    Here's a quick User Guide, showing the interface and what the buttons are for:

    This app is launched by a registry key created in [HKEY_LOCAL_MACHINE\init], so it launches directly at boot after shell gets initialized.
    Chefs: If u are going to cook this app into your ROM, make sure that this key gets added DURING your customization procedure (and not before!)

    There are 2 checkboxes, enabling automatic boot:
    AutoBoot: enabling this mode will automatically boot the OS of your choice after a 10 second countdown
    > disabling autoboot will remove the countdown completely
    FastBoot: enabling this mode will automatically boot the OS of your choice after a 3 second countdown (requires AutoBoot to be enabled first)

    Now apart from these 2 checkboxes, u have 2 radiobuttons, which allow u to choose which OS gets automatically booted.

    And last but not least, u have the 2 manual launch buttons. Pressing these buttons will directly launch (overriding autoboot) Windows Mobile or Android.

    Gen.Y DualBOOT checks for 5 registry keys, which allow some form of customiation. Apart from the last key (StorageBootMode), all keys can be modified utilizing the radio & check buttons in the GUI. All of these keys can be found in:

    Here's quick list describing what the keys are for
    • "AutoBootEnabled"=dword:1 (1: enable autoboot | 0: disable autoboot)
    • "FastBootEnabled"=dword:0 (1: enable fastboot | 0: disable fastboot)
    • "AutoBootAndroid"=dword:1 (1: boot Android | 0: boot Windows)
    • "StorageBootMode"=dword:0 (1: boot from Storage Card (SDMemory) | 0: boot from Internal Storage (moviNAND))
    • v1.0.6.0 and newer: "AndroidBootFolder"="string" ("": boot from root of storage (e.g. \Storage Card\haret.exe)| "andboot": boot from \Storage Card\Andboot\haret.exe, string can be edited in registry)
    • v1.0.5.0 and older: "AndroidBootFolder"=dword:0 (1: boot from \Android\ folder on storage (e.g. \Storage Card\Android\haret.exe)| 0: boot from root of storage)

    The example values are the ones that are in the CAB for Internal Storage devices.

    Planned features
    - Complete boot processes control
    - Slight GUI redesign
    - Config app in WM & Android

    - Added flexible android boot folder option
     > Set boot folder by entering the desired folder string to the "AndroidBootFolder" key in the registry
    - Minor code adjustments
     > No longer requires seperate .MUI file
    - Added program icon (+ WM6.5 png icon)
    - Added shortcut to Start Menu > Programs
    - Re-checked code, now working perfectly
    - Fixed bug with autoboot being disabled on boot if android was missing
    - Fixed bug with manual Android launch only working if AutoBoot set to Android
    - Added new registry key to allow booting from \Android\ folder on memory card
    - Added checking for haret.exe before enabling the android boot option
     > if the android button is disabled, u can re-enable it (after disabling usb mass storage mode, or inserting the sd card that contains the android setup) simply by pressing the disabled android icon
    - QVGA layout fixed
    - Signed .exe file with SDKCerts
    - Fixed boot problems by moving genyboot to Launch62 in HKLM\init
     > Now boots even on stock ROMs!
    - Fixed registry issues
    - Initial Release

    The source of Gen.Y DualBOOT (and also DualSWITCH, a tool to switch between AT&T and normal Touch Pro keyboards in android) has been released.
    This is for developers only. The source has been compiled in Basic4ppc.
    Gen.Y DualBOOT Source

    Download the attached cabs or simply click the link below to download all resolutions in one zip package

    There are 5 versions available:
    • QVGA, boot from Storage Card (e.g. Vogue, Kaiser,..)
    • WQVGA, boot from Storage Card
    • VGA, boot from Internal Storage (e.g. Diamond)
    • VGA, boot from Storage Card (e.g. Raphael)
    • WVGA, boot from Storage Card (e.g. Blackstone, Topaz, Xperia,..)

    Gen.Y DualBOOT v1.0.6.0 CABs (QVGA|WQVGA|VGA|WVGA)
    Gen.Y DualBOOT v1.0.6.0 VisualKitchen EXT packages for Chefs (QVGA|WQVGA|VGA|WVGA)

    This app MUST be installed on your internal memory in order for autoboot to work. (installing on internal storage/storage card will cause the app not to launch on boot)
    Also make sure that all registry entries are correct, since an incorrect/missing registry key can cause errors (v1.0.6.0: make sure the AndroidBootFolder key is a STRING (not dword!)

    For chefs: if u are also cooking in RunCC, cooking this app to the \Windows folder is recommended to save storage space (since the progress image are the same)
    For chefs: u can make Gen.Y DualBOOT start faster by moving editing the following (be aware, this will not work in all roms!). Open mxipupdate_xdandroid-genyboot_100.provxml, and change "Launch62" to "Launch52" in the following line:
    <parm name="Launch62" value="genyboot.exe" datatype="string"/>

    The CAB works for all languages (v1.0.6.0)

    GT inspired Skins by sk8inmonk

    ElCondor has made a nice Android Theme for Gen.Y DualBOOT, you can find it in this thread

    I would like to express my thanks to all of you who have provided me with feedback, bug reports and donations.
    This app wouldn't have been the same without you.

    If u like my work and would like to thank me for the time spent, you can always donate
    Can someone explain how to fix the "Android is missing" error in simple terms? I am having this problem on my TP and Diamond, too.
    When you are running from the Andboot folder on the Storage card, do the following at the Registry location shown on the first page of this thread:


    When you are running from the root of Storage card (without any folders), leave the string blank.

    Hit that Thanks button if this worked for you... :)
    Yes, I can run it manually.

    could you try this new attached WVGA cab then? This new cab directly installs it into the windows folder, which should work better for the HKLM\init procedure. Also, i signed the .exe this time with msigner. Let me know if it works.

    * check the new version at the first post
    As a programmer, I am VERY ANGRY with this application.
    How can a application stupid like this? Are you kidding me? hardcode the path? Ask user to change registry just for change the path?

    shame on you.
    Dear Lord, why doesn't anything works as it should, like it used to be???

    I'm also having this problem, and here's what I found:

    1- (of course) I have a working haret.exe on the root of Internal Storage
    2- Installed Gen.Y VGA to the internal memory (NOT the Internal Storage): check registry, entries are there;
    3- run Gen.Y, click Android, it boots Android
    4- After reboot, the dreaded "An error occurred retrieving the registry key" error appears: click cancel, go to the registry, entries are not there!! wth?!!?
    5- manually create entries, reboot, still the same friggin' error: go to the registry, entries are still NOT there!! wtf?!!?

    So there is the friggin' problem: why are the registry entries dissapearing? And YES, i've red almost all of this giant thread. geez..
    I had this problem too.
    Make the registry entry and restart windows to apply it. It seems a side-effect of running haret is that the recent keys are not saved. It's odd, but that was the problem.