[APP][CAMERA-MOD][7.1.X] Collection camera Modded [NEWS][12/08]

Search This thread

jbmc83

Senior Member
i can warmheartedly recommend this website right here: https://www.celsoazevedo.com/files/android/google-camera/

listing all current GCam ports from the most important devs in that area :)

At the moment, it looks like the Arnova8G2 ports are the most compatible ones with our Mi Max 2 phones. v1.2 doesnt have Portrait Mode but works flawlessly including HDR+ Enhanced and basically all Phone Model HDR+ modes. All v1.3 and v1.4 ports dont work well on our phones (lots of black screens). v1.5 beta works better and also includes a working Portrait Mode, however only "Nexus 6" Auto and "Pixel 2017 ZSL HDR no PD" Phone models work concerning HDR+, all others cause a black screen. Thus, HDR+ Enhanced is not available.

So its either v1.2 including HDR+ Enhanced due to lots of HDR+ phone models working properly, but without Portrait Mode

or

v1.5 including Portrait Mode but only with regular HDR+ due to just two phone modes working for HDR+

cheers!
 

silverstream

Senior Member
Sep 24, 2009
759
70
Updated to V1.5Beta 2 and it's a lot better, Potraits works front and back. Motion took picture but nothing is saved.
I noticed Nexus 6 is really slow in processing
EDIT: Pixel 2017 ZSL HDR No PD/Pixel2 seems faster but stuck at processing HDR+ in gallery and photo never saved
 
Last edited:
  • Like
Reactions: drtrinhtanlap

jbmc83

Senior Member
Updated to V1.5Beta 2 and it's a lot better, Potraits works front and back. Motion took picture but nothing is saved.
I noticed Nexus 6 is really slow in processing
EDIT: Pixel 2017 ZSL HDR No PD/Pixel2 seems faster but stuck at processing HDR+ in gallery and photo never saved
yes thats the same experience i am having. only nexus 6 auto works, unfortunately.

in what way is v1.5 beta 2 better? please specify...

Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk
 

Ruguoli

Member
Jan 12, 2018
13
1
It does not work when you try to make a video with the rear camera with the video stabilizer.
 
Last edited:

jbmc83

Senior Member
It does not work when you try to make a video with the rear camera with the video stabilizer.
works fine here. arnova8g2 v1.5 beta1, beta2 and stable...

Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk

---------- Post added at 05:58 PM ---------- Previous post was at 05:55 PM ----------

Bro can you please s suggest which version to use with which settings that work with video mode too? Currently using v1. 5 beta of arnova and video mode isn't working on nexus 6 settings
arnova8g2 v1.5 beta1, beta2 and stable all work fine, including all video resolutions back and front camera. be sure to set "nexus 6 auto" for config camera hdr+ and "nexus 6p" for model in settings.

rest of the settings i have detailed in the lineage os thread, it was post number...dont remember exactly, but it was somewhere 845-850 in that range :)

Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk
 
  • Like
Reactions: ridershahmir

Ruguoli

Member
Jan 12, 2018
13
1
Hi. yes, I do have the configuration that you mention. from old versions, 1.3. to me the video gives me failure. in version 1.5. recording at 4k I have no problem. if under the resolution to 1080 recording at 30FPM / 60FPM to take advantage of the stabilization, I get an error. therefore I have it at 4k and no error. the rest works great for me. Keep investigating. I have the .21 version of xiaomi eu. The other scrubber app works for me.
 

jbmc83

Senior Member
Hi. yes, I do have the configuration that you mention. from old versions, 1.3. to me the video gives me failure. in version 1.5. recording at 4k I have no problem. if under the resolution to 1080 recording at 30FPM / 60FPM to take advantage of the stabilization, I get an error. therefore I have it at 4k and no error. the rest works great for me. Keep investigating. I have the .21 version of xiaomi eu. The other scrubber app works for me.
ah yes, versions 1.3 and 1.4 are no good, video doesnt work there. stick to either 1.2 or 1.5.

as for sub 1080p with video stabilization, i think thats miui related, since another member posted something similar. i have no troubles at all with video recording on lineage os 14.1, no matter which resolution or camera is used. stabilization is always switched on btw.

Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk
 

ridershahmir

Senior Member
Dec 5, 2012
571
126
ah yes, versions 1.3 and 1.4 are no good, video doesnt work there. stick to either 1.2 or 1.5.

as for sub 1080p with video stabilization, i think thats miui related, since another member posted something similar. i have no troubles at all with video recording on lineage os 14.1, no matter which resolution or camera is used. stabilization is always switched on btw.

Nope, with these settings you can only record video once, when you start recording another video, camera crashes. I'm on Los
 

Attachments

  • Screenshot_20180115-153047.png
    Screenshot_20180115-153047.png
    117 KB · Views: 533
  • Screenshot_20180115-153053.png
    Screenshot_20180115-153053.png
    173.4 KB · Views: 539

jbmc83

Senior Member
Nope, with these settings you can only record video once, when you start recording another video, camera crashes. I'm on Los
nope, i an record as many video clips as i like in direct succession. be aware though that i have jpeg wuality set to 100% and dirty lens warning disabled. no idea if that makes any difference though. i also have back camera set to 4k and front to 1080p for video recording.

this is on arnova8g2 v1.5 stable btw.

Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk
 
Last edited:

ridershahmir

Senior Member
Dec 5, 2012
571
126
nope, i an record as many video clips as i like in direct succession. be aware though that i have jpeg wuality set to 100% and dirty lens warning disabled. no idea if that makes any difference though. i also have back camera set to 4k amd front to 1080p for video recording.
Front video camera recording well?

---------- Post added at 11:38 AM ---------- Previous post was at 11:38 AM ----------

nope, i an record as many video clips as i like in direct succession. be aware though that i have jpeg wuality set to 100% and dirty lens warning disabled. no idea if that makes any difference though. i also have back camera set to 4k amd front to 1080p for video recording.

this is on arnova8g2 v1.5 stable btw.
And which magisk modules are you using?
 

jbmc83

Senior Member
Front video camera recording well?

---------- Post added at 11:38 AM ---------- Previous post was at 11:38 AM ----------


And which magisk modules are you using?
ill check front video recording for you, give me a moment.

dont have magisk installed, using inbuilt privacy guard of lineage os for root access control.

edit: front camera video recording works as well, just recorded two clips right after each other without problems.

Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk
 
  • Like
Reactions: ridershahmir

jbmc83

Senior Member
Also try to record 2 to 3 clips using rear camera on 1080p, and see if you face any error. BTW thanks for your timely replies
sure thing, gimme another moment.

recorded three clips one right after another, each at 1080p with 30fps and 60fps, respectively (total of 6 clips). no problems encountered.

have u given proper storage permission for the app? also, have u installed the modded media_profiles.xml file in system/etc for proper usage of slomo and 60fps? maybe one of those two is the culprit in your case...

Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk
 
Last edited:

ridershahmir

Senior Member
Dec 5, 2012
571
126
sure thing, gimme another moment.

recorded three clips one right after another, each at 1080p with 30fps and 60fps, respectively (total of 6 clips). no problems encountered.

have u given proper storage permission for the app? also, have u installed the modded media_profiles.xml file in system/etc for proper usage of slomo and 60fps? maybe one of those two is the culprit in your case...
Well given proper media storage but don't know what media profiles are you talking about, can you please tell me how to do that?
 

jbmc83

Senior Member
Well given proper media storage but don't know what media profiles are you talking about, can you please tell me how to do that?
well im assuming you have root access, so:

- download the modded media_profiles.xml file as part of this zip package here: https://mega.nz/#!MKYyWaDL!zUzUivAblq9watfHBvFuCfhC0pBJMqgd6OalVSMLvHw
- unzip the package and overwrite the stock media_profiles.xml file in system/etc directory with the modded one
- set proper permissions of the new file to rw-r-r
- reboot
- test again and see if your issues are resolved

ull need a file manager with root access for that, im using es file explorer pro, for example.

Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk
 
  • Like
Reactions: ridershahmir

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    i can warmheartedly recommend this website right here: https://www.celsoazevedo.com/files/android/google-camera/

    listing all current GCam ports from the most important devs in that area :)

    At the moment, it looks like the Arnova8G2 ports are the most compatible ones with our Mi Max 2 phones. v1.2 doesnt have Portrait Mode but works flawlessly including HDR+ Enhanced and basically all Phone Model HDR+ modes. All v1.3 and v1.4 ports dont work well on our phones (lots of black screens). v1.5 beta works better and also includes a working Portrait Mode, however only "Nexus 6" Auto and "Pixel 2017 ZSL HDR no PD" Phone models work concerning HDR+, all others cause a black screen. Thus, HDR+ Enhanced is not available.

    So its either v1.2 including HDR+ Enhanced due to lots of HDR+ phone models working properly, but without Portrait Mode

    or

    v1.5 including Portrait Mode but only with regular HDR+ due to just two phone modes working for HDR+

    cheers!
    1
    @Arnova8G2 starting this thread for Mi Max 2. Please feel free to edit the content.
    1
    Updated to V1.5Beta 2 and it's a lot better, Potraits works front and back. Motion took picture but nothing is saved.
    I noticed Nexus 6 is really slow in processing
    EDIT: Pixel 2017 ZSL HDR No PD/Pixel2 seems faster but stuck at processing HDR+ in gallery and photo never saved
    1
    It does not work when you try to make a video with the rear camera with the video stabilizer.
    works fine here. arnova8g2 v1.5 beta1, beta2 and stable...

    Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk

    ---------- Post added at 05:58 PM ---------- Previous post was at 05:55 PM ----------

    Bro can you please s suggest which version to use with which settings that work with video mode too? Currently using v1. 5 beta of arnova and video mode isn't working on nexus 6 settings
    arnova8g2 v1.5 beta1, beta2 and stable all work fine, including all video resolutions back and front camera. be sure to set "nexus 6 auto" for config camera hdr+ and "nexus 6p" for model in settings.

    rest of the settings i have detailed in the lineage os thread, it was post number...dont remember exactly, but it was somewhere 845-850 in that range :)

    Sent from my Xiaomi Mi Max 2 (Oxygen) using Tapatalk