Themes / Apps / Mods [App]Galaxy Max Hz (Refresh Rate Mods, Screen-off Mods, QS Tiles, Tasker Support and More)

Search This thread

Roei.e

Senior Member
May 5, 2022
188
71
If it's fine with you, will appreciate that.
Thanks.
I did see that Bixby Routine is unable to turn on PSM when screen off.
I have a routine that turns on PSM below certain battery percentage, and I see that when screen is on it works perfectly but when the screen is off, the routine does works (I can see in notification panel) but it does not turned on the PSM. Is there anyway the app is linked to that?
 

Roei.e

Senior Member
May 5, 2022
188
71
Update: The app does linked to the problem. I turned off Keep smoothness in PSM & Force Lowest HZ when screen off and Routine works again.
(I tried with the app and 3 times it didn't work)
Now with the app disabled the routine works. Can you fix?
 

tribalfs

Senior Member
Mar 28, 2014
2,074
1,576
I did see that Bixby Routine is unable to turn on PSM when screen off.
I have a routine that turns on PSM below certain battery percentage, and I see that when screen is on it works perfectly but when the screen is off, the routine does works (I can see in notification panel) but it does not turned on the PSM. Is there anyway the app is linked to that?
I can confirm the issue. Actually PSM does turn ON on screen off when triggered by Bixby Routine. It's just that GMH turns it off on screen on. Please check latest in-app update that includes the fix.
Thanks.
 

Roei.e

Senior Member
May 5, 2022
188
71
I can confirm the issue. Actually PSM does turn ON on screen off when triggered by Bixby Routine. It's just that GMH turns it off on screen on. Please check latest in-app update that includes the fix.
Thanks.
ok I checked it now with Wireless debugging and I used "adb shell settings put global low_power 1" I guess it's the same as bixby routine. And now everything works perfectly. Would you mind sending me one last final version so I can do clean install?
 
  • Like
Reactions: tribalfs

Cujou2

Member
Jun 22, 2022
8
1
So i trying 7days trial and really thinking about buy this great app. But yesterday evening i saw that when the brightness is very low i see that switching between 60-120hz little change colours... :( it was annoying. Can be it fixed?
 

MemurBey

Member
Nov 17, 2020
46
11
Samsung Galaxy S21 FE
Hi, can you add a setting? "Animations dont raise screen to 120hz"
Most of applications doing this. I want raise screen to 120hz just when tapping or scrolling.
-Instagram(videos and stories)
-Youtube vanced
-Volume panel animations
-Internal video player (substitles)
-Amazon prime video (substitles)
-Lichess
 

KlemenC

Member
Aug 5, 2020
17
3
Samsung Galaxy S21 FE
Just installed and bought the premium version.
Looks great. Adaptive refresh rate switching looks good.
Looking forward to see how much better the battery life will be with the: battery saving, sensors, sync and doze mode on screen off!
GJ
 

KlemenC

Member
Aug 5, 2020
17
3
Samsung Galaxy S21 FE
I noticed something :p
When i have the sensorsoff option active, it moves the tile to the fourth place (even if i move it away) and every time i unlock the screen the notification bar flashes quickly. is this behaviour normal?
Tnx for the answer.
 

tribalfs

Senior Member
Mar 28, 2014
2,074
1,576
I noticed something :p
When i have the sensorsoff option active, it moves the tile to the fourth place (even if i move it away) and every time i unlock the screen the notification bar flashes quickly. is this behaviour normal?
Tnx for the answer.
It's an expected behavior. Please check FAQ#19 for more details.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi @tribalfs , thank you so much for all your efforts in supporting this phone. Got mine for a month now and installed your app on day 2. Works awesome mate, keep up the good work!

    There is however 1 minor thing I'm noticing and I don't know what's causing it, whether it's a bug or just my own wrong settings or something.

    Whenever I charge the phone with a regular charger at home, the app remains in adaptive mode (switching between 60-120hz). However when I charge my phone in the car / connect it to Android Auto, after disconnecting I notice the mode has always switched to standard which is 60hz max and I have to select adaptive again manually.

    You guys have any idea how to resolve this minor but still a bit annoying issue?
    Thanks a lot in advance!
    Will look into this issue. Thank you
  • 12
    screenshot_20220819-154719_galaxy-maxhz-jpg.5689911
    screenshot_20220819-154703_galaxy-maxhz-jpg.5689913
    screenshot_20220819-154652_galaxy-maxhz-jpg.5689915


    About this app:


    Refresh Rate Mods

    • Change default refresh rates
      -Easily change the overall refresh rate settings of devices supporting multiple refresh rates.
      -Set supported mid refresh rates as the maximum refresh rate limit for battery savings (e.g. 96hz instead of 120Hz).
      (S21 FE only supports 60hz and 120Hz)
      -Quick settings shortcut
      -Tasker plugin support

    • Motion smoothness mode switcher(Normal, Adaptive or High)***
      -Set you device motion smoothness mode to stationary refresh rates (high mode) for better smoothness if so desired on Samsung devices with native Adaptive motion smoothness with a little trade-off to the battery.
      -Apply adaptive mod on device that don't natively support adaptive mode [premium]
      -Tasker plugin support

    • Per-app refresh rate settings:
      Set different refresh rate settings for every app either adaptive or fixed(stationary) [premium].****

    • Motion smoothness on power saving mode (not working to all devices with OneUI4.**+, test first). ***
      -GMH will apply a workaround to bypass 60Hz limitation on Power Saving Mode (PSM) on supported Samsung smartphones.
      -Automatically apply workaround when PSM is enabled [premium]
    Screen-off Mods:
    • Force to Lowest Hz
      -Force the lowest refresh rate on screen-off or Always-On Display(AOD) to improve standby power consumption a bit.

      -Select refresh rate to set for AOD/screen-off[premium]
      -Tasker plugin support.

    • Auto apply power saving mode during screen-off ***


    • Auto disable Autosync***


    • Quick-doze mod
      -
      Quickly enter doze mode during screen-off that can not be interrupted by motion [premium]***
      -Tasker plugin support


    • Auto SENSORS OFF (experimental non-root workaround)
      -Device sensors will automatically turn off while screen is off until the device is unlocked to help minimize battery-draining motion-triggered wakelocks while device is not being used [premium]
      -Tasker plug-in support
    Others
    • Battery protection mod (Experimental)
      -Option to set maximum charge to 86%-95%(for OneUI4+)[premium]

    • Customizable refresh rate monitor
      -
      Use statusbar or overlay which you can place anywhere on screen.
      -Tasker plugin support



    • Net speed statusbar indicator
    OneUI inspired UI. Dynamic theme and Icon. Manual language selection

    Note: Premium license is on a per device basis (not per user)


    *** these marked features require a one-time ADB procedure (this is not root)
    ****requires ADB for S21FE

    Galaxy Max Hz background service is highly optimized. Background battery usage p is very negligible


    Info:
    This app targets older android sdk in order to control refresh rates without ADB setup or root. Just tap OK the dialog that says "This app was built for an older version of Android...." when opened for the first time. If OK button is not visible, just tap the blank space on the lowest portion of the dialog.

    If google play protect will prompt during install that the app is built for older version of android and doesn't include the latest privacy protections, you can ignore it and proceed to the installation. For privacy related concern, please refer to FAQ No. 3.


    Download
    v8.0.0

    v7.14.58

    Changelogs
    Github wiki

    2
    I don't have this bug, so it must be something else on your side?
    I found that "Prevent switching to high mode" toggle fixed the issue. Thanks!
    2
    after trying it turned out that version 7.14.20 the resolution can be 2340, 7.14.30 is 2400
    Yes, I mistakenly changed the in-app profile to 2400 in the latest version, thinking it's the right one for S21 FE .
    But I already reverted to 2340 the profile on my backend. So everyone can reload it even in v7.14.30. while connected to the internet.
    I'll revert the in-app to 2340 in the next update.

    Will this be fixed for 7.14.30 or should i downgrade?
    No need to downgrade. Just reload profile while connected to internet so the device will get the backend copy.
    1
    Sadly, on the S21 FE we cannot select 96hz. Only 60 and 120. Also, screen off refresh rate can only be set to 60.
    Screenshot_20220112-162000_Galaxy Max Hz.jpg Screenshot_20220112-162123_Galaxy Max Hz.jpg
    1
    Hi @tribalfs , thank you so much for all your efforts in supporting this phone. Got mine for a month now and installed your app on day 2. Works awesome mate, keep up the good work!

    There is however 1 minor thing I'm noticing and I don't know what's causing it, whether it's a bug or just my own wrong settings or something.

    Whenever I charge the phone with a regular charger at home, the app remains in adaptive mode (switching between 60-120hz). However when I charge my phone in the car / connect it to Android Auto, after disconnecting I notice the mode has always switched to standard which is 60hz max and I have to select adaptive again manually.

    You guys have any idea how to resolve this minor but still a bit annoying issue?
    Thanks a lot in advance!
    Will look into this issue. Thank you