[APP] Japanese display and input addon (updated 2009.07.03)

flinx1

Senior Member
Sep 18, 2008
252
6
0
What this does is that it enables display and input of Japanese characters. It can for instance be used to read web pages, or together with a dictionary program such as EBPocket and commercial dictionaries.

USAGE NOTES: READ THIS FIRST

This .cab is designed for a CLEAN/HARD RESET device. If you have other Japanese enabling software like decuma, CE-star, letsjapan etc. installed, remove them. I have no idea how they might interact with each other without testing. This file is a single install that has everything you need and want to get JP display and input working. If it doesn't work and you had some other type of JP enabling software previously installed, try a hard reset.

After installation and soft reset you'll notice you now have several new keyboard SIPs available. HOWEVER JAPANESE INPUT WILL NOT WORK JUST BY CLICKING ON THEM. You have to activate it first.

Diamond/device with no keyboard: Bring up the regular software keyboard. Press ctrl, shift, shift, ctrl. In that order. You can now switch to any of the Japanese keyboards and JP input will work. T9 input will be disabled for that session. If this doesn't work either try using PQzII to switch keyboards (I don't know if this works) or change the registry setting mentioned below.

Raphael/device with H/W keyboard: The instructions are basically the same as for the Diamond, except that you can do the activation using the hardware keyboard, if you want. Press ctrl+shift at the same time to activate it. Do not press them in succession like on the software keyboard.

JP input will only be activated on a per program basis, so you can have EBPocket open and use Japanese, and then switch to a writing a text message and use T9 or a localized keyboard. Once JP input has been activated, you can use ctrl+shift again to switch back and forth between a regular (non-localized/non-T9) layout and Japanese. On the Diamond just switch from kana to eigo mode instead, using the soft keyboard. Restarting a program will cause the keyboard to revert back to t9/localized.

If you want to change this behavior and avoid having to activate every time you want to type in Japanese, change the following registry key:

From
Code:
[HKEY_CURRENT_USER\keyboard layout\Preload]
@="e0010409"
to
Code:
[HKEY_CURRENT_USER\keyboard layout\Preload]
@="e0010411"
Note that this will completely disable T9/localized input. You can also use this to change the default keyboard if you use a SIP other than 409. In that case you also have to change the value in Preload\1 to match.

NOTES FOR THE 6.5 EXPERIMENTAL VERSION

This is for VGA/WVGA only. If you need other resolutions, use the regular cab (it works on 6.5). Some files (most notably wince.nls) have been extracted from WM6.5, but this is by no means a complete port. The romaji SIP has been removed to reduce SIP clutter and memory footprint. Reloadnls has been removed as I found that it was no longer needed, at least on my Raphael.


COMPATIBILITY NOTES

People are reporting problems with the HD2, so until those are fixed I recommend you not use this

Some Japanese software requires that the regional settings in the Control Panel be set to Japanese, in order for them to work. If you have any problems with display of Japanese characters, try changing that first. While this add-on doesn't set that default, it does add the setting itself to the control panel applet. Note that changing this setting will also change the language for some multi-language applications, such as Google Maps Mobile.

NEW: If you're having trouble with compatibility, you can also try the ime6compat.cab file I've attached below (install after the main file). It contains registry settings with the previously mentioned settings as default instead, and should be tried before reporting any issues in the thread.

If you're having trouble with the names of the input modes not showing up, the cab failed to install properly. This can either be fixed by reinstalling (you may have to try multiple times), or you can use the ime6SIPnamefix.cab file to replace the names of the SIPs with romaji equivalents.

The main .cab file contains files for all known screen resolutions, so should work on pretty much anything out there, including the Touch HD. If you're scrapped for space, you can delete some files from the Windows folder.

For QVGA devices delete the following (4.8 MB):

mboxjpn.192.dll
mskana.192.dll
msimj.192.dll
mboxjpn.128.dll
mskana.128.dll
msimj.128.dll

For 320x320 resolution devices delete the following (3.5 MB) :

mboxjpn.96.dll
mskana.96.dll
msimj.96.dll
mboxjpn.192.dll
mskana.192.dll
msimj.192.dll

For VGA resolution and higher devices delete the following (1.77 MB) :

mboxjpn.96.dll
mskana.96.dll
msimj.96.dll
mboxjpn.128.dll
mskana.128.dll
msimj.128.dll

It has been tested as working on WM5 and newer, including 6.5. However, install at your own risk. I will not be held responsible if this does not work for some reason, or messes up your device.


Download link


Regular version
Experimental WM6.5 version

History:

2009.07.03

Added experimental WM6.5 version.

2009.05.01

Cleaned up some corrupt registry entries and updated some of the files to a newer version from the Softbank X05HT. Changes should be mostly cosmetic however, so no need to update if it's already working.

2009.01.02

Reverted to original wince.nls, removing Chinese support (it was patchy anyway - and needed a different font to work completely). Memory footprint should be a tad reduced, and may also affect (improve) stability.
Attached .cab file with registry settings for people with compatibility issues.

2008.12.05

Added support for 320x320 devices.
Added some limited support for displaying Chinese - will be switched out to a separate file later with full support.
Switched core from letsjapan to reloadnls.

2008.11.16

Removed default region setting to accommodate multi-lingual apps.

2008.11.15

Removed SystemLCID setting so that font bolding works the same way as prior to installation.

2008.11.14

Fixed "\" being shown as "¥".
Added Option3="D".
Initial release.

-
This software is beerware. If you like it and would like to buy me a beer (up to you of course), donate and I'll make a toast in your honor :)
 

Attachments

Last edited:

genfersee

Member
Aug 13, 2008
48
0
0
Thanks Flinx1!! Great work!!
The only visible problem is the "Yen" instead replacing "\" issue ;o)
Reminder to fix it for those who do not know:

HKLM\SOFTWARE\Microsoft\FontLink\SkipTable

The you should set the following keys:

Key: Courier New, Value: 00a5,007e,0391-03c9,2026,2116,221a,25a0-25ff
Key: Tahoma, Value: 00a5,007e,0391-03c9,2026,2116,221a,25a0-25ff

After a soft reset you should have your "\" back. The entry for changing the "\" for "¥" is 00a5. So maybe you want to add only this value to the key.

Great work!!!!
 

fhsieh

Senior Member
Aug 15, 2008
459
30
0
I posted this over in the Raphael forum, but I will note it again for posterity.

For Raphael users, you may want to use these reg settings:
Code:
[HKCU\Keyboard Layout\Preload]
default = "E0010411"
[HKCU\Keyboard Layout\Preload\1]
default = "E0010411"
[HKCU\SOFTWARE\Microsoft\IMEJP\3.1\MSIME]
Option3 = "D"
[HKLM\System\CurrentControlSet\Control\Layouts\e0010411]
Keyboard Layout = "00000409"
First two re-enable hardware keyboard and buttons. Third option sets Romaji as default conversion. Last option keeps SIP conversion enabled (kensaku/tegaki/etc) -- otherwise JP IME is broken.

Diamond users may wish to try the last setting if they are having problems getting both English and JP SIPs working at the same time (untested since I don't have a Diamond, but worth a try).

And continuing the previous discussion about hotkey romaji/kana toggle, Raphael users may want to use PQzII. Typing "0xE6" into the IME option (see screenshot) will map the hardware "SYM" key to change romaji/kana conversion mode on-the-fly.
ime.jpg

You can use PQzII_Check to confirm the 0xE6 keycode, or to find the keycode for another key.

Diamond users can also use PQzII, but without the IME hotkey option. Just enable the icon, and tap the icon to switch IME modes (notice the あ in the icon tray). "Matching" black iconset is attached below.
icon.jpg
 

Attachments

genfersee

Member
Aug 13, 2008
48
0
0
Hey Flinx1,

After appliying the patch to get back the "\", the names of the Japanese SIP are not anymore shown or replaced by a unique "\".. Well, does not matter but it is strange :eek:)
 

flinx1

Senior Member
Sep 18, 2008
252
6
0
First two re-enable hardware keyboard and buttons.
You don't need to re-enable it, it works. What you suggest will also break T9/localized input as I mentioned in the top post. If you just want the JP IME as default, all you need to do is change preload, not preload\1.

I'll have a look at the other two you mentioned.

EDIT: Of the other two options you mentioned, one was already set (the 409 one) and the other does nothing that I can tell. Can you describe in more detail what exactly it's supposed to do?
 
Last edited:

flinx1

Senior Member
Sep 18, 2008
252
6
0
After a soft reset you should have your "\" back. The entry for changing the "\" for "¥" is 00a5. So maybe you want to add only this value to the key.
The code was 005c, not 00a5. Delete the courier new entry and change the Tahoma one to the one you mentioned. I'll be changing it in the .cab to match.

EDIT: Done. If you still have problems, try adding 005c back in front. Deleting it should normally change "¥" to "\" as you mention, but something sounds like it's broken on your end, maybe due to compatibility issues with some other conversion app. Only other thing I can suggest is to try a hard reset and start from scratch. It's possible to change the names of the Japanese SIPs to something that doesn't contain Japanese characters, but unless other people have the same problem, I'd rather not.
 
Last edited:

fhsieh

Senior Member
Aug 15, 2008
459
30
0
That's not necessary and will break T9/localized input as I mentioned in the top post. If you just want the JP IME as default, all you need to do is change preload, not preload\1.

I'll have a look at the other two you mentioned.

EDIT: Of the other two options you mentioned, one was already set (the 409 one) and the other does nothing that I can tell. Can you describe in more detail what exactly it's supposed to do?
I am coming from a Raphael so the registry settings will likely be different for Diamond users.

On the Raphael, you need to set both Preload and Preload\1 to 411, otherwise the hardware qwerty keyboard will not work. Yes unfortunately it will break T9, but with the full qwerty that's not a big problem (at least if you only need 日英入力).

Setting Layouts\e0010411 to 409 addresses an older problem where WM would load IMEJP properly, but would not let you switch to any IMEJP SIPs. Specifically, everytime you try to select Kensaku/Tegaki/etc WM would always revert to the standard "Keyboard" SIP.

Option3 is purely preferential. Setting it to D tells IMEJP to use direct input [_A] by default when the phone is turned on. If you type mainly in Japanese, you may prefer to leave the original reg setting, which will tell IMEJP to use hiragana/romaji input [あ] by default.





Again, these settings are specific to the Raphael. Both Preload and Preload\1 are necessary. Whether Layouts\e0010411 matters anymore in WM6.1 isn't really known (on some devices it works, on others it doesn't, or doesn't matter). But I've gone through most (if not all) of the Japanese-input threads at most forums/sites, and the above settings have given me the most reliable SIP- and 変換-switching for the Raphael.
 

Obsidian72

Senior Member
Jun 11, 2008
74
0
0
Diamond users can also use PQzII, but without the IME hotkey option. Just enable the icon, and tap the icon to switch IME modes (notice the あ in the icon tray).
Could you elaborate on the necessary settings. I can't get it to work the way it should. It just doesn't change the IME-mode by tapping on the icon (well, it changes from あ to A, but the input method remains the same). The automatic change of the SIP according to portrait or landscape mode is nice, though.

And many thanks to flinx1 for his work. This is excellent. I had to write a manual for myself how to recover my Japanese settings in case of a hard reset. I can throw that away now! :)
 

fhsieh

Senior Member
Aug 15, 2008
459
30
0
Could you elaborate on the necessary settings. I can't get it to work the way it should. It just doesn't change the IME-mode by tapping on the icon (well, it changes from あ to A, but the input method remains the same). The automatic change of the SIP according to portrait or landscape mode is nice, though.

And many thanks to flinx1 for his work. This is excellent. I had to write a manual for myself how to recover my Japanese settings in case of a hard reset. I can throw that away now! :)
PQzII is just a simple program to toggle IMEJP if it's present. I don't know what device you have or which specific SIP you're trying to use -- and I don't know if the registry settings flinx1's cab are causing any conflicts.

I put up a brief video showing what you should be expecting if you want to use PQzII:
http://jp.youtube.com/watch?v=c2RzpL-OCxM

From there we can start to figure out what's working and what isn't.
 

flinx1

Senior Member
Sep 18, 2008
252
6
0
I have a Raphael too, so it's not an issue :).

On the Raphael, you need to set both Preload and Preload\1 to 411
Not with this .cab - you just need to change Preload itself. 411 is already set in Preload\2 to facilitate switching keyboard layouts.

I see what you mean by the D option now - I'll add it.

Setting Layouts\e0010411 to 409 addresses an older problem where WM would load IMEJP properly, but would not let you switch to any IMEJP SIPs. Specifically, everytime you try to select Kensaku/Tegaki/etc WM would always revert to the standard "Keyboard" SIP.
Already set in the original CAB :).
 
Last edited:

fhsieh

Senior Member
Aug 15, 2008
459
30
0
I have a Raphael too, so it's not an issue :).



Not with this .cab - you just need to change Preload itself. 411 is already set in Preload\2 to facilitate switching keyboard layouts.

I see what you mean by the D option now - I'll add it.
See, I installed LetsJapanNo6 (then softreset), then IME_31J_F (then softreset); and there is no Preload\2 in my registry. Have you added any extra 3rd party keyboard layouts?
 

flinx1

Senior Member
Sep 18, 2008
252
6
0
I'm not using IME_31J_F. I've modified things a bit for a more streamlined install, including adding the ability to switch keyboard layouts between 409 and 411 so T9/localized keyboards work.

PQzII works fine by the way, just like in the video linked. Ctrl+shift does the same thing though, so I doubt I'll bother with it.
 
Last edited:

genfersee

Member
Aug 13, 2008
48
0
0
hello flinx1! another issue i see now is that the bold characters in windows are not any more displayed in bold..

letsjapan6 has installed the msgothic.ac3 font. i don't know he this font is able to display bold characters? i was using meiryo.ttc as main font for my diamond .. do you know how to recover bold characters? do you have the same issue than me?

for example, the bottom screen software button from windows are not anymore in nsbold..
 

flinx1

Senior Member
Sep 18, 2008
252
6
0
Okay, I found the problem. It's not the font, but instead the SystemLCID setting:

Code:
[HKEY_LOCAL_MACHINE\nls]
SystemLCID="1041"
That sets the system region to Japanese, which means that it will behave exactly as a Japanese winmo install - on my emulator the fonts in Japanese WinMo don't appear in bold for those parts of the OS.

So what I've done is that I've created a new cab which doesn't contain that key. It will remain unchanged, even if you changed the regional settings in the control panel. From my limited testing, things seem to work, but I can't guarantee anything. Please try it out. If there's any compatibility issues, you can try changing the key above, but make note of the original value so you can change it back again.

Let me know if everything works, and I'll replace the links in the top post.

http://rapidshare.com/files/164079800/JPIMEWM6.rar.html
 
Last edited:

aro

Senior Member
Jun 25, 2005
293
5
0
Munich
Thanks flinx1,
I also experienced the "missing bold font" problem with your previous version, but after uninstalling and installing the latest update, I can confirm the big font is still there.
Also everything elese I tested so far works great.
Thank you.

One minor thing: I mainly use your language pack to be able to show japanese characters in google maps and read japanese internet sites.
Thus I would prefer, if the regional setting of my device would not be set to Japan after installation, as I have to switch back to english manually (as frequent rom updater, I would like to aviod this extra step).

Thanks and regards,

EDIT: I found that the SIP icon to open shows now always japanese symbol (see screenprint attached). when opening SIP, it switches to normal qwerty keyboard sysmbol, but while SIp is closed, always hiragana "a" is shown. Any chance to have normal qwerty symbole shown even when SIP is closed?
 
Last edited:

flinx1

Senior Member
Sep 18, 2008
252
6
0
Just change the regional setting in the control panel to match whatever region you prefer, and the language for Google Maps will change. The problem is that some applications require the regional setting be set to Japanese, in order for them to work. I'll change it and make a note about software compatibility in the top post and readme.

As for the SIP symbol, I'm not sure what's causing that. It doesn't happen in any of the WinMo emulators, so I'm thinking it must be specific to HTC. That makes it much harder to figure out too. Ultimately it's not worth the effort I think.
 

Zgembo

Senior Member
Dec 1, 2006
316
10
0
Installed on Hermes (schaps latest ROM). Works great, fonts seems much easier to read.

Only problem was manual switching, no go on that ctrl-shift combinations, had to made Japanese IME default in registry.

flinx1, thanks big time for this one!
 

flinx1

Senior Member
Sep 18, 2008
252
6
0
Did you try both using the hardware keyboard and the soft keyboard? The reason it doesn't work with the hardware keyboard I suspect is because you have to hit the FN key to get ctrl working on the Hermes, and that will change the behavior of the shift key to capslock instead.
 
Last edited: