• XDA Forums have been migrated to XenForo. We are aware of several issues including missing threads, pages, logins, and more. To discuss, use this thread.

[APP][JBED][UPDATE][run j2me app on android device]for gingerbread

mohammadN

New member
Aug 19, 2010
52
292
0
mashhad
In the name of Allah
hi there,
Jbed an app to running java mid-let on Android device.

installation:
download Jbed.apk from attachment and install it.

if last section not working for you,

download Jbed.zip and flash it with CWM!

I created a signed flash-able package for easy install it!
Tested on my wildfire and 100% working!

you can press on Thanks button and download it from attachment.
you can flash this package on all clockworkmod recovery version (2 and 3 and 4)

enjoy!

Note :
It isn't my own app!
please read my post carefully! ;)
I only created Flashable package to easy to install this app for all

sorry for my bad English!


Screenshot added
some screenshot from a java app!
 

Attachments

Last edited:

thehelios

New member
Jul 17, 2007
107
10
0
If it's the same thing from Windows Mobile, then it's an app that will let you run java apps on your phone. The same kind of programs that basically ruled Nokia for years.
 

Hzu

New member
Nov 13, 2010
1,682
575
0
Assalamualaikum brother. I had successfully installed this on my X10, but I cannot press anything as my phone has no trackballs. Is there anyway to overcome this problem?

Thanks.

Sent from my X10i using XDA App
 
  • Like
Reactions: MaMsAnA

fd99601

New member
Aug 26, 2010
37
2
0
Thanks but there's a pbm

What do you know? It works. However there are some real major glitches. If you remember, almost all JAR games etc depended on left/ right soft keys. And in my SGS there is no such thing.

I tried all buttons and keys on this phone, but to no avail. Also the resolution of the games leave a lot to be desired (though for this you cannot do anything from your end).

Any suggestions on the key bug that I have highlighted above will be really appreciated. But once again thanks for making this - LONG TIME PENDING!
 

aamadorj

Well-known member
Jan 11, 2010
981
556
93
Error message: Maybe no sd card or sd card is busy, please check it

I tried this JBED package and other different JBED versions (from 2.1 to 2.3.1).

The previous versions to 2.3.1 show an FC right after trying to open. ROM details are at the signature.

JBED version 2.3.1, the one contained in this package as well on the LeeDrOiD v3.3.1 ROM for Desire HD / Inspire 4G and the add-on at Android Revolution HD thread for Desire HD / Inspire 4G, doesn't show FC but all of them display a "Maybe no sd card or sd card is busy, please check it" message. So it isn't possible to install any jar.

Any ideas how to make JBED (or other Java VM) work with this Virtuous Unity 1.31 ROM?
 
Jul 9, 2011
582
130
0
Screen distorted

Hi there,
I installed the zip through the stock recovery of gingerbread on my galaxy fit. It installed fine on my galaxy fit and I now have a java app in my app drawer. But when I run the app it searches the jar files on my sdcard (don't know why it also shows my framework.jar etc. system files). When I install and run the java app the screen becomes pixelated. I mean the app doesn't run correctly.. the screen is distorted.. I can't read or view anything. Please help me fix this !!
 
Our Apps
Get our official app! (coming soon)
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone