• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[APP][LOCKED BOOTLOADER] BootieScreen - Personalize your boot screen, like MotoMaker!

Search This thread

geeksunny

Member
Jan 31, 2011
23
16
Chicago, IL
beepboop.me
Hey guys! This is an app I've been working on called BootieScreen.

BootieScreen will personalize your Moto X's boot screen with a message of your choosing. Think of it like the Moto Maker service but with so much more freedom! Using BootieScreen, you can choose...
  • The font size
  • The font color
  • The typeface used (currently only uses system fonts. User fonts are on the way!)
  • Where your message sits on the boot screen
  • Exactly what your message says! (No profanity filter... if you're in to that sort of thing.)
Want to change your boot message? Just fire BootieScreen back up and re-personalize!

Want to remove your boot message all together? Hit the menu item labeled "RESTORE ORIGINAL BOOTSCREEN"!

Want to install a new bootscreen graphic but you don't want to fuss with fastboot? Just drop your bitmap onto your phone at /sdcard/BootieScreen/clogoDeviceBackup.bmp, fire up BootieScreen, and personalize from there! (If you just want to install your graphic with no personalization, just do the personalization with a blank message. There will be a quicker & easier way to install new graphics in a future release!)

Notice any bugs? Want to request a feature? Just wanna give me your 2-cents? Let me know here, and thanks for looking!


Notes
  • This app requires your device to be rooted!
  • This app currently only supports devices with LOCKED BOOTLOADERS. The reason for this is because it writes to clogo, which is used when the bootloader is locked. When the bootloader is unlocked it reads from logo, which is not something that BootieScreen is capable of writing to at this time. I am hopeful that I'll be able to support locked bootloaders in the future.
  • BootieScreen is open source! Find it on github.
Changelog
Code:
v0.4.0 (Feb. 2, 2014)
- New Moto Sans typeface
- In the case of an empty or corrupt clogo block, a stock graphic will be used.
- Added preliminary root and device restriction checks.

v0.3.0 (Jan. 19, 2014)
- New interface theme
- The vertical positioning of your message is now adjustable
- Added the option to manually re-pull the device's bootscreen graphic.
- Fixed a common force-close on app launch

v0.2.1 (Dec. 28, 2013)
- First public release
- Add a personal message to your device's boot screen

Download (v0.3.0)
Download BootieScreen from the Google Play Store!

Coming Soon...
  • Custom user fonts
  • New bootscreen graphic installation
  • An improved user interface
  • And more!
Thanks
I must say thank you to jcase for his rooting methods for the Moto X and his information about flashing clogo.
 
Last edited:

geeksunny

Member
Jan 31, 2011
23
16
Chicago, IL
beepboop.me
This is a neat little app I'll give it a try later and report back thanks :D
Thanks for your comment! That means a lot!

The thread Moto X Boot Logos has some good info on file formats. I'd love to see your app create whole bins that include altering (or not) the battery warning, and the unlocked screen.
Thanks for the heads up! I knew those graphics were all kept together but not much more. I will make a note of this info. I would really like to be able to support the unlocked graphics at some point.

Great idea about the battery graphics, too! I will put that down on my list. :D
 
  • Like
Reactions: cartmenicus

Cyphir

Senior Member
Jan 22, 2012
104
28
I get a force close as soon as I open the app. Running 4.2.2, rooted, model XT049. I submitted an error report. Tried both normal and rw mode.
 
  • Like
Reactions: geeksunny

geeksunny

Member
Jan 31, 2011
23
16
Chicago, IL
beepboop.me
This app dying off? Force close on open, stock rooted 4.4 Verizon Non-DE

Sent from a White Moto Xposed

No, I am still working on it. I'm hoping to have a new build posted by this weekend but we will see.

I see your error report on Google Play. It looks to be the same crash that Cyphir had reported. I believe I've got that problem fixed in the upcoming release.

Thanks for your interest! I will try to have an update out soon.
 
  • Like
Reactions: remicks

geeksunny

Member
Jan 31, 2011
23
16
Chicago, IL
beepboop.me
Hey, guys! v0.3.0 is now live on Google Play and ready for download! I updated the first post to reflect the changes.

This update SHOULD fix the force-close that a few people have reported. If you are still experiencing this crash (or any others!) please submit a crash report and feel free to drop a note in this thread.
 
  • Like
Reactions: cartmenicus

geeksunny

Member
Jan 31, 2011
23
16
Chicago, IL
beepboop.me
Should this work on rooted unlocked BL kit kat devices?

Tested on it, nothing happens...

No, it currently does not work for unlocked bootloaders. Only locked bootloaders are supported at this time. logos for each bootloader state are stored in separate locations and formats, and I haven't been able to work in the support for locked logos yet.

I expect to have them supported at some point but I can't really offer an ETA at this time.
 
  • Like
Reactions: d14gvn

jimbo0914

Member
Dec 16, 2009
27
5
Wondering if I am missing a step. 4.4 rooted, VZW non-DE.

Lost my motomaker personalized boot screen after going through the root process so wanted to use this to get it back.

It seems to personalize the boot screen, but I can't use the "Pull Device Bootscreen" option. I keep getting the "Could not read the bootscreen's bitmap file. Try pulling a new copy". If I personalize the boot screen, it just shows a black screen on boot (even with font color changed to non-black).

FWIW, /sdcard/BootieScreen/clogoDeviceBackup.bmp is just a blank black image.

Thanks,
 

geeksunny

Member
Jan 31, 2011
23
16
Chicago, IL
beepboop.me
Wondering if I am missing a step. 4.4 rooted, VZW non-DE.

Lost my motomaker personalized boot screen after going through the root process so wanted to use this to get it back.

It seems to personalize the boot screen, but I can't use the "Pull Device Bootscreen" option. I keep getting the "Could not read the bootscreen's bitmap file. Try pulling a new copy". If I personalize the boot screen, it just shows a black screen on boot (even with font color changed to non-black).

FWIW, /sdcard/BootieScreen/clogoDeviceBackup.bmp is just a blank black image.

Thanks,

That sounds like your clogo block might have been blank when you tried to pull the bootscreen... (Admittedly a situation I haven't compensated for yet.) That would make sense if you just reflashed during the root process. If you replace that blank clogoDeviceBackup.bmp with a new graphic and then personalize and install with BootieScreen, that should fix it.

Interesting about the black-screen with non-black text... If you open /sdcard/BootieScreen/clogo.bmp, does that show a black graphic with your non-black text? I will try to recreate this at home and see what's going on.

My long-term plan is to pull the first frame of the boot animation in the case that there is no existing clogo to work with.
 

jimbo0914

Member
Dec 16, 2009
27
5
That sounds like your clogo block might have been blank when you tried to pull the bootscreen... (Admittedly a situation I haven't compensated for yet.) That would make sense if you just reflashed during the root process. If you replace that blank clogoDeviceBackup.bmp with a new graphic and then personalize and install with BootieScreen, that should fix it.

Interesting about the black-screen with non-black text... If you open /sdcard/BootieScreen/clogo.bmp, does that show a black graphic with your non-black text? I will try to recreate this at home and see what's going on.

My long-term plan is to pull the first frame of the boot animation in the case that there is no existing clogo to work with.

So here's what I did since the post:

Restored original boot screen, seemed to bring back the original screen from after the reflash. Then I tried to pull that and it gave the same error. I then wrote the bootscreen again (blue text on blank black bckg) and it booted with nothing again (all blank). I wasn't thinking and then pulled that, which this time worked, and now I had a black bckg where I could add the blue text over. Booted and now it shows the blue text on a black bckg. Will try to play with clogo.bmp tonight. Don't know where things went wrong or if I'll ever be able to re-create that sequence of errors, but I hope this helps.
 
Last edited:
  • Like
Reactions: geeksunny

jimmydafish

Senior Member
Nov 10, 2007
286
307
That sounds like your clogo block might have been blank when you tried to pull the bootscreen... (Admittedly a situation I haven't compensated for yet.) That would make sense if you just reflashed during the root process. If you replace that blank clogoDeviceBackup.bmp with a new graphic and then personalize and install with BootieScreen, that should fix it.

Interesting about the black-screen with non-black text... If you open /sdcard/BootieScreen/clogo.bmp, does that show a black graphic with your non-black text? I will try to recreate this at home and see what's going on.

My long-term plan is to pull the first frame of the boot animation in the case that there is no existing clogo to work with.

I have a few ideas to help with this issue and it should be seamless, I just pulled your git and I'm going to check on a few things to see what it will take to implement this.

The application now checks to verify the device is a Moto X (Currently the other devices you mentioned do not fully support the cLogo and thus there is no reason for them to use this app. Yet)

Check your PM for the code
 
Last edited:
  • Like
Reactions: geeksunny

geeksunny

Member
Jan 31, 2011
23
16
Chicago, IL
beepboop.me
I have a few ideas to help with this issue and it should be seamless, I just pulled your git and I'm going to check on a few things to see what it will take to implement this.

The application now checks to verify the device is a Moto X (Currently the other devices you mentioned do not fully support the cLogo and thus there is no reason for them to use this app. Yet)

Check your PM for the code

Awesome, man, thanks! I really appreciate that. I will give it a look and get back to you!
 

petrr311

Member
Mar 12, 2012
41
3
NYC
First I want to say awesome concept for an app... But I do have an issue... I tried to personalize and it worked... But then I wanted to change it so I redid it and now I just have a black screen with both of my personalizations on top of each other and it's barely legible... And when I try to restore it doesn't do anything... Please help lol
 
  • Like
Reactions: geeksunny

geeksunny

Member
Jan 31, 2011
23
16
Chicago, IL
beepboop.me
First I want to say awesome concept for an app... But I do have an issue... I tried to personalize and it worked... But then I wanted to change it so I redid it and now I just have a black screen with both of my personalizations on top of each other and it's barely legible... And when I try to restore it doesn't do anything... Please help lol

What did you do when you tried to change the personalization? All you have to do to change it is change your settings, preview, and personalize. There would be no need to restore the original graphic, or re-pull the graphic. It sounds like your device backup file may have become corrupt at some point after the first personalization.

Before you installed the second personalization, did the preview show a properly re-personalized graphic? That is to say, your device's graphic with the new text and no underlapping old text?

To fix it, you will need to find a new copy of the boot graphic you were using. Place it on your phone at /sdcard/BootieScreen/clogoDeviceBackup.bmp. (The filename and path are case sensitive!) When you launch BootieScreen again, this graphic should be displayed in the preview window. From there you can run BootieScreen as normal again.

I'm sorry for the trouble. I don't know what would have caused this to happen. I wonder if an option to keep a redundant backup copy of every graphic pulled from the device might be beneficial until that can be figured out. I am going to add this to my future feature list.
 
Last edited:

SystemErrorOne

Senior Member
Jun 7, 2011
597
384
28
Jacksonville
BootieScreen Icon Idea

12210758753_f6e6882dcb_z.jpg


What do you think ? :rolleyes:
 
  • Like
Reactions: geeksunny

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Hey guys! This is an app I've been working on called BootieScreen.

    BootieScreen will personalize your Moto X's boot screen with a message of your choosing. Think of it like the Moto Maker service but with so much more freedom! Using BootieScreen, you can choose...
    • The font size
    • The font color
    • The typeface used (currently only uses system fonts. User fonts are on the way!)
    • Where your message sits on the boot screen
    • Exactly what your message says! (No profanity filter... if you're in to that sort of thing.)
    Want to change your boot message? Just fire BootieScreen back up and re-personalize!

    Want to remove your boot message all together? Hit the menu item labeled "RESTORE ORIGINAL BOOTSCREEN"!

    Want to install a new bootscreen graphic but you don't want to fuss with fastboot? Just drop your bitmap onto your phone at /sdcard/BootieScreen/clogoDeviceBackup.bmp, fire up BootieScreen, and personalize from there! (If you just want to install your graphic with no personalization, just do the personalization with a blank message. There will be a quicker & easier way to install new graphics in a future release!)

    Notice any bugs? Want to request a feature? Just wanna give me your 2-cents? Let me know here, and thanks for looking!


    Notes
    • This app requires your device to be rooted!
    • This app currently only supports devices with LOCKED BOOTLOADERS. The reason for this is because it writes to clogo, which is used when the bootloader is locked. When the bootloader is unlocked it reads from logo, which is not something that BootieScreen is capable of writing to at this time. I am hopeful that I'll be able to support locked bootloaders in the future.
    • BootieScreen is open source! Find it on github.
    Changelog
    Code:
    v0.4.0 (Feb. 2, 2014)
    - New Moto Sans typeface
    - In the case of an empty or corrupt clogo block, a stock graphic will be used.
    - Added preliminary root and device restriction checks.
    
    v0.3.0 (Jan. 19, 2014)
    - New interface theme
    - The vertical positioning of your message is now adjustable
    - Added the option to manually re-pull the device's bootscreen graphic.
    - Fixed a common force-close on app launch
    
    v0.2.1 (Dec. 28, 2013)
    - First public release
    - Add a personal message to your device's boot screen

    Download (v0.3.0)
    Download BootieScreen from the Google Play Store!

    Coming Soon...
    • Custom user fonts
    • New bootscreen graphic installation
    • An improved user interface
    • And more!
    Thanks
    I must say thank you to jcase for his rooting methods for the Moto X and his information about flashing clogo.
    1
    This is a neat little app I'll give it a try later and report back thanks :D
    Thanks for your comment! That means a lot!

    The thread Moto X Boot Logos has some good info on file formats. I'd love to see your app create whole bins that include altering (or not) the battery warning, and the unlocked screen.
    Thanks for the heads up! I knew those graphics were all kept together but not much more. I will make a note of this info. I would really like to be able to support the unlocked graphics at some point.

    Great idea about the battery graphics, too! I will put that down on my list. :D
    1
    I get a force close as soon as I open the app. Running 4.2.2, rooted, model XT049. I submitted an error report. Tried both normal and rw mode.
    1
    This app dying off? Force close on open, stock rooted 4.4 Verizon Non-DE

    Sent from a White Moto Xposed

    No, I am still working on it. I'm hoping to have a new build posted by this weekend but we will see.

    I see your error report on Google Play. It looks to be the same crash that Cyphir had reported. I believe I've got that problem fixed in the upcoming release.

    Thanks for your interest! I will try to have an update out soon.
    1
    Worked for me! Looking forward to the next version(s)