[APP][May 26][V10]COS12/CM12/CM12.1 CameraNextMod

abhi08638

Senior Member
Jul 11, 2012
2,165
4,385
0
CameraNextMod COS12
There is no need to do anything with your original camera or the previous CameraNextMod. Just download the apk file, this installs as a separate app.
Xposed users that want to save pictures to external storage, try this module
http://forum.xda-developers.com/xposed/modules/mod-pictures2sd-v1-0-6-makes-camera-t2408880

@Yeti12 made a material blue and black version of the icons. They looked so good I couldn't use just one. Download the appropriate apk for the icons.



Set the quality to 100. The bug from the previous version has been fixed, I have gotten pictures that go up to 9MB on Auto settings.

Requirements

Changelog

V1
  • 1/32, 1/16, 1/8, 1/4, 16, 24, 32, 64 second shutter added
  • Saturation, Contrast, Sharpness
  • Material blue and black icons by @Yeti12
  • Burst mode re-added
  • Zero Shutter Lag re-added
  • Focus Ring shrunk

V5
Please clear data after Installing
  • 1/64, 1/125, 1/250, 1/500, 1/1000, 1/2500, 1/5000, 1/7000(experimental) second shutter added
  • Denoise added (IMO no need to turn off)
  • Material blue and black icons by @Yeti12
  • Burst mode 30, 50
  • Video duration limit raised to 24 hours
  • ISO 3200 added
  • ISO_HJR is now default (need feedback)
  • Auto mode picture delay fixed (Scene will now not reset anymore)

V6
Please clear data after Installing
  • 50 mp photo from Color OS ported by @BOOTMGR

V10
  • scene mode added in settings(not all of them work, let me know which ones do so I can remove the non functional ones)
  • ISO auto is now default
  • autofocus zone added
  • sharpness 4, contrast 4, saturation 6 default
  • skintone enhancement added
  • color effect added
  • red eye reduction added
  • histogram added
  • video stabilization toggle
  • video color effect
  • video HDR toggle
    @BOOTMGR
  • 50MP bugfixes
  • support for vanir/exodus?(Needs testing)
    @infinityplus
  • help with new quickbar with ISO options


Bugs
  • Screen might freeze- toggle ZSL in settings to unfreeze it
  • Scene mode might reset to slow shutter
  • All previous Stock CameraNext Bugs

To use it, you must change the scene mode to "slow shutter" and then select the speed. If you don't have this scene available, then your camera does not support it and won't work.

Things I can do
  • Remove scenes
  • Rearrange settings
  • Unlock hidden options

Things I can't do
  • Modify the ViewFinder
  • Change the framerate for 1080p to use 60
  • make the an option for 240 fps

To remove camera sounds
  • go into /system/media/audio/ui
  • delete camera_click.ogg
  • delete camera_focus.ogg
  • delete VideoRecord.ogg

Picture Settings
  • All defaults except two things
  • Set quailty to 100 (Bug has been fixed)
  • set focus and exposure to frame-average

Notes
The required lib files have been included inside the app. No need to flash anything, just install the apk file.

Credits
Credits to @Yeti12 for his material icons
Credits to @funCrash93 for the mirrors
Credits to @BOOTMGR for his additions like 50 mp port
Credits to @infinityplus for bugfixes


Mirror link
https://cloud.mail.ru/public/a8XwguR7aYRT/COSCameraNextMod

Please don't distribute the app. Just link them to the thread.
 

Attachments

Last edited:

abhi08638

Senior Member
Jul 11, 2012
2,165
4,385
0
Awesome ;)
catch this :
Code:
https://cloud.mail.ru/public/a8XwguR7aYRT/COSCameraNextMod


---------- Post added at 12:23 AM ---------- Previous post was at 12:22 AM ----------

p.s. hope that removing that silly videoRec Limit is on your TODO List ;)
Did I do that on the previous version? I don't remember:p

Sent from my A0001 using XDA Free mobile app
 

abhi08638

Senior Member
Jul 11, 2012
2,165
4,385
0
BTW @abhi08638, why it is impossible to make an option on removing shutter sound.? gets really annoying (removing those files everytime after updating the system)
Its impossible in app because the code is unreadable. However there are three workarounds.

1.
Most Roms have an option to disable shutter sound in the settings

2.
I can make a flash able zip to remove them for you

3.
I can make an addon.d script that deletes them automatically whenever you flash an update. So basically this is a one time affair and the best option.


Sent from my A0001 using XDA Free mobile app
 

funCrash93

Senior Member
Jan 30, 2012
1,650
584
143
Iași
Its impossible in app because the code is unreadable. However there are three workarounds.

1.
Most Roms have an option to disable shutter sound in the settings

2.
I can make a flash able zip to remove them for you

3.
I can make an addon.d script that deletes them automatically whenever you flash an update. So basically this is a one time affair and the best option.


Sent from my A0001 using XDA Free mobile app
will you be so sweet to do that.? :D

so that script is per ROM one time solution like flash once and forget.? so that it will resist "OTA-like" (dirty flashing) updates of the ROM.?
what are the cases it will have to be flashed (clean install).?
 

anees167

Senior Member
Mar 20, 2011
200
49
0
Nice work., but pictures take a few seconds to capture and made sure that it's on Auto. And toggled zero shutter lag on and off but made no difference. Running COS12 rooted

EDIT: It seems to be the problem in the blue icon app. I installed the black icon app and it works fine.
 
Last edited:

abhi08638

Senior Member
Jul 11, 2012
2,165
4,385
0
will you be so sweet to do that.? :D

so that script is per ROM one time solution like flash once and forget.? so that it will resist "OTA-like" (dirty flashing) updates of the ROM.?
what are the cases it will have to be flashed (clean install).?
Of course its only a few lines:D
You would only have to flash it once if you keep doing dirty flashes.

If you are doing a clean flash then you have to flash the file again






Nice work., but pictures take a few seconds to capture and made sure that it's on Auto. And toggled zero shutter lag on and off but made no difference. Running COS12 rooted

EDIT: It seems to be the problem in the blue icon app. I installed the black icon app and it works fine.
I'm using the blue one and it works fine. Did your try clearing data?

Edit: make sure the scene mode is one auto. There is a bug where it resets to slow shutter sometimes

Sent from my A0001 using XDA Free mobile app
 
Last edited: