[APP][Q][XPOSED] GravityBox v10.1.2 for Android 10 [07/03/2021]

XtraWater

Senior Member
Apr 8, 2018
561
91
38
After a few days of using GravityBox I can say that 'trusted wifi' to keep the phone unlocked isn't 100% reliable. Every kow and then I have to unlock manually. Smartlock I kept disabled.

Is it known why this happen or is there a workaround?

Thanks.
 

R2-Brute

Member
Aug 5, 2015
38
8
28
Hey! The Lockscreen Rotation only half works. When I hit the button and my lockscreen comes up, it's in landscape mode, but then I swipe to bring up my pattern unlock grid, and it rotates to portrait!

I tried Renovate Ice, and now Gravitybox! This damn phone REALLY doesn't want to be held sideways. :\

I am almost done with it, and Oneplus in general. Shouldn't be this hard.
 

C3C076

Recognized Contributor
Dec 15, 2012
7,744
24,588
263
Bratislava
ceco.sk.eu.org
I have magisk canary 21401, edxposed 5.2.0, latest GB. Android 10 samsung s10
Everything seems to work except navigation key actions.. is this a known thing?
Navbar tweaks master switch has to be enabled for full navigation key actions support.
If it still doesn't work as expected then it's an incompatibility between module and Samsung OS.
More info on compatibility in the 1st post.

Hello, is it possible to add option to control the extra padding in the status bar? Also the old landscape battery icon in the status bar from Nougat was great, can we get it back?
Try "Remove corner padding" in Statusbat tweaks.

After a few days of using GravityBox I can say that 'trusted wifi' to keep the phone unlocked isn't 100% reliable. Every kow and then I have to unlock manually. Smartlock I kept disabled.
Is it known why this happen or is there a workaround?
Thanks.
Trusted WiFi respects when Trust Manager (system service) decides that there are conditions to lock the device despite trust providers meet conditions for device to be unlocked (e.g. device not being used for a longer time). This is a security feature of the system itself.

Hey! The Lockscreen Rotation only half works. When I hit the button and my lockscreen comes up, it's in landscape mode, but then I swipe to bring up my pattern unlock grid, and it rotates to portrait!
I tried Renovate Ice, and now Gravitybox! This damn phone REALLY doesn't want to be held sideways. :\
I am almost done with it, and Oneplus in general. Shouldn't be this hard.
Module only enables feature that is already in the system. It doesn't actually implement it. So the result is always depending on how it is implemented in the ROM.
 
  • Like
Reactions: XtraWater

R2-Brute

Member
Aug 5, 2015
38
8
28
Module only enables feature that is already in the system. It doesn't actually implement it. So the result is always depending on how it is implemented in the ROM.
Thanks for responding. So Oneplus must have gone out of their way to make absolutely sure the damn lockscreen wouldn't rotate. Fantastic. Never Settle. :\
 

flyl0

Senior Member
Dec 8, 2018
208
51
38
Paris
Hi I'm using gravitybox Q on stock sony rom and hide clock works partially, I mean everytime I reboot my phone, the clock returns to my status bar. It's a bit annoying because I have to re-enable the option manually each time. Can you please fix this little issue? Thank you
 

Ghisy

Senior Member
Mar 27, 2010
1,402
209
83
Hey,

I just updated Magisk to v21.4 and I just realized the power key actions don't work anymore in GB: I can't activate the flashlight with a long press anymore...

Other GB settings work, module is active in edxposed manager. I don't know what's going on here? (Pixel 4 XL on Android 10, August 2020 security patch)

Magisk 21.4 stable / latest Manager
Riru 23.4
EdXposed YAHFA 0.5.1.4 (4655)
Latest GB for Android 10
 
Last edited:

BeardKing

Senior Member
Nov 1, 2012
374
162
63
Philadelphia
Hey,

I just updated Magisk to v21.4 and I just realized the power key actions don't work anymore in GB: I can't activate the flashlight with a long press anymore...

Other GB settings work, module is active in edxposed manager. I don't know what's going on here? (Pixel 4 XL on Android 10, August 2020 security patch)

Magisk 21.4 stable / latest Manager
Riru 23.4
EdXposed YAHFA 0.5.1.4 (4655)
Latest GB for Android 10
Update to the latest EdXposed Canary.
 

Ghisy

Senior Member
Mar 27, 2010
1,402
209
83
Update to the latest EdXposed Canary.
Seems like no more YAHFA or SANDHOOK for EdXposed by the way. There's only one release now. I probably missed this piece of information. Edit: yup, since 4671, YAHFA and SANDHOOK have been merged and YAHFA is default.


Anyway, I just updated to EdXposed Canary v0.5.2.0_4672-master-release, no difference in GB! 😕
 
Last edited:

AlphaDream0

Member
Jan 8, 2015
33
3
38
Rotterdam
I updated to the newest magisk, then also had to update riru core to the newest version, now a lot of gb features don't work!!

so WARNING, don't do this!! :p stay on the older magisk, because it's difficult to downgrade (on galaxy s10 at least)
 

AlphaDream0

Member
Jan 8, 2015
33
3
38
Rotterdam
Seems like no more YAHFA or SANDHOOK for EdXposed by the way. There's only one release now. I probably missed this piece of information. Edit: yup, since 4671, YAHFA and SANDHOOK have been merged and YAHFA is default.


Anyway, I just updated to EdXposed Canary v0.5.2.0_4672-master-release, no difference in GB! 😕
doesn't gravitybox itself has to update to work with the latest riru core? I think we'll just have to wait for that
 

Soumy1234

Senior Member
Aug 19, 2017
576
157
43
doesn't gravitybox itself has to update to work with the latest riru core? I think we'll just have to wait for that
I don't think it's with the latest Ritu core but rather the latest Edxposed (which GB did update for with 10.1.0). There is no direct connection between Riru and Edxposed modules. Riru updated its hiding mechanism so Edxposed had to update too, but it brought some sepolicy changes that GB had to account for (I think).
 

thirtythr33

Senior Member
Sep 3, 2011
124
59
58
New York
thirtythr33labs.net
what up all. before I get into my question, my setup is as follows: op6T / gb 10.1.0 / magisk 21.4 / riru core 23.4 / edxposed 0.5.0.6_4569 YAHFA
so in short, gb does not find unlocker or essentially work if I attempt to upgrade edxposed to anything above what is current, which is both latest and canary ( 0.5.14 & 0.5.2.0), but as soon as I flash back to 0.5.0.6 everything works again. anyone having this issue? oh and the rest of my modules seem to work and edxposed manager reports everything is working but it seems gb has issues. any help appreciated.
 

iElvis

Senior Member
May 24, 2012
5,019
2,830
253
Modville
what up all. before I get into my question, my setup is as follows: op6T / gb 10.1.0 / magisk 21.4 / riru core 23.4 / edxposed 0.5.0.6_4569 YAHFA
so in short, gb does not find unlocker or essentially work if I attempt to upgrade edxposed to anything above what is current, which is both latest and canary ( 0.5.14 & 0.5.2.0), but as soon as I flash back to 0.5.0.6 everything works again. anyone having this issue? oh and the rest of my modules seem to work and edxposed manager reports everything is working but it seems gb has issues. any help appreciated.
Have you tried yahfa 4655? That with your setup works for me.
 

C3C076

Recognized Contributor
Dec 15, 2012
7,744
24,588
263
Bratislava
ceco.sk.eu.org
- GravityBox is not dependent on Riru version, is is dependent solely on EdXposed
- EdXposed is dependent on Riru
- My current setup on Android 10 (OnePlus 7pro) is: Magisk v21.4 (stable), Riru v23.4, EdXposed v0.5.2.0_4672 and everything is working fine

Btw, some EdXposed devs split and are going for their own project based on EdXposed - called LSPosed.
There is some discussion here: https://github.com/LSPosed/LSPosed/discussions/2
 

thirtythr33

Senior Member
Sep 3, 2011
124
59
58
New York
thirtythr33labs.net
- GravityBox is not dependent on Riru version, is is dependent solely on EdXposed
- EdXposed is dependent on Riru
- My current setup on Android 10 (OnePlus 7pro) is: Magisk v21.4 (stable), Riru v23.4, EdXposed v0.5.2.0_4672 and everything is working fine

Btw, some EdXposed devs split and are going for their own project based on EdXposed - called LSPosed.
There is some discussion here: https://github.com/LSPosed/LSPosed/discussions/2
hmm my setup is identical to yours aside from the device. any ideas why only edxposed 0.5.0.6 works yet 0.5.2.0 does not? thanks for the reply and I've been a supporter for years!