[APP][ROOT] cSploit - Android Network Toolkit (Mobile PenTesting)

Search This thread

Alvaro1982

Senior Member
Apr 10, 2016
176
11
Evora
Hey man, are you still working on cSploit or is it an abandoned?
I mean, you did a great job stabilazing on patching dSploit into it, but I wonder if it has a future.

Completely freezes my phone when try to test a mitm intrusion. I'm using a lenovo zuk z2 pro with Rr rom android 8.1 and magisk
 

ddarvish

Senior Member
Dec 20, 2009
420
37
after we hijack a https session via mitm attack how can we move the session over to a computer browser. the builtin browser is horrible...
 

xkpx

New member
Jul 27, 2020
4
0
Metasploit RPCD stopped - same error with all apps ( on Samsung j3 2016 - viper os 2020 0504 ) rooted with twrp 3.1.1 , magisk 21 beta.

But i will not give up and i will find a way to run it :), i suspect there is something wrong with chown and chmod settings of the installer. Or maybe something else .:confused:
 

magistrjanRUS

New member
Oct 18, 2020
2
0
Help me)

Metasploit RPCD stopped - same error with all apps ( on Samsung j3 2016 - viper os 2020 0504 ) rooted with twrp 3.1.1 , magisk 21 beta.

But i will not give up and i will find a way to run it :), i suspect there is something wrong with chown and chmod settings of the installer. Or maybe something else .:confused:
Hey. I downloaded the application today, I also have this error. Can you please write if you solve this problem?
 

magistrjanRUS

New member
Oct 18, 2020
2
0
thank for the answer

Hi i dont think it was ever fixed, updating and it never finishs the update. Use interceptor ng or zanti

Unfortunately, I don't know how to use Intercepter-ng. And I can't find a normal instruction anywhere, because I have some problem
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 25
    nxltwuW.png


    cSploit Is The most complete and advanced IT security professional toolkit on Android. This App was actually called dSploit but some reason they had close the project to know read Csploit story The Android OS contingency have a BusyBox full designation with each focus commissioned (not a prejudiced installation). If we do not have busybox already, we can get it here or here (note cSploit does not validate any busybox installer, these are usually dual we found).



    Features
    • Map your internal network
    • Fingerprint hosts’ handling systems and open ports
    • Add your possess hosts outward a internal network
    • Integrated traceroute
    • Integrated Metasploit horizon RPCd
    • Search hosts for famous vulnerabilities around integrated Metasploit daemon
    • Adjust feat settings, launch, and emanate bombard consoles on exploited systems
    • More coming
    • Forge TCP/UDP packets
    • Perform male in a center attacks (MITM) including:
    • Image, text, and video replacement– reinstate your possess calm on unencrypted web pages
    • JavaScript injection– supplement your possess javascript to unencrypted web pages.
    • password sniffing ( with common protocols ratiocination )
    • Capture pcap network trade files
    • Real time trade strategy to reinstate images/text/inject into web pages
    • DNS spoofing to route trade to opposite domain
    • Break existent connections
    • Redirect trade to another address
    • Session Hijacking– listen for unencrypted cookies and counterpart them to take Web session
    • For More Details Please Visit www.csploit.org


    After being initially created by evilsocket, I ( tux-mind ) started working on dSploit in summer 2012, i forked it and added the following features:

    • Vulnerability finder
    • Exploit finder
    • MetaSploitFramework integration ( draft )

    Story

    After some weeks the project owner ( evilsocket ) asked me to merge it to the upstream branch. Initially there were about 2 main developers (me and evilsocket) and an UI developer ( androguide ). After a few months evilsocket got overloaded by work and stop working on it.

    But I kept working on dSploit, always trying to improve it. Many functions were slow and error-prone, I changed the way them work, added new features and corrected many bugs.

    Finally, in summer 2014 I suggested a new way to make dSploit work, the new core. basically I wish to move all the slow and inefficent code out of Java. Evilsocket agreed with my suggestion and told me to start working on it. Evilsocket is very busy with work because he started working for zImpremium.

    On autumn 2014 evilsocket received the order to merge dSploit into zANTI2. this decision killed the project. I asked if I could bring it on, but evilsocket told that the domain dsploit.net belongs to him and dsploit will officially merge into zANTI2. so I forked the project and finished my work on the new core.

    NOTE: Evilsocket told, that in a far future zANTI2 will be open source, but I don’t want to wait for this, I want to finish all original dSploit TODOs.

    This was when cSploit was born.


    cSploit target

    My final goal is to write an application that is able to:

    - enumerate local hostsdone
    - find vulnerabilitiesdone
    - find exploits for these vulnerabilitiesdone
    - use those exploits to gain access to the targetdone
    - crack wifi passwords
    - install backdoors for later access


    Portability

    Thanks to the new core, cSploit will be easily portable.

    Basically it can run on any UNIX-based system, but for now only Android is supported. When I reach a beta-state version I will consider working on iOS, OSX, GTK+ and QT.


    Support us

    Please donate to cSploit to support our efforts and resources. Thank you!

    Also, if you want to contribute fork the repo you want to contribute to and create a pull request when you're done. If you actively contribute to the project I will ask you to join the team.



    Current project status

    We are in a delicate first phase of this project and we are not stable, yet. Currently we are moving many parts of the code into a new core. Even if you see a release marked as release, this does not mean that it has no bugs. My apologies for that, I’m doing my best to achieve a stable app :v:.
    Possible error

    A short error message isn’t often self-explanatory. Sometimes it too difficult to explain an issue with a short message and here you can find a few common examples that explain some errors:

    cannot start process: this message is printed when the core of cSploit cannot start the required process.
    cmd returned #number: this message is printed when cmd has exited with an error code number
    cmd killed by signal number: this message is printed when cmd has been killed by signal number

    The errors above are bugs that are specific for your device. Hence, please report them if no one already did.
    Reporting bugs

    I’m human, thus I can fail. This is why we need a good issue tracker like the one provided by github. I’m working on an automated way of reporting bugs directly from the app just by clicking on a button. Until then you have to manually collect your logcat and share it on the github issues page.
    FAQ
    Is cSploit the same as dSploit ?

    The basic code is the same but I’m continuing the development since dSploit has been officially merged into zANTI2.
    When will feature XYZ implemented or bug ABC fixed?

    Like on every other open source project - don’t ask for ETA :grin:
    How can I contribute to cSploit ?

    There are many ways to contribute: by donating, by improving the source code or by correcting my English on this website.



    cSploit Release APK

    cSploit releases are hosted on github.

    - release are stables versions.
    - pre-release are almost stable versions.

    To download the application, click on the green button below and download the latest "cSploit-release.apk" file.

    Download


    cSploit Nightly APK

    Thanks to xaitax - nightly builds are available:

    Download


    3
    Unfortunately I have same issue like majority of people "lately".
    "Metasploit RPCD stopped" error on Magisk 20.3 root, running on OnePlus 5 (Pie)
    2
    New release is out!

    changelog : fixed ExploitFinder not finding exploits.
    2
    Does this app works with android 9? Or is there another app witch does the same kind off actions?
    2
    everytime when i try to open the app,my phone restart

    n9005
    lineage os 15.1
    magisk 16.3

    Try with this busybox:

    https://my.pcloud.com/publink/show?code=XZiLqj7Ze55mxvWILk5PpfwGXrB0YbWoCC57

    To me works fine