[APP][ROOT/NONROOT][OFFICIAL] AdAway v5.12.1/ v6.0.0b

Search This thread


Recognized Contributor
Aug 31, 2013
precisely why i asked to whitelist youtube. my history on different devices don't get synced, and i get suggested vidoes i already watched etc.

cheers y'all!
You will get video's you watched suggested again. Its a part of YouTube AI. I would guess the logic as, if you were interested once, you may watch it again (possibky by accident), and its simply another opportunity for google to serve you ads.
  • Like
Reactions: rodken


Senior Member
Hi all,

Frankly, I don't know if you could block ads in Chrome while using AdAway in VPN mode

A year+ ago I had two phones, rooted and not-rooted one, both with AdAway (one hosts, the other VPN mode), both running Chrome with Lite mode off.
On the rooted phone, AdAway blocked ads in Chrome and 'everwhere' (of course, not in e.g. YT).
On the not rooted phone ads were blocked 'everywhere' but I never managed to let AdAway block them in Chrome

Nowadays I have only the rooted phone and AdAway still perfectly blocks me ads in Chrome and 'elswhere'

Btw, Chrome for me is essential, primarily because of the built-in translator - sometimes, if I want I even read in Japanese, Chinese, Arabian, whatever


If you have Android 9 or higher, disable AdAway and enable Private DNS in your native Settings, and for DNS provider put e g: dns.adguard.com

I don't recall anymore but I think Chrome will also bypass that VPN and you will still see the ads in Chrome (that Private DNS uses VPN to the configured DNS server which blocks the sites pushing ads by not resolving their DNS names)

IMHO, only some pretty old versions of Chrome can be enforced to go through your VPN (AdAway or Private DNS), and that's why you cannot block ads in Chrome, with AdAway in the non-root mode
I can successfully block ads on Chrome if lite mode is not enabled.
I just set up an emulator on Android 11 with Play API, install AdAway, block a custom site, apply and check if it is blocked on Chrome. It is.

Not I did not set a Google account so lite mode was not enabled.

I am no longer using AdAway. one of the reasons is that it isnt so good at looooong blocking lists.
Did you move to another app? if so, which one?
I could have a look to check how it handles the hosts merge better but it is challenging subject. I already released several implementation of the subject and they is currently two strategies running in the app...

The solution I have is to do the merging client side. So you can set as many as host files you want without impacting your device resources but (there is always a but) I should charge for this feature.
I don't know how much but moving the processing power from all your devices to one place won't be free from the cloud provider that will run it ^^'


Dec 5, 2010
OnePlus 9
AdAway blocks Spotify?!
Recording dns request and allow them didn't solve the problem.
Any ideas?
With my old phone AdAway and Spotify worked well. Only with new phone I have the problems.


Senior Member
Oct 10, 2016
no not the notification, but the app itself.
I don't have the app on all the time, especially at home, but i notice that the app has turned itself on, without any interaction from myself
Preferences, Updates, disable all automatic updates

However, non-root must be running all the time its VPN service, monitor media reconnections - search for the non-root version and some reconnection issues already reported and discussed in the thread
Last edited:


Senior Member
May 25, 2008


Senior Member
Aug 14, 2008
Getting this "Fatal error: Uncaught PDOException: PDO::__construct(): php_network_getaddresses: getaddrinfo failed: {Mod edit, as requested in the below post}

This app is wonderful. Thank you!
Last edited by a moderator:
  • Like
Reactions: naudmick


Senior Member
Getting this "Fatal error: Uncaught PDOException: PDO::__construct(): php_network_getaddresses: getaddrinfo failed

This app is wonderful. Thank you!

Thanks for the info.
There are some issues here. First database should answer. Then, error should not leak the database password (that I just changed).

I will investigate what happened for those two problem and revert the whole hosting to ensure nothing was altered... (better safe than sorry).
Could you trim the error message from your post? It won't prevent Google from indexing it or remove it from the Internet history but better removing it. Thanks.

Oswald Boelcke

Senior Moderator / Moderator & RC-RT Committees
Staff member


Senior Member
Thanks for the quick edit!

On my side, my hosting provider just changed my database domain name 15 mins ago, breaking most of my services...
And I also found an error in the debug settings on the AdAway backend that I obviously did not test, leading to display error context in production.

Everything should be back in order now.


Senior Member
Feb 25, 2021
Good afternoon @PerfectSlayer

First of all thank you for your work and time.

I wanted to report a bug in Adaway. It turns out that if you update, add lists of hosts, etc... With data, normal wiffi there is no problem. But if you use 5 ghz wiffi. Adaway goes crazy. Meaning:

On the main screen where you get the number of sources you have installed, and the ones to update. Well, you see how the number of installed lists decreases, and even says 0 installed fonts. Again where this the lists of hosts. To some of them it says installed a few minutes ago, to another one updated for few minutes. Or simply it does not load the total. That is to say for example source Steven and it leaves a number for example 250k and this number removes it.

I have already tried rebooting, reinstalling Adaway and backup, Adaway without backup and putting one by one the lists. Clearing cache, etc... And always the same.

And it is not a failure of the mobile or wifi. Because everything goes fine on the wiffi 5 ghz. That is browser without problems, fdroid without problems, etc... I tested on a Nexus 6p with lineageos and Magisk in its latest version. And on Samsung S9+ also with lineageos magisk updated. And Adaway in its latest version 5.8.0 . And this before I did not do that I realize. And I have not changed anything on the phone

I would also like to ask you if it would be possible to add Adaway. An option that after updating the sources of the host lists, are updated. Adaway reboot the mobile. Or a warning if you want to restart the phone or not. As it happened in versions 4. I comment it because I see that Adaway processes better the updates and changes after restarting the mobile.

Thank you very much for your time and help.

Best regards


Senior Member
sorry but I don't know English.
I have installed Adaway 5.8.0-210808 on POCO F3 ROM Xiaomi.eu when I start the app and get to the sync it says "Sync failed: Unable to install new file". I understand that I need to change some settings but I don't know exactly what and where to find them.
Can someone explain to me how to do this? Thank you.


Senior Member
Oct 10, 2016
sorry but I don't know English.
I have installed Adaway 5.8.0-210808 on POCO F3 ROM Xiaomi.eu when I start the app and get to the sync it says "Sync failed: Unable to install new file". I understand that I need to change some settings but I don't know exactly what and where to find them.
Can someone explain to me how to do this? Thank you.
You need to enable Systemless hosts in Magisk
  • Like
Reactions: pegasoc


Senior Member
Jun 22, 2010
I am getting ERR_CONNECTION_REFUSED for websites that are part of my Allowed or Redirected lists. Specifically, I am trying to add the ad services sites used on SlickDeals. Here is a paste of my backup JSON that I try to restore. I see that you can only have them in Allowed or Redirected. I have tried both methods, but I still get the error when browsing.

Specifically, in the case of tkqlhce.com, I see that it is part of the Blocked list. Is that causing a conflict? Can I remove it somehow?

Is there something else that I need to do?

Top Liked Posts

  • 1
    ....It is as if version 5.12.1 was slower doing these things than the previous version...
    i'm experiencing the same. don't know about 6.0.0b, though. haven't updated yet.
  • 38
    Hi all,

    I talked about it for weeks, if it's not month, but it's finally here! 🎉
    The new major version comes with a whole new VPN ad-blocker implementation that greatly improves stability and reliability. Most of the disconnections issue should be fixed by now.
    I daily use it for months, using cellular (4g + 5g) and WiFi (private + public + public behind authentication portal) networks, doing handovers between them and it works fine. I distributed early builds on GitHub issues and I got good feedback too.

    I also work on DOH (DNS Over HTTPS) support. It works but it is not yet configurable from the settings.
    I might add other DNS client alternatives later to provide a better privacy.
    And of course, it comes with a batch of bug fixes and third party upgrades.

    If you like the project, feel free to show your support or become sponsor 💖
    Without further ado, here comes the full changes!

    • Add a new VPN ad-blocker implementation
    • Add initial DOH (DNS Over HTTPS) support
    • Add VPN connection monitor, heartbeat and throttler to improve reliability
    • Add long press action to copy hostname from user lists and DNS log to clipboard
    • Fix VPN state on network connectivity change and lost
    • Fix VPN restart when system kills it
    • Fix wrong DNS read on VPN restart
    • Fix VPN unwanted restart while paused
    • Fix crash on application update unknown size
    • Improve VPN user control reliability
    • Update logging system
    • Update libsu
    • Update Android gradle plugin
    • Update AndroidX libraries
    • Update NDK
    • Update third party libraries


    AdAway v6.0.0b
    Hi all,

    It's been a long time since (more than two months 😮) the last update.
    During this period, I mainly spent all my free time preparing for job interviews and, good news, I just signed a new contract! 🎉
    And with my 2 weeks trip to USA canceled due to covid, I found some hours this week to fix the most urging issues.

    So, here comes the v5.12.1 that fixes the root ad-blocker on Android 13 (AdAway failed to install the hosts file).
    It also slim down the F-Droid build that recently grows from 15mb to 25mb (due to the wrong NDK).

    On top of that, I will also relaunch the beta update channel to distribute the v6.
    Since I know I will have free time in the coming weeks, I could properly follow its launch and handle the user feedback. So stay tunes!

    (As usual, beta versions will only be available for the GitHub install users as F-Droid store does not handle it.)

    • Fix hosts file install on Android 13


    Special thanks to AAGaming00 and KieronQuinn for their bug reports.


    AdAway v5.12.1
    Hi all,

    For the record, I patched the backend to improve the beta channel behavior.
    It will now serve whatever beta or stable stable release is the most up-to-date.

    So now, if you subscribe to beta channel, you will receive the upcoming beta builds (as previously) but your app will keep updating once the v6 hits stable channel (whereas previously it was stuck on old beta builds indefinitely).

    For those who want to try the bleeding edge, feel free to switch to beta channel!
    (keep in mind beta channel is only available for GitHub install users)
    Further on boxes, check, and colors.

    It first appeared that the buttons on the Blocked and Redirected lists were always the same. While experimenting, I've been able to produce Blocked list buttons of empty white box and red checked box. I can toggle them.

    This leads to the quesion of what do the changable colors on the blocked list buttons mean?

    Similar on the redirected list.

    Finally, when I use the search feature, there doesn't seem to be a way to turn it off, i.e. restore all entries to the display. But save that problem for later.

    If I can get a good explanation of things, I will write a help page.

    Next topic is how the allow, block, and redirect lists interact. For example, which order are they searched? When a wild card is on one list, will it catch an exact match to an entry on another? How do the "pre loaded" (source) lists take precedence, and how can entries be overridden since they don't seem to be deletable from the user lists.
    Answering to one of your questions:
    Allowed is stronger than blocked

    First off all, if you don't have any hosts source, than all sites are allowed.
    Hence you actually don't need to put anything to the Allowed list

    But as the name says, this is an ad blocker. Hence the purpose is to use the hosts sources that will BLOCK certain sites

    But once you start using someone's hosts source (by default, I'm talking about the blocking lists), you have no influence on which sites will be blocked by the hosts source or not

    If it blocks to less, you will another hosts source to your list, and later maybe more and more hosts sources there

    However, at some moment you may find that you can no more shop at eg Amazon, because one (or more) of your hosts sources blocks the Amazon. You could spend time to find which hosts source blocks the Amazon and remove it from your hosts sources list. But the Amazon may soon appear in another hosts source...
    Or, you may otherwise like that hosts source that blocks the Amazon because it blocks a zillion of other sites you really want them to be blocked

    Hence you better put Amazon to your own Allowed list. Then you don't need to worry about in which of your hosts sources Amazon is blocked (or might become blocked in the future, upon the hosts sources updates)

    AdAway first reads and compiles the list of Allowed sites. Then it goes to the blocked lists. Whenever it finds the Amazon site (that you did put to the Allowed list) in any of the blocked lists, it will ignore it, knowing that you specifically asked to allow that Amazon site

    That's the use case behind the Allowed list. And the reason why it is, and why it must be stronger than Blocked list.
    And the same policy (allowed is stronger than blocked) applies also to other ad blockers
    Sorry all for a bit of OT. 🙃
    OT for this thread but, slightly relevant with the last few comments/posts.

    Also true! 8+ has all of those: https://chromium.googlesource.com/a...pstream/shell_and_utilities/#android-8_0-oreo

    (Actually you can see Android's had those specific commands since the beginning, though their implementations weren't without their quirks back then). 🙂
    It is odd though. :confused:
    The toolbox binary is depreciated but, still exists in Android 12L builds.
    getprop (for example) is reverted back to toolbox for some reason. 🙃

    Stock Google.
    The command is only included in toolbox if not available/(or reverting) the one available in toybox.

    angler:/ $ toybox
    acpi base64 basename blkid blockdev cal cat chattr chcon chgrp chmod
    chown chroot chrt cksum clear cmp comm cp cpio cut date dd df diff
    dirname dmesg dos2unix du echo egrep env expand expr fallocate false
    fgrep file find flock free freeramdisk fsfreeze getenforce getfattr
    getprop grep groups gunzip gzip head help hostname hwclock id ifconfig
    inotifyd insmod install ionice iorenice kill killall ln load_policy
    log logname losetup ls lsattr lsmod lsof lspci lsusb makedevs md5sum
    microcom mkdir mkfifo mknod mkswap mktemp modinfo modprobe more mount
    mountpoint mv nbd-client nc netcat netstat nice nl nohup od partprobe
    paste patch pgrep pidof pivot_root pkill pmap printenv printf ps pwd
    pwdx readlink realpath renice restorecon rev rfkill rm rmdir rmmod
    runcon sed sendevent seq setenforce setfattr setprop setsid sha1sum
    sha224sum sha256sum sha384sum sha512sum sleep sort split start stat
    stop strings swapoff swapon sync sysctl tac tail tar taskset tee time
    timeout top touch tr traceroute traceroute6 true truncate tty tunctl
    ulimit umount uname uniq unix2dos uptime usleep uudecode uuencode
    vconfig vmstat wc which whoami xargs xxd yes zcat
    angler:/ $ 
    angler:/ $ toolbox
    dd getevent newfs_msdos

    oriole:/ $ toybox
    [ acpi base64 basename blkdiscard blkid blockdev cal cat chattr chcon
    chgrp chmod chown chroot chrt cksum clear cmp comm cp cpio cut date dd
    devmem df diff dirname dmesg dos2unix du echo egrep env expand expr
    fallocate false fgrep file find flock fmt free freeramdisk fsfreeze
    fsync getconf getenforce getfattr getopt grep groups gunzip gzip head
    help hostname hwclock i2cdetect i2cdump i2cget i2cset iconv id ifconfig
    inotifyd insmod install ionice iorenice iotop kill killall ln load_policy
    log logname losetup ls lsattr lsmod lsof lspci lsusb makedevs md5sum
    microcom mkdir mkfifo mknod mkswap mktemp modinfo modprobe more mount
    mountpoint mv nbd-client nc netcat netstat nice nl nohup nproc nsenter od
    partprobe paste patch pgrep pidof ping ping6 pivot_root pkill pmap printenv
    printf prlimit ps pwd pwdx readelf readlink realpath renice restorecon rev
    rfkill rm rmdir rmmod rtcwake runcon sed sendevent seq setenforce setfattr
    setsid sha1sum sha224sum sha256sum sha384sum sha512sum sleep sort split stat
    strings stty swapoff swapon sync sysctl tac tail tar taskset tee test time
    timeout top touch tr traceroute traceroute6 true truncate tty tunctl ulimit
    umount uname uniq unix2dos unlink unshare uptime usleep uudecode uuencode
    uuidgen vconfig vi vmstat watch wc which whoami xargs xxd yes zcat
    oriole:/ $ 
    oriole:/ $ toolbox
    getprop modprobe setprop start stop toolbox
    oriole:/ $


    When I was going though the toybox updates.
    I laughed out loud when I saw they where Douglas Adams fans like me. :p

    Including one of my favorite lines from the books. 🙃

    "We are now cruising at a level of two to the power of twenty-five thousand to one against and falling, and we will be restoring normality just as soon as we are sure what is normal anyway."

    - The Hitchhiker's Guide to the Galaxy​

    Cheers all. :cowboy:
  • 3329

    AdAway is an open source ad blocker for Android using the hosts file.

    Google Play Store notice

    According the Google Play Developer Policy, especially the "Device and Network Abuse" section, ad blocker like AdAway violates the "Apps that block or interfere with another app displaying ads." rule and can't be distributed on distributed on the Play Store.
    As Free and Open Source Software, AdAway is available from F-Droid Store or this XDA thread :good:


    This application requires Android 8 or above and does no more require root.

    For older Android versions, a rooted device is required.


    If you don't want to read each announce post of this thread, you can:


    Stable versions are available on GitHub releases and F-Droid Store:

    Beta versions are available on GitHub releases only:

    AdAway 6.0.0

    The app provides an in-app updater for both GitHub and F-Droid builds.
    Keep in mind beta channel is limited to GitHub builds, and F-Droid releases usually have a several days latency.

    Problem? Read this

    * If you use Chrome and still see ads on web pages, remember to disable the "data saver" or "reduced data usage" browser option.
    * Check your APN settings for any proxy, the proxy itself could be allowing ads. Disable the proxy.
    * After you install or make any change to AdAway, you must reboot for those changes to take effect.
    * If you are still having issues please read and understand all the info in the wiki before asking for help here.

    Otherwise, this is the right thread to discuss about it or file a bug report here.


    PerfectSlayer, Vankog, jawz101
    Source Code: https://github.com/AdAway/AdAway
    Hi all,

    A new year is coming and I wish you all to have nice holidays :victory:

    Just few words about this ending year. There was about 12 releases in 2019 which brings you a new UI, a lot of bug fixes, Android 10 support, Gist and GitLab hosting support and better Magisk support.
    All of this is possible thanks to the community to help users to discover the app, learn how to use it and report any new bug and also your moral, nice words and thanks you can send to me, and financial support.
    Thanks a lot for all donators, GitHub sponsor and the Pixel 2 you sent me to test Android 10 support.

    For the next year, I hope to release the next version (V5), at least in beta to start. It's been 9 months since its first lines of code and things are working quite nicely.
    It aims to make the app simpler to use for the main use cases, support rooted and non rooted devices and remove old hacks/workaround which are no more needed on recent setups.

    But before this big next update, I still have time to fix current issue with a new release :p

    • Fix GitLab hosting support (commit date parsing failed)
    • Translation update


    Special thanks to @gallegonovato for its helpful bug report and @Vankog for translation update.


    AdAway 4.3.2 on AndroidFileHost (md5: 78fde09a0e92044c45e901bb1cec8e2e)
    Hi all,

    Long time no see! It's been more than two months since the last update.
    I can't say I was not active on the project as I start working on a new version (5.x.y) as a side project.
    I won't share the source code yet as it is not ready at all and I don't want to give an ETA but this new version targets the following goals:
    • 1. Revamp the UI
    • 2. Clean up old support
    • 3. Address one of the main drawback of the app

    1. The card based UI does not feel right. Welcome card takes too much space, update button / status has a lot of critic. I guess I can do better.
    I started a new simpler and lighter design which provide the most useful information on home screen and all main actions to trigger in one tap (no more burger menu).
    It is still under heavy development but I hopefully get a friend onboard, specialized in graphics and design, to help me :highfive:

    2. In order to simplify the development, I clean up the app and remove support for old features.
    I bump target SDK version so I finally get Java 8 language feature (it was released 5y ago…) and move to topjohnwu root library (instead of home made one). It means systemless support is now handled by Magisk and other root solutions will still work.

    3. Think of what prevent most of users to use AdAway? Now it's gone!
    It's not gone forever. It's still here but there will be a fallback to workaround it.
    I won't tell more until the first public beta but I guess you get the point :fingers-crossed:

    In the meanwhile, here is a new version!


    Is anyone using a hosts list hosted on Gitlab? It keeps showing "Unknown update status".
    GitLab, like GitHub do not set LastModified HTTP header so update status is not supported... yet!

    • Add Gist and GitLab hosting support for hosts file
    • Add option to set default IPv6 redirection
    • Improve reboot command
    • Improve UI for overlays
    • Update translations


    Special thanks to @MSF Jarvis and ralayax for theirs contributions and @andy356 for its helpful bug report.


    AdAway 4.2.5 on AndroidFileHost (md5: ab81225745afaaa7646024109de299c0)
    Hi all,


    Hmm, not working for me for this URL, v4.1.0 shows something like not updated in -360 days (some large negative value). Can you please see if you can reproduce?
    It works well here. I failed to reproduce as I change the HTTP client library and how I use it.
    But update date for the source you link definitely works now.

    All the F-Droid apps I know of have manual push updates to the store.

    Isn't automatic build basically for nightlies?
    Not really. You could choose a lot of different mode.
    For example, F-Droid server watches AdAway GitHub repository to find tags which match a specific versioning pattern.

    I exist still... do you know what i have to do to transfer ownership? if i edit project it doesn't let me change the primary author so i assume i have to PM some higher up to make this happen?
    Thank you so much! :highfive:

    This is now done, @PerfectSlayer is the OP of this thread.
    Thank you too!

    • Add hosts source download cache
    • Add snackbar notification to update host from DNS request listing
    • Update UI from Material Design to Material Theming
    • Update gradle, plugins and dependencies
    • Fix crash parsing not defined host source last modified date
    • Fix native modules build script (required for F-Droid build server)
    • Fix Transifex issues


    Special thanks to all recent donators! Your help is really appreciated :good:


    AdAway 4.2.0 on AndroidFileHost (md5: 023169e7c345ef7297095793024f8478)
    Hi all,

    I talked enough about it the past weeks and here it is: the first beta for the next version of AdAway.
    As you know, the main feature is the removal of root requirement but it also comes with a lot of improvements like an easier to use UI, a builtin updater, new cache and databases to improve reliability or even a quick pause/resume adblocking button that 3rd party apps can control.

    It took me literally a year and 330+ commits to build it (the first commit of this branch was April the 7th) and I hope it will be worth it.
    It should allow the app to be viable in the future with root being more and more difficult to achieve at each new Android release and Google hardening SafetyNet checks.

    I will try to answer to the most expected questions here so you still can post a link to this FAQ later to lost users.


    Does this version replace the v4.x versions?
    No. This is still a preview version and does not replace the stable one.
    It is available to test it and report issues and feedback before being promoted to stable.

    Can I upgrade and revert safely?
    Yes. Both v4 and v5 use the same settings export format.

    Why does this version targets Android 8+ Oreo only?
    Like the v4, v5 is expected to offer support for latest devices.
    Android 8 and above represent more than 60% of device distribution and will grew through time.
    If you use an older device, root solutions work very well and v4 is here for you (like v2 and v3 stayed for legacy devices).

    How the hell does it work without root?
    This version provides two adblocking methods: the usual root one using hosts file and a new one using local VPN.
    The VPN solution allows to filter and alter connections of your devices without root access.

    Is using a VPN safe?
    In the case of AdAway, yes. It uses VPN API but does not connect to a VPN server.
    In the case of VPN client app, it depends.
    To give you more details, a VPN client app uses the VPN API to create a virtual network interface on your device and redirect all your traffic into it.
    If you imaginge the VPN like a pipe (the right word is tunnel), client VPN app outputs all your traffic on a VPN server which is able to check what you are doing on the Internet.
    With AdAway, your network is not redirected to a VPN server but your device internet connection (same as no VPN). VPN API is only used to get traffic into it to break the connections to ad servers.

    Is VPN use battery?
    Yes, like everything you do on device.
    Witouth root, a VPN service will be running permanently to filter your traffic.
    Good news is it will only filter DNS traffic. Not all traffic is redirected into it so it won't be as expensive as you can fear.

    Did you come up with this idea alone?
    Absolutely not! I spent a lot of hours trying to find altenatives to hosts based adblocking (like routes or private DNS). But nothing was better than VPN based adblocking.
    So we (MrRobinson and I) approched Julian Klode, developer of DNS66 more than three years ago to see if we can merge our apps. It wasn't that easy as we don't develop our apps the same way so I ended up by integrating the DNS66 adblocking method into AdAway. It is fine for Julian, his app is Open Source and he himself built it from the core code of AdBuster app (an VPN based adblocking app).

    Should we stop using DNS66 for AdAway?
    Not at all. DNS66 is a great app and provides some features that AdAway doesn't have (yet?), like DNS settings.
    DNS66 is a great app, keep using it if you like it!
    If both apps used the same adblocking method a year ago when I start this version, I keep adding feature to the VPN adblocking method and most of them won't be in DNS66.
    If Julian ports them back to DNS66, it's great if it can help his app and users!

    Is it me or the app put on weight?
    Yes, the app significantly grew due to new libraries like VPN related ones and Android Jetpack.
    It also stores more data on device: a http cache, a host database, a hosts copy, etc...
    I think 15~20mo of storage is still fine.


    Without further ado, check the summarized changelog (it was hard to summarize a one year development)

    • Add new home screen
      • Provides all main controls from one screen
      • Displays currently blocked, allowed and redirected domains
      • Displays current hosts sources status and control to force apply
    • Add non root ad-blocking feature
      • Uses a builtin local VPN to filter DNS request to blocked domains
      • Based on the work of dns66 by julian-klode
      • Allows to excluded system applications and per user applications
    • Add builtin updater with changelog display
    • Add feature to quickly pause and resume ad-blocking
    • Add wizard screen for first run setup
    • Add feature to display and filter all blocked, allowed, redirect domains
    • Improve preferences screen
    • Add broadcast receiver to control ad-blocking from third party applications
    • Update Android target to Android 10
    • Improve root and shell support
    • Split translation files to easier understand their context
    • Add GitHub action test and build tasks


    AdAway 5.0.0 beta (sha2: 200fd7789b174735d3af5925b4e568b09475bb3f39a79d24d6617af4b19cd19d)

    If you like my work, feel free to support me. Check my sign for donation links. Thanks all! :highfive: