Apps force closing on newer Androids

Search This thread


Feb 10, 2023

Long thread and I'm sorry if this is not the right place to post this, if it isn't please feel free to point me in the right direction so that I can fix my mistake :)

I'm using a note 3 N9005 and I've been jumping from ROM to ROM to find the most stable and less buggy ROM I can to keep this as my main phone for a while. Even tho most Android 7 ROMs were pretty stable, I needed to use a newer version because of some apps that are only A-8/9+ compatible.

Unfortunately, for some unknown reason, whenever I use any A-8+ ROM some apps keep crashing for apparently no reason, some even almost crash instantly on start (mainly Uber and Pokemon GO). Since I've been trying to find the reason behind it for months I'm making this thread to see if someone can help me on this or even tell me if this is something fixable, Android/model related or if it is just my phone dying :(
Here is what I have so far:
  • Uber/Cornershop - It's usable but force closes sometimes when changing screens or "under heavy load", gets worse on A-10 and becomes unusable on A-11 (FC as soons as map/drivers start to show up).
  • Inter bank - FC same as Uber but at random, so it can or cannot work when you need it.
  • PicPay - Instant FC when opened on A-9+, doesn't even give a message.
  • Pokemon GO - On A-9 it starts ok but then it freezes and crashes at random times (specially when changing screens in-game) and gets progressively worse/more frequent over time. On A-10 and A-11 it gets to the point where when you login and assets are loading around you, it crashes. On A-8 it freezes/crashes while assets are loading, same as A-11 but happens since first boot so it's unplayable.
All of these, apart from PoGo, doesn't happen on A-7 ROMs, PoGo still has some crashes but it takes so long to happen that they almost don't bother me that much. I also noticed that, on PoGo, when I turn off location before the assets show up, it stays longer without freezing/crashing (gives me more time to do some things that don't need my immediate location in-game).

Things I tried so far to fix these problems:
  • Different based ROMS - AOSP, GZOSP, AOKP, CAF, AICP (CAF ROMs seemed more stable, at least on PoGo but it can just be a coincidence or placebo).
  • Kernel tweaking - Using virtual memory, over/under clocking CPU and GPU, tweaking hotplugs, using Lspeed.
  • Using lolz-kernel on A-9/11.
  • Changing a bunch of developer options including killing all apps as soons as you leave.
  • Updating adreno drivers (tried with 2 different versions I found here on XDA).
  • Trying different webviewers - bromite, mulch, chrome, chromium.
Unfortunately I don't have any logs of these crashes since I have no experience with logcat or any other log program, also I was jumping from ROM to ROM and it was kinda hard for me to do it, but if it's needed it and someone can guide me through the process I can try to provide those.

My current setup:
LineageOS 18.1 (official), default kernel and OpenGApps​
Baseband and bootloader updated (UGPQB1/SGBQD1)​
No adreno driver custom updates​
Magisk 26.1 root with zygisk on, modules:​
USNF v2.4.0 (mod by Displax)​
Shamiko v0.7.3(174)​
ViPER4AndroidFX repackagedhoch69 v2.7.2.1-v69-(dd44f54)​
L speed v1.7​
Bromite System WebView Overlay v0.4​
Lspeed tweaks:​
GPU Tuner - Render OpenGLES using the GPU, Optimize buffer and Force GPU Rendering​
Net tweaks - DNS Manager (cloudflare)​
RAM Manager - RAM Manager (Gaming), Virtual memory tweaks (Performance) and Swappiness tendency 25%​
Misc - DIsable debugging, Kernel panic and all animation scales at .5x​

Important to mention that my battery temperature sensor is apparently broken/misbehaving, it shows a lower temperature than intended, dropping even more as soon as a cable is connected (sometimes it even says "too cold to charge" and refuses to charge). I suspect a hardware problem on the sensor and USB jack since both are apparently "together", but idk if this is related to the problem in question or not.

Bonus info:
I noticed that some apps like PoGo Chat have weird graphical issues on A-8+ which I'm gonna include some screenshots below, the screen just flickers like crazy and stays like that, tho they never happen on A-7 so I thought MAYBE it could mean something?
Last edited:


Feb 10, 2023
Presume you have no problems on Samsung based roms/firmware .
That rules out phone on the way out .
If I remember correctly I had no problems using Samsung based ROMs, unfortunately they only go up to Android 6 so they lack even more compatible apps than 7 which is a deal breaker for me :/ for instance I can't even test PoGo on those since it's only for A-7+