Archos 101 G8 - browsing is broken

Search This thread


New member
Oct 6, 2022
I've just taken a 101-G8 out of its box after about 10 years. I was pleased to find it was still in working conditions, was able to connect it to the wifi, use the installed apps, but trouble started when I tried to browse (using the pre-installed Dolphin browser). Almost all sites give me the 'Web page not available' message. After some trials I found that accessing http version instead of https would work, if the site didn't force a redirect. So I suspect a certificate issue, but I have no clue how to update them. Then I found out that the AppsLib and Market apps are no longer supported, so I can't update or install new apps.
After reading the forums, I know I could try to upgrade Android to something like 4.0 (via Cyanogen), but I'm not even sure this would fix my browsing issues, which is all I need right now (I'd like to use it for my kids to access the website). Any advice for me?



If you're running 2.2, then this browser should work with its 2015 limitations. It has its own downloader so it should be able to get some apks without the download error the stock browser shows. Not gonna be nexus 7 speeds, but it works! also, you need to have a windows computer to sideload the browser as the stock browser can't download apks...hope your learning website worked!
download here: