[ARM64][GApps][Android 11] NikGApps [31st Dec 2020]

SilentException

Senior Member
Sep 27, 2010
66
13
38
Mi 5s Plus

ROM:
(https://sourceforge.net/projects/luk-lineageos/files/natrium/lineage-18.1/)

ROM Version:
lineage-18.1-20210110_125014-UNOFFICIAL-natrium.zip
(same with lineage-18.1-20210102_122007-UNOFFICIAL-natrium.zip)

Wiped everything, installed ROM, install NikGapps (NikGapps-full-arm64-11-20201231-signed.zip), system reboot, after few minutes it reboots back to recovery. ROM boots fine without NikGapps. Logs attached. Any pointers? Thanks
 

Attachments

lepicane1

Senior Member
Dec 9, 2016
192
52
28
Hi, there's anyone else having problems with this gapps?
First of all, ty developer
Second, when I flash PixysOS 4.0.3 (android 11, onclite) and then Nickgapps, looks like everything is ok, but when try to reboot, keep going again to recovery, any solution?
Edit:
Android R: tried with Full and Stock packages
Android Q: with LineageOS 17.1, didn't work (maybe it's recovery problem?, no, tried TWRP 3.1 and OrangeFox, both FBE)
Mi 5s Plus

ROM:
(https://sourceforge.net/projects/luk-lineageos/files/natrium/lineage-18.1/)

ROM Version:
lineage-18.1-20210110_125014-UNOFFICIAL-natrium.zip
(same with lineage-18.1-20210102_122007-UNOFFICIAL-natrium.zip)

Wiped everything, installed ROM, install NikGapps (NikGapps-full-arm64-11-20201231-signed.zip), system reboot, after few minutes it reboots back to recovery. ROM boots fine without NikGapps. Logs attached. Any pointers? Thanks
See my post a few posts back. Seems to be an issue with the 31 December build of NikGApps. Discussed and confirmed on the LOS 18.1 mido telegram channel. Try earlier version or other GApps.
 

namaf

Member
Dec 28, 2012
8
3
23
Does core package work with android auto on android 11? My phone tells me that I need Google play services.
i tried (los 18.1 - android 11) but didn't work (without message about google play services-just not connecting). it worked (both usb and wireless) with the full package ( i edited the nikgapps.config file to install only the core + android auto+tts)
 
  • Like
Reactions: Marcyvee

Marcyvee

Senior Member
Oct 9, 2015
135
8
38
i tried (los 18.1 - android 11) but didn't work (without message about google play services-just not connecting). it worked (both usb and wireless) with the full package ( i edited the nikgapps.config file to install only the core + android auto+tts)
So, do I install a full package "debloated"?
 
Dec 14, 2020
6
0
11
Firstly, apologies for getting back so late, still adapting to the new xda theme, honestly, it is faster but operating it seems to be very difficult.

1. you should be able to use core, basic, omni without issues. starting macro overlays are involved and it may conflict with pixel experience rom
2. i wouldn't do that. use nikgapps.config instead, it's really very simple.


works for me! hope it does for you too.



When it says storage space may be full, it is informing that the space is full.
you can try setting InstallPartition=system in nikgapps.config before flashing, that will force the installer to install it in system partition that has more space


oh boy, 10th oct is pretty old build. would have been ideal if you had reported immediately after it stopped working, would have been easier for me to compare the changes and identify what went wrong.

nevertheless, I will compare the core package of 10th oct and latest build, will see what changes I made since then.
Hi. How 'bout crDroid? Which package (NikGApps of course) you recommend for the real Pixel feel?
 

namaf

Member
Dec 28, 2012
8
3
23
So, do I install a full package "debloated"?
i uploaded my nikgapps.config. As you can see i have set core apps to 1 and everything else to 0 (don't install) except android auto +tts to 1 (install).
you have to place the file to the same directory NikGapps zip package is located (you can read the first lines of the file for explanation)
 

Attachments

  • Like
Reactions: Marcyvee

djrion

Senior Member
Oct 30, 2011
190
46
48
clean install LOS18.1 (no root) - which boots fine.

but run into this error with GAPPS Q when sideloading [12/31/20]

"- Is on top of NikGapps: false

------------------------------------------
This Addon can only be flashed on top of NikGapps
------------------------------------------

Aborting while mounting This Addon can only be flashed on top of NikGapps"

1st time NikGapps user so forgive my ignorance.
 

Nikhil

Senior Member
Sep 26, 2012
1,345
2,226
153
Ahmedabad
clean install LOS18.1 (no root) - which boots fine.

but run into this error with GAPPS Q when sideloading [12/31/20]

"- Is on top of NikGapps: false

------------------------------------------
This Addon can only be flashed on top of NikGapps
------------------------------------------

Aborting while mounting This Addon can only be flashed on top of NikGapps"

1st time NikGapps user so forgive my ignorance.
Apologies for the inconvenience caused. This will be fixed with next version. A small glitch is causing this. If you flash it normally (any way without sideloading) will work.
 

djrion

Senior Member
Oct 30, 2011
190
46
48
Apologies for the inconvenience caused. This will be fixed with next version. A small glitch is causing this. If you flash it normally (any way without sideloading) will work.
Could I sideload an earlier version? If not, when will next ver be dropped (approximately)? Thank you
 

LightofMagic

Member
Feb 26, 2008
20
1
33
Hi there,

first thanks to make the NikGApps avaliabel. BUT, I do encounter some issues - mainly I have a family controlled Gmail account for my children. While setting the S7 up, completly from scratch, I do have a loop, telling me that the Profilemanager needs to be installed along with family controll app, but it simply does not complete the installation. Any suggestions?

Thanx,
lightofmagic
 
Last edited:
  • Like
Reactions: Marcyvee

m.omdaa

Senior Member
Jan 24, 2014
173
23
48
I'm on kangos with gapps built in rom and want to use nikgapps what should i do to avoid data lose or battery drain issues???
 

zoppa

Senior Member
Apr 29, 2011
101
15
38
After dirty flashing Lineage OS and NikGapps as recommended by maintainer, all my data is there, but all app permissions have been reset, including system apps. Not the app settings, just the permissions.
Same for me on CrDroid Cepheus latest (crDroidAndroid-11.0-20210112-cepheus-v7.2.zip).
 

Nikhil

Senior Member
Sep 26, 2012
1,345
2,226
153
Ahmedabad
Could I sideload an earlier version? If not, when will next ver be dropped (approximately)? Thank you
Yes, you could sideload on earlier version. Also, you will be able to sideload on next versions.

@Nikhil How do i remove the module?
The whole gapps?
Delete /system/addon.d/nikgapps-addon.sh
Reflash your Rom

If you just want to remove a single package
Set the value to -1 in nikgapps.config and reflash NikGapps zip.

Hi there,

first thanks to make the NikGApps avaliabel. BUT, I do encounter some issues - mainly I have a family controlled Gmail account for my children. While setting the S7 up, completly from scratch, I do have a loop, telling me that the Profilemanager needs to be installed along with family controll app, but it simply does not complete the installation. Any suggestions?

Thanx,
lightofmagic
Can you share a screenshot of how it looks?

Did you or anyone get an answer to this?
I'm not sure which of these two addons to use.
Use PixelSetupWizard

I'm on kangos with gapps built in rom and want to use nikgapps what should i do to avoid data lose or battery drain issues???
If you're already on inline gapps rom then why flash another set of gapps?

is possible disable backup ?
Yes, simply set execute.d=0 in nikgapps.config
With this in place, backup/restore won't happen the next time you dirty flash the rom.

Same for me on CrDroid Cepheus latest (crDroidAndroid-11.0-20210112-cepheus-v7.2.zip).
Apologies for the inconvenience.
It's a known issue and will be fixed with next release! Stay tuned! :)

FlameGApps Basic solved it for me. Didn't try any earlier versions of NikGapps.
Earlier version of NikGapps didn't have this issue. It was introduced to support dynamic partitions where users were not able to install the gapps due to space issue.

This is fixed already. Will be part of next release.