[ARM64][GApps][Android 11] NikGApps [31st Dec 2020]

Nikhil

Senior Member
Sep 26, 2012
1,345
2,226
153
Ahmedabad
Great project. Always wanted to get custom gapps since the aroma installer doesn't work anymore with twrp. I'll be testing new rom with your gapps tonight. Will edit here with the result.

Thank you.
You might want to download the file again if you already did. ;)

Android force close in Latest update of NOS. I used NikGapps-stock-arm64-9-20190415
Fixed that, was a small derp.
Download NikGapps-stock-arm64-9-20190415 and let me know if it works for you
 
  • Like
Reactions: Daruwalla

Nikhil

Senior Member
Sep 26, 2012
1,345
2,226
153
Ahmedabad

anvesh583

Senior Member
Jul 5, 2015
96
20
0
@Nikhil I am using microg without any gapps. So irface unlock not working. What gapps are required for working face unlock on microg? It would be really helpful if you could make a custom build for irface unlock for microg.
 

Nikhil

Senior Member
Sep 26, 2012
1,345
2,226
153
Ahmedabad
@Nikhil I am using microg without any gapps. So irface unlock not working. What gapps are required for working face unlock on microg? It would be really helpful if you could make a custom build for irface unlock for microg.
Can you ping me on telegram! @iNikhilMenghani, I'll try to create migrog package with your help. I'll share the face unlock files and libs there.

Everything is fine in los16 official, thank you
Thanks for reporting!

I get always the massage that my Device is not compatible with the phone app, but the app works....
Yeah, it's not officially compatible with our device however it works since it's just another app. I may spend some time after it if it bothers a lot of people. Build.prop change should somehow fix the issue.
 
  • Like
Reactions: _HUGO_
May 17, 2015
26
2
0
havoc + Nik Gapps ---- :(
facing the following issues as of now
1. "couldn't restore backup" from google account after signing in.

2. google dialler showing "this device isn't supported and phone calls may not work correctly"
 
Last edited:

Mafioso

Senior Member
Nov 13, 2007
1,059
122
93
Pune
I got below error with fresh install of RR ROM on first boot with basic package.

Code:
time: 1555524653665
msg: java.lang.NoSuchFieldError: No static field UUID_PRIVATE_INTERNAL of type Ljava/lang/String; in class Landroid/os/storage/StorageManager; or its superclasses (declaration of 'android.os.storage.StorageManager' appears in /system/framework/framework.jar!classes2.dex)
stacktrace: java.lang.NoSuchFieldError: No static field UUID_PRIVATE_INTERNAL of type Ljava/lang/String; in class Landroid/os/storage/StorageManager; or its superclasses (declaration of 'android.os.storage.StorageManager' appears in /system/framework/framework.jar!classes2.dex)
	at android.ext.services.storage.CacheQuotaServiceImpl.getReservedCacheSize(CacheQuotaServiceImpl.java:124)
	at android.ext.services.storage.CacheQuotaServiceImpl.lambda$onComputeCacheQuotaHints$3(CacheQuotaServiceImpl.java:90)
	at android.ext.services.storage.-$$Lambda$CacheQuotaServiceImpl$Zxx38GzcxY8KWXA1odhi6pQPchE.accept(Unknown Source:6)
	at java.lang.Iterable.forEach(Iterable.java:76)
	at android.ext.services.storage.CacheQuotaServiceImpl.onComputeCacheQuotaHints(CacheQuotaServiceImpl.java:55)
	at android.app.usage.CacheQuotaService$ServiceHandler.handleMessage(CacheQuotaService.java:100)
	at android.os.Handler.dispatchMessage(Handler.java:106)
	at android.os.Looper.loop(Looper.java:193)
	at android.app.ActivityThread.main(ActivityThread.java:6723)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:495)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:858)
Although it came only once, after signing into play store haven't encountered yet. Vanced YouTube and gcm are also working fine so not complaining.
BTW is there any way to detatch YouTube app from play store so it doesn't show in updates?
 

Nikhil

Senior Member
Sep 26, 2012
1,345
2,226
153
Ahmedabad
havoc + Nik Gapps ---- :(
facing the following issues as of now
1. "couldn't restore backup" from google account after signing in.

2. google dialler showing "this device isn't supported and phone calls may not work correctly"
1. Works fine for me, did you try that again or with a different ROM?
2. Yeah, it's because of pocophone being the device model, will check later.

How to update VancedYT?
Is there any update? I think we're on latest! I'll provide an update once the app gets updated.

I got below error with fresh install of RR ROM on first boot with basic package.



Although it came only once, after signing into play store haven't encountered yet. Vanced YouTube and gcm are also working fine so not complaining.
BTW is there any way to detatch YouTube app from play store so it doesn't show in updates?
Unfortunately no. :( I'll try to achieve that though!
 
Last edited:

mendax99

Senior Member
Nov 21, 2017
155
28
0
Yes, I don't see why it wouldn't work.



those are built from pixel experience ROM so......
pixel experience rom is an AOSP caf rom
and to my knowledge it uses aosp gapps
could you please make a pixel gapps version
which utilizes gapps directly extracted from pixel
and are a little different than stock aosp gapps