Was this thread helpful?


  • Total voters
    2,092
Search This thread
Apr 30, 2019
6
0
POCO M3
I don`t know exactly for your model, and being a spreadtrum device, doing it unnoficially would be risky. If the OEM allows the bootloader being unlockable, then you should try with the generic commands.
I appreciate your response, I have tried the fastboot method but it gives a response that bootloader can't be remotely unlocked, no information regarding how to root it on the internet, the phone is blackview oscal c20 pro
 

SubwayChamp

Senior Member
Aug 6, 2016
4,204
4
1,670
I appreciate your response, I have tried the fastboot method but it gives a response that bootloader can't be remotely unlocked, no information regarding how to root it on the internet, the phone is blackview oscal c20 pro
If the vendor doesn't allow unlock the bootloader you can't, unfortunately it's a device not so popular, and the processor being Unisoc, difficults an unauthorized procedure as they're not many tools available to try with. About root it, is not recommendable to root a device it's bootloader can't be unlocked, and this is in the theory the device can, a thing that I don't think, unfortunately. Anyway, said this, keep trying with all the fastboot commands you can find, to fully fulfill the first mandatory step.
 
  • Like
Reactions: Degreatstephen
Apr 30, 2019
6
0
POCO M3
If the vendor doesn't allow unlock the bootloader you can't, unfortunately it's a device not so popular, and the processor being Unisoc, difficults an unauthorized procedure as they're not many tools available to try with. About root it, is not recommendable to root a device it's bootloader can't be unlocked, and this is in the theory the device can, a thing that I don't think, unfortunately. Anyway, said this, keep trying with all the fastboot commands you can find, to fully fulfill the first mandatory step.
Okay, thanks
 

Woolicorn

New member
Dec 25, 2020
3
0
Unfortunately I need back the ability to make in-app purchases through google (I lived happily with lineageOS+microG for the last few years), but I want to keep google apps to the absolute minimum that is necessary. How do I do that? I have no idea what I'm doing on a technical level, I just blindly follow tutorials.
I tried to install "lineage for microG" (https://download.lineage.microg.org/FP3/) and openGapps pico on top of that, but I just got an error that the android version is not compatible.
I have a Fairphone 3
Any help is much appreciated!
 

Hamza67

Member
Mar 14, 2022
10
0
Unfortunately I need back the ability to make in-app purchases through google (I lived happily with lineageOS+microG for the last few years), but I want to keep google apps to the absolute minimum that is necessary. How do I do that? I have no idea what I'm doing on a technical level, I just blindly follow tutorials.
I tried to install "lineage for microG" (https://download.lineage.microg.org/FP3/) and openGapps pico on top of that, but I just got an error that the android version is not compatible.
I have a Fairphone 3
Any help is much appreciated!
You have downloaded the wrong Gapps package ~
 

SubwayChamp

Senior Member
Aug 6, 2016
4,204
4
1,670
Unfortunately I need back the ability to make in-app purchases through google (I lived happily with lineageOS+microG for the last few years), but I want to keep google apps to the absolute minimum that is necessary. How do I do that? I have no idea what I'm doing on a technical level, I just blindly follow tutorials.
I tried to install "lineage for microG" (https://download.lineage.microg.org/FP3/) and openGapps pico on top of that, but I just got an error that the android version is not compatible.
I have a Fairphone 3
Any help is much appreciated!
LOS 18.1 it`s based on Android 11, and LOS 19.1 it`s based in Android 12, so if it is related to the Android version, you just need to download the right version for you.

Anyway, did you check if these ROMs, like the name suggest, don`t come with Google apps included, if it is the case, won`t be a good idea, flashing a version of Google apps, on the top of a different version. It could be the case too, that these ROMs version, don`t include google apps, but, it is recommended to flash only microG, on the top of them. Just guessing because the name given to the files.
 

Droidriven

Senior Member
Jan 27, 2014
15,784
11
5,460
NC
Verizon Samsung Galaxy S III
HTC Thunderbolt
Unfortunately I need back the ability to make in-app purchases through google (I lived happily with lineageOS+microG for the last few years), but I want to keep google apps to the absolute minimum that is necessary. How do I do that? I have no idea what I'm doing on a technical level, I just blindly follow tutorials.
I tried to install "lineage for microG" (https://download.lineage.microg.org/FP3/) and openGapps pico on top of that, but I just got an error that the android version is not compatible.
I have a Fairphone 3
Any help is much appreciated!
Go to opengapps page and download a nano or pico gapps package for your android version.
 

foxy9999

New member
Jul 19, 2021
4
0
Hello android devs,
I'm asking if someone can help me to downgrade some app's android version ? to be honest Its pubg mobile "appgallery version (huawei) I want to downgrade it to android version 7+ the app require android 11, why huawei version not google play, cuz there is some personal purpose if you want to help and want to know sure I'll tell you why :D
notice: I have tried some apk editors apps but everytime there are some errors appears
 

LloydEwing

Member
Sep 17, 2022
5
0
Austin Texas USA
I need information on how to buy a good aftermarket battery.

I had expected to find a Guide or a Tutorial or at least a forum discussion, but I did not find anything on XDA-Developers or with internet search. My phones are older models, and I see lots of aftermarket brands on Amazon. I have tried eBay and found that those "new" battteries have been salvaged from used phones.

Is there a seller that can be trusted for good, new, non-OEM replacement batteries? Thanks very much for your help!
 

mrrocketdog

Senior Member
Oct 27, 2013
4,957
2,314
good morning , evening , night ; when someone has time , i have a htc one M9 att , Android7 , twrp , superSu , super cid , s-off , firmware official , RR-N-v5.8.0-20170106 , v.main 4.30.617.12 , v.bootloader 1.0.0 , mid OPJA1100 ;
and i cannot get a data (att) connection.
tried adding att apns in settings/data/apns
without luck. added apns and hit "save" even though there is the message when opening the apns , "this user has no access to apn settings.
in /system/etc i found file = "apns-conf.xml" which shows me virizon , t-mobile ; all but ATT.
could someone/anyone post an ATT apns-conf.xml file?
if that would even work.
or perhaps there is something in the secret dialer codes i need to edit?
 
Last edited:

RRosh

Member
Oct 28, 2015
14
0
Why does the MatLog app command for permission give this error? It's the code given by the app. I'm on Project Elixir 2.1 on Poco X3 Pro (vayu) which has random restart errors. I want to find out why. (Please ignore the first error, I made an unnecessary space in the beginning)

Also, there is no option to ask a new question. That's why I'm posting here.

Untitled.jpg
 

DiamondJohn

Recognized Contributor
Aug 31, 2013
6,503
6,476
Sydney
Why does the MatLog app command for permission give this error? It's the code given by the app. I'm on Project Elixir 2.1 on Poco X3 Pro (vayu) which has random restart errors. I want to find out why. (Please ignore the first error, I made an unnecessary space in the beginning)

Also, there is no option to ask a new question. That's why I'm posting here.

...snip...
I* do0nt know the details of what you are trying to achieve, but wha5t I* d0 see is that you are mixing fastboot with adb. They are not the same.

Normally when I use ADB, I first have to connect to the device before I issue commands.
 

RRosh

Member
Oct 28, 2015
14
0
I* do0nt know the details of what you are trying to achieve, but wha5t I* d0 see is that you are mixing fastboot with adb. They are not the same.

Normally when I use ADB, I first have to connect to the device before I issue commands.

Thanks for the reply..

I want to report a bug in the rom I've installed. For that, I need system logs. I'm trying to get it. And the app (recommended by the rom author) for it requires this specific permission.

Screenshot_20220922-063256_MatLog~01.png
 

DiamondJohn

Recognized Contributor
Aug 31, 2013
6,503
6,476
Sydney
Thanks for the reply..

I want to report a bug in the rom I've installed. For that, I need system logs. I'm trying to get it. And the app (recommended by the rom author) for it requires this specific permission.

..snip...
again, the details aren't for me.

Have you tried running adb devices before you issue the ADB command? As I said, I n0ortmally issue an adb connect before I issue ADB commands.

OS: You do not need to insert the full image, a thumbnail will suffice.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I'm slightly concerned that one day i may totally kill my screen.
    It's best to be prepared. Definitely make sure that you have ADB enabled.
    It's best to keep ro.adb.secure=1 so at least you have a popup dialog if you plug it into something rogue.
    Not that it's quick or great but it will work with any stock device without additional software:
    http://www.temblast.com/adbgrab.htm
    Check if your device actually works with USB Type C alt modes.
    Get an adapter that has a USB 2.0 Type A and check and see if a keyboard/mouse on it works while doing HDMI.
  • 301
    Hello guys..:)
    I would like you to go through XDA new users guide and you must read the FORUM RULES before posting here or anywhere else on xda.

    The rate at which the new users are joining xda on daily basis is very high. A lot of users join because they have got some problems with their devices like bricked phone, bootloops etc. because of following incorrect processes. Some join to help out others, to share their knowledge and gain more.

    So basically this thread is for all of those who want to ask questions and answer those.


    So those who want to help here, just try to answer without flaming, let it be answered thousands of times earlier, show them the path, direction and let them do things on their own. Do not spoon feed, rather just try to point them to right direction.

    This whole idea is of @undercover and the former OP Bruce Wayne and I thank him.

    To The people asking questions here, don't forget to check for the links from 2nd post. That will help you increase your knowledge, and do answer the questions asked by others if you know the answer. Please don't simply say thanks if some member helps you, instead use the thanks button, that will help us keep this thread less cluttered.
    79
    [Ask Any Question] [Help Thread] NOOB FRIENDLY

    Here are the names of some of my friends helping you on the thread.(Updated often)
    @iamareebjamal
    @Zatta
    @dagger (the original OP of this thread)
    @Stryke_the_Orc
    @prototype-U
    @EatHeat
    @nlygamz
    @plegdroid
    @Gogeta
    @malybru
    @Jimlarck
    @ADDICT.ANK
    @Primokorn
    @luqman98
    @hnkotnis
    @thenookieforlife3
    @ИΘΘK¡€
    @Sam Nakamura
    @xunholyx

    @SubwayChamp

    @ktmom

    @Ibuprophen

    Please do let me know if I have missed some names..:)
    49
    [Ask Any Question] [Help Thread] NOOB FRIENDLY

    For a list of guides,refer here.
    http://forum.xda-developers.com/showthread.php?t=2073370
    Thanks to @Hpsgill
    25
    [Ask Any Question] [Help Thread] NOOB FRIENDLY

    Atlast

    Please dont spam the thread..​
    19
    Hi mate!
    Nice to see a much needed thread like this here.. hope new members as well as old ones find this thread useful! :thumbup:

    "To err is human, to forgive is divine"
    Sent from my SGS II