Was this thread helpful?


  • Total voters
    2,096
Search This thread

yeyaaa

Member
Oct 23, 2022
7
0
Hi guys.
I have a cubot x19. I used the remove telephony subsystem option in one of the custom roms's settings menu.
I cannot make calls but i have messages and 4g internet.
I tried to install a new rom but its the same problem with them.
I only have a TWRP backup from this state sadly.
I tried flashing the stock fimware but after flashing it works but without any service. I see my imei in the settings but it might be some problem relating to that.

The remove telephony subsystem code is on github. Maybe we could reverse engineer that. I can make root so no problem just help me.

I have a twrp full backup from the reinstalled service not working stock rom.
and the custom rom with working service but no calls.

I tried mixing these two backups in twrp restore. I got the stock rom running with service but no calls just like the custom. I was mixing the nvdata of the two roms maybe.
I have many backup partitions. I can upload them if it helps. But i think a root explorer solution might be what we need.

Thanks for anyone who helps me.
I wish a pleasant day to everyone reading this.
 

Tubeczka

Member
Sep 23, 2022
11
0
hello, I have a problem with this question:


How I can get time, add few second get time second time and compare this?
 

SubwayChamp

Senior Member
Aug 6, 2016
4,330
4
1,701

SubwayChamp

Senior Member
Aug 6, 2016
4,330
4
1,701
Hi guys.
I have a cubot x19. I used the remove telephony subsystem option in one of the custom roms's settings menu.
I cannot make calls but i have messages and 4g internet.
I tried to install a new rom but its the same problem with them.
I only have a TWRP backup from this state sadly.
I tried flashing the stock fimware but after flashing it works but without any service. I see my imei in the settings but it might be some problem relating to that.

The remove telephony subsystem code is on github. Maybe we could reverse engineer that. I can make root so no problem just help me.

I have a twrp full backup from the reinstalled service not working stock rom.
and the custom rom with working service but no calls.

I tried mixing these two backups in twrp restore. I got the stock rom running with service but no calls just like the custom. I was mixing the nvdata of the two roms maybe.
I have many backup partitions. I can upload them if it helps. But i think a root explorer solution might be what we need.

Thanks for anyone who helps me.
I wish a pleasant day to everyone reading this.
Not sure what you meant with "telephony subsystem", so I don't see the advantages for that.

Actually your device still have IMEIs? And what about baseband?
 
Nov 4, 2022
5
1

DiamondJohn

Recognized Contributor
Aug 31, 2013
6,510
6,486
Sydney
hello, I have a problem with this question:


How I can get time, add few second get time second time and compare this?
There are so many "style" differences between your code and what I would try. And to be clear, that does not mean your code is wrong, just not the way I would go about it. Just re-typing over what you appear to be trying. Just noticed, you also have a typo of your "if" clause ending with "if" instead of "fi;"
Code:
#!/system/bin/sh

let timetoclose=300; # how long to loop for, 5 min=5*60
let SECONDS=0; # only accurate to a whole second
let end_early=0; # set to 1 to exit loop early
let timenow=0;

let loop_count=0;
let loop_count_max=5000;

while [ $timetoclose -ge $timenow ]
    do
        # if some condition is met,
        # let end_early=1
  
        if [ $end_early -eq 1 ]; then
            echo "End Early exit...";
            break;
        else
            sleep 1.2;
            let timenow=$SECONDS;
            echo "do_something($timenow)";
        fi;
        if [ $loop_count -gt $loop_count_max ]; then
            echo "Loop count exit ($loop_count > loop_count_max )...";
            break;
        else
            let loop_count=loop_count+1;
        fi;
    done;

echo "Loop finished in $loop_count loop(s), after $SECONDS seconds ( $timetoclose < $timenow ).";

exit 0;
1.2 seconds seems random for a wait. And my code removes the complexity of handling any accuracy above whole seconds. I also put a safety of 5000 max loops, just in case something goes unexpectadly wrong.

I have example code that goes down to the millisecond in the app in my signature.
 

SubwayChamp

Senior Member
Aug 6, 2016
4,330
4
1,701
via fastboot, i tried to do this INFINIX NOTE 10 PRO (X695/X695C/X695D) UBL, TWRP 3.6.1 & ROOT | XDA Forums
as i want to remove bloatwares


for the firmware i actually tried to flash all of those firmware but stuck at "Downloading DA 100%" in SP Flash Tool
I don´t see the issue with that guide, it looks fine. Anyway, you also have this tool to flash the firmware https://www.google.com/url?sa=t&rct...er/mtkclient&usg=AOvVaw1EA0UgBcE8bbeVuiVn4L7c
 
Nov 4, 2022
5
1
After flashing the TWRP im stuck in bootloop, i forgot to backup my original boot.img so i cant reflash it back, i tried factory reset and wipe dalvik after reflashing TWRP still no luck, so that i resort to flashing original firmware even its lower version (which is the version available online), i use SP Flash Tool to flash with + MTKMETAUtility to bypass auth, but cant pass the "Downloading DA 100%".


btw, whats with MTKClient? it seems like just like fastboot in cmd? or i just gonna use the "Bypass SLA, DAA and SBC (using generic_patcher_payload)" part then proceed to SP Flash tool?
 
Nov 4, 2022
5
1
Can anyone help me?
I cant gix my phone stuck in boot loop after install TWRP,
my phone is Infinix Note 10 Pro (X695D),
cant flash it via SP Flash tool (stuck at Downloading DA 100%)
i cant find latest stockrom for my phone so im stuck on trying to flash it with old rom (1 year old rom)
This is fixed now!
maybe SPFlashtool.com is not that updated?
after using the SP Flash Tool for this link: Question - sp flash tool stuck at download da 100% and get this error how to fix? | XDA Forums

i works like a charm!

Thanks you everyone helps me ^^
 
  • Like
Reactions: SubwayChamp
Jun 26, 2006
43
3
I have a question.. i'm slightly concerned that one day i may totally kill my screen. I was thinking if so it would be cool if the device could still be used for a car computer using the usb-c port out with an hdmi adapter.. and BT keyboard or something like that.. or even a streaming box in purpose..

I'm thinking that there could be a way to pre-emptively have my phone able to be controlled by the port.. would that be enable USB or adb whatever debugging in developer mode? Maybe then what use some kind of shell access or something and could install something like team viewer or something?
 

SubwayChamp

Senior Member
Aug 6, 2016
4,330
4
1,701
idk what baseband is. i can send sms and i have mobile network.

here is what i mean under telephony subsystem https://github.com/phhusson/device_phh_treble/blob/android-11.0/remove-telephony.sh
Well, trying to learn what is baseband may help to solve your issue, no?

I don't see anything serious on that guide, nothing that can't be solved reinstalling the teleservice app or placing it in the same directory, where it was pulled out https://dumps.tadiphone.dev/dumps/g...m/system/priv-app/TeleService/TeleService.apk

Also, doing previous formatting and wipes, and reinstalling the stock ROM, with a tool, can solve it.
 

Renate

Recognized Contributor / Inactive Recognized Dev
I'm slightly concerned that one day i may totally kill my screen.
It's best to be prepared. Definitely make sure that you have ADB enabled.
It's best to keep ro.adb.secure=1 so at least you have a popup dialog if you plug it into something rogue.
Not that it's quick or great but it will work with any stock device without additional software:
http://www.temblast.com/adbgrab.htm
Check if your device actually works with USB Type C alt modes.
Get an adapter that has a USB 2.0 Type A and check and see if a keyboard/mouse on it works while doing HDMI.
 
  • Like
Reactions: dannysportbike

yeyaaa

Member
Oct 23, 2022
7
0
Well, trying to learn what is baseband may help to solve your issue, no?

I don't see anything serious on that guide, nothing that can't be solved reinstalling the teleservice app or placing it in the same directory, where it was pulled out https://dumps.tadiphone.dev/dumps/g...m/system/priv-app/TeleService/TeleService.apk

Also, doing previous formatting and wipes, and reinstalling the stock ROM, with a tool, can solve it.
thank you for the teleservice app i will put it into /system/priv-app/TeleService

i tried flashing the 8.1 stockrom and the 9 stockrom with spflashtool. but after flashing there was no signal no service.

only if i restore this previous customrom backup i have sms and 4g internet. if i flash over that backup other custom roms i still dont have calling.

imma try this thx. will wwrite about whether its good or not.
 

yeyaaa

Member
Oct 23, 2022
7
0
Well, trying to learn what is baseband may help to solve your issue, no?

I don't see anything serious on that guide, nothing that can't be solved reinstalling the teleservice app or placing it in the same directory, where it was pulled out https://dumps.tadiphone.dev/dumps/g...m/system/priv-app/TeleService/TeleService.apk

Also, doing previous formatting and wipes, and reinstalling the stock ROM, with a tool, can solve it.
i already had a teleservice apk in that folder but i replaced it with the one you sent. but nope. 😢

if its a baseband problem how can i solve it?

if i flash stock rom from sp flashtool i dont have service.
but could i flash only the baseband? if there is such a thing possible. help me 🥺

i can see my imei and i can send sms and i have internet so its not imei problem i think.

i just replaced teleservice and rebooted. all permissions are rw on that file but do i need to do something more maybe?

flashing other custom roms doesnt help as well.
 

SubwayChamp

Senior Member
Aug 6, 2016
4,330
4
1,701
i already had a teleservice apk in that folder but i replaced it with the one you sent. but nope. 😢

if its a baseband problem how can i solve it?

if i flash stock rom from sp flashtool i dont have service.
but could i flash only the baseband? if there is such a thing possible. help me 🥺

i can see my imei and i can send sms and i have internet so its not imei problem i think.

i just replaced teleservice and rebooted. all permissions are rw on that file but do i need to do something more maybe?

flashing other custom roms doesnt help as well.
First off, baseband status can be found in Settings/About device/All specs (or a similar directory)

Usually, flashing a stock ROM have to fix the issue.

Flashing the latest version have to fix the baseband issue too.

Anyway, that said, it's also probable that some partitions didn't flash it, so, some of them are not allowed or simply not performed from SPFT.
Check the scatter.txt, and see, depending on your motherboard, the scatter text contains two cycles of flashing for every partition, because of eMMC or LPDDR4, check which partitions says "download=false" and change it for "true", usually, I don't know exactly your device, but for baseband matters, nvdata, nvcfg, cfg, nvram, modem1, modem2 (some of them may or may not exist in your firmware).
Again, a simple update has to fix the baseband issue, not the same with IMEI.
And never, format data or use other option in SPFT, that Download.
 

yeyaaa

Member
Oct 23, 2022
7
0
First off, baseband status can be found in Settings/About device/All specs (or a similar directory)

Usually, flashing a stock ROM have to fix the issue.

Flashing the latest version have to fix the baseband issue too.

Anyway, that said, it's also probable that some partitions didn't flash it, so, some of them are not allowed or simply not performed from SPFT.
Check the scatter.txt, and see, depending on your motherboard, the scatter text contains two cycles of flashing for every partition, because of eMMC or LPDDR4, check which partitions says "download=false" and change it for "true", usually, I don't know exactly your device, but for baseband matters, nvdata, nvcfg, cfg, nvram, modem1, modem2 (some of them may or may not exist in your firmware).
Again, a simple update has to fix the baseband issue, not the same with IMEI.
And never, format data or use other option in SPFT, that Download.
thanks. i will check the scatter file when is get home.

after i flash the newest stock rom i dont have service. i fixed that problem by restoring nvdata from the previous custom roms twrp backup. but then i still dont have calling.

how can i fix imei on stock rom without messing up baseband?
 
Last edited by a moderator:

SubwayChamp

Senior Member
Aug 6, 2016
4,330
4
1,701
thanks. i will check the scatter file when is get home.

after i flash the newest stock rom i dont have service. i fixed that problem by restoring nvdata from the previous custom roms twrp backup. but then i still dont have calling.

how can i fix imei on stock rom without messing up baseband?
Don´t remember if I provided this tool link https://www.google.com/url?sa=t&rct...er/mtkclient&usg=AOvVaw1EA0UgBcE8bbeVuiVn4L7c with it you can make some backups, flashings and more.

You said your IMEI was OK, so? Recovering IMEI is, actually, for newer MediaTek devices, in last round of updates, virtually impossible, by normal means or using regular software. This is just an assumption but, it seems, it depends or relies on other partition to have a proper permission to be overwritten or rather rewrite.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi everybody!
    I'd like to root an unbranded China tablet and replace Android with some Linux distro, like Ubuntu Touch, but I'm a total newbie and I don't know where to start from.
    Here is what I see in the settings:

    View attachment 5798989

    Any help would be highly appreciated!
    You don´t need to root the device, in order to put a different ROM, instead, you need to unlock the bootloader. Anyway, From what I know you should need, an Ubuntu Touch ported for your device, the list of devices supported is not extensive, and at least you think to build it for your device, I don´t hink your device is in the list, anyway, you can see the official site, to ckeck it yourself https://ubports.com/nl/supported-products?pk_vid=a6767500f5634ae2167262928843d322
    1
    Hi, thank you for replying. Unfortunately, my device is not listed since it's unbranded. It's still not clear to me how to build and port it for a generic device, when the only information I could retrieve is that it's based on Android 8.
    How can I find the required rom version for a generic Android device from some unknown Chinese manufacturer?
    I don't think is because it's "unbranded", also many "branded" devices are not supported, the official UBports is most likely abandoned?, or if you prefer; "not growing", although some devices had some development in the past, just because of personal initiatives from developers/enthusiasts, I used it in my MiA3, RN7, but I saw, that also these, are abandoned. Also, from what I know, devices not specifically developed for them, should need a custom ROM as a base, i.e. LineageOS.

    If you want to know more from your device, you can get more information using an app like Device Specs, or others, try to know if your device can support Treble, I don't think but, just to be sure, install and run an app like treble support, if your device can support it, you, at least, are able to run a GSI, if not, then you are out of luck.
    1
    Hello all, I'm having a bit of an issue. I am currently working with a Trio Stealth G4 10.1 v2. It is currently rooted via kingo root (double checked the root via a separate checker), and I am in the process of trying to install TWRP. It is running KitKat 4.4.2, and I am not able to have the device show up on my computer. I initially attempted to flash TWRP with the recommended app Flashify for root users, but that app seems to not be operational anymore. At that point i discovered the TWRP manager made by Team Win, the same people who make TWRP, which at the very least lets me navigate and initiate a stock recovery back up. This is where the problems begin.

    The tablet is freshly factory reset, and only has ~1GB of files total on internal storage. Despite this, when I begin to back up, the img file being created is several times the size. I initially tried to save it to an 8GB microSD inserted in the device, and it gave me a 2GB file before returning to the manager's main screen. Not being able to find any reference for what size this file should be, I moved the img to my computer and inserted a different, 32GB, microSD. I initiated another recovery, and now i have a 4GB img file and TWRP manager gives me a screen saying the back up failed. how can I tell if either of these recovery images are functional or corrupted? do I need to put the img files into an emulator like Bluestacks or in VirtualBox? does this mean I cant flash a custom recovery image? I'm trying to push this tablet past KitKat if I can, and I seem to have gotten a bit farther than others I've seen on forums with this tablet. any help is appreciated and desperately needed.
    The stock recovery backup just backs up your stock recovery to be used in case something goes wrong when flashing your custom recovery via TWRP Manager. You could just as easily download a copy of your stock firmware and extract the stock recovery from the firmware, this ensures you have an uncorrupted copy of your stock recovery.img. If you extract a copy from your stock firmware, you can skip the stock recovery backup step in TWRP Manager and just flash your TWRP.img if you have one.

    If TWRP Manager fails to flash your TWRP recovery.img, you could use a Terminal Emulator app to flash the TWRP.img via dd commands but you would have to use some technical methods to identify exactly which mmcblk0(partition) location is the recovery partition on your device then use that address in the dd command to flash the TWRP.img to your recovery partition. You have to be certain you are using the correct dd command with exactly the correct mmcblk0 address, if you get any part of the syntax, characters or spacing wrong, you absolutely WILL brick the device.
    1
    Alright, that definitely seems like a method. how do I go about extracting the recovery image directly from the firmware? I cannot get the device to be detected by my computer and updated drivers for this device are non-existent as the parent comapany who made these devices went bust in 2019, and there's nowhere to source drivers the tablet detects (but i did find a driver windows installed automatically the first time i connected the tablet to my PC, though this is a generic driver that claims to be the latest version). I have a MicroSD that is double the storage of the entire tablet currently in it, is there a way to copy it to the SD manually, like what TWRP manager is trying to do, without my PC? thank you for your help, its greatly appreciated!

    Edited to put the quoted post in my reply
    Three ways.

    1) if your PC has a card reader you can use a micro SD card to transfer between phone and device

    2) you can use a USB pen driive with an adapter to convert USB to Micro USB or USB C to transfer between device and PC

    3) you can use a mobile browser on the device to download the firmware and then use an app like Zarchiver from the PlayStore to extract the recovery.img from the firmware.
    1
    I recently tried the dumb move of updating Magisk through the app itself. When rebooted it got stuck on bootloop, I then booted to Orangefox on my Redmi K20 Pro. I then did resetting to defaults in settings which showed 2 errors- Unable to mount system root and vendor(invalid arguement something like that) which resulted in my data being encrypted. When I tried to reboot it said no OS installed. I didn't know what to do so I watched a youtube video instructing to wipe data and rebooting to recovery to fix this(encrypion) and so i did another dumb move of doing it which resulted in my device getting rid of Orangefox then, and now I am stuck on either boot loop with no recovery or in fastboot mode which isn't really doing much since it's not being recognised by my pc. I am not much of a knower in this side but I knew some of the basics and followed instructions to install recovery and root and now have managed to break it. And now I'm panicking. SOMEONE HELP!!
    Repeat the method you did, to boot to TWRP, and, I guess, then flash it to the ramdisk partition, to permanently have it.
    About the PC not recognizing your device, just update the drivers when your device is in fastboot mode, you should see under device manager, something like "bootloader interface".
  • 301
    Hello guys..:)
    I would like you to go through XDA new users guide and you must read the FORUM RULES before posting here or anywhere else on xda.

    The rate at which the new users are joining xda on daily basis is very high. A lot of users join because they have got some problems with their devices like bricked phone, bootloops etc. because of following incorrect processes. Some join to help out others, to share their knowledge and gain more.

    So basically this thread is for all of those who want to ask questions and answer those.


    So those who want to help here, just try to answer without flaming, let it be answered thousands of times earlier, show them the path, direction and let them do things on their own. Do not spoon feed, rather just try to point them to right direction.

    This whole idea is of @undercover and the former OP Bruce Wayne and I thank him.

    To The people asking questions here, don't forget to check for the links from 2nd post. That will help you increase your knowledge, and do answer the questions asked by others if you know the answer. Please don't simply say thanks if some member helps you, instead use the thanks button, that will help us keep this thread less cluttered.
    79
    [Ask Any Question] [Help Thread] NOOB FRIENDLY

    Here are the names of some of my friends helping you on the thread.(Updated often)
    @iamareebjamal
    @Zatta
    @dagger (the original OP of this thread)
    @Stryke_the_Orc
    @prototype-U
    @EatHeat
    @nlygamz
    @plegdroid
    @Gogeta
    @malybru
    @Jimlarck
    @ADDICT.ANK
    @Primokorn
    @luqman98
    @hnkotnis
    @thenookieforlife3
    @ИΘΘK¡€
    @Sam Nakamura
    @xunholyx

    @SubwayChamp

    @ktmom

    @Ibuprophen

    Please do let me know if I have missed some names..:)
    49
    [Ask Any Question] [Help Thread] NOOB FRIENDLY

    For a list of guides,refer here.
    http://forum.xda-developers.com/showthread.php?t=2073370
    Thanks to @Hpsgill
    25
    [Ask Any Question] [Help Thread] NOOB FRIENDLY

    Atlast

    Please dont spam the thread..​
    19
    Hi mate!
    Nice to see a much needed thread like this here.. hope new members as well as old ones find this thread useful! :thumbup:

    "To err is human, to forgive is divine"
    Sent from my SGS II