• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

assert failed: oppo.verify_trustzone("TZ.BF.4.0.1-81399") == "1"

Search This thread

ZaGaZ8

Member
Aug 26, 2016
8
3
Hi and sorry for the potential newb post :confused:

Been using CM / Lineage for years and never come across an individual firmware upgrade requirement until now.
I am on Lineage nightly Feb 8th and cant go any further due to:

comparing tz version TZ.BF4.0.1-83199 to tz.bf.4.0.1-76917
assert failed: oppo.verify_trustzone("TZ.BF.4.0.1-81399") == "1"
updater process ended with ERROR: 7 error installing zip file


I have the working 1+3 TWRP installed so Is it possible to upgrade the firmware only?
Or do I have to wipe and install the latest OOS then go back to Lineage?

I downloaded OOS 41 and there is a firmware folder in there with a few bin / mbn files so kinda hoping I can somehow flash just the firmware and keep my build.

Appreciate any help....
Cheers
Gaz :D
 

Z-master

New member
Jan 22, 2011
1
0
Here is the latest firmware (4.0.3). Download firmware + modem and flash in TWRP before LineageOS.

Hey there, sorry to bug you guys. Unfortunately I'm noob so I can't comment on the main LOS thread, but I have an issue that hopefully someone can help with. Originally on CM14 nightlies, without any dramas, obviously with the change from CM on LOS I've flashed the experimental build, then the LOS nightly to get started, all went fine until the change to unified requiring the firmware update. I've installed 2nd March nightly (by editing the file to ignore the trustzone version) in case it was that, but no seems not.

I've flashed the latest FW as mentioned, and the Baseband version is M8996FAAAANAQM-1.85373.1.86546.1 so it appears I'm running definitely running the latest FW (and there were no errors on install) I then reboot to system, download the latest nightly and go to install - still getting the TZ.BF.4.0.1-83199 to TZ.BF.4.0.1-85373 error.... Have I missed a step somewhere? or is this blindingly obvious and I'm a muppet?

Any helps appreciated! cheers
 

devianity

New member
Mar 13, 2017
1
0
Same issue with the same parameters!

Hey there, sorry to bug you guys. Unfortunately I'm noob so I can't comment on the main LOS thread, but I have an issue that hopefully someone can help with. Originally on CM14 nightlies, without any dramas, obviously with the change from CM on LOS I've flashed the experimental build, then the LOS nightly to get started, all went fine until the change to unified requiring the firmware update. I've installed 2nd March nightly (by editing the file to ignore the trustzone version) in case it was that, but no seems not.

I've flashed the latest FW as mentioned, and the Baseband version is M8996FAAAANAQM-1.85373.1.86546.1 so it appears I'm running definitely running the latest FW (and there were no errors on install) I then reboot to system, download the latest nightly and go to install - still getting the TZ.BF.4.0.1-83199 to TZ.BF.4.0.1-85373 error.... Have I missed a step somewhere? or is this blindingly obvious and I'm a muppet?

Any helps appreciated! cheers

Hi, I have the exact same issue. I've flashed the firmware to 4.0.3 and successfully installed the nightly from 08/02/2017. Now when I try to flash the nightly from 09/03/2017 I get this issue again! This time nothing helps so far.
Please, if you find a solution - let me know!
 

ricksrod

Member
May 12, 2011
34
4

Top Liked Posts