• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Atoto S8 General Discussion

Search This thread

HellyHans

Member
Oct 6, 2021
9
7
Sorry if this is stupid question, but I couldn't find the answer in this topic.
Is it possible to automatically connect to Carplay? (Atoto S8 premium G2).
I think it requires the Carlink app to start when the unit starts, but I can't find an option to do so.

Also, Volume is extremely low when the Atoto reads a Whatsapp message through Carplay. Is there some hidden volume setting?
I don't have an iPhone, but I think it should connect automatically. In the menu, I think you can select Carlink as the Autostart App. I know it starts my AA automatically when I set that up.
 

jdarundell

New member
Jan 5, 2016
3
0
Hello and thank you for a really informative discussion on the ATOTO S8 headunit. I read the entire thread yesterday and learned a lot.

I am the new owner of an ATOTO S8 Ultra. I have had it installed in my 2011 Ford F350 for about 10 days. I have a love-hate relationship with the head unit. It could be amazing, but I’ve spent a ton of time over the last 10 days configuring it and still do not have it to a stage where I can know if I will keep it. But I am persevering.

The main reason I chose the ATOTO S8 headunit is because I want to run GPS navigation applications offline in situations where I do not have service. I was particularly impressed by the large high--resolution screen and the ability to have a 512GB SD card to store my offline maps.

However, I have had a terrible time getting the headunit to recognize an SD card.

I have tried two different SanDisk Extreme SD cards and neither worked. The first was a 512GB SD card formatted to NTFS on a Windows PC and a the other was a 64GB SD card formatted to FAT32 on a Samsung Android tablet. Neither worked in the ATOTO S8, but they work in other devices. The ATOTO S8 said the NTFS card was corrupted when I know it is not and it did not recognize the FAT32 card at all.

With the 512GB SD card, the HU said it was corrupted but at least it was showing in device storage. As I continue I get an option that says “Format as portable storage”. It seems to me I should not have to reformat the SD Card since I’ve already formatted it in Windows just a few minutes earlier. However, I went ahead and tried several times to use the ATOTO S8 Ultra to format the card, but it begins with formatting and crashes at 20% within a few seconds.

Has anyone else experienced this issue and do you have any advice for me?

Once I decide whether or not I will keep the unit I will do a detailed review to help others.
Did you resolve this? I have a brand new S8Gen2 which will not reconize sd card in the sd card slot but when I put the same card in a reader and hang it out of a USB -> no problems. Sensible (and funny) suggestions welcome.
 

Reechings

Senior Member
Jan 22, 2012
5,135
1,271
Did you resolve this? I have a brand new S8Gen2 which will not reconize sd card in the sd card slot but when I put the same card in a reader and hang it out of a USB -> no problems. Sensible (and funny) suggestions welcome.
I had an existing 200GB microSD that I had to reformat using the S8Gen2 and then it worked great. I then bought a 512GB microSD and it worked right away without reformatting. Both are SanDisk Ultra.
 

HellyHans

Member
Oct 6, 2021
9
7
Ok, I will update you guys a little as not much activity going on here.

I've been through all 22 pages here and pretty much ALL the issues people are reading about and having with the contacts getting deleted are with Gen 1 units. The Gen2 units don't have this issue. And couple of other issues with Auto restart apps etc have been fixed with Gen2.

Tethering:
Now, one thing I can't get to work on my phone is BT tethering... Seems my phone might not even have this feature enabled because when I connect to BT2, I get a "!" and my phone keeps disconnecting. (Samsung SM-A520W)
I tried USB tethering and that doesn't seem to work either. The only way I can tether my phones data with a USB cable is using EasyConnect App.
The only way I can tether wirelessly is by enabling a WiFi hotspot on my phone.

GPS:
I also noticed the GPS signal is VERY low even with the external antenna plugged in.
I've read in the manual that if you power on the unit for the first time WITHOUT the external antenna, it will use the internal GPS antenna EVEN if you plug the external one after.
I did this because when I installed the unit I didn't plug everything as I had to reroute the cables etc a couple of times. So the unit was turned on many times before I plugged the GPS antenna.
Atoto mentions the fix is to plug everything in and completely reboot/power cycle the unit.
I will try this and see if I get my GPS signal back.

Front/Rear camera :
For people asking if the unit records the back camera: It doesn't. I was a little fooled on this as the description of LRV let me believe that it can record the rear. But it's just a live cam when you go into the app or backing up. Maybe there is some App somewhere that can trigger the rear cam and record it.. I will search up on this.
The front cam app works well.. The version installed is newer than the APK provided on the units internal storage. So I might have to backup the one installed.

Radio app:
Another small irritant I found out was on the Radio App:
When you enable the RDS function, the lower tickerbar at the bottom that shows usually the radio stations now removes the numbers and puts the RDS info in that section which sux because you now have RDS info on the main section AND at the bottom so you don't see the radio station numbers anymore... I will see if Atoto has an update for this App. Here is a pic of an example.
You can see the bottom section has a mixed display of radio stations and RDS info.(13-16)

20211015_083409.jpg
 
Last edited:

deezp1

Member
Oct 10, 2009
16
3
Is there a way to view the Bluetooth metadata from my phone on a widget instead of using the Fullscreen Bluetooth app on the unit?
 

Gaugamela

Member
Feb 12, 2016
38
8
Ok, I will update you guys a little as not much activity going on here.

I've been through all 22 pages here and pretty much ALL the issues people are reading about and having with the contacts getting deleted are with Gen 1 units. The Gen2 units don't have this issue. And couple of other issues with Auto restart apps etc have been fixed with Gen2.

Tethering:
Now, one thing I can't get to work on my phone is BT tethering... Seems my phone might not even have this feature enabled because when I connect to BT2, I get a "!" and my phone keeps disconnecting. (Samsung SM-A520W)
I tried USB tethering and that doesn't seem to work either. The only way I can tether my phones data with a USB cable is using EasyConnect App.
The only way I can tether wirelessly is by enabling a WiFi hotspot on my phone.

GPS:
I also noticed the GPS signal is VERY low even with the external antenna plugged in.
I've read in the manual that if you power on the unit for the first time WITHOUT the external antenna, it will use the internal GPS antenna EVEN if you plug the external one after.
I did this because when I installed the unit I didn't plug everything as I had to reroute the cables etc a couple of times. So the unit was turned on many times before I plugged the GPS antenna.
Atoto mentions the fix is to plug everything in and completely reboot/power cycle the unit.
I will try this and see if I get my GPS signal back.

Front/Rear camera :
For people asking if the unit records the back camera: It doesn't. I was a little fooled on this as the description of LRV let me believe that it can record the rear. But it's just a live cam when you go into the app or backing up. Maybe there is some App somewhere that can trigger the rear cam and record it.. I will search up on this.
The front cam app works well.. The version installed is newer than the APK provided on the units internal storage. So I might have to backup the one installed.

Radio app:
Another small irritant I found out was on the Radio App:
When you enable the RDS function, the lower tickerbar at the bottom that shows usually the radio stations now removes the numbers and puts the RDS info in that section which sux because you now have RDS info on the main section AND at the bottom so you don't see the radio station numbers anymore... I will see if Atoto has an update for this App. Here is a pic of an example.
You can see the bottom section has a mixed display of radio stations and RDS info.(13-16)

I could also only get the tethering to work via Wifi hotspot. Via Bluetooth I could get it to pair and share data, but it never worked consistently. I just gave up and created a Tasker routine to enable the Wifi hotspot whenever my phone connected to Bluetooth 1.

My GPS sometimes is really slow getting signal. But it usually works. The radio app is a steaming pile of crap. I gave up on it and am now using an internet radio app since my country does not have DAB radio.
 

Sifimaso

Member
Jun 24, 2021
16
4
My problem with Atoto S8 Gen 2 is DRM Widevine coz I can’t use streaming apps my device is already Rooted google certified and passes safetynet but still I have the DRM issue
When I try using streaming apps
 

HellyHans

Member
Oct 6, 2021
9
7
My problem with Atoto S8 Gen 2 is DRM Widevine coz I can’t use streaming apps my device is already Rooted google certified and passes safetynet but still I have the DRM issue
When I try using streaming apps
never seen that issue. You can't stream from your phone to the S8? via BT? USB tethering? Wifi hotspot?
What apps?
 

Seskwein

New member
Oct 21, 2021
2
0
Hey new here, have been reading through the thread. I just ordered the s8 ultra plus gen 2.
Anyone know if the sub out will work with a pioneer pioneer gm-d8601 amp ?
And different amp on speakers for doors? (hertz DPower 4)
Complete car audio noob.

Also, was wondering if anyone has used the spdif?
And if how did you do it?
 
Last edited:

HellyHans

Member
Oct 6, 2021
9
7
Hey new here, have been reading through the thread. I just ordered the s8 ultra plus gen 2.
Anyone know if the sub out will work with a pioneer pioneer gm-d8601 amp ?
And different amp on speakers for doors? (hertz DPower 4)
Complete car audio noob.

Also, was wondering if anyone has used the spdif?
And if how did you do it?
what would you want to use the SPDIF for? It's pretty much obsolete in Car audio these days.
Also the preamp outputs are VERY low voltage, (0.5v or something) you need a preamp voltage amplifer to raise the signal
 
  • Like
Reactions: Seskwein

HellyHans

Member
Oct 6, 2021
9
7
Another update

Low bad GPS signal:
I fixed my low signal by placing the GPS antenna directly on the dash.
I had it fixed on my windshield before and since the antenna was pointing DOWN I had almost zero reception.. It's a stupid antenna because most other brands of GPS antenna's can be stuck on the windshield and the emitters/receptors point in the right direction (UP) This one is pretty much uni-directional. The sticky back is made to be on a dash/roof as the emitters/receptors are on the top part.
 
  • Like
Reactions: Ofergomez

Seskwein

New member
Oct 21, 2021
2
0
what would you want to use the SPDIF for? It's pretty much obsolete in Car audio these days.
Also the preamp outputs are VERY low voltage, (0.5v or something) you need a preamp voltage amplifer to raise the signal
I thought spdif would deliver better sound tbh. And eliminate any chance for noise. Like i said car audio noob.
I have been trying to google those, but do not really know what i am looking for. But thanks for the reply, I will ask dude who is hooking it up for me what it is lol
 

HellyHans

Member
Oct 6, 2021
9
7
Tethering update:

The best solution and app I found to enable wireless tethering is with MacroDroid. Plus the free version needs all I need and it has no ads, and the toggle ON/OFF is directly in the android quick launch on the phone.

It has MANY features with rules/exceptions/triggers/constraints etc..
I use it to enable my WiFi hotspot when the phone connects to the ATOTO BT. And when I turn the car off... it disables the hotspot because I have another rule to turn it off when the BT is terminated.

It works perfectly without me doing anything with my phone or radio.

 

Reechings

Senior Member
Jan 22, 2012
5,135
1,271
what would you want to use the SPDIF for? It's pretty much obsolete in Car audio these days.
Also the preamp outputs are VERY low voltage, (0.5v or something) you need a preamp voltage amplifer to raise the signal
I used a line booster for my sub output but front preout to my amp was more than strong enough. I'm not a competition level guy or anything though.
 
  • Like
Reactions: Seskwein

Sifimaso

Member
Jun 24, 2021
16
4
Hi my Atoto S8 Ultra Plus Gen2 is Rooted and i google certified it pass Safetynet as well
but still i can't use streaming apps like Netflix i get an error DRM failed to initialize or
device not supported please help thank you .
 

Attachments

  • eed96802-ca40-450a-89f0-14d91b18f6a3.jpg
    eed96802-ca40-450a-89f0-14d91b18f6a3.jpg
    55.7 KB · Views: 17
  • 7127f047-313b-48b2-931b-e9e9843ba28c.jpg
    7127f047-313b-48b2-931b-e9e9843ba28c.jpg
    54.4 KB · Views: 17
  • d38116f4-a812-4c58-9979-355c43c3a316.jpg
    d38116f4-a812-4c58-9979-355c43c3a316.jpg
    77.8 KB · Views: 17

Sifimaso

Member
Jun 24, 2021
16
4
I found out that Atoto was to lazy to pay for a widevine CDM license, so that's why we get black screens or playback errors. Unfortunately nothing we can do unless we root it, and install magisk and L1 module. Boycott Aoto
Hi my Atoto S8 Ultra Plus Gen2 is Rooted and i google certified it pass Safetynet as well
but still i can't use streaming apps like Netflix i get an error DRM failed to initialize or
device not supported please help thank you .
 

Attachments

  • d38116f4-a812-4c58-9979-355c43c3a316.jpg
    d38116f4-a812-4c58-9979-355c43c3a316.jpg
    77.8 KB · Views: 12
  • eed96802-ca40-450a-89f0-14d91b18f6a3.jpg
    eed96802-ca40-450a-89f0-14d91b18f6a3.jpg
    55.7 KB · Views: 12
  • 7127f047-313b-48b2-931b-e9e9843ba28c.jpg
    7127f047-313b-48b2-931b-e9e9843ba28c.jpg
    54.4 KB · Views: 12

Xarano

Member
Dec 6, 2017
25
5
Has anyone been able to get ADB working on the gen2? I've tried plugging in my laptop to the USB 1 device link connector, with USB debugging enabled on the head unit, but I'm not getting it to work.

Other mentions of ADB say you need to select option 2 from a list that isn't translated, but I'm not seeing anything like that
 

tmz83

Senior Member
Nov 1, 2011
134
14
Turin
Is there a way to autostart an app when when the S8 is switched on, without using any tasker app?
I tried with Agama but doesn't works.
 

tmz83

Senior Member
Nov 1, 2011
134
14
Turin
Has anyone been able to get ADB working on the gen2? I've tried plugging in my laptop to the USB 1 device link connector, with USB debugging enabled on the head unit, but I'm not getting it to work.

Other mentions of ADB say you need to select option 2 from a list that isn't translated, but I'm not seeing anything like that
I tried with Torque, no problems at all
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    You need to take those measurements yourself. I recommend you go to a sound system installer and ask some of these questions to him.
    1
    If I said I don't want to offend, it's because I was genuine. I couldn't think of an use case for this that was safe but you gave me one that makes plenty of sense, so thank you for that!
    At least for Netflix there are .apks that run on Android devices without DRM support but you can't stream at more than HD.

    This provides a tutorial to get Netflix working on Android boxes:
    I would recommend maybe trying to follow those instructions.

    Another way might be using Kodi:

    Anyway, I hope this helps.
    1
    Hi guys, had my s8 pro head unit for about a year now, it’s great but it does a full reboot every time I turn on the car, it’s quite annoying cause I have to sit there for a while as it does the full boot sequence, is there any way to turn on fast boot or is this down to how it’s connected via my car?

    Sorry if this has been mentioned here before, I did do a search but couldn’t see anything directly referencing this, thanks in advance!
    If you have had the problem since day one, I would suggest verifying that you have wired the unit correctly. Check your yellow wire, that is the constant voltage wire and I think it is the one that keeps it "active". Refer to the system operations manual section 09-15 in 13.2. It talks about fastboot and the yellow and red wire. Yellow should be hot at all times with battery voltage present.
    1
    I thought I was onto something good with the s8, but not so much anymore. It is a good HU, sounds great and has some nice features. BUT, after finding out they have known about issues for over a year, and have not updated the unit to fix the problems it seems they are trying to pacify by bandaid instead of investing in programmers. these units haven't been updated since release. I have the issue where backup camera doesn't work, but the reverse camera works, and their response to me was that it was wired incorrectly. I didn't try to switch the rca jacks for rcin and vin yet, but will be even more discouraged it that is the fix. I may just send this unit and the darn camera, that I bought because i assumed my working camera was incompatible, back to amazon. Unfortunate that when we deal with chinese products we have no recourse as far as holding them accountable except to return their junk to their stateside warehouse so that amazon can send it out to another customer.
    Now can I get some cheese to go with my whine?
  • 3
    Welcome! Please feel free to ask for help or share your experience with the Atoto S8 line of head units.

    Current lineup:

    S8 Standard S8G2A71S(2GB/16GB)
    S8 Pro Version S8G2A75P(4GB/32GB)
    S8 Ultra


    attachment.php


    Tips/Notes
    • Ensure your Google contacts are backed up if you allow the HU to access them. It has been known to delete them. You can disable Contact Sync from the Accounts section in Settings.
    • Developer Options can be enabled via the repeated clicking under 'About', but to access the menu, you need a play store program that will take you directly to it. A lot of alternative launchers provide a way to access them.
    • The ONLY USB connection that USB debugging works on is USB1 --> Phone Link. For it to work, you need to change the "computer connection" to whatever the SECOND option is [untranslated]. This can be selected from the top right menu in Developer Options
    • File down the very end, outer part of the wire harness clip, and it will go in all the way and latch like it's supposed it. Just needs to clear the casing by 1/16" or less.
    • On at least the first batch of S8's there is a chance the RCA Rear and Front outputs are incorrect and need swapped. The labels are incorrect.


    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Just got mine in this afternoon and installed it in my 86 Ford truck this evening. Prior to that I set it up via the AC adapter (sold separately).
    I know there are a lot more fleshed out reviews out there but here's my take on it.
    I really liked the A6Y Pro. It started out really strong and for 95% of the time it did what was needed. When you consider it's a head unit so it encompasses a lot more than just an Android tablet, it really is impressive. Everything it did, it did well - it just did it kind of slowly. It got pretty sluggish at times when trying to switch between a lot of apps and installing apps from the app store was painfully slow. It should be noted that in just the normal run of the mill drive when you are listening to a single music/radio app or navigation it did great. It was really just when I was sitting in my truck messing with it that one noticed these things. So take those complaints as being a tad bit critical.
    In comes the S8. I didn't have any plans of getting the S8 initially but since I am still working on the interior of the truck I am restoring I felt like it made sense to get the latest version before finalizing the wiring and dash.
    Right off the bat, it's noticeably faster and more responsive. I could install my apps from the app store about as fast as I could click them. Even the cold boot wasn't much slower than my phone (A6Y Pro would go through the 'Optimizing app' process every time and that took awhile). The status bar has changed quite a bit in that the navigation is at the top left vs the bottom. The three primary buttons work really well there and the split screen feature works slick.
    This is a personal preference but while I like the new status bar approach, I wouldn't mind seeing a way to style it differently. I am not a huge fan of colors up there like is seen when a phone is connected.

    As I said, there are better video reviews out there but let me just say that if you have the A6Y and feel like you are pushing it, the S8 is the answer for you.
    Additionally the Atoto support team is very quick to respond (realize that hours may differ from where you are) and is extremely helpful. That's a huge plus especially with the S8 being fairly new to market.

    Items of note that I have found:
    1. LastPass and FCC Launcher.
    Both need Accessibility Services but when trying to grant them and click OK I am unable to due to a message of: "Because an app is obscuring a permission request, Settings can't verify your response"
    There may be other apps that will run into this issue also or if someone has tried either one of these and they don't have the issue granting it, please let me know

    2. RCA Rear and Front outputs are incorrect
    This one threw me for a minute. I am using the RCA FR and FL for my door component speaks and am joining the RR and RL for my Hideaway sub. Turns out in the first shipment of S8's the ports are backwards so you will need to hook the Fronts to the RL/RR and vice versa. I am told that the next shipment will have this resolved. Those are the only RCA outputs I have used so far as the male part of my rear view camera RCA cable fell off when removing the A6Y Pro so I have to wait for a new connector to come in so I can repair it.
    3
    To bad Atoto is not monitoring this thread to help it's customer's a little bit with these type of questions.
    2
    I have the S8 standard, I've been running and messing with it for about a week now. The stock launcher, the icons are way too big and there's no way to resize them, so I installed Google Now Launcher and the icons are smaller and I can stack 2 rows on the bottom of the screen. The only issue that I'm having with the launcher is that the Phone app is gone. It's not onscreen and it's not in the app drawer. It's like it disappeared when I installed the new launcher. I still receive calls through it connected to bluetooth to my cell, but I can't find the app to make calls out.

    With the radio, I have the same back up cam that everyone gets installed and it worked great the first day that I installed it. I put the car in reverse and 3 seconds later I have video. My car sat for 2 days and then when I drove it again, the reverse cam video shows up, but it says no signal and the screen is black. So I know at least the trigger wire works, and it has to be a short in the video cable itself. But every now and then, I get video on the screen.

    I'm guessing there's no way to set certain apps to load on startup. I'd like to turn on the car and the radio app just turns on and plays, but it defaults to the the home screen and I have to load the radio app. I don't use the radio widget, I use the icon to bring up the full screen version of the radio. Once the radio app is running, I have a habit of hitting the back button and it turns the radio app off. So I have to get used to hitting the home button after I load it so it goes back to the home screen.

    Google Maps works great, I downloaded over 600MB of offline maps. I don't have a hotspot except when I use my phone, so it is completely shut off from wifi. I can get into some pretty deep woods with it. But sometimes the app gets stuck and you get a white screen and the GPS can't find you. So you have to force stop Google Maps and reload it and hope that the GPS finds you. I'll post up more of my experiences with it as time goes on. But I have to say, this is my 4th Android car stereo and it's really great so far.
    2
    I'm guessing there's no way to set certain apps to load on startup. I'd like to turn on the car and the radio app just turns on and plays, but it defaults to the the home screen and I have to load the radio app. I don't use the radio widget, I use the icon to bring up the full screen version of the radio. Once the radio app is running, I have a habit of hitting the back button and it turns the radio app off. So I have to get used to hitting the home button after I load it so it goes back to the home screen.

    I'm still waiting on my S8 Pro to arrive but I was looking through a thread for must have apps for android head units and this comment suggested AutoStart - No root. Hopefully this helps you, or it looks like there's plenty on the Play Store to try out.
    2
    IThoughts
    Theres a lot of praise for atoto which there should be, this device is much smoother than the A6 and i would say even better value for money if you can get it cheap and sell your A6. However there a few issues that i managed to find in just 30 minutes. BUT damn, this thing is quick, and only £60 more than the A6 sometimes. I dont think ill upgrade again. hopefully i can sell the A6 for a good enough amount to cover the cost of this upgrade.

    1) Z LINK - this does not work well with android auto (ironic this an android head unit). There is a DPI issue, spotify icon does not scale properly, whether thats my p30 pro or the app i am not sure yet. Right hand side does not work for us in the UK, always showing left hand side arrangement.

    2) finger gestures - we should be able to choose this but minor in the grand scheme

    3) AUDIO - oh audio, so much promise. Can definitely be fixed with software updates tho. other asked for help in setting a nice eq setting, so far a smooth v shape from +5 at the low, 0 at the mids and +6 at the high is doing well. There is a catch, turn off audio delay ( the distances are too small to make a difference imo and makes it sound weird, comes set up for left and side tho i believe).
    Subwoofer RCA is 0.8v so be aware. I am not sure how to even amplify such a small signal

    4) in car calls - The new system is SICK. with all the reviews ive seen, i cannot stress how good the s8 handles calls. new pop up is small and out of the way, can pick up and hang up like usual. On top of that you can change weather you want handset or car audio if you want to make a private call! and lastly, floating number pad!!

    5) horsepower - since Z link is for me subpar with AA, i am using headunit reloaded. The a6 could barely handle 720p and it had to be done with software. now i run AA at 720p with hardware acceleration! buttery smooth, feels like it was design by a name brand. I will use Zlink for car play but HUR for AA.

    6) some of my contacts were also delete -_- (Fix: turn off sync for contacts. then roll back changes to your account and hour or to yesterday)