• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Atoto S8 General Discussion

Search This thread

Gaugamela

Senior Member
Feb 12, 2016
74
11
Tethering update:

The best solution and app I found to enable wireless tethering is with MacroDroid. Plus the free version needs all I need and it has no ads, and the toggle ON/OFF is directly in the android quick launch on the phone.

It has MANY features with rules/exceptions/triggers/constraints etc..
I use it to enable my WiFi hotspot when the phone connects to the ATOTO BT. And when I turn the car off... it disables the hotspot because I have another rule to turn it off when the BT is terminated.

It works perfectly without me doing anything with my phone or radio.

Similar to Tasker then.
 
Dec 22, 2012
37
9
28
Envigado
Soooo, guys, long time without visiting XDA, I got a S8 GEN2 Single Din, and I HAVE AN ISSUE! When I'm trying to play video from HBO MAX or any other streaming app, the video won't play, it's just a black screen (everything else works as intended but the video (also, no sound) what could it be? Is the android OS missing any DRM files or anything like that? also, is it a good idea to root it and mess with the BUILD file so I can get more apps in the store, or that's not possible anymore?
 

Robotech740

New member
May 5, 2020
1
0
Gracias por su respuesta. Mi tarjeta SanDisk Extreme SD también fue formateada previamente a exFAT. Pero la guía de instalación de ATOTO S8 y su soporte técnico dicen que exFAT es incompatible con el A8, la tarjeta SD debe estar formateada en FAT32 o NTFS. Debido a esas instrucciones, reformateé mi tarjeta SD, primero a NTFS y luego fallé, probé FAT32. Quizás estén equivocados; no sería la primera vez que descubro que las instrucciones son incorrectas o están desactualizadas. He probado FAT32 y NTFS sin éxito, así que tal vez intente reformatear la tarjeta SD a exFAT.
¡Hola! Tengo el mismo problema, ¿lograste solucionarlo?
 
Jul 29, 2011
35
5
Hey people.

Just installed this unit today (pro gen2) and having huge issues with swc.

I came from an atoto a6, so I was using a connects2 module with a ctmultilead.2 (key1, key2 and ground wires). Was working great on the a6, nothing on the s8. Ford Mondeo 2005.

Is there anything I can try to get it to work? I've been at my wit's end all day trying to get it to work.

Thanks!
 

chudiy

Member
May 31, 2007
9
0
Hi all

I installed an atoto s8 premium 7 inch double din, it has a 2 usb cables, one for phone link/android auto and the other for other stuff, my issue is I want to connect a usb dash cam and usb tpms to the other usb cable, is there a way to use a usb hub, i tried a usb splitter cable i bought of ebay and only one item works, so it is either the dash cam or tpms. anyone have any expereince with such.?
 

fastfed

Senior Member
Feb 13, 2008
912
63
Anyone know why google maps when navigating is offset to the right? My atoto A6 did this I remember but I fixed it somehow.

Now I upgraded to this unit and its happening again
 

ahardie

Member
Sep 16, 2009
21
0
Hey people.

Just installed this unit today (pro gen2) and having huge issues with swc.

I came from an atoto a6, so I was using a connects2 module with a ctmultilead.2 (key1, key2 and ground wires). Was working great on the a6, nothing on the s8. Ford Mondeo 2005.

Is there anything I can try to get it to work? I've been at my wit's end all day trying to get it to work.

Thanks!
I installed an S8 premium and used the same set up as you to install the swc's. It worked perfectly initially but then stopped. It may be coincidence but it was after I had problems fitting a back up camera to the unit (now working). I contacted Connects2 and they replied -
"Sometimes when you are mapping the buttons on this aftermarket china radio's you need to press the buttons a few times repeatedly until a button press is picked up.

If we can verify the radio is not at fault by testing another unit, then I would recommend perhaps try a CTSMARTLEAD instead of the CTMULITLEAD.2."

I haven't got around to trying the lead they suggested yet but this is the cheapest one I could find
https://audiovisualworld.co.uk/univ...d-for-steering-wheel-control-ctsmartlead.html

I might give it a try, if it works I will post back.
 
Last edited:

pinhead97

Senior Member
Jul 20, 2013
334
139
Southampton
Hi guys, had my s8 pro head unit for about a year now, it’s great but it does a full reboot every time I turn on the car, it’s quite annoying cause I have to sit there for a while as it does the full boot sequence, is there any way to turn on fast boot or is this down to how it’s connected via my car?

Sorry if this has been mentioned here before, I did do a search but couldn’t see anything directly referencing this, thanks in advance!
 

alignwith9

New member
Oct 6, 2012
4
0
Hi I am on the verge of purchasing an ATOTO S8 Gen2 Premium Lite but I have a question first.
My car is 2013 Nissan Altima SL with Bose sound system. Will the

ATOTO S8 Lite S8G2113LT
Work with my car? I want to make sure it will work with the Bose sound system that comes with the nissan altima. Also will the 10.1" screen fit inside my car or will it stick out?
Thanks for answering .​

 

Gaugamela

Senior Member
Feb 12, 2016
74
11
You need to take those measurements yourself. I recommend you go to a sound system installer and ask some of these questions to him.
 
  • Like
Reactions: marchnz

Gaugamela

Senior Member
Feb 12, 2016
74
11
No wanting to offend or anything, but why would is watching videos on a head unit is important to you? That's dangerous when driving...
Either way, if that was important you should've checked that before buying. It's also an issue on Android TV boxes where only ones with Amlogic SoCs support the DRM to run Netflix.
 

vonny571

Member
Nov 10, 2020
12
5
No wanting to offend or anything, but why would is watching videos on a head unit is important to you? That's dangerous when driving...
Either way, if that was important you should've checked that before buying. It's also an issue on Android TV boxes where only ones with Amlogic SoCs support the DRM to run Netflix.
It's useful for me because I have the head unit connected to a rear entertainment system for my kids. It's interesting that you start your statement saying you don't want to offend and then immediately assume that we are using the head unit in an unsafe manner. That said, if you don't have a solution to suggest or are not suffering from a similar issue, it's probably wise for you to refrain from joining this conversation.
 

Gaugamela

Senior Member
Feb 12, 2016
74
11
If I said I don't want to offend, it's because I was genuine. I couldn't think of an use case for this that was safe but you gave me one that makes plenty of sense, so thank you for that!
At least for Netflix there are .apks that run on Android devices without DRM support but you can't stream at more than HD.

This provides a tutorial to get Netflix working on Android boxes:
I would recommend maybe trying to follow those instructions.

Another way might be using Kodi:

Anyway, I hope this helps.
 
  • Like
Reactions: WinoOutWest

marchnz

Senior Member
Nov 26, 2012
4,100
798
NZ
If I said I don't want to offend, it's because I was genuine. I couldn't think of an use case for this that was safe but you gave me one that makes plenty of sense, so thank you for that!
At least for Netflix there are .apks that run on Android devices without DRM support but you can't stream at more than HD.

This provides a tutorial to get Netflix working on Android boxes:
I would recommend maybe trying to follow those instructions.

Another way might be using Kodi:

Anyway, I hope this helps.
Do either of these work or just guesses
 

packpride85

New member
Dec 2, 2021
3
0
Just installed the S8 Premium into my Xterra and had a few questions about carplay:

1. Has anyone had issues with the wired carplay not being able to connect? Mine shows connecting on the carlink screen then just goes back to "detecting". It does charge the phone so its seeing something. I did confirm I'm using the phone link portion of the usb cable.

Update: It was an issue with routing the USB connection through my OEM USB harness. When I plugged the phone directly into the Atoto USB harness it worked.


2. The wireless carplay connection seems to stay alive after the car ignition is turned OFF. Is there a way to disable that? Otherwise I have to manually disconnect on my iphone every time.

UPDATE: Have to wait 2 minutes and it will shut off the connection

4. Can the carlink app be set to start automatically when I turn the car on?

UPDATE: Atoto said this is only possible within the unit software with USB wired CarPlay. If I want car link to automatically start for wireless I'll need to use a 3rd party app like Tasker.

For anyone using the wireless carplay function, the S8 software did not like the 5ghz wireless option in the carlink app settings. Got alot of freezes/disconnects. Once I changed it to 2.4ghz it works great.
 
Last edited:

mrphil101

Senior Member
Apr 2, 2009
323
46
NPR, Florida
I replaced a head unit with a standard S8 unit in my truck. Problems with backup camera. The old unit had a functioning camera. so I plugged it in and no video, so I was wanting to use the reverse option and went ahead and bought the 02LR camera. Restrung the new cables and hooked it up using the same backup wire that engaged the camera on the older unit, so I know it is the proper trigger wire. The camera works for a rear view, but not for the backup. It doesn't do anything when i put it in reverse, not even a flicker. Looking at the posts from around #160 (back in 2020) it appeared to be not an uncommon issue with these units. Are other folks still having issues with the backup cameras in "defective" units? I can't remember where I saw the manufacture date at, but it was only a couple of months ago. Seems that if there was an issue known to them from back in 2020 that it would have been corrected by now. Guess I will have to email them next.
Edit: 12-04 Sent an email and got a response stating I had hooked it up wrong. So I took a picture for them showing the pink wire hooked up they said was incorrect. Explained again -had working camera before, connections are same for the reverse wire. 02 Camera works for reverse but not backup. Ball is in their court again. 2 b cont.
 
Last edited:

mrphil101

Senior Member
Apr 2, 2009
323
46
NPR, Florida
Hi guys, had my s8 pro head unit for about a year now, it’s great but it does a full reboot every time I turn on the car, it’s quite annoying cause I have to sit there for a while as it does the full boot sequence, is there any way to turn on fast boot or is this down to how it’s connected via my car?

Sorry if this has been mentioned here before, I did do a search but couldn’t see anything directly referencing this, thanks in advance!
If you have had the problem since day one, I would suggest verifying that you have wired the unit correctly. Check your yellow wire, that is the constant voltage wire and I think it is the one that keeps it "active". Refer to the system operations manual section 09-15 in 13.2. It talks about fastboot and the yellow and red wire. Yellow should be hot at all times with battery voltage present.
 
  • Like
Reactions: pinhead97

packpride85

New member
Dec 2, 2021
3
0
Hi I am on the verge of purchasing an ATOTO S8 Gen2 Premium Lite but I have a question first.
My car is 2013 Nissan Altima SL with Bose sound system. Will the

ATOTO S8 Lite S8G2113LT​

Work with my car? I want to make sure it will work with the Bose sound system that comes with the nissan altima. Also will the 10.1" screen fit inside my car or will it stick out?​

Thanks for answering .​

It will, but you'll want to use a line out converter to sit between the Atoto speaker wiring and your OEM Bose Amp/harness. Otherwise the Atoto will overdrive your amp and it will sound distorted. I have this setup with my factory Rockford Fosgate system and it works great.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Guys, there's a new radio app available for the Atoto S8!!! I already tested this and it actually works!
    It's the only radio app besides the native one (well and any from other FYT head units) that actually works with our head unit. :D
    1
    Hello. I recently had an ATOTO S8 Ultra installed in my 2010 Mazda 5, and everything is working nicely




    except for one small issue:

    Everything is perfect! But.


    Anyone, that thinks they have Android Auto on these Chinese origin head units has a misunderstanding, been fooled or naive.

    Poster, if Android Auto is want you really want, select a unit from here https://www.android.com/auto/compatibility/#compatibility-stereos

    If you don't see your car or headunit listed here, or actually understood that unit brought from china, isn't AA but somehow think Zlink will do AA or something like AA, you have been fully duped.

    Don't ask for support for this rubbish, You got what you paid for and the reseller is the first point of contact.

    Senior members should know better
    1
    Had a bit of a skim through this thread as I've been heavily considering an S8 premium 7" or a Joying 7"

    Very mixed bag reviews going on in here but it also seems like a lot of people are possibly just asking too much of this unit?

    As someone who is only going to use this for Radio/Spotify/Maps/Reverse Cam how trouble free of a unit will this be? Any opinions?
    S8 Premium is enough for Radio/Spotify/Maps/Reverse Cam, most android headunit will support those, you can compare more like warranty and price then get the most suitable one.
  • 4
    Welcome! Please feel free to ask for help or share your experience with the Atoto S8 line of head units.

    Current lineup:

    S8 Standard S8G2A71S(2GB/16GB)
    S8 Pro Version S8G2A75P(4GB/32GB)
    S8 Ultra


    attachment.php


    Tips/Notes
    • Ensure your Google contacts are backed up if you allow the HU to access them. It has been known to delete them. You can disable Contact Sync from the Accounts section in Settings.
    • Developer Options can be enabled via the repeated clicking under 'About', but to access the menu, you need a play store program that will take you directly to it. A lot of alternative launchers provide a way to access them.
    • The ONLY USB connection that USB debugging works on is USB1 --> Phone Link. For it to work, you need to change the "computer connection" to whatever the SECOND option is [untranslated]. This can be selected from the top right menu in Developer Options
    • File down the very end, outer part of the wire harness clip, and it will go in all the way and latch like it's supposed it. Just needs to clear the casing by 1/16" or less.
    • On at least the first batch of S8's there is a chance the RCA Rear and Front outputs are incorrect and need swapped. The labels are incorrect.


    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Just got mine in this afternoon and installed it in my 86 Ford truck this evening. Prior to that I set it up via the AC adapter (sold separately).
    I know there are a lot more fleshed out reviews out there but here's my take on it.
    I really liked the A6Y Pro. It started out really strong and for 95% of the time it did what was needed. When you consider it's a head unit so it encompasses a lot more than just an Android tablet, it really is impressive. Everything it did, it did well - it just did it kind of slowly. It got pretty sluggish at times when trying to switch between a lot of apps and installing apps from the app store was painfully slow. It should be noted that in just the normal run of the mill drive when you are listening to a single music/radio app or navigation it did great. It was really just when I was sitting in my truck messing with it that one noticed these things. So take those complaints as being a tad bit critical.
    In comes the S8. I didn't have any plans of getting the S8 initially but since I am still working on the interior of the truck I am restoring I felt like it made sense to get the latest version before finalizing the wiring and dash.
    Right off the bat, it's noticeably faster and more responsive. I could install my apps from the app store about as fast as I could click them. Even the cold boot wasn't much slower than my phone (A6Y Pro would go through the 'Optimizing app' process every time and that took awhile). The status bar has changed quite a bit in that the navigation is at the top left vs the bottom. The three primary buttons work really well there and the split screen feature works slick.
    This is a personal preference but while I like the new status bar approach, I wouldn't mind seeing a way to style it differently. I am not a huge fan of colors up there like is seen when a phone is connected.

    As I said, there are better video reviews out there but let me just say that if you have the A6Y and feel like you are pushing it, the S8 is the answer for you.
    Additionally the Atoto support team is very quick to respond (realize that hours may differ from where you are) and is extremely helpful. That's a huge plus especially with the S8 being fairly new to market.

    Items of note that I have found:
    1. LastPass and FCC Launcher.
    Both need Accessibility Services but when trying to grant them and click OK I am unable to due to a message of: "Because an app is obscuring a permission request, Settings can't verify your response"
    There may be other apps that will run into this issue also or if someone has tried either one of these and they don't have the issue granting it, please let me know

    2. RCA Rear and Front outputs are incorrect
    This one threw me for a minute. I am using the RCA FR and FL for my door component speaks and am joining the RR and RL for my Hideaway sub. Turns out in the first shipment of S8's the ports are backwards so you will need to hook the Fronts to the RL/RR and vice versa. I am told that the next shipment will have this resolved. Those are the only RCA outputs I have used so far as the male part of my rear view camera RCA cable fell off when removing the A6Y Pro so I have to wait for a new connector to come in so I can repair it.
    3
    To bad Atoto is not monitoring this thread to help it's customer's a little bit with these type of questions.
    2
    I have the S8 standard, I've been running and messing with it for about a week now. The stock launcher, the icons are way too big and there's no way to resize them, so I installed Google Now Launcher and the icons are smaller and I can stack 2 rows on the bottom of the screen. The only issue that I'm having with the launcher is that the Phone app is gone. It's not onscreen and it's not in the app drawer. It's like it disappeared when I installed the new launcher. I still receive calls through it connected to bluetooth to my cell, but I can't find the app to make calls out.

    With the radio, I have the same back up cam that everyone gets installed and it worked great the first day that I installed it. I put the car in reverse and 3 seconds later I have video. My car sat for 2 days and then when I drove it again, the reverse cam video shows up, but it says no signal and the screen is black. So I know at least the trigger wire works, and it has to be a short in the video cable itself. But every now and then, I get video on the screen.

    I'm guessing there's no way to set certain apps to load on startup. I'd like to turn on the car and the radio app just turns on and plays, but it defaults to the the home screen and I have to load the radio app. I don't use the radio widget, I use the icon to bring up the full screen version of the radio. Once the radio app is running, I have a habit of hitting the back button and it turns the radio app off. So I have to get used to hitting the home button after I load it so it goes back to the home screen.

    Google Maps works great, I downloaded over 600MB of offline maps. I don't have a hotspot except when I use my phone, so it is completely shut off from wifi. I can get into some pretty deep woods with it. But sometimes the app gets stuck and you get a white screen and the GPS can't find you. So you have to force stop Google Maps and reload it and hope that the GPS finds you. I'll post up more of my experiences with it as time goes on. But I have to say, this is my 4th Android car stereo and it's really great so far.
    2
    I'm guessing there's no way to set certain apps to load on startup. I'd like to turn on the car and the radio app just turns on and plays, but it defaults to the the home screen and I have to load the radio app. I don't use the radio widget, I use the icon to bring up the full screen version of the radio. Once the radio app is running, I have a habit of hitting the back button and it turns the radio app off. So I have to get used to hitting the home button after I load it so it goes back to the home screen.

    I'm still waiting on my S8 Pro to arrive but I was looking through a thread for must have apps for android head units and this comment suggested AutoStart - No root. Hopefully this helps you, or it looks like there's plenty on the Play Store to try out.
    2
    Guys, there's a new radio app available for the Atoto S8!!! I already tested this and it actually works!
    It's the only radio app besides the native one (well and any from other FYT head units) that actually works with our head unit. :D