Atoto S8 General Discussion

Search This thread
May 27, 2022
10
1
Hi All,

Really like my newish S8 Ultra, but there is one bug I haven't been able to fix.

I use the USB I cable for wired CarPlay, and the second USB cable on that plug I am using for TPMS. The trouble is, the TPMS doesn't connect when the CarPlay is connected. Remove CarPlay on the unit from the running apps list, and the TPMS works great. Start CarPlay again, and the TPMS doesn't detect the TPMS interface.

Any suggestion on how I can get both working? If I need to plug in the second pair of USB cable to achieve it, then I'll do it, but I really don't want to pull it all apart to plug in the second set of USB cables as an experiment, only to have it be no better.

And I am trying to avoid wireless CarPlay. I only go on long trips in this car and so need to plug in the phone for charging - much prefer the stability of the wired CarPlay and since the phone is going to be plugged in, I might as well use wired CarPlay.

Thanks in advance.
 

Icecosta

Member
Jun 28, 2009
10
2
Hi guy's, i recently installed an S8 standard, i also got an external powered dab aerial and connected to the headunit using a usb dab receiver, one of those that are usually used with window antennas.

My question is can i get a better dab receiver to connect the antenna to the headunit, I'm not 100% satisfied with the reception and the antenna is great so I'm guessing it's the receiver that isn't the best.

Catches signal very well, but loses signal pretty fast under certain circumstances like under a bridge, the fm antenna works fine but the dab immediately fails even in a short bridge, everything else is connected to this antenna and works fine, fm/gps no issue whatsoever.

Any suggestions? 🤔
 
May 27, 2022
10
1
I expect the issue is the antenna, not the DAB receiver. You might be able to run an antenna amplifier on your existing antenna, provided the amplifier is one suitable for DAB, and most likely provided your car doesn't already have a built in antenna amplifier.
 

03hdfatboy

Senior Member
Sep 4, 2009
158
31
I wanted a screen protector as I intend to off road in the desert and sand gets everywhere....
The ones that came with the unit were horrible, but I found some I really like on AliExpress for my Atoto S8 Ultra Gen 2. These are 9H tempered glass:
I ordered the 153x85mm size. This leaves a bit of room on each edge, about 1 mm. This allows for easier installation and removal.
Install was VERY easy compared to those silly plastic ones.
You can see the edge of the protector in the picture below.
iP1Kx4pCfvgyZyX2lRxLLqxfi5hg-Z_lRNj-gsUySuQmjpj8b8vWBRnBpK550CnHYoz8RLwi5HAB77yCegaJNfY4m_BIQd9NwffC6tfdczIKR-vJvrM6_3KPN1RFalDG2-rnGDhTTODzQ0_izcJ8oUJ6Xn27_c25Q7Ure6Y2diQiVdNB5bBAts3yvNXVWTa7FXdF8MRwvyedek6SnrxcuQobEmSvgEv70Udf7oOET9OmcguDKnxBBVTHkpLoLOKCI2muNmOohV6ib_UfLDpywf_Lf6x_VZ-IgOoHROac5ZNrwGbJfQr7noa0dYTRCyPNgpvmg65MC5crGDXzh0XKpgZcJGkRrJwD6D9Bs46wLJuLUL1zltkklTSh4q5NNCRoVg516HqI9SZndhYos5dJ78Br1H32WmAOY-kaAV3toER_O_adlgyzbHoerZXs2D1QOZ3ISSC5pkMQAyeXye_eejeh58YORahadxFY71UkQ-0t0j9H2Y_ARB4X5xMmAYkl57D33-wclqnT7ulskq_pXQ5wfmpP77ICqmhjChMZR2KNq8ii-54KglrO2copY4gF7-TFSGxSCA7gLgWrjkXGIVR1rW7XkZfWA8jl70QtKlQ3lNYXMyGYxizfFHMAcRY_zQLaZElBLnX4kHCaJE6j09ZWrtClDFzSty8nSunR_uP7qAcHgKEsUC__-NP8ebwqFkWML3A6-_6nYHvPQsDcc8MY2HoJJDrbnWlcw0BBE2OSI5D6KRJAcdxJpY81=w1080-h810-no
Found this on ebay thanks to your mesurments screen protector
 
  • Like
Reactions: vintagephone

03hdfatboy

Senior Member
Sep 4, 2009
158
31
The PS2 Slim connected to composite input on my Atoto S8 7" Premium in my '07 Forester XT was fun (takes up the whole glovebox though, and makes my power inverter fan run even with PS2 powered off), but I'm ditching it now that I tried something that I wanted to share with the group:

The PS5 (and probably PS4) gamepad works great on Bluetooth 2 and also via the USB DVR cable. I plugged in an unpaired PS5 gamepad to the USB port and Beach Buggy Racing worked with it immediately and perfectly. I then paired it to BT2 and it also worked perfectly. I tried a couple other games I had installed. Traffic Rider mostly works after setting controls to gamepad. Trials Frontier might or might not work - I haven't sat thru the forced intro yet (I'm a fan of the Trials series). I'll have to try some better driving games and maybe some others that work well with gamepad.

I imagine game compatibility is as expected for PS4/PS5 gamepads on Android. I used to use a program (that required root-access and I can't remember the name of anymore) that would map gamepad buttons/axis to parts of the touchscreen. I used to play Hill Climb Racing 2 a TON and was doing it with a PS4 gamepad for awhile, sitting back and grinding out the coins on an old Android tablet. You could virtually play any Android game with this app, and just navigate around the OS with damn near any gamepad. I see a new app that sounds like it does the same thing called Mantis. I'll check it out and see if it works well.

Next up: Emulators. They'd better give me 8-way DPAD or I'm going to be very upset when I can't slide under the bricks in Super Mario Bros. 1, stage 1-2.
I've got a full blown Linux (MX21) PC in my truck with a 10" screen with nintendo emulators and neary every game every game ever made. Plan to install one in my car connected to my S8 but ill need a HDMI to composite adapter use bluetooth for audio
 

arkrumm

New member
Aug 6, 2022
1
0
Just installed my S8 standard a week or so ago, experimenting with different launchers to see what I like. So far I like the Agama one pretty well, but there are a couple of issues that don't work, and I don't know if it's because it's not compatible or I have done something wrong, so hoping someone might be able to let me know so I stop wasting time if it's not possible, haha.
1) Can't get Google Maps nav to work in the center section. Won't ever connect. Can't find any settings I'm missing. I used the settings apk file from Atoto and that got the music player communicating, but still can't get the map nav to work.
2) Can Agama adjust the volume on the S8? Or are apps not able to do that? I can't get that to work.

Thanks in advance, I've found some good tidbits in this thread, so hoping someone can throw me a bone on these 2 items I'm struggling with.
 

scorpio76r

Senior Member
Jan 10, 2016
1,467
533
All over like street lights
Just installed my S8 standard a week or so ago, experimenting with different launchers to see what I like. So far I like the Agama one pretty well, but there are a couple of issues that don't work, and I don't know if it's because it's not compatible or I have done something wrong, so hoping someone might be able to let me know so I stop wasting time if it's not possible, haha.
1) Can't get Google Maps nav to work in the center section. Won't ever connect. Can't find any settings I'm missing. I used the settings apk file from Atoto and that got the music player communicating, but still can't get the map nav to work.
2) Can Agama adjust the volume on the S8? Or are apps not able to do that? I can't get that to work.

Thanks in advance, I've found some good tidbits in this thread, so hoping someone can throw me a bone on these 2 items I'm struggling with.
Waze works best for me.
 

gregrap

New member
Jan 2, 2021
1
1
I purchased the ATOTO S8 Ultra Double Din 7 Inch Android Car in-Dash Navigation, and the ATOTO AC-44P2 1080P USB DVR On-Dash Camera. I am in process of installing both.


I am having an issue as I don’t how to plug the camera into the S8 head unit. The camera has a USB end while the head unit has a slot that is for round RCA type plug marked at the back of the head unit as front camera input..... Is there suppose to be an adapter cable? I bought both off of Amazon and the posting stated the two where compatible……… Do I plug the camera into one of the 4 usb extension plugs?

Thanks
yes you can connect the camera to the "DVR" usb input
 
  • Like
Reactions: 03hdfatboy

Colemanuk82

Member
Jan 19, 2019
10
5
Sounds like something that they would say. They bypass users concerns and, only implement what they feel we should have on a update. If root was possible for this device then we would be in better control. The only reason that I haven't attempted root is because I am unsure if I can recover it from a hard brick if it happened.
Root works completely fine. Check my previous posts... You can download the new firmware images straight from atoto if you need to
 

scorpio76r

Senior Member
Jan 10, 2016
1,467
533
All over like street lights
That is for all atoto radios running Android 10? What exactly is the atoto radio your using? Does this work with the latest atoto software update? I'm asking because I saw the file that you shared and, would like to use it but, don't want to brick. I depend on waze daily.
 

peperonikiller

Senior Member
May 22, 2009
210
31
34
Cedar Rapids
Followed the directions to root my S8 Standard (VW Model) and it worked great! It even worked on my buddies S8 Premium. So I can confirm Standard firmware also works on premiums.
 

Icecosta

Member
Jun 28, 2009
10
2
I expect the issue is the antenna, not the DAB receiver. You might be able to run an antenna amplifier on your existing antenna, provided the amplifier is one suitable for DAB, and most likely provided your car doesn't already have a built in antenna amplifier.
Hum the antenna is an external FM/Am GPS Dab Antenna with amplifier built in, it's a new antenna that I installed to replace the old FM/AM antenna the car came originally equipped with, FM works fine, GPS signal is always strong, I'm guessing DAB reception just ain't great where I live, in the city it's almost spotless.


I might still invest in something like this

Just to see if it makes any difference
 

03hdfatboy

Senior Member
Sep 4, 2009
158
31
My background keeps disappearing leaving the background black, does it when I play music. It has the one I set until I play music, It appears to change but when I go back to car launcher it’s not there. Is that a car launcher issue?
 
Last edited:

badhabit_wb

Senior Member
Jan 17, 2013
129
29
Hi All,

Really like my newish S8 Ultra, but there is one bug I haven't been able to fix.

I use the USB I cable for wired CarPlay, and the second USB cable on that plug I am using for TPMS. The trouble is, the TPMS doesn't connect when the CarPlay is connected. Remove CarPlay on the unit from the running apps list, and the TPMS works great. Start CarPlay again, and the TPMS doesn't detect the TPMS interface.

Any suggestion on how I can get both working? If I need to plug in the second pair of USB cable to achieve it, then I'll do it, but I really don't want to pull it all apart to plug in the second set of USB cables as an experiment, only to have it be no better.

And I am trying to avoid wireless CarPlay. I only go on long trips in this car and so need to plug in the phone for charging - much prefer the stability of the wired CarPlay and since the phone is going to be plugged in, I might as well use wired CarPlay.

Thanks in advance.
I have an s8 premium gen 2. I put in the wireless android auto firmware and use that to connect to AA, Tpms app works fine when using it this way. There's also a way to switch it off if you don't want to use it. It works great with my pixel 6 pro.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Just rooted my S8 Gen2 Ultra with the 2022-04-15 firmware. Patched and ready to go files can be found here:

    Instructions said to copy the files in the extracted directory to a sdcard formatted NTFS or FAT32. Neither of these worked (tried a 8GB FAT32 and a 400GB NTFS). An sdcard formatted to exFAT worked perfectly. Note: Flashing the firmware erases data so you will loose all your settings. At least it did not erase the apps that I had installed.

    Now hopefully I can fix the micrphone button to open Google Assistant instead of Google Voice Search, along with fixing the AC-44F5 Front Camera button to open the HDDVR app instead of the FCAM app.

    Installed Swift Backup and I backed up the apps on the head unit. Now when I calibrate the backup camera I won't loose all my work when installing firmware update. ADB Wieless also seems to work now.

    BTW, none of the USB ports worked with ADB.

    I'll have to see about the ODBII problem to see if I'll patch the newer firmware.
    2
    I've rooted phones before but what do I gain/loose by rooting my headunit?

    For the vast majority of users they don't need to root. If the system does what they want then leave well enough alone.

    I've rooted all my Android devices since the original Google G1, with the exception of my Sony TVs. For me, rooting gives me full control of my device. I can backup all my apps along with their settings and I can easily restore them. I can block ads (I hate the ads in Waze). I can transfer files back and forth via ADB wireless for the ATOTO (none of the usb ports work for ADB). For the ATOTO, I want to fix the bloody buttons that don't open the correct app. Why in the world would I want the microphone button to open Google Voice Search and search the web instead of Google Assistant that I can open apps and have it make calls with. The AC-44F5 also is hard coded to open the FCAM app instead of being able to change it to open the HDDVR app.

    I was really dissapointed to loose the rear cam calibration settings after spending 90 minutes measuring and calibrating the rear camera. So I was not going to go through that again unless I can backup the apps and the settings. Swift Backup gives me that.

    So root if you want full control over your device, otherwise leave well enough alone and run the stock firmware.
    2
    With the update, the sound quality of the telephone speakerphone has been improved. Great.
    2
    Tomorrow I'm going to see what bluetooth version is in the update and see what else I can find out is different....
    I'll try this out tomorrow too.
    Thanks for all the info and help.
    Where is the new update you posted from.
    Is it newer than the may update?
    2
    Seems i may be the only one having firmware update errors.
    I have tried the latest update, and the one from January i beleive, and after inserting usb stick, i get the firmware/restart prompt, the unit shuts down and restarts, then instantly shows the dead android, with Error at the bottom.

    Have never been able to get any of the firmware updates installed. Any tips from users with similar issues?

    My model is S8G2A74SD and i downloaded the update for my model directly from ATOTO site.

    I have attahced files that may be of use :)

    Thanks
    I had issues with an update and it allowed me to do it without the dead android and the "no command" error
    Take a formatted sd card put the Full update on it and do this
    make a "config.txt" with this on it:

    #test
    ro.fyt.launcher=com.android.launcher4
    ro.fyt.amp_type=0
    sys.fyt.bluetooth_type=0
    persist.sys.zlink.mic.vol=9.9
    sys.fyt.ec_version=6
  • 5
    Welcome! Please feel free to ask for help or share your experience with the Atoto S8 line of head units.

    Current lineup:

    S8 Standard S8G2A71S(2GB/16GB)
    S8 Pro Version S8G2A75P(4GB/32GB)
    S8 Ultra


    attachment.php


    Tips/Notes
    • Ensure your Google contacts are backed up if you allow the HU to access them. It has been known to delete them. You can disable Contact Sync from the Accounts section in Settings.
    • Developer Options can be enabled via the repeated clicking under 'About', but to access the menu, you need a play store program that will take you directly to it. A lot of alternative launchers provide a way to access them.
    • The ONLY USB connection that USB debugging works on is USB1 --> Phone Link. For it to work, you need to change the "computer connection" to whatever the SECOND option is [untranslated]. This can be selected from the top right menu in Developer Options
    • File down the very end, outer part of the wire harness clip, and it will go in all the way and latch like it's supposed it. Just needs to clear the casing by 1/16" or less.
    • On at least the first batch of S8's there is a chance the RCA Rear and Front outputs are incorrect and need swapped. The labels are incorrect.


    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Just got mine in this afternoon and installed it in my 86 Ford truck this evening. Prior to that I set it up via the AC adapter (sold separately).
    I know there are a lot more fleshed out reviews out there but here's my take on it.
    I really liked the A6Y Pro. It started out really strong and for 95% of the time it did what was needed. When you consider it's a head unit so it encompasses a lot more than just an Android tablet, it really is impressive. Everything it did, it did well - it just did it kind of slowly. It got pretty sluggish at times when trying to switch between a lot of apps and installing apps from the app store was painfully slow. It should be noted that in just the normal run of the mill drive when you are listening to a single music/radio app or navigation it did great. It was really just when I was sitting in my truck messing with it that one noticed these things. So take those complaints as being a tad bit critical.
    In comes the S8. I didn't have any plans of getting the S8 initially but since I am still working on the interior of the truck I am restoring I felt like it made sense to get the latest version before finalizing the wiring and dash.
    Right off the bat, it's noticeably faster and more responsive. I could install my apps from the app store about as fast as I could click them. Even the cold boot wasn't much slower than my phone (A6Y Pro would go through the 'Optimizing app' process every time and that took awhile). The status bar has changed quite a bit in that the navigation is at the top left vs the bottom. The three primary buttons work really well there and the split screen feature works slick.
    This is a personal preference but while I like the new status bar approach, I wouldn't mind seeing a way to style it differently. I am not a huge fan of colors up there like is seen when a phone is connected.

    As I said, there are better video reviews out there but let me just say that if you have the A6Y and feel like you are pushing it, the S8 is the answer for you.
    Additionally the Atoto support team is very quick to respond (realize that hours may differ from where you are) and is extremely helpful. That's a huge plus especially with the S8 being fairly new to market.

    Items of note that I have found:
    1. LastPass and FCC Launcher.
    Both need Accessibility Services but when trying to grant them and click OK I am unable to due to a message of: "Because an app is obscuring a permission request, Settings can't verify your response"
    There may be other apps that will run into this issue also or if someone has tried either one of these and they don't have the issue granting it, please let me know

    2. RCA Rear and Front outputs are incorrect
    This one threw me for a minute. I am using the RCA FR and FL for my door component speaks and am joining the RR and RL for my Hideaway sub. Turns out in the first shipment of S8's the ports are backwards so you will need to hook the Fronts to the RL/RR and vice versa. I am told that the next shipment will have this resolved. Those are the only RCA outputs I have used so far as the male part of my rear view camera RCA cable fell off when removing the A6Y Pro so I have to wait for a new connector to come in so I can repair it.
    3
    To bad Atoto is not monitoring this thread to help it's customer's a little bit with these type of questions.
    2
    I have the S8 standard, I've been running and messing with it for about a week now. The stock launcher, the icons are way too big and there's no way to resize them, so I installed Google Now Launcher and the icons are smaller and I can stack 2 rows on the bottom of the screen. The only issue that I'm having with the launcher is that the Phone app is gone. It's not onscreen and it's not in the app drawer. It's like it disappeared when I installed the new launcher. I still receive calls through it connected to bluetooth to my cell, but I can't find the app to make calls out.

    With the radio, I have the same back up cam that everyone gets installed and it worked great the first day that I installed it. I put the car in reverse and 3 seconds later I have video. My car sat for 2 days and then when I drove it again, the reverse cam video shows up, but it says no signal and the screen is black. So I know at least the trigger wire works, and it has to be a short in the video cable itself. But every now and then, I get video on the screen.

    I'm guessing there's no way to set certain apps to load on startup. I'd like to turn on the car and the radio app just turns on and plays, but it defaults to the the home screen and I have to load the radio app. I don't use the radio widget, I use the icon to bring up the full screen version of the radio. Once the radio app is running, I have a habit of hitting the back button and it turns the radio app off. So I have to get used to hitting the home button after I load it so it goes back to the home screen.

    Google Maps works great, I downloaded over 600MB of offline maps. I don't have a hotspot except when I use my phone, so it is completely shut off from wifi. I can get into some pretty deep woods with it. But sometimes the app gets stuck and you get a white screen and the GPS can't find you. So you have to force stop Google Maps and reload it and hope that the GPS finds you. I'll post up more of my experiences with it as time goes on. But I have to say, this is my 4th Android car stereo and it's really great so far.
    2
    I'm guessing there's no way to set certain apps to load on startup. I'd like to turn on the car and the radio app just turns on and plays, but it defaults to the the home screen and I have to load the radio app. I don't use the radio widget, I use the icon to bring up the full screen version of the radio. Once the radio app is running, I have a habit of hitting the back button and it turns the radio app off. So I have to get used to hitting the home button after I load it so it goes back to the home screen.

    I'm still waiting on my S8 Pro to arrive but I was looking through a thread for must have apps for android head units and this comment suggested AutoStart - No root. Hopefully this helps you, or it looks like there's plenty on the Play Store to try out.
    2
    IThoughts
    Theres a lot of praise for atoto which there should be, this device is much smoother than the A6 and i would say even better value for money if you can get it cheap and sell your A6. However there a few issues that i managed to find in just 30 minutes. BUT damn, this thing is quick, and only £60 more than the A6 sometimes. I dont think ill upgrade again. hopefully i can sell the A6 for a good enough amount to cover the cost of this upgrade.

    1) Z LINK - this does not work well with android auto (ironic this an android head unit). There is a DPI issue, spotify icon does not scale properly, whether thats my p30 pro or the app i am not sure yet. Right hand side does not work for us in the UK, always showing left hand side arrangement.

    2) finger gestures - we should be able to choose this but minor in the grand scheme

    3) AUDIO - oh audio, so much promise. Can definitely be fixed with software updates tho. other asked for help in setting a nice eq setting, so far a smooth v shape from +5 at the low, 0 at the mids and +6 at the high is doing well. There is a catch, turn off audio delay ( the distances are too small to make a difference imo and makes it sound weird, comes set up for left and side tho i believe).
    Subwoofer RCA is 0.8v so be aware. I am not sure how to even amplify such a small signal

    4) in car calls - The new system is SICK. with all the reviews ive seen, i cannot stress how good the s8 handles calls. new pop up is small and out of the way, can pick up and hang up like usual. On top of that you can change weather you want handset or car audio if you want to make a private call! and lastly, floating number pad!!

    5) horsepower - since Z link is for me subpar with AA, i am using headunit reloaded. The a6 could barely handle 720p and it had to be done with software. now i run AA at 720p with hardware acceleration! buttery smooth, feels like it was design by a name brand. I will use Zlink for car play but HUR for AA.

    6) some of my contacts were also delete -_- (Fix: turn off sync for contacts. then roll back changes to your account and hour or to yesterday)