• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

ATTN: Backup your boot0 block today

Search This thread

Hashcode

Senior Recognized Developer
Sep 3, 2011
3,426
23,731
ATTENTION: PUBLIC SERVICE ANNOUNCEMENT

It has come to my attention that under certain circumstances when the Kindle HD's get stuck in a bootloader bootloop the information on the "boot0" block of the internal storage can be ERASED and RESET.

This partition is special and contains ALL of your device's hardware specific information:
- Wifi MAC address + Encoded Secret for registering w/ Amazon services
- BT MAC address
- Serial #
etc

FOR BACKING UP THIS PARTITION:
Code:
adb shell su -c "dd if=/dev/block/mmcblk0boot0 of=/sdcard/boot0block.img"
adb pull /sdcard/boot0block.img

Place the "boot0block.img" file with the other files that you backed up in the original instructions for safe keeping.


FOR RESTORING THIS PARTITION:
(do not do this unless you are absolutely SURE that your boot0 block got wiped out -- hopefully you never need to)
This is done via adb from your PC while the device is in TWRP recovery or in the Android OS (not fastboot):

Code:
cd <your safekeeping files>
adb push boot0block /sdcard/boot0block.img
adb shell "echo 0 > /sys/block/mmcblk0boot0/force_ro; dd if=/sdcard/boot0block.img of=/dev/block/mmcblk0boot0;"

THIS FILE IS UNIQUE TO YOUR DEVICE AND CANNOT BE REPLACED OR REBUILT FROM ANOTHER DEVICE. DO NOT SHARE IT WITH ANYONE AS IT CONTAINS INFORMATION ABOUT YOUR DEVICE USED BY AMAZON DURING REGISTRATION.
 

seokhun

Senior Member
Feb 23, 2013
325
225
Odd, I can't seem to find the file after I pulled it with ADB.

EDIT: I didn't even assign the command an output location to begin with. LOL.
 
Last edited:

esox_hu

Senior Member
Dec 16, 2010
51
4
Thanks for the info.
How can I access KFHD via ADB if CM10.1 installed.
I can't see my device in device manager only as a media storage or sth like that.
Should I remove KFHD adb driver and install the google driver?

Or just using the hidden trick in cm10.1?
"Enable Developer options in your phone (Settings > About phone and tap Build Number until you are a developer (about 7 times)
Set root access for APPS and ADB in: Settings > Developer Options > Root Access
Enable Android debugging at the same page (Developer Options). Enable ADB over network if you need.
Check if your Settings > Security > Unknown Sources is checked. you will need it to install over ADB."

Yeah...it helped :)
 
Last edited:

seokhun

Senior Member
Feb 23, 2013
325
225
Thanks for the info.
How can I access KFHD via ADB if CM10.1 installed.
I can't see my device in device manager only as a media storage or sth like that.
Should I remove KFHD adb driver and install the google driver?

Or just using the hidden trick in cm10.1?
"Enable Developer options in your phone (Settings > About phone and tap Build Number until you are a developer (about 7 times)
Set root access for APPS and ADB in: Settings > Developer Options > Root Access
Enable Android debugging at the same page (Developer Options). Enable ADB over network if you need.
Check if your Settings > Security > Unknown Sources is checked. you will need it to install over ADB."

Yeah...it helped :)

Just turn on ADB debugging on the tablet, and plug it into the computer. On the computer, open command prompt, use the command "adb devices" to see if your ADB is working.

Other than that, I don't know what happened in your post.
 

AmrBanawan

Senior Member
Nov 26, 2012
245
43
Alexandria
Ok i really can't figure this one out, I used adb many times while testing KFFAide tool so I am 100% sure my adb drivers are installed correctly, But since i switched to cm10.1 (Thanks hashcode) ADB cannot recognize my device anymore, I have enabled ADB on my KFHD and when i connect it to my pc a small notification appears "Android debugging enabled" but when i use "adb devices" command nothing shows up!

Can anyone help me with this i'm completely lost here!
 

seokhun

Senior Member
Feb 23, 2013
325
225
Ok i really can't figure this one out, I used adb many times while testing KFFAide tool so I am 100% sure my adb drivers are installed correctly, But since i switched to cm10.1 (Thanks hashcode) ADB cannot recognize my device anymore, I have enabled ADB on my KFHD and when i connect it to my pc a small notification appears "Android debugging enabled" but when i use "adb devices" command nothing shows up!

Can anyone help me with this i'm completely lost here!

Leave the device plugged in, go to Developer Setting and uncheck ADB debugging, then check it again. You should see a prompt, select OK for both.
 

xxsurfacexx

Member
Dec 11, 2012
40
12
Thanks for the heads up hash, got it on a usb stick now

---------- Post added at 11:41 PM ---------- Previous post was at 11:39 PM ----------

Yeah I actually have the same problem too now :eek:

I had to manually check android debugging and usb debugging notify and it worked just fine.... make sure adb over network is not checked
 

theProtomartyr

Senior Member
Mar 9, 2013
295
120
Houston
Why don't you guys try this, go into CMD while connected with the device (ADB debugging on), and type "adb devices" to start the daemon, then try the commands. Other than that, I don't know what else to do.

Nope. Just get "List of Devices Attached" but no serial number. Checked device manager and it's showing up as a portable device. Probably will reinstall them and see if that solves it.

On a side note:
if we ran these commands in terminal emulator on the device, would that be sufficient?
 

AmrBanawan

Senior Member
Nov 26, 2012
245
43
Alexandria
Nope. Just get "List of Devices Attached" but no serial number. Checked device manager and it's showing up as a portable device. Probably will reinstall them and see if that solves it.

On a side note:
if we ran these commands in terminal emulator on the device, would that be sufficient?

Yes
run the first command then pull it manually

But we need to know what's going on, i will need adb sometime soon when prokennexusa releases the next version of KFFAide
 

dugoy13

Senior Member
Nov 21, 2012
132
31
Cainta
How do we know the boot0 partition is erased?

Sent from a Kindle Fire HD running CM10.1 using Tapatalk 2
 

bro1

Senior Member
Nov 29, 2010
57
3
had same probs on cm10 getting the files no matter what i tried.in windows 7 and xp it wouldnt install normal driver so i could see kindle as a drive so flashed an amazon zip and pc recognizes it without any problems and now have the files needed :p
 

PaulJCW

Member
Feb 23, 2013
18
1
I can't get ADB to find it either, think i'll revert back to stock to get the file then go back to CM - I notice though on CM turning USB Debugging on doesn't change anything in device manager, it still stays connected as a media device or camera, depending on which you have ticked in storage setting *shrugs*

Thank you Hashcode
 

AmrBanawan

Senior Member
Nov 26, 2012
245
43
Alexandria
I can't get ADB to find it either, think i'll revert back to stock to get the file then go back to CM - I notice though on CM turning USB Debugging on doesn't change anything in device manager, it still stays connected as a media device or camera, depending on which you have ticked in storage setting *shrugs*

Thank you Hashcode

No don't, just type the command hashcode provided in terminal emulator and you'll find the backup in your sdcard, just copy it to your pc like normal!
 

drugfreejonnyxxx

Senior Member
Dec 23, 2012
90
27
You can do it from the terminal without typing ADB. that may be why people are confused. Start with hashcodes command but start with "su -c" in the terminal.

Sent from my Nexus S 4G using xda app-developers app
 

Top Liked Posts

  • There are no posts matching your filters.
  • 19
    ATTENTION: PUBLIC SERVICE ANNOUNCEMENT

    It has come to my attention that under certain circumstances when the Kindle HD's get stuck in a bootloader bootloop the information on the "boot0" block of the internal storage can be ERASED and RESET.

    This partition is special and contains ALL of your device's hardware specific information:
    - Wifi MAC address + Encoded Secret for registering w/ Amazon services
    - BT MAC address
    - Serial #
    etc

    FOR BACKING UP THIS PARTITION:
    Code:
    adb shell su -c "dd if=/dev/block/mmcblk0boot0 of=/sdcard/boot0block.img"
    adb pull /sdcard/boot0block.img

    Place the "boot0block.img" file with the other files that you backed up in the original instructions for safe keeping.


    FOR RESTORING THIS PARTITION:
    (do not do this unless you are absolutely SURE that your boot0 block got wiped out -- hopefully you never need to)
    This is done via adb from your PC while the device is in TWRP recovery or in the Android OS (not fastboot):

    Code:
    cd <your safekeeping files>
    adb push boot0block /sdcard/boot0block.img
    adb shell "echo 0 > /sys/block/mmcblk0boot0/force_ro; dd if=/sdcard/boot0block.img of=/dev/block/mmcblk0boot0;"

    THIS FILE IS UNIQUE TO YOUR DEVICE AND CANNOT BE REPLACED OR REBUILT FROM ANOTHER DEVICE. DO NOT SHARE IT WITH ANYONE AS IT CONTAINS INFORMATION ABOUT YOUR DEVICE USED BY AMAZON DURING REGISTRATION.
    3
    Go to your apps on your kindle, open up a terminal emulator, type the command from my screenshot on this post. After pressing enter open a file manager and browse to /sdcard you'll see a file named boot0block.img .... Copy to your pc.

    sent from Cm10.1 on KindleFireHD 7"
    2
    How do we know the boot0 partition is erased?

    Sent from a Kindle Fire HD running CM10.1 using Tapatalk 2

    Normally you would notice WiFi doesn't work under any circumstances same for BT. And when on Amazon's software it won't let you register.

    Sent from my Amazon Kindle Fire HD using Tapatalk 2
    2
    Have you tried drugfreejonnyxxx method 2 posts up? (i.e. entering the commands in a terminal window)
    Does it execute the "su" command there?
    1
    Yeah I actually have the same problem too now :eek:

    Ok thanks i tried but to no avail :(

    Why don't you guys try this, go into CMD while connected with the device (ADB debugging on), and type "adb devices" to start the daemon, then try the commands. Other than that, I don't know what else to do.