Audio Bug Fix [MM][LOLLIPOP][MIUI]

Search This thread

phantom97

Member
Nov 30, 2014
46
23
The audio bug on our devices which cause the music to stutter and pause can be fixed by a very simple hack. You just have to download a kernel tweaking app, preferably kernel adiutor, and disable hotplugs from the hotplugs section. And manually enable two or more cores and voila music will never lag from now on!!!( even with viper4android or audiofx switched on :D:D:D:D:D:D). Also you can preferably use AwesomePlayer instead of nuPlayer. This setting can be switched in Developer Options. For cm13 with default kernel you need to enable audio offload in the build.prop file in system directory.

Alternative / better method
Credits
@fefifofum
add this line to /system/build.prop
ro.qualcomm.perf.cores_online=2

Thanks @vicky romero
 

Attachments

  • Screenshot_2016-06-02-14-44-31.png
    Screenshot_2016-06-02-14-44-31.png
    87.3 KB · Views: 2,671
  • Screenshot_2016-06-02-14-44-36.png
    Screenshot_2016-06-02-14-44-36.png
    46.1 KB · Views: 2,612
  • Screenshot_2016-06-02-14-35-11.png
    Screenshot_2016-06-02-14-35-11.png
    104.1 KB · Views: 2,625
Last edited:

vhick

Senior Member
Feb 13, 2012
626
123
Antipolo City
Great! I will try it later and give you feedback.

Have a question, about awesomeplayer. I never find it in my current rom. What rom do you use?
 

IvanX9

Senior Member
Feb 22, 2013
59
10
I'll follow this thread. It really interests me. I look forward to your reviews

Enviado desde mi HM 1SW mediante Tapatalk
 
  • Like
Reactions: phantom97

vhick

Senior Member
Feb 13, 2012
626
123
Antipolo City
It's a Developer Options

I'm using Dirty Unicorn 10.2 but I never find that option in developers option as see in screenshot.

I cannot use custom kernel until some issues that I've experienced has been fix. So this feedback is for default kernel of DU.

I removed media storage in "don't optimize" state. I cannot retain to use only two cores because it dynamically change, so the only option that I change is mpdecision. I disabled mpdecision, I also use PowerAmp and enabled "use wakelock" under mics tweaks, then reboot.

I've surprised that I don't experienced annoying audio bug. I don't know the impact in battery but I really happy with the result.

This is initial because I've plan to use custom kernel and I will do this again if will replicate the result. Still, I'll give feedback in the future.

Thanks for the fix.
 

Attachments

  • Screenshot_20160602-202424.png
    Screenshot_20160602-202424.png
    87 KB · Views: 615
  • Like
Reactions: phantom97

IvanX9

Senior Member
Feb 22, 2013
59
10
I use Mokee 5.1 Lollipop (History versión) with STOCK kernel and I never face the music bug.
Nevertheless I know that changing into a custom kernel will bring me along the music bug.... That's why I want to know If this hack really works fine with custom kernels.
If it does for you, say Rom and Kernel, please. Thank you.


Enviado desde mi ifiveMini4 mediante Tapatalk
 

ipoel

Member
Nov 9, 2010
27
6
Jakarta
I'm using Dirty Unicorn 10.2 but I never find that option in developers option as see in screenshot.

I cannot use custom kernel until some issues that I've experienced has been fix. So this feedback is for default kernel of DU.

I removed media storage in "don't optimize" state. I cannot retain to use only two cores because it dynamically change, so the only option that I change is mpdecision. I disabled mpdecision, I also use PowerAmp and enabled "use wakelock" under mics tweaks, then reboot.

I've surprised that I don't experienced annoying audio bug. I don't know the impact in battery but I really happy with the result.

This is initial because I've plan to use custom kernel and I will do this again if will replicate the result. Still, I'll give feedback in the future.

Thanks for the fix.

There isn't awesome player option on MM Rom. The awesome player option only exist on Lollipop Rom. I think the problem is on mpdecison cause I only change/disable mpdecision using kernel adiutor and the music bug is definitely gone.
 
Last edited:
  • Like
Reactions: phantom97

ateeq72

Senior Member
Dec 28, 2011
319
304
Chennai
OnePlus 7
This seems to work!! Oh.. man finally something which works.. but doing what the OP says to do so makes the phone a little bit hotter. But atleast the issue is gone! Thanks Bro! :D :D :highfive:
 
Last edited:

phantom97

Member
Nov 30, 2014
46
23
This seems to work!! Oh.. man finally something which works.. but doing what the OP says to do so makes the phone a little bit hotter. But atleast the issue is gone! Thanks Bro! :D :D :highfive:
Try setting the max frequency to 300Mhz if you are only using your phone for audio. Btw nice signature :p
 

iam_babloo

New member
Jun 16, 2016
2
0
The audio bug on our devices which cause the music to stutter and pause can be fixed by a very simple hack. You just have to download a kernel tweaking app, preferably kernel adiutor, and disable hotplugs from the hotplugs section. And manually enable two or more cores and voila music will never lag from now on!!!( even with viper4android or audiofx switched on :D:D:D:D:D:D). Also you can preferably use AwesomePlayer instead of nuPlayer. This setting can be switched in Developer Options. For cm13 with default kernel you need to enable audio offload in the build.prop file in system directory.

tq brother i followed ur method music lag is no more on my redmi 1s , actually iam using xsop 6.1 rom with god's kernal music lag is not there ... tq so much ......
 

ateeq72

Senior Member
Dec 28, 2011
319
304
Chennai
OnePlus 7
Try setting the max frequency to 300Mhz if you are only using your phone for audio. Btw nice signature :p

For now, I have added the code provided by @fefifofum in his thread to build.prop, you know the one which makes MPDecision to keep two cores always on. That kinda fixed the Audio bug :highfive: . But, the heating issue is still there though. But, that aint no big deal for me now!. So, :highfive:

And, Thanks! :D :cowboy:
 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    The audio bug on our devices which cause the music to stutter and pause can be fixed by a very simple hack. You just have to download a kernel tweaking app, preferably kernel adiutor, and disable hotplugs from the hotplugs section. And manually enable two or more cores and voila music will never lag from now on!!!( even with viper4android or audiofx switched on :D:D:D:D:D:D). Also you can preferably use AwesomePlayer instead of nuPlayer. This setting can be switched in Developer Options. For cm13 with default kernel you need to enable audio offload in the build.prop file in system directory.

    Alternative / better method
    Credits
    @fefifofum
    add this line to /system/build.prop
    ro.qualcomm.perf.cores_online=2

    Thanks @vicky romero
    2
    those who are using custom kernel, set 2 core max when screen off in hotplug setting
    you will good to go
    1
    I'll follow this thread. It really interests me. I look forward to your reviews

    Enviado desde mi HM 1SW mediante Tapatalk
    1
    It's a Developer Options

    I'm using Dirty Unicorn 10.2 but I never find that option in developers option as see in screenshot.

    I cannot use custom kernel until some issues that I've experienced has been fix. So this feedback is for default kernel of DU.

    I removed media storage in "don't optimize" state. I cannot retain to use only two cores because it dynamically change, so the only option that I change is mpdecision. I disabled mpdecision, I also use PowerAmp and enabled "use wakelock" under mics tweaks, then reboot.

    I've surprised that I don't experienced annoying audio bug. I don't know the impact in battery but I really happy with the result.

    This is initial because I've plan to use custom kernel and I will do this again if will replicate the result. Still, I'll give feedback in the future.

    Thanks for the fix.
    1
    this is working for all roms starting from kitkat to nougat