banking app detecting root

Search This thread

Thomas.swe

Member
Jan 29, 2022
7
0
I tried the previous version and now this one, still the same. I'm in no hurry to fix it, all other stuff work and the old bankid solution works 2 more years I think (hope)
 

tsnake

Member
Aug 8, 2010
13
0
I'm in your exact same position.
I have the MagiskHide module and used the DenyList, I also tried Shamiko, no luck for this app.
I tried the modified USNF module and no luck either.

I have several other apps where the above methods to avoid detection are working without problems, but not this one.
 

jale

Senior Member
In the same boat as you guys. Also tried the modified magisk delta project with the old magisk hide, no luck.

SafetyNet is good, all other banking-and wallet-apps is working. RootBeer is not detecting root.

Oneplus 7t pro, stock latest stable rom. Magisk delta. Hide root from all apps. Renamed magisk app.
 
Last edited:

DankDaddy

New member
Aug 24, 2022
2
0
same problem here. tried everything i could find and no luck. might be a DRM problem? because 1 other issue i cant fix is apps like Netflix and prime video which are currently unusable because of DRM.
 

jale

Senior Member
My app was updated today, and immidiatly after the update I tried activating/logging in, and to my surprise it worked. There is a one hour grace/waiting period to activate, and I'm currently waiting for that.
If it is not working after the wait, I will update this post. So if no update, it is working.

See my previous post in this thread about my setup.
 

DankDaddy

New member
Aug 24, 2022
2
0
My app was updated today, and immidiatly after the update I tried activating/logging in, and to my surprise it worked. There is a one hour grace/waiting period to activate, and I'm currently waiting for that.
If it is not working after the wait, I will update this post. So if no update, it is working.

See my previous post in this thread about my setup.
same for me. so its probably okay for everyone for now. disable auto update on it now hahaha and lets hope it stays that way.
 

tsnake

Member
Aug 8, 2010
13
0
Can confirm, it works now without any change to Magisk or other modules.
I waited the 1h period and after that I was able to activate it and use it to login.

I am using Shamiko and a modified USNF module, but probably are not required.