Baseband Unknown and IMEI Null NOW WORKING

Search This thread

karlonicolas

Senior Member
Sep 18, 2010
281
32
Just sharing my experience in solving this issue. Hopefully it will help solve those who have similar issues.

I flashed a file which messed up my EFS partition. I had a backup and tried to use the available programs to restore my EFS using my backup. None worked. I even brought it to the samsung store, but they said they would change the motherboard and reprogram, and replacement and service would cost more than half the cost of a new N7105. I purchased the phone in another country. The people who had stores to repair phones gave up on my phone. They also offered to replace the motherboard for US$175.00.


My phone was originally under a DMB2 rom (from Singapore I think). I flashed a DMC3 rom, and used this for five months, until i encountered the problem.

I initially gave up and got a note 3. But i could not believe the phone was junk and people in XDA (as I observed) do not seem to give up.

After two weeks, i found the solution below, which brought my phone to working condition.


1. I flashed the stock rom N7105ZHDMI2_N7105ZZHDMI2_TGY from sammobile.

2. I flashed a pit file using Odin. The pit file is found here:

http://forum.xda-developers.com/showthread.php?t=2137008

This restored the baseband. But IMEI was no longer NULL. However, it was still 0.

3. I downloaded and used the EFS Pro from this link:

http://forum.xda-developers.com/showthread.php?t=1308546

Before using EFS Pro, make sure you dial *#7284# and change the setting of Qualcomm USB Settings to

"RMNET + DM + MODEM"

I will not hurt your phone if you do, but EFS Pro will just not work. If you don't do this, the EFS Pro will display "Phone not responding" or something similar.

NOTE: I couldn't find the option with RMNET, but i used the option that also had an "RM*** + DM + MODEM".

After the phone is read, change back the IMEI to what it was originally.

Dial *#7284# again to change back to "MTP+ADB".

It's all working now.


Hope this is able to help someone. Now i have two working versions of Note.

Thanks to the authors of the program i used, and the people who uploaded the files used.

Cheers!
 

karlonicolas

Senior Member
Sep 18, 2010
281
32
I lost my imei again after tinkering, so i went back to this post, followed the procedure and it worked again.

hope this will save somebody's phone also.
 

colman1982

Senior Member
Jul 21, 2010
77
5
I treid to use EFS Pro, but when I push the connect button, it says connection was lost and the program crash and ask me to restart it.
What am I doing wrong?
 

Miaxus

Senior Member
Jun 12, 2013
81
1
Just sharing my experience in solving this issue. Hopefully it will help solve those who have similar issues.

I flashed a file which messed up my EFS partition. I had a backup and tried to use the available programs to restore my EFS using my backup. None worked. I even brought it to the samsung store, but they said they would change the motherboard and reprogram, and replacement and service would cost more than half the cost of a new N7105. I purchased the phone in another country. The people who had stores to repair phones gave up on my phone. They also offered to replace the motherboard for US$175.00.


My phone was originally under a DMB2 rom (from Singapore I think). I flashed a DMC3 rom, and used this for five months, until i encountered the problem.

I initially gave up and got a note 3. But i could not believe the phone was junk and people in XDA (as I observed) do not seem to give up.

After two weeks, i found the solution below, which brought my phone to working condition.


1. I flashed the stock rom N7105ZHDMI2_N7105ZZHDMI2_TGY from sammobile.

2. I flashed a pit file using Odin. The pit file is found here:

http://forum.xda-developers.com/showthread.php?t=2137008

This restored the baseband. But IMEI was no longer NULL. However, it was still 0.

3. I downloaded and used the EFS Pro from this link:

http://forum.xda-developers.com/showthread.php?t=1308546

Before using EFS Pro, make sure you dial *#7284# and change the setting of Qualcomm USB Settings to

"RMNET + DM + MODEM"

I will not hurt your phone if you do, but EFS Pro will just not work. If you don't do this, the EFS Pro will display "Phone not responding" or something similar.

NOTE: I couldn't find the option with RMNET, but i used the option that also had an "RM*** + DM + MODEM".

After the phone is read, change back the IMEI to what it was originally.

Dial *#7284# again to change back to "MTP+ADB".

It's all working now.


Hope this is able to help someone. Now i have two working versions of Note.

Thanks to the authors of the program i used, and the people who uploaded the files used.

Cheers!

So did you solve it without an EFS backup or I misunderstood?
 

sora9009

Senior Member
Jun 29, 2013
338
160
after dialing *#7284#
 

Attachments

  • Screenshot_2013-12-16-22-00-22.png
    Screenshot_2013-12-16-22-00-22.png
    62.7 KB · Views: 5,207

colman1982

Senior Member
Jul 21, 2010
77
5
So did you solve it without an EFS backup or I misunderstood?

EFS backup is not enough on N7105. The IMEI is stored somewhere else. EFS Pro can backup IMEI from Nvram and restore it.

It is also suppose to write IMEI to the phone, but I never manage to connect it to my phone.

Sent from my GT-I9505 using Tapatalk
 

sir273

Member
Dec 10, 2013
8
0
Same problem facing but i have this on my GT N7100 ???????

I`m also facing the same problem from few months but in my case it has been repaired by the repairing shop in only 5$ , and they said me that the has done this by some uart tools. But when i gets unrooted by flashing stock or any firmware my note 2`s IMEI gets zero. So i cant stay unrooted and every time I`ve to go back to that repairing shop. So i just wants to know that is this helps to fix this problem permanently . Imeant i just want to stay unrooted after facing all shorts of complications. Plz help
 

onedirection

Member
Dec 16, 2013
46
53
After dialing *#7284#

after dialing *#7284#
yeah I got the same with you after dialing *#7284#. It shows 2 radio buttons of UART (MODEM, PDA), and 2 radio buttons of USB (MODEM, PDA). How to solve this thing?? I got my IMEI messed up too.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

HIT THANKS IF I HELPED YOU :good:

Device that I'm using right now: Samsung GALAXY Note II International N7100
Firmware: Latest Android 4.3 N7100XXUEMK4 with KNOX Bootloader *NO!!!, somebody please help me remove this idiot BL*
Recovery: CWMR Philz Touch v6
Root: Hell yeah, of course! :cool:

One Direction is on XDA-Developers! Note: This 1D XDA account is run by one of official 1D crew, NOT those five singers!
 
  • Like
Reactions: TheNotWowDev

karlonicolas

Senior Member
Sep 18, 2010
281
32
after dialing *#7284#

there's supposed to be an option "qualcomm USB settings" after hitting *#7284#. have you tried scrolling down. i recall it was below the "save and reset button"

perhaps your chipset is Exynos. i have tried this only for note 2 lte which has qualcomm.

otherwise, you current modem may be different. perhaps you can flash the modem from DMC3 using odin, reboot, and follow the steps again.

the "qualcomm USB settings" should be similar to the one below (i said similar, because the image below is for S4 not Note 2 LTE)


howto-enable-tmobile-aws-bands-on-att-galaxys4-sgh-i337-4-690x380.jpg
 
Last edited:

karlonicolas

Senior Member
Sep 18, 2010
281
32
I treid to use EFS Pro, but when I push the connect button, it says connection was lost and the program crash and ask me to restart it.
What am I doing wrong?

this happened to me also in the process of fixing. i suppose you configured correctly the Qualcomm USB settings, right? using the option with RM***NET...?

What computer OS are you using?

i was able to fix the phone using Windows XP. Also i downloaded all the USB drivers as required in the EFS Pro link.

"Make sure you have Microsoft .NET Framework v4.0 installed on your PC." it also says in the post.

I also turned off Kies. There was also a note to turn off all programs that use ADB.

Good luck!
 

sora9009

Senior Member
Jun 29, 2013
338
160
there's supposed to be an option "qualcomm USB settings" after hitting *#7284#. have you tried scrolling down. i recall it was below the "save and reset button"

perhaps your chipset is Exynos. i have tried this only for note 2 lte which has qualcomm.

otherwise, you current modem may be different. perhaps you can flash the modem from DMC3 using odin, reboot, and follow the steps again.

the "qualcomm USB settings" should be similar to the one below (i said similar, because the image below is for S4 not Note 2 LTE)


howto-enable-tmobile-aws-bands-on-att-galaxys4-sgh-i337-4-690x380.jpg


international n7100 use exynos mate
 

colman1982

Senior Member
Jul 21, 2010
77
5
this happened to me also in the process of fixing. i suppose you configured correctly the Qualcomm USB settings, right? using the option with RM***NET...?

What computer OS are you using?

i was able to fix the phone using Windows XP. Also i downloaded all the USB drivers as required in the EFS Pro link.

"Make sure you have Microsoft .NET Framework v4.0 installed on your PC." it also says in the post.

I also turned off Kies. There was also a note to turn off all programs that use ADB.

Good luck!

I did configure the Qualcomm USB settings. I use windows 8 64 bit. It crashed with some framework error also. Windows 8 says framework is already installed. I will try next year on my windows 7 64 bit computer.

Sent from my GT-I9505 using Tapatalk
 

colman1982

Senior Member
Jul 21, 2010
77
5
I sent my phone to service and it came back with new mother board and update software to 4.3.

I now manage to make backup with EFS pro on windows 7 64 bit. Just in case.

Sent from my GT-N7105 using Tapatalk
 

Martins2040

Member
Feb 3, 2014
8
3
Just sharing my experience in solving this issue. Hopefully it will help solve those who have similar issues.

I flashed a file which messed up my EFS partition. I had a backup and tried to use the available programs to restore my EFS using my backup. None worked. I even brought it to the samsung store, but they said they would change the motherboard and reprogram, and replacement and service would cost more than half the cost of a new N7105. I purchased the phone in another country. The people who had stores to repair phones gave up on my phone. They also offered to replace the motherboard for US$175.00.


My phone was originally under a DMB2 rom (from Singapore I think). I flashed a DMC3 rom, and used this for five months, until i encountered the problem.

I initially gave up and got a note 3. But i could not believe the phone was junk and people in XDA (as I observed) do not seem to give up.

After two weeks, i found the solution below, which brought my phone to working condition.


1. I flashed the stock rom N7105ZHDMI2_N7105ZZHDMI2_TGY from sammobile.

2. I flashed a pit file using Odin. The pit file is found here:

http://forum.xda-developers.com/showthread.php?t=2137008

This restored the baseband. But IMEI was no longer NULL. However, it was still 0.

3. I downloaded and used the EFS Pro from this link:

http://forum.xda-developers.com/showthread.php?t=1308546

Before using EFS Pro, make sure you dial *#7284# and change the setting of Qualcomm USB Settings to

"RMNET + DM + MODEM"

I will not hurt your phone if you do, but EFS Pro will just not work. If you don't do this, the EFS Pro will display "Phone not responding" or something similar.

NOTE: I couldn't find the option with RMNET, but i used the option that also had an "RM*** + DM + MODEM".

After the phone is read, change back the IMEI to what it was originally.

Dial *#7284# again to change back to "MTP+ADB".

It's all working now.


Hope this is able to help someone. Now i have two working versions of Note.

Thanks to the authors of the program i used, and the people who uploaded the files used.

Cheers!


Hello, I am on my way to try this, since i dont have a Baseband or IMEI. (started with no service, signal at all on stock, now im custom, still nothing).

But step 1 is that with the recovery, since it wont accept my N7105XXUEMK9_N7105DNFEMK2_DNF.zip ?
ODIN wont see it in download mode. Perhaps its my recovery (Philz ver 6.12. with cwm 6.0.4.7.).?? :confused:
 

osirls

Senior Member
Mar 12, 2008
63
6
I'm trying to restore my IMEI but having followed all the steps, I get "IMEI written successfully" but if I re-read the IMEI or look on the phone (even after rebooting) the IMEI has not changed.

Any ideas?
 

activic

Member
Mar 3, 2008
7
0
I am trying with n5120 from 2 months but no use Imei null
needs newboard I guess
bst dongle useless
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Just sharing my experience in solving this issue. Hopefully it will help solve those who have similar issues.

    I flashed a file which messed up my EFS partition. I had a backup and tried to use the available programs to restore my EFS using my backup. None worked. I even brought it to the samsung store, but they said they would change the motherboard and reprogram, and replacement and service would cost more than half the cost of a new N7105. I purchased the phone in another country. The people who had stores to repair phones gave up on my phone. They also offered to replace the motherboard for US$175.00.


    My phone was originally under a DMB2 rom (from Singapore I think). I flashed a DMC3 rom, and used this for five months, until i encountered the problem.

    I initially gave up and got a note 3. But i could not believe the phone was junk and people in XDA (as I observed) do not seem to give up.

    After two weeks, i found the solution below, which brought my phone to working condition.


    1. I flashed the stock rom N7105ZHDMI2_N7105ZZHDMI2_TGY from sammobile.

    2. I flashed a pit file using Odin. The pit file is found here:

    http://forum.xda-developers.com/showthread.php?t=2137008

    This restored the baseband. But IMEI was no longer NULL. However, it was still 0.

    3. I downloaded and used the EFS Pro from this link:

    http://forum.xda-developers.com/showthread.php?t=1308546

    Before using EFS Pro, make sure you dial *#7284# and change the setting of Qualcomm USB Settings to

    "RMNET + DM + MODEM"

    I will not hurt your phone if you do, but EFS Pro will just not work. If you don't do this, the EFS Pro will display "Phone not responding" or something similar.

    NOTE: I couldn't find the option with RMNET, but i used the option that also had an "RM*** + DM + MODEM".

    After the phone is read, change back the IMEI to what it was originally.

    Dial *#7284# again to change back to "MTP+ADB".

    It's all working now.


    Hope this is able to help someone. Now i have two working versions of Note.

    Thanks to the authors of the program i used, and the people who uploaded the files used.

    Cheers!
    1
    After dialing *#7284#

    after dialing *#7284#
    yeah I got the same with you after dialing *#7284#. It shows 2 radio buttons of UART (MODEM, PDA), and 2 radio buttons of USB (MODEM, PDA). How to solve this thing?? I got my IMEI messed up too.

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    HIT THANKS IF I HELPED YOU :good:

    Device that I'm using right now: Samsung GALAXY Note II International N7100
    Firmware: Latest Android 4.3 N7100XXUEMK4 with KNOX Bootloader *NO!!!, somebody please help me remove this idiot BL*
    Recovery: CWMR Philz Touch v6
    Root: Hell yeah, of course! :cool:

    One Direction is on XDA-Developers! Note: This 1D XDA account is run by one of official 1D crew, NOT those five singers!