• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Battery drain with bad LTE signal but with Wifi on?

Search This thread

Utini

Senior Member
Dec 25, 2010
1,167
214
www.whymacsucks.com
www.whymacsucks.com
Hello everyone,
on my companies area I have a really bad phone signal (LTE). How ever, I am constantly connected to my companies WIFI.
I now wonder if being connected to the WIFI will reduce battery drain due to low LTE signal?
I was hoping that the phone then only needs to search for better reception if the signal for phone calls (bot not internet) goes completely off?

Another solution would be to use Tasker to switch to my company SIM with full signal strenght (I am using dual SIM) for data/internet when on my companies area.
In any case, my private SIM will still always have bad signal but will be active for phone calls. However, my data reception will be very good (while I am still also connected to WIFI).
Just looking for the best solution in terms of battery drain.

Thanks!
 

miravision

Senior Member
Oct 5, 2021
278
154
VoWifi is a boon for low cellular coverage area usage while saving battery life on WIFI and still being available for phone calls. Ask your provider for specifics
 
Last edited:

miravision

Senior Member
Oct 5, 2021
278
154
Yes, in fact you can enable Airplane Mode which switches off all radios, turn on wifi radio manually to enjoy great battery life and VoWifi calls.
 
  • Like
Reactions: roirraW "edor" ehT

miravision

Senior Member
Oct 5, 2021
278
154
Even without VoWifi you can save battery life by manually switching to 3G or even 2G for calls while using high speed data on wifi

Your carrier must support VoWifi to be seen as an option on your device.
Here is a list of US carriers that use the newer advanced Vo technologies:

T-Mobile
– VoLTE: Yes
– VoWiFi: Yes


AT&T
– VoLTE: Yes
– VoWiFi: No


Verizon
– VoLTE: Yes
– VoWiFi: No


Sprint
– VoLTE: Yes
– VoWiFi: Yes
 

Utini

Senior Member
Dec 25, 2010
1,167
214
www.whymacsucks.com
www.whymacsucks.com
I am from Europe so I use a different carrier. That carrier has VoLTE and VoWiFi enabled.
How ever, it seems like the carrier also has to approve each specific devices to be allowed to use VoWiFi.

As the P6P is not being officially sold in my country, I suspect that my carrier doesn't have my device on their whitelist :/
 

miravision

Senior Member
Oct 5, 2021
278
154
VoLTE/VoWiFi Activation
It is mandatory to have your Pixel rooted with Magisk to install this module. Make sure that Magisk is installed properly on your system, then proceed with these steps:

Install this module (Zip file) on Magisk and reboot the system.
After rebooting, the phone may be showing "No service" due to the parsing of new configurations, so please wait until the operator name showed up.
Go to Settings -> Network and Internet -> Mobile network and enable "Enhanced 4G LTE Mode" and "Wi-Fi calling".
Turn off Wi-Fi
Go to Phone -> dial *#*#4636#*#* -> Phone information tap at the top-right button, select "IMS Service Status".
Check if IMS Registration is Registered and Voice over LTE is Available then, congrats, you're succeeded.
(Voice over Wi-Fi will be activated upon the "Wi-Fi calling" option in 2.)

 
  • Like
Reactions: Utini

miravision

Senior Member
Oct 5, 2021
278
154
After rooting, try this with any terminal app like termux from f-droid
Code:
su
settings put global wfc_ims_mode 2

Toggle Airplane mode on and then off
Enable Wifi preferred toggle in settings
 
  • Like
Reactions: Utini

Utini

Senior Member
Dec 25, 2010
1,167
214
www.whymacsucks.com
www.whymacsucks.com
VoLTE/VoWiFi Activation
It is mandatory to have your Pixel rooted with Magisk to install this module. Make sure that Magisk is installed properly on your system, then proceed with these steps:

Install this module (Zip file) on Magisk and reboot the system.
After rebooting, the phone may be showing "No service" due to the parsing of new configurations, so please wait until the operator name showed up.
Go to Settings -> Network and Internet -> Mobile network and enable "Enhanced 4G LTE Mode" and "Wi-Fi calling".
Turn off Wi-Fi
Go to Phone -> dial *#*#4636#*#* -> Phone information tap at the top-right button, select "IMS Service Status".
Check if IMS Registration is Registered and Voice over LTE is Available then, congrats, you're succeeded.
(Voice over Wi-Fi will be activated upon the "Wi-Fi calling" option in 2.)


After rooting, try this with any terminal app like termux from f-droid
Code:
su
settings put global wfc_ims_mode 2

Toggle Airplane mode on and then off
Enable Wifi preferred toggle in settings

Thank you very much. I will probably root soon and will give it a try then. Although there is an github issue open which says that the module is not support by the Pixel 5.
Just a bit annoying that I would have to apply this after every OTA but I guess it's doable :)

I also talked to my carrier today. They are saying that only phones that are being sold by the carrier support VoWiFi as the phones OS needs special settings that are being provided by the carrier. That is why usually the Android updates from phones bought through our carriers come later than the official google updates (due to the carrier updating the OS himself first).
On the other hand it seems like google could integrate those "special" settings right out of the box.
How ever, google seems to say the carrier has to get in touch with them and start the procedure whole the carrier says that is google who has to take care of it by them self.

Since the phone signal for my SIM is really bad on my companies area but the WIFI is very good, this should then hopefully help a lot with battery drain.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Yes, in fact you can enable Airplane Mode which switches off all radios, turn on wifi radio manually to enjoy great battery life and VoWifi calls.
    1
    VoLTE/VoWiFi Activation
    It is mandatory to have your Pixel rooted with Magisk to install this module. Make sure that Magisk is installed properly on your system, then proceed with these steps:

    Install this module (Zip file) on Magisk and reboot the system.
    After rebooting, the phone may be showing "No service" due to the parsing of new configurations, so please wait until the operator name showed up.
    Go to Settings -> Network and Internet -> Mobile network and enable "Enhanced 4G LTE Mode" and "Wi-Fi calling".
    Turn off Wi-Fi
    Go to Phone -> dial *#*#4636#*#* -> Phone information tap at the top-right button, select "IMS Service Status".
    Check if IMS Registration is Registered and Voice over LTE is Available then, congrats, you're succeeded.
    (Voice over Wi-Fi will be activated upon the "Wi-Fi calling" option in 2.)

    1
    After rooting, try this with any terminal app like termux from f-droid
    Code:
    su
    settings put global wfc_ims_mode 2

    Toggle Airplane mode on and then off
    Enable Wifi preferred toggle in settings