• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Battery from 74% to 0% in 1 second

Search This thread

Allewar

Senior Member
May 3, 2013
261
121
Yesterday I experienced a weird behaviour...
I was using my Moto G and it was with 74% battery. I connected it to my macbook using the usb cable and when I disconnected it the battery instantly dropped to 0% and the phone turned off!

Screenshot_2013-11-26-15-28-21.png


After that I charged it again and so far so good. But I wonder what could have caused this behaviour?
I have never saw something like that before.
 
  • Like
Reactions: Sree.dhar

jojosch93

Member
Nov 6, 2012
17
4
I had the same problem a few hours ago. It suddenly dropped and shut down itself. I started the phone again and it is still at 1% since 5 hours. I guess this is related to a bad battery calibration because I've unplugged it during the first charge for a moment (I have the phone since yesterday).
 

TeamKilo

Member
Mar 9, 2012
42
2
LONDON
i used to have the exact same issue with my Galaxy S2. it would freeze and then reboot or i would have to force restart only to lose about 50% battery. when i sent it back to Samsung, i think they replaced a circuit inside.
 

theoneofgod

Senior Member
Dec 1, 2011
1,489
322
I could always get another. The issue may haunt the device over time, it's not worth it for such a day old phone.

Sent from my HUAWEI Y300-0100 using xda app-developers app
 
  • Like
Reactions: Sree.dhar

SilverScooby

New member
Dec 2, 2013
1
1
I had exactly the same issue yesterday.

I had the phone attached to my Win 7 laptop with USB cable (in USB debugging mode)
When I took the cable out the battery went from 52% to 0%.
I was using the white USB cable that came with the phone, have the official Motorola Device Manager which installed Motorola device drivers v 6.3.0. The USB ports are all v3.0

As this issue happened to 2 of us when detaching from USB ports, could something weird be happening like the phones battery is somehow being drained and trying to charge the laptop's battery? Or could the USB cable be faulty?
 
  • Like
Reactions: Sree.dhar

lost101

Inactive Recognized Contributor
May 30, 2008
7,434
9,332
I believe it is an adb / usb related bug in the stock firmware. A new rom will probably fix this. Unless someone wants to report it to Motorola.
 
Last edited:

mr_nooby

Senior Member
Jul 17, 2012
1,222
472
You guys should tweet it to Motorola on Twitter, it happened to 3 people already and they haven't yet released it in many countries

Sent from my One V using xda app-developers app
 

Jake Bullit

Senior Member
Dec 22, 2006
178
18
I bought mine yesterday from Tesco.It has been charging on my PC for 2 hours now ,and won`t power on.The battery isnt even warm.

Will leave it on till this afternoon,if its still not working I will have to return it.

EDIT
Just tried it on a colleagues Kindle charger and its charging OK.
 
Last edited:

rbtrrnss

New member
Dec 6, 2013
1
0
Hello there,
today i experienced the same issue, the battery dropped to 1% with no reason at all. It's not even charging anymore (I did restart it a few times).
I tend to replace it, but if this is a software bug, will this help at all?
 

mr_nooby

Senior Member
Jul 17, 2012
1,222
472
If you guys can get a logcat of it we can see if it's hardware or software. And send it to Motorola maybe.

Sent from my One V using xda app-developers app
 

Sn0opy

Senior Member
Aug 10, 2010
118
16
Just happened to me again. Phone was on for several hours and most of the time connected to my mobile battery. Phone was at 100% when I got home and turned off ~45 min after.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    from Motorola forum

    Update from Motorola:

    We know this is frustrating and apologize for the experience. We are working closely with Qualcomm to confirm root cause (which we believe is an intermittent error in a sensor measurement) and we are testing algorithm adjustments to filter out any spurious measurements. The phone is shutting down in these instances as a protection mechanism based on this incorrect measurement.

    All of the diagnostic data we've examined shows that the battery of your devices is okay - indeed this is why you can continue to use the phone at "1%" - because the battery still is really charged at whatever level before the abrupt drop.

    We are testing this adjustment now (better filtering) for the next system update. We know this is frustrating, both for the folks for which this appears to occur randomly, as well as those for whom it is fairly repeatable (USB). Thank you to the users who have swapped units so that we could examine them - the occurrence of this in the *total* Moto G population is very low, but that doesn't matter if it is happening to you!

    We'll share more data here as soon as we have it; unfortunately exact release schedules for updates depend on several things (carrier lab approvals, etc.) and this is not the only item in this release. However it is a priority to get out and we are testing algorithm adjustments now.

    https://forums.motorola.com/posts/7a7b068df1?page=8
    2
    Had the same problem. Contacted Motorola help through their website and got this canned response from one of their tier 1 techs. This solution solved my battery problem. Stock Moto G with with OTA 4.4.2. No battery apps to make my battery last longer or any of that nonsense.

    Code:
    This will remove any temporary files that may be causing the problem, but will not delete your files or settings.
    
    1. With the phone powered off, press the VOL DOWN KEY for 2-3 seconds then POWER key then release.
    2. The device will display different BOOT OPTIONS 
    3. Use the VOL DOWN Key to SCROLL to Recovery and VOL UP Key to select
    Tip: If the device reboots, you may have waited [too] long to make a selection, you will need to begin the process again. 
    4. The device will display the Motorola logo and then the Android in distress (logo with Exclamation mark)
    5. Press and hold the VOL UP key for 10-15 seconds. While still holding the VOL UP key tap and release the POWER key
    Tip: You can try this step, holding the phone in landscape. If you are stuck on step 6, try a force reboot by pressing the Power key and Vol Down key, and start the process again.
    6. The device will display additional menu options (Text will appear in BLUE) 
    7. Use the VOL DOWN Key to scroll to wipe cache partition and the POWER Key to select this option
    8. The device will then perform the partition wipe
    9. The device will reboot and start the normal power up sequence
    2
    Full discharge of a Li-ion Battery to that extent can actually harm the Battery, and I would not recommend it at all, normally!!!

    http://www.howtogeek.com/169669/debunking-battery-life-myths-for-mobile-phones-tablets-and-laptops/





    But, it does appear we are getting false battery status information from Android, especially as some are using the device for hours after the low power warning has been issued, so, as stated in the piece above, calibration by full discharge/full charge cycle should fix this.....

    mine has shown no further problems after full charge again, although I did not do the "full discharge" recommended by robpty......if it happens again, that is what I will do.

    Sent from my Nexus 7 using Tapatalk


    Check this out!

    http://motoxhub.com/how-to-solve-battery-life-problem-of-moto-x-after-kitkat-android-4-4-update/
    2
    The fix for this issue is included in 4.4.3 / 4.4.4 - Only report if you have it happen after updating.

    Official thread:
    2
    hi!
    i have the same problem!

    i have install rooted 4.4 and when i flashed cerberus.zip in CWM at the reboot the battery dropped to 48% from 100%....

    everytime i have rooted or flashed a boot.img etc on my motoG the battery drops from 100% to 48% - then when i plug it in to charge it is full again within 5 - 10mins

    i think there is definitely something scewey going on with the battery stats readings more than the actual units having battery problems